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3D MODELING AND AMG 

Background 
The MaineDOT considers the use of Automated Machine Guidance (AMG) by Contractor 
for MaineDOT Projects, to be a desirable process. Used effectively, AMG provides a method 
to accelerate highway construction, while improving quality and safety. 

The MaineDOT has updated Standard Provision 105.6 Construction Surveying to address the 
use of 3D Modeling in the AMG Process. Currently 3D Models created by the Contractor are 
used to control the Guidance of Construction Equipment. In order to facilitate this process 
the Department provides 3D CADD data to the Contractor, and reviews the Contractor’s 3D 
Model to confirm compliance with the Contract Documents.  

 

• 105.6.2.2 Electronic Design Data and Digital Terrain Model (DTM)  

“If provided by the Department, at the request of the Contractor, any electronic project 
design data will not be deemed a part of the contract, and is supplied as a courtesy by the 
Department. The Contractor shall not take advantage of any ambiguity or error contained in 
said data, and upon discovery of any ambiguity or error shall notify the Department before 
proceeding.” 

 

Process Overview 
The Review of a Contractor’s 3D Model is initiated by the Receipt of the 3D Model; per 
Standard Specifications the format of the model should be either an InRoads Surface (.dtm) 
or LandXML (.xml) file. Any other format may be accepted, at the discretion of the Design 
Team. 

 

The review is typically made by one or more of four methods. These are: 

1. Creation of an Isopach Surface based from the Contractor’s Model, and the 
Design Model. This surface will have an elevation (Z) based on the difference 
between the two surfaces; so indication of an elevation of 0.0 indicate that the 2 
surfaces are identical at that location. 

a. While this is a very thorough technique for the review of the Contractor’s 
Model; it relies on the Designer’s 3D Model to provide a basis for 
anaylsis. Locations where the Designer’s 3D Model differs from the 
Contract Plans, are not available for analysis by this technique. 

2. Display the Contractors Surface on the Cross Sections created as part of the 
Contract Documents. Coincident lines are an indication that the surfaces are the 
same at this Cross Section Station. 
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a. This technique checks the Contractor Model against the Contract Plans, so 
provides a checking option when the Designer’s 3D Model differs from 
the Contract Plans. The problem is that it only checks at the location of the 
Cross Sections (typ. Every 50’) 

3. Comparison of Features with Contract Plans. Many features can be reviewed by 
comparing the Contractors Model with the Plan View .dgns This is typically a 
convenient way to determine whether the Cut / Fill Slopes terminate as desired. 

a. Care should be exercised as the Contractor’s Model may not have an 
associated Exterior Boundary, to limit the triangulation. This may display 
as triangulation across areas where no work is proposed. 

4. Comparison of the Contractors 3D Model with the Right of Way Plan can identify 
Right of Way Conflicts.  

 

The review process is completed when the comparisons indicate that the Contractors 3D 
Model do not deviate from the Contract Plans by more than the tolerance for the item being 
installed. The tolerance(s) can be found as part of the Standard Specifications. 

Any deviation from the Design Surface , above the item tolerance, should be noted and the 
Contractor notified by contact with the Project Manager and/or Project Resident.  

When the surfaces are within tolerance, the Engineer of Record should provide 
documentation to the Project Manager and Construction Resident, indicating the name, size 
and date of the Contractors 3D Model file that was evaluated, stating that Model met the 
“Design Intent”.  
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IMPORTING THE CONTRACTOR 3D MODEL 

Overview 
Models for the Contractor are specified to be either InRoads Surface (.dtm) or LandXML 
(.xml) format. 

 

Opening InRoads .dtm 
InRoads Surface file (.dtm) files can be directly imported into InRoads via the File > Open 
menu in InRoads. 

 

 

 

Importing LandXML .xml 
While intended as a Universal Format; the LandXML Surface file (.xml) files cannot be 
directly imported into InRoads.  

LandXML Surface files are formatted in a Points section and a Faces section. 
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Using the LandXML Translator from within InRoads, through the command File > 
Translators > LandXML Translator will not import the TIN Faces, so InRoads will 
prompt to create a triangulation, which can force triangulation across featured which should 
be breaklines. 
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Note: This example can be found on the Y: drive in a folder named Cont-Rev. This 
folder should be copied to the local C:\pin\ folder. The file Design.rwk can be loaded 
from the C:\pin\Cont-Rev\00\HIGHWAY\MSTA folder. In order to use the sample 
project load the Cont_Rev_00.pcf file from the folder into the C: /!msproj/ folder. 

  
In order to import the LandXML file correctly the following procedure should be performed. 

 Step One 
From the File > MakeSheetz macro create a 3D plan view file that reflects the name of the 
LandXML file being opened. 

  

 

The file created will have a series of References attached and opened. These References may 
be distracting when conducting the review, as they may display multiple copies of the same 
feature, some 2D and some3D. 

These References can be eliminated from the drawing by the command(s): 

 File > Reference (DOT) > Dialog 

 Tools > Detach All 
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 Step Two 
Launch the Data Acquisition menu from the Tasks Toolbar. The Data Acquisition 
command can also be accessed from the  Tools menu. 

 

From the Surfaces tool Right-Click to open the Create Surfaces > Import External 
Surface > Import LandXML Surface. 

 

Select the file FG MAIN STR SURFACE.XML and press Open 
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From the Select Surfaces dialog box, Highlight the Surface Name and  Press Accept 

 Step Three 
After the Surface is imported turn off the display of all elements except the Feature 
“Triangles”. 
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 Step Four 
Right click on the surface name, and select Create Graphics. This will write the triangles to 
MicroStation. 

 

 

Press Fit View to view the imported Triangles. 

 

***NOTE*** As the result of there not being an External Boundary imported with this data 
extraneous triangles will be created on the inside of any curved portion of the surface.  
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These triangles should not be used to determine the validity of any 3D Models, and can be 
removed by using the Drop Element tool to drop the Mesh.  

Qualities > Drop > Complex 

 

 Step Five 
After the graphics are created, create a Selection Set from the Triangle legs, by Edit > Select 
All. 

From the InRoads menu the graphics can be imported into a surface by the command File > 
Import > Surface > From Graphics 
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Provide a Surface name that is consistent with the name of the Contractor’s Model, or which 
provided enough descriptive information to know what the surface is. 

By having a Selection Set of all triangle legs created before the Surface is created the  Load 
from: Single Element can be used.  

Click Apply 

At the prompt:  Click OK 
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Save the created surface. 
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From the InRoads menu select File > Open and open the newly created surface. 

 

 

 Right Click the surface name and Set Active. 
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REVIEWING THE CONTRACTOR 3D MODEL 

Overview 
Now that the Contractor’s Model has been imported into an InRoads surface; the InRoads 
tools can be employed to compare the Contractor’s Model to the Plan Set, and the Design 
Model. 

 

Reviewing Design Model 
The first step in reviewing the Contractor’s Model is to identify locations where the Design 
Model is inconsistent with the Plan Set. One way to identify these locations is to Reference 
the Design Model into the base drawing for the Plan Set.(Highway.dgn) 

This process will allow us to identify the Horizontal variances in feature between the two 
Surfaces. 

 

 

 

In this instance it appears that edits were made on the Cut/Fill lines in Plan and Cross 
Section, after the Model was created. The Roadway Centerline, Edge of Travelway and 
Shoulder, appear consistent between the Plan and 3D Model.  

In areas where the Design Model deviates from the Plan Set, Plan Set information needs to 
be used to access accuracy. 
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Reviewing Contractor Model against Design Model 
After determining areas where the Design Model is inconsistent with the Plan Set, InRoads 
can be utilized to compare the two surfaces. This is accomplished by using the 2 surfaces to 
create an Isopach surface. The Isopach elevation represents the difference between the 
elevation of the surfaces. This elevation difference can be judged against the allowable 
tolerance for the work to be performed. 

Step One 
From the File > MakeSheetz macro create a 3D plan view file that reflects the name of the 
Contractor Model, and that this will be an Isopach Surface. 

 

Step Two 
From the InRoads menu, select Surface > Design Surface > Generate Isopach Surface 
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From the Main Tab, select First Surface and  Second Surface; and enter the name of the 
Isopach Surface to be created. 

 

From the Staking tab, Select the Grid Display Mode, and an Interval of 10’. Select a Cut & 
Fill Height Precision of 2 decimal places (0.12). Delete all Prefix and Suffix options.  

These selections will provide a listing of the elevation difference every 10’; which is about as 
close as is possible with this text height. 

 

Press Apply to create the Isopach surface. 
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This output is shown with the Reference files displayed. This allows locations to be 
identified and determines the edges of the paved area. 

In order to simplify the output and remove extraneous infromation the MicroStation 
command Edit > Find/Replace Text can be used to remove the 0.00’, 0.01’, and 0.02’ 
elevations. 
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From the resulting output, areas having differences that should be noted, and reviewed can be 
identified. In this display much of the upper roadway looks good (< 3/8”), but areas in the 
lower section have differences approaching 0.5’. 
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REVIEWING THE CONTRACTOR 3D MODEL IN 

CROSSSECTION  

Overview 
Now that the Contractor’s Model has been imported into an InRoads surface; the Contractors 
Finish Grade Surface can be displayed on the existing Cross Sections to further identify 
deviations from the Plan Set. 

 

Modifying Contractors Model 
In order to visualize the Contractor’s Model easier, the Properties of the Finish Grade 
Surface (not the Isopach surface) will be modified. Right Click on the Surface  and Click 
Properties 

 

In the Advanced Tab of the Surface Propertied dialog, change the Symbology to a color and 
linestyle that is more visible. In this case, the Symbology D_Bridge_Abutment is chosen. 
Then press Apply. 
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Viewing the Contractors Model in Cross Section 
Open the Cross Section sheet drawing (Xsect.dgn) that was the basis of the Cross Sections in 
the Contract document. 

From the InRoads menu select the Evaluation > Cross Section > Cross Section.  

Choose the Set Name of the Contract Set of Cross Sections. In the Update > Surfaces 
dialog, select Display On, highlight the Contractors Finish Grade Surface and select Apply 
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In the Cross Section drawing the offset and elevation  of the Contractor’s Model can be 
viewed and compared, at each Cross Section Station. 
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REVIEWING THE CONTRACTOR 3D MODEL DRAINAGE  

Overview 
Now that the Contractor’s Model has been imported into an InRoads surface; the Contractors 
Finish Grade Surface can be displayed using InRoads Slope Vectors tools to evaluate the 
surface flow direction. 

 Step One 
From the File > MakeSheetz macro create a 3D plan view file that reflects the name of the 
LandXML file being opened and that Slope Drainage is being checked. 

 

 Step Two 
From the InRoads Menu Surface > View Surface > Feature display the triangulation of the 
Contractor’s Model. 
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With the Reference files attached the Existing Conditions and Proposed Design Features are 
visible. 

 

 Step Three 
From the InRoads Menu Surface > View Surface > Slope Vectors display the slope and 
direction of the Contractor’s Model. 



MaineDOT 
InRoads Training 

Contractor Model Review 
 

 

 

From the Main Tab, select the surface, the Display Mode as Grid with an Interval of 
10’and deselect Direction in Symbology. 

 

From the Advanced Tab, change the Vector Scale to 20 
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Select Apply 

 

Direction of Flow and Slope can be reviewed to determine that Drainage of the Contractors 
Model meets the Design Intent. 
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REVIEWING THE CONTRACTOR 3D MODEL FOR RIGHT OF 

WAY COMPLIANCE  

Overview 
Now that the Contractor’s Model has been imported into an InRoads surface; the Contractors 
Finish Grade Surface can be displayed and the proposed Right of Way Referenced to confirm 
that the Contractors Model does not extend outside the State’s Right of Way or acquired 
Rights. 

In this example the Contractor’s Model does not extend to the Cut/Fill Lines, so this review 
would not apply. 

In instances where omissions are made in the model those omissions must be noted in the 
Review Evaluation/Approval. 
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CERTIFYING THE CONTRACTOR 3D MODEL AFTER REVIEW  

Overview 
Now that the Contractor’s Model been reviewed and evaluated against the Contract Plan Set, 
a written notice needs to be prepared and distributed to the Project Manager and/or 
Construction Resident. 

The notice needs to be signed by the Engineer of Record for the Plans, and should contain: 

1. The name, date, and size of the file received from the Contractor for review. 

2. Indication that the 3D Model received from the Contractors meets the “Design 
Intent” of the Project, within the tolerance specified in the Projects Contract 
documents ; or 

3. Indications of  each location identified to be out of tolerance. 

Ideally, the Contractor’s 3D Model will agree with the Contract Plan Set. There can be 
instances where revision of the is not in the Department’s best interest, and the Resident and 
Inspectors need to know where the Contractors 3D Model cannot be relied upon, and 
alternative inspection procedures are necessary to assure compliance with the Contract Plan 
Set. 

After distribution, copy of the notice should be placed in the CONST folder for the Project 
(Y:\pin\). 

 

 

 

 

 

 


