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CChhaapptteerr  11  GGeenneerraall  
PPrroocceedduurreess  

This chapter offers an introduction to the MicroStation working environment that you’ll find 
at the Maine Department of Transportation. If you are new to MicroStation, you’ll find some 
helpful references about tool locations and document management. If you have previously 
used MicroStation, you’ll also find some helpful hints, since we have customized our user 
interface to increase productivity. 

This manual is to be used in conjunction with the Bridge Plan Development Guide and the 
Highway Design Guide. Please refer to these other documents for standard plan package 
requirements. 
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KEEPING YOUR MANUAL UP TO DATE 
Users Responsibility 
It is the MicroStation/InRoads user’s responsibility to keep their manuals up-to-date. When 
an area of the manual has been modified, we will recommend replacing the whole chapter 
affected by the change. This may require replacing the Table of Contents also. The 
MaineDOT internet website will contain individual chapters available for downloading.  We 
will be adjusting the dates of the chapters as they are revised and add a note as to what 
specifically was changed within the chapter(s). 

We will be sending the users a pop-up message, via the “Message of the Day”, indicating 
which chapter(s) has been modified.  

Message of the Day 
The “Message of the Day” is a Visual Basic program that we use to send important messages 
to MicroStation/InRoads users. If a message was sent to you, read it to see if it affects you. 
Please do the recommended action if any is required. Clicking OK will remove the message 
and will not display it again. If you do not have time to read the message, hit Cancel and the 
message will appear again when you enter MicroStation/InRoads. A typical message might 
ask you to run your Update Utility, letting you know if a plotter is working or tell you that 
the Manual has been updated. Try to treat these messages as high importance as we wouldn’t 
be sending them otherwise. 

Website Location 
The updated MicroStation/InRoads Manual and our configuration files for MicroStation and 
InRoads are available on the internet for both in-house employees and the consultant 
community. The address to the individual chapters of the manual is as follows: 
http://www.maine.gov/mdot/caddsupport/msinroads/microstationinroadsmanual.htm  

Check the date of your hard copy with the chapters on the internet. This is another way to 
find out if you need to update a chapter. Keeping your manual up-to-date will ensure that a 
reference to another portion of the manual is accurate. 

http://www.maine.gov/mdot/caddsupport/msinroads/microstationinroadsmanual.htm�
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USING THE TABLE OF CONTENTS AS A QUICK 
PUNCH LIST 

We have had requests to make quick To-Do list for some of the Chapters. We have added a 
few here and there, but not throughout the entire manual. This doesn’t mean that you 
shouldn’t read and follow all directions. Once you get familiar with a process, we suggest 
that you use the Table of Contents as a quick punch list for any given chapter. In most cases, 
the important steps are outlined in the table. If a step is unclear, open to the page and read 
more thoroughly. 
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USING THE ON-LINE MANUAL 
Overview 
We have created a PDF document of the entire MicroStation/InRoads manual and have made 
it available for in-house and consultant use. Many people prefer hard copies of the manual; 
however the PDF document provides more functionality.  

Opening from within MicroStation 
The MDOT MicroStation and InRoads Manual can be accessed from the MaineDOT Cadd 
Support website by using a shortcut provided in the main menu (looks like a book with a 
magnifying glass on it) (Figure 1-1). 

 
Figure 1-1: MicroStation/InRoads Manual Icon 

So that you can access the manual locally and for offline work, download the pdf.  If the 
shortcut for this manual and the adjacent shortcut to the MDOT Cadd Web Page are not 
available (shown above), navigate to Tools > Maine DOT Online Resources and left click 
to display the menu. 

Searching the Manual 
Like with most software, type Ctrl+F, click the binoculars or select Edit > Find (on This 
Page) and it will bring up the Find tool. Enter the topic you are searching for and Adobe will 
show you every occurrence of the word you are searching for, starting with the Table of 
Contents. Select the one that best fits your needs.   

Following Cross References 
In many places in the manual, we refer you to another topic for more information. With a 
hard copy, you have to browse to the chapter and page number. When using the on-line 
manual, you simply click the link to go to the page. 



mdot MicroStation 

08/8/12 

MaineDOT MicroStation & 
InRoads Procedures 

1-41 

 
 

INTERNAL HELP PROGRAMS 
Internal Help for MicroStation 

 Overview 
As with most programs, MicroStation has an internal help program that is very useful and 
detailed. There are many options in using help. Selecting Help from the main menu bar with 
expose these options. 

 Contents 
Help > Contents is similar to many Microsoft html Help products. It has a Contents, Index, 
Search and Favorites tabs. 

 Tool Index 
This option opens a tool specific dialog and allows a user to search based on a tool selection. 
It still ultimately opens the larger help document but helps narrow the search. 

 Tool Tips 
With this option checked on, hovering the pointer over a tool icon displays a tool tip, which 
is a yellow rectangle with text that provides the name of the tool. 

 Tracking 
Turning on Help > Tracking will display help for whatever tool or view control you pick. 
This is a good option for new users because it will display all possible options for using the 
specific tool. 

Internal Help for InRoads 

 Dialog Help 
Most dialogs within InRoads have a Help button that provides help directly related to that 
specific dialog. 

 Contents 
Help > Contents is similar to many Microsoft html Help products. It has a Contents, Index, 
Search and Favorites tabs. 

 Search for Help on 
 Allows a user to search the Help for key words. 
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 Technical Support 
This is available, but you must know the Select ID number, available through CADD 
Support. This is a last resort. Please contact CADD Support first to try and solve the issue. 

CADD Support Personnel 

 Phone 
Please feel free to call your support personnel at any time when help is needed. We may refer 
you to a portion of this manual for detailed instructions or guide you through the task at hand 
by using the phone and Microsoft’s Remote Assistance software. We can view the problem, 
take over your mouse and provide help.  

 Remote Assistance 
Remote assistance can be kicked off through an email to us or we can Offer Remote 
Assistance to you.  

Go to Start > Programs > Remote Assistance or Start > Help and Support and select Invite 
Someone To Help You. Pick Microsoft Outlook as the way you’d like to contact us and type 
in our email address or use the Address Book to select the name from the list. Follow the rest 
of the prompts, and include a password. Place a call in to the person you sent the email to and 
tell them the password. 

Call and we’ll Offer Assistance 
We can Offer Remote Assistance in the event you need a hand. Give us a call and we’ll do 
the rest. 
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LAUNCHING MICROSTATION 
Overview 
To work only in MicroStation (MicroStation tools) on an InRoads project, you should launch 
the MicroStation V8i icon on your desktop. If you decide you need to do design related 
tasks with InRoads, this can be launched from within MicroStation Applications menu. 

Launch MicroStation V8i 

 Part One: 
Launch MicroStation V8i from your desktop icon. The first dialog to open is the File Open. 

  
At the bottom of this dialog you will notice the Workspace area. User should be set to your 
appropriate group. If working on your project locally, this can be switched to InRoads 
Local_V8i. Interface should be set to mdot. 

 Part Two: 
Select the down arrow next to Project and select your project number from the list. 

 If you work on projects locally (unplugged from the network), you will need to 
manually copy the PCF for the project from the y:\msworksp\!msproj folder to your 
c:\!msproj folder. 
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 Part Three: 
Select a .dgn from the left side of the File Open and click OK. 
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GUI: THE GRAPHICAL USER INTERFACE 
There are a couple of places that MicroStation will offer instructions, read out data, and 
generally try to be helpful. These are the Tool Settings Window, Status Bar and Message 
Center. Make sure you know where these things are and check back with them often. 

 
Figure 1-2: Interface Components 

Main Menu 

 Overview 
Menu items can be chosen with your mouse or from your keyboard. Notice the underlined 
letters in the menu (File, Element, etc.) Open any menu by typing the Alt key, then typing 
that underlined letter. Then type the underlined letter of a command in the menu. We've tried 
to maximize the keystrokes accessible with your left hand in order to keep one hand on the 
mouse. 

Let's look at the menu structure, including important modifications we’ve made to existing 
menus as well as menus we've added:  

 Menus 
The File menu has been modified to allow access to custom sheet-creation routines. The 
Reference (DOT) option has also been enhanced to give quick access to common Reference 
commands. 

The Edit and Element menus have only minor changes. 
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The Dimension menu has been added to give quick access to some common Dimension 
settings.  

The Group menu helps place and manipulate groups of objects. Using this menu, you can 
control fences and graphic groups and access tools for element selection sets as well. 

The Macros menu is used to launch custom applications and enhancements. 

The Measure menu measures distances, angles, areas and volumes.  

The Qualities menu matches and changes color line style and other attributes. 

The Settings menu has been modified to give you access to a wide range of tools. 

The Stretch helps you modify, extend, clip and trim elements. 

The Text menu places and modifies text. 

The Tools, Utilities, Window, and Workspace menus have only minor changes. 

The Zip menu helps you place lines, shapes and cells. It also lets you move, copy, and 
modify, as well as hatch and delete. 

Status Bar 
There are a couple of places that MicroStation will offer instructions, read out data, and 
generally try to be helpful. These are the Tool Settings Window, Status Bar and Message 
Center. Make sure you know where these things are and check back with them often. 

View Controls 

 Overview 
There are a number of view controls that you will use on a daily basis. You might want to 
edit your Function Keys to give you quick access to them. They include Zooming, Fit View, 
View Previous and View Next.  

 Step One: View Controls 
Starting left to Right, hover over the view controls to get a description of the tool. Click on 
each one of the tools. Follow the prompts. We will explore the Rotate View tool in more 
detail. 

 Step Two: Rotate View Tool 
Choosing the Rotate View (Figure 2-12) command gives you a number of choices.  
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Figure 1-3: View Rotation Methods 

The majority of these Methods relate to 3D view control. Remember that Top view is the 
default and always a safe starting point. 

3 Points is the method of choice for rotating a view to something other than the default. The 
3 points that you enter correspond to a xy axis. The first point is xy of zero (the coordinate 
origin). The second point defines the direction of the positive x-axis. The final point defines 
the direction of the positive y-axis.  

 It is beneficial to have depth lock turned on for this operation.  

 3D Troubleshooting 
Sometimes you will get unexpected results when you are working with 3D files. There are a 
couple of tricks that you can try out.  

Flattening is always a good start by using the File > Export > 2D command from the Main 
Menus. You have to use the File > Open command to open the 2D file that was just 
exported. 

Also make sure to rotate your view to “top.”  

How do I get back Tool Bars that are missing? 
If any aspect of the GUI has been closed, you’re probably going to need to get it back. Every 
item outlined above can be closed except for the Menus and the Status Bar.  

The Attributes Tools can be opened from the Menus by choosing Tools > Attributes. 

The Primary Tools can be opened from the Menus by choosing Tools > Primary.  

The Standard Tools can be opened from the Menus by choosing Tools > Standard. 

The Main Tool Tasks can be opened from the Menus by choosing Tools > Main. 

The Main Task Tasks can be opened from the Menus by choosing Tools > Task. 

 

The Tool Settings Window can be opened by simply activating any command from a 
toolbox or menu. 
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The Window Open/Close button bar is used to open and close MicroStation Views. (The 
words “View” and “Window” are used interchangeably in MicroStation.) This button bar can 
be activated from the Menus by choosing Window > Views > Dialog.  

With our in-house customization we have specific Tasks Menus docked on the left and more 
can be opened using the Maine DOT WorkGroups drop-down. Log in credentials should 
open your primary Task Menu (i.e. HighwayGroup) automatically upon start up.  

AccuDraw can be opened by pressing the Toggle AccuDraw button on the Primary Tools 
bar (Figure 1-4). 

 
Figure 1-4: AccuDraw Button 

How do I retrieve missing tools on a Tool Bar? 
“I have my tool bar up but it is not showing all the tools.” Well in MicroStation V8i they 
have made the GUI more windows oriented. You can now right click on any tool bar and 
remove from display any of the dockable tools. 
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MOUSEING 
Standard Buttons 
Remember that the three buttons of the mouse are called Data, Tentative, and Reset. Here is 
a brief table of mouse button functions: 

Left Button Middle Button Right Button 

Data Tentative Reset 

Accept Snap Reject 

Yes Maybe No 

Troubleshoot the Middle Button 
It is possible that your Middle Button may not be snapping. From your main menu, select 
Workspace > Button Assignments. This will open the Button Assignments, and then click 
Remap Buttons to get the Button Mappings dialog (Figure 1-5). 

 
Figure 1-5: No Middle Button Assigned 

Highlight the Tentative row. Notice the Invoked by column is not set to Middle Button. 

Put your cursor in the Button Definition Area and hit your middle button. You should see 
the Invoked by column change to Middle Button (Figure 1-6) 

 If you are using a 2 button mouse you can setup the tentative by following this same 
procedure and either holding the Alt button when hitting your Left mouse button or 
hitting your Left and Right mouse buttons simultaneously in the Button Definition 
Area.  



mdot MicroStation 

08/8/12 

MaineDOT MicroStation & 
InRoads Procedures 

1-51 

 
 

 
Figure 1-6: Middle Button Correctly Assigned 

Press the OK button to preserve the assignment. 

Using a Wheel Mouse 
If you are using a wheel mouse you need to establish the wheel as a Middle Button in your 
mouse properties of your Operating System (Start > Control Panel > Mouse). 
There are some settings that you can set in your preferences for controlling the zoom and 
panning of your wheel mouse. You can find these setting by going to Workspace > 
Preferences… in the main menu. Select Mouse on the left side of your Preferences under 
your Category options. Check the different options out to the right and see what best fits your needs. 
(Figure 1-7) 

 
Figure 1-7: User Preferences 
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MENU OVERVIEW 
Introduction 
Our menu structure lets you run MicroStation from the keyboard. To let you keep one hand 
on the mouse, we've tried to maximize the keystrokes accessible with your left hand only. 

The Principal 
Menu items can be chosen with your mouse or from your keyboard. Notice the underlined 
letters in the menu (File, Element, etc.) Open any menu by typing the Alt key, then typing 
that underlined letter. Then type the underlined letter of a command in the menu.  

Organization: The Top Level 
Commands have been grouped together to make them quick to run and easy to find. Let's 
look at the menu structure, including important modifications we’ve made to existing menus 
as well as menus we've added:  

The File menu has been modified to allow access to custom sheet-creation routines. The 
Reference (DOT) option has also been enhanced to give quick access to common Reference 
commands. 

The Edit and Element menus have only minor changes. 

The Dimension menu has been added to give quick access to some common Dimension 
settings.  

The Group menu helps place and manipulate groups of objects. Using this menu, you can 
control fences and graphic groups and access tools for element selection sets as well. 

The Macros menu is used to launch custom applications and enhancements. 

The Measure menu measures distances, angles, areas and volumes.  

The Qualities menu matches and changes color line style and other attributes. 

The Settings menu has been modified to give you access to a wide range of MaineDOT, 
organized by task. 

The Stretch helps you modify, extend, clip and trim elements. 

The Text menu places and modifies text. 

The Tools, Utilities, Window, and Workspace menus have only minor changes. 

The Zip menu helps you place lines, shapes and cells. It also lets you move, copy, and 
modify, as well as hatch and delete. 
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Organization: The Next Level 
To keep things simple we've tried to keep the menus similar. The Group and Zip menus 
have some items in common: Copy, Move, Delete, and Scale are in both menus. They also 
have similar entries for Mirror and Rotate.  

For commands that are unique, we've tried to balance logic with convenience. On the 
convenience side, you can run the "place line" from Zip > Zipline. "Zipline" isn't a familiar 
word, but it's convenient to "place line" with the keystroke Alt+Z, Z. On the logical side, 
there's the "Measure Length" command. Alt+R, L. The Alt+R opens the Measure menu, and 
the L chooses "Length" as an option. 

Organization: Submenus 
Some commands have a lot of options you might want. With "Rotate", you might want to 
rotate by a specific angle. Then again, you might want to eyeball it. The Rotate item under 
both the Group and Zip menus has both of these options. You can "Rotate by Angle" or 
"Rotate by 3 Points".  

Conclusion: The Pros and Cons 
With this system, you can execute virtually every MicroStation command with a two or three 
letter shortcut that can be typed with one hand. If you forget the shortcut, you can remind 
yourself just by browsing through your menus.  
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MICROSTATION/INROADS CONFIGURATION 
Configuration Files and Drawing Files 
The master MicroStation customization files are on the network in a secure location that isn’t 
normally seen when mapping a drive letter. All users have a local copy of the customization 
on their C: or D: drive. Updates to the configuration are handled with an Update Utility. 
This utility does a date check of your local customization and updates files if changes were 
made to the master copy.  

Users also have a folder on their hard drive called \!msproj.  This \!msproj folder contains 
project specific information that are used as variables. These variables store information such 
as town name, federal project number, street or route number and user names of those who 
have worked on the project. A copy of this folder is on your C: or D: drive for offline work. 
As new PIN’s are created, you may need to update this folder for offline work so your project 
shows up in the list. 

The master copies of all drawing files are located on the network of: 

 \\oit-teaqasdtiis.mdot.w2k.state.me.us\pcpin1\  
This folder has been “mapped” to your machine as your Y: drive. This folder contains all of 
your design/detailing (project) information in the form of MicroStation files (.dgn).  

Regional Office users create sync copies of their project drawing files to their local hard 
drive because the network speed is diminished due to the geographical location and in some 
cases offline work. In this case, the files are setup in a briefcase “PIN” folder at the root of 
their C: or D: drive. 
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OPENING FILES 
To work only in MicroStation on an InRoads project, you should always launch 
MicroStation V8i from your desktop icon.  

 If you intend on using the InRoads tools, select Applications > InRoads Group > 
Activate InRoad. 

 Please refer to page 13-22 for more information on launching InRoads.  
The first dialog to open is the File Open. At the bottom of this dialog you will notice the 
Workspace area. User should be set to InRoads_network_V8i. If working on your project 
locally, this can be switched to InRoads_local_V8i. Interface should be set to mdot. 
Project should vary depending on what project you are working on. When you click on the 
Project picker, you should see a list of all active PINs. Pick your PIN from this list and 
MicroStation will take you directly to the design file directory for your Project. This is 
important because MicroStation will work smoother if it knows what project directory it 
should look to by default. If this is not working, please contact your CADD Support section. 

Select a file to open from the left side of the File Open and press OK.  

 You can open multiple MicroStation sessions while working on a single project (i.e. 
Plan view and Cross Section), however if you open a file having the same name (i.e., 
two highway.dgn’s) in two different project PINs, you may lose some work. You should 
always close all sessions of MicroStation prior to switching between projects. 
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MAKING NEW FILES 
Setup 
This macro is used to make new design files that meet MaineDOT standards. It will create 
them only in the same folder as the MicroStation design file that is open when the macro is 
run. To create new files for a specific project, launch the project and open an existing file in 
the project’s folder. 

Launch the Make Sheetz macro 
Select File > Make Sheetz. This will open the File Prefix Dialog (Figure 1-8). 

 
Figure 1-8: File Prefix 

Choose Preliminary Information 
In the File Prefix Dialog, you can choose to make a numbered sheet, a z-file, a c-file or a 
file with no prefix. 

• Numbered Sheets contain borders. These are the drawings that comprise the plan set for 
delivery to Contracts. They are the sheets that get plotted. Choose a Sheet Number. 

• Z-Files are the files where detailing work gets done. They typically get referenced into 
Numbered Sheets for plotting. 

• C-Files are the files where coloring is done for visualization purposes. 

• If you do not want a number, a “c” or a “z”, you can also choose “no prefix.” 

 Notice you can choose a different Workgroup here. This option starts with your 
default workgroup. You can change this to create a file that would normally be made 
by another Workgroup. 

When you have set your options, press OK. 

Choose a File Type 
This will bring up the Create File of Type… dialog (Figure 1-9). 
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Figure 1-9: Create File of Type 

Scroll down the list to find the file type that you want to create. Select it and press OK 

Final Filename Editing 
This will bring up the Make File dialog (Figure 1-10). 

 
Figure 1-10: Make File 

You can edit the entry in the Create file called box.  

Choose a number from the pull down for multiple drawings of the same type: (Figure 1-11) 
or type a suffix into the text entry box (Figure 1-12). 

 
Figure 1-11: Index Picker 
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Figure 1-12: Suffix 

Press OK when you have finished editing your filename. 

 The macro will automatically enter the underscore character before your suffix. If you 
do not type a suffix in, it will not insert an underscore. 

End Game 
This will create the new file based on appropriate seed files and place the correct border cell, 
where needed. It will then opens up the File Prefix dialog again and prompt you to create 
another file (Figure 1-13) 

 
Figure 1-13: File Prefix Again 

Press Cancel if you are done making files, or repeat these steps to make another file. 

Safety Features 
This macro will not automatically overwrite existing files, if you happen to tell it to create a 
file that already exists. It will first prompt you (Figure 1-14). 

 
Figure 1-14: File Overwrite Alert 
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If you press No, the macro will bounce you right back to the File Prefix Dialog to let you 
pick a new sheet number. 
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FILE NAMES 
The file names are important because the automatic sheet numbering capability of 
MicroStation relies on the first three digits of the file name. We all have had plots that came 
out with “XSE” in the “sheet number” box on your cross section plot. This is because the 
filename of your cross section you plotted was something like XSECTMC10_002.dgn. File 
names are also important because MicroStation automatically loads the Tasks Menus that 
should be used based on the user log in credentials. 

 Do not manually edit the sheet numbers on any of your drawings. Allow the automated 
procedure to handle this.  

Consider using the default number that displays, based on your workgroup, when cutting 
plan sheets. This will leave room for sheets that will go before the plans and numbered in the 
beginning of the project, for example: 

001_title.dgn 

002_typical_01.dgn 

003_typical_02.dgn 

004_estimate.dgn 

005_drainage.dgn 

006_notes_general.dgn 

007_notes_construction.dgn 

008_??.dgn 

009_???.dgn 

010_????.dgn 

011_HDPlan1.dgn 

The renumbering utility can be used again and again if necessary. Don’t worry if they aren’t 
in the correct order until final print. 

 Avoid having sheets with the same prefix and suffix in their filename. Add a suffix to 
sheets to differentiate the like drawings (i.e. Typical_01.dgn, Typical_02.dgn). The 
sheet renumbering utility doesn’t like having two drawings with the same prefix or root 
filename and suffix. You can use Windows Explorer to rename any identical root 
filenames to add a suffix or you can let the renumbering utility give you the warning 
and start rebuilding the list to the right. 
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SHEET RENUMBERING UTILITY 
Introduction 
This utility was developed to quickly rename/renumber your plot drawing files in the event 
that a sheet is added or deleted from a plan set. It allows you to prioritize the plan set based 
on the order of files in the list. 

Step One: Start the Utility 
To use this utility click on the icon on your desktop (Figure 1-15) or by selecting Start > 
Programs > MDOT Utilities > MDOT MicroStation Sheet Numbering Utility. 

 
Figure 1-15: The Tao of Renumbering 

Step Two: Browse to Project 
Next you will need to click your way to the PIN directory that you are interested in by 
changing the drive letter in the lower left corner, above the Renumber Plot Files button, to 
y:\\oit-teaqasdtiis.mdot.w2k.state.me.us\Pcpin1. Double click on the pin folder and select 
the desired project identification number (pin). You should keep double clicking on the 
sub folders to get yourself to your workgroups MSTA folder as shown in Figure 1-16. 
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Figure 1-16: Browsing for Files. 

Once there, you will see the list of drawings under the heading Available Drawings to the 
left and the utility automatically creates a list of all your numerical prefix drawings to the 
right under the Listing of Sheets category (Figure 1-17). 

 If you have drawings with the same prefix numbers the utility will not populate the 
file names under the Listing Of Sheets beyond the duplication. You can either use 
Windows Explorer to rename individual prefixes or just populate the Listing Of 
Sheets beyond that point. 
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Figure 1-17: Renumbering Interface 

Step Three: Prioritize Plan Set 
Now we are ready to prioritize the drawing list to create the correct numbering of sheets for 
the final plan set. You may have noticed that the list to the right side of the utility shows 
place holders between the original numbered drawings you had created, that's O.K. just 
simply highlight each place holder (015_xxxx) that you don't want and hit the Remove button 
or hit the Clear button and remove all files so that you can rebuild you list of files by 
highlighting and using the arrow in the middle to push the file back to the right. 

 The CLEAR button doesn’t give you a warning! If you hit clear, this will remove all of 
the numbered prefixes from your drawings! You will need to locate and rebuild them.  

You have the ability to add placeholders between drawings to create a gap in your sheet 
numbers in case there are sheets being inserted from other workgroups. You can move a 
selection of files up and down with the arrows to the right of the utility to prioritize your plan 
set. 

Once you have done this, go ahead and hit the Renumber Plot Files button and you should 
see your file names renumbered and the list to the left renamed as shown in Figure 1-18. 
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Figure 1-18: Renumbered Files 

Press Done when you are finished. 

Precautions 
This utility is set up to look for files within your folder. It is necessary that all file names are 
unique not only in their root filename and suffix, but in their prefix as well. If this 
requirement isn't met then you will experience problems activating this utility and/or 
renumbering when in the utility. 

The utility reverses the order of files when they are the first files pushed into the “Listing of 
Sheets”. Add a couple of place holders and click on the last place holder prior to pushing a 
large grouping of sequential files into this area. 

 If you get an error when first opening the utility, it may be because a PIN number that 
was previously renumbered no longer exist. To fix this problem, browse to your 
C:\windows directory and open the control.ini file. Delete the InitDirectory line in this 
file and the path to the PIN that it refers to. Reopen the Sheet Renumber Utility: 
(Figure 1-19) 

 
Figure 1-19: Control file 
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Adding Place Holders 
You have the ability to add placeholders between drawings to create a gap in your sheet 
numbers in case there are sheets being inserted from other workgroups. You can move a 
selection of files up and down with the arrows to the right of the utility to prioritize your plan 
set. 
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PCF EDITING 
Overview 
PCF Files - “Project Configuration files” are files that contain project specific information 
that will be used by MicroStation and databases that can extract project information from 
lines of text in the file.  

Open one of your prefix numbered drawings.  

Edit PCF File 
Go to Workspace > Edit Project Data (PCF) to revise or add information about this 
project. A list of variables will appear in a dialog. 

 If you get the warning that says “Close MicroStation and choose a project that is 
consistent with your file location”, there are two thing it could be.(Figure 1-20)  

 
Figure 1-20: Information Dialog  

1. You may have entered MicroStation improperly. You must open MicroStation by 
clicking on the MicroStation icon on your desktop and selecting your PIN number in the 
project pull down (this is in the lower portion of your File Open window. This selects the 
PCF file that is associated with your PIN number) If you have the wrong project specifics 
on your plot, this is a BIG clue that you selected the wrong PCF in the project pull down 
or that your PCF has bogus information in it.  

2. If the line in your PCF file says “PCF_PINNUMBER = _______”, and does not have a 
value, you will still get this warning. Simply correct this by adding your PIN number (i.e. 
1234.00), saving the PCF file and restarting MicroStation. 

 Do not enter the word “PIN” in the PCF_PINNUMBER field. 
Verify that the fields crucial to your drawing are filled in. Edit a field by clicking on the field 
and hit OK.  

Another dialog will prompt you for input. Add the information and click OK (Figure 1-21). 
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Figure 1-21: PCF Selections 

When done, hit Cancel to Exit. Click Yes to save the changes.  

 In the caption above, you will notice some similar selections. Due to the fact that 
some border drawings may contain different variables, you should enter the primary 
designer in both the PCF_DESIGNER and the PCF_DESIGNER1 fields. The same 
goes for PCF_DETAILER. Additional designer and detailer fields are there for a 
future border that will have the additional fields. 

 If no changes were made and you attempt to save the file anyway, you will get an 
error. Click OK to bypass the error.  

The macro will ask you if you would like to edit the border information. Say Yes to process 
all of the numbered drawings now or No to process them later using Macros > Border 
Information from the Main Menu. Figure 1-22 

 
Figure 1-22: PCF Edit Alert 

 Refer to the Border Information Macro on page 1-69. 
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BORDER INFORMATION MACRO 
Overview 
The standard border cells contain variables for sheet number, total number of sheets, street 
name, etc. These variables begin and end with a “$” or “@”.  

We have a macro that will substitute your active project information into those variables. 

It will also look for the first three digits of your file name and use those as your current sheet 
number. 

This is called the Borderinfo macro, and you run it from your main menu by selecting 
Macros > Border Information. 

The macro is capable of processing a whole folder-full of files at once. 

 Refer to page 1-72 for information on disabling edited items. 

Sheet Numbering 
Before you run the macro, make sure your file fits naming conventions, i.e., begins with a 3-
digit number and an underline. 

 Check page 1-62 for instructions on using the Sheet Renumbering Utility. 

Process Options 
If you are running the macro from an appropriate file and project setup, you will get the 
Border Info dialog box (Figure 1-23) that offers you two options. 

 
Figure 1-23: Border Info 

Option One: Change Current File 
Process your active file by picking Change Current File.  
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Option Two: Change Project Files 
Process a whole directory full of files by selecting the Change Project Files option. This 
will select all eligible files in your current directory for processing.  

You will get a dialog that lists all the files that will be processed. You can browse through 
this list to confirm that only the files you want to process are listed (Figure 1-24). 

 
Figure 1-24: Batch Process 

If you don’t wish to process a certain file in the list, highlight it and press OK. Otherwise, 
press Cancel and MicroStation will open and process each file on the list.  

 Remember that only files in your active directory that begin with a 3-digit number 
(followed by the underscore "_" character) will be processed.  

Error Messages 
When running this macro, you may get one of two error messages.  

1.  If you didn't pick your current project before opening the file, you'll get a prompt to 
"Close MicroStation and choose a project (PIN) that is consistent with your file location." 
This will protect you from substituting incorrect information onto a border. 

2.  If you are working in a file that is not properly named, you will get a prompt that explains 
the file naming criteria. You will get this message if you try to run the macro from a file 
that is not a border file or it has not been run through the Sheet Renumbering Routine.  

Side Effects 
The most important side effect of this macro to be aware of is that it will drop all border cells 
in every file processed.  

 The macro may not substitute information if you don’t have a standard border cell. In 
that case, drop the cell manually from Qualities > Drop > Complex.  

Changing Data After the Fact 
If you go back and need to change your project data, select Workspace > Edit Project Data 
(PCF).  
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 Refer to page 1-67 for the specific details of editing PCF files. 

Troubleshooting 
If it seems like the macro is not finishing, it may be because of one of the following reasons. 

1. Someone may have changed or hard coded a variable on the border. 

2. You cannot use a backslash between the month and year in your PCF file. 

3. Your file may be corrupt. (See your CAD administrator) 

4. If there is any multiline text in the border cell the macro can get hung up. 
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DISABLING THE BORDERINFO SUBSTITUTION 
Overview of Droplink.bas 
The downside of using the Borderinfo macro to substitute project information onto the 
border sheets (Macros > Border Information) is that you are limited in your ability to alter 
the results of the substitutions. 

Once the macro has run, you can edit the text as normal. However, every time the 
Borderinfo macro runs, it will re-substitute its text: potentially overwriting your custom text 
entry. 

The DropLink macro has been written to allow you to “hide” your altered text, preventing 
the Borderinfo macro from changing it when it is run. 

A possible good use of this is if you want to maintain a certain designer/technician name of a 
plan sheet then you would droplink these names so that the border information would not 
change them. 

Setup 
There are two ways the DropLink macro can process elements.  

You can place a fence or select a bunch of elements using Element Selection and then run the 
macro. The macro will process all the indicated elements. 

Or, you can run the macro with no Fence or Selection Set, and the macro will allow you to 
pick elements one at a time to drop. 

Run the DropLink Macro 
From the main menu, select Macros > DropLink.  

If you have a Selection Set or Fence, Datapoint to Accept. 
Otherwise, select each element you’d like to drop the linkage from. 

What Does it Do? 
The DropLink macro removes an invisible tag from the elements you indicate. This tag is 
the only way the Borderinfo macro can find these elements to change them. Without the tag, 
the Borderinfo macro will not further alter the elements. 

 This process is only reversible by using Edit > Undo.  

Quitting 
To exit out of the macro, simply choose another command. 
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MAINEDOT PLOT DRIVERS – REGION 0 
Overview 
The plot drivers below are located in the /!msV8iconf/standards/plotdrv folder. 

Plots can be sent to any plotter, regardless of its location. Due to network speed, it may be 
more feasible to have someone at the location send the plots. 

 The recommended printing solution is Printing to PDF by creating single sheet or a 
multi-page PDF and then print from Adobe directly to a plotter. 

 Refer to page 28-10 for instructions on plotting a PDF from Adobe software 
directly to one of the plotter listed below. 

 When plotting a PDF, consider sending it directly from the Adobe PDF viewer software 
to a plotter that is mapped to your computer. You can reverse the order (depending on 
the plotter it goes to) and ask for additional copies. For your convenience, we have 
provided instructions on mapping the various plotters below each description. 

US_ XEROX6279b-full-rm126 – Final Full Size Plotting 
This option sends a full size plan sheet, which is 36” wide, to the plotter located in the 
reproduction room at MaineDOT – Augusta. 

This plotter produces excellent plots and is capable of handling large batch jobs. 

US_ XEROX6279b-half-rm126 – Final Half Size Plotting 
This option sends a half size plan sheet, which is 18” wide, to the plotter located in the 
reproduction room at MaineDOT – Augusta.  

The plotter has an 18” roll; therefore, no trimming is required. 

US_ XEROX6279b-long-rm126 – Long Plots (5’ – 20’) 
This option sends plots longer than our normal plan sheet is tall (24”+/-). Currently, we have 
4 different lengths available: 5ft, 10ft, 15ft, and 20ft. We use this in conjunction with clip 
boundaries of the same size to achieve a plot that is to a desired scale. 

US_PLOT2FILE 
This option is for creating plot files (.plt or .000). This is primarily used in conjunction with 
the Print Exec Workgroup. The Print Exec Workgroup can use the plot files to create full or 
half size plots. Depending on where you send you plots, you may be required to print the job 
in reverse order. 

US_ XEROX6204-full-rm312 - Full Size Check Plots 
This option sends a full size plan sheet, which is 36” wide, to the plotter located in Room 312 
on the 3rd level of MaineDOT in Augusta. 
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This plotter is for quick working plots and is not intended to be used for final plots or large 
batch jobs. Please send only 50 plots at a time to this plotter. 

US_ XEROX6204-half-rm312 – Half Size Check Plots  
This option sends a half size plan sheet, which is 18” wide, to the plotter.  

It is not intended for large half size batch jobs. Please send only 50 plots at a time to this 
plotter. 

US_ XEROX6204-long-rm312 – Long Plots (5’ – 20’) 
This option sends plots longer than our normal plan sheet is tall (24”+/-). Currently, we have 
4 different lengths available: 5ft, 10ft, 15ft, and 20ft. We use this in conjunction with clip 
boundaries of the same size to achieve a plot that is to a desired scale. 

US_CANONColor-full-rm126 – Full Size Color Plotter 
This option is for sending Full Size color plan sheets to Room 126 (reproduction room) at 
MaineDOT – Augusta. This is a high quality and fastest wide format color plotter in the 
building.  

US_CANONColor-half-rm126 – Half Size Color Plotter 
This option is for sending Half Size color plan sheets to Room 126 (reproduction room) at 
MaineDOT – Augusta. This is a high quality and fastest wide format color plotter in the 
building. 

US_CANONColor-long-rm126 – Half Size Color Plotter 
This option sends color plots longer than our normal plan sheet is tall (24”+/-) to Room 126 
(reproduction room) at MaineDOT – Augusta. Currently, we have 4 different lengths 
available: 5ft, 10ft, 15ft, and 20ft. We use this in conjunction with clip boundaries of the 
same size to achieve a plot that is to a desired scale. This is a high quality and fastest wide 
format color plotter in the building. 

US_HPCOLOR4 
This option is for sending color plots to the HP1055CM Plotter in Room 303 on the 3rd level 
of MaineDOT in Augusta. This plot driver points to the plotter through the same print server 
as all the printers and photocopiers in the building.  

US_HPCOLORRoom303 
This option is for sending Full Size plan sheets to scale or larger color plots to the 
HP1055CM Plotter in Room 303 on the 3rd level of MaineDOT in Augusta. This plotter uses 
a different print server than the US_HPCOLOR4. It should be used when sending for large 
color plots. 
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US_HPCOLORRoom303Half 
This option is for sending Half Size plan sheets to scale or other color plots to the 
HP1055CM Plotter in Room 303 on the 3rd level of MaineDOT in Augusta. This plotter uses 
a different print server than the US_HPCOLOR4. It should be used when sending for large 
color plots. 

US_HPCOLORRoom321 
This option is for sending Full Size plan sheets to scale or larger color plots to the 
HP1055CM Plotter in Room 321 on the 3rd level of MaineDOT in Augusta. This plotter was 
intended to be used to share the load of the HPCOLORRoom303. It should be used when 
sending for large color plots. 

US_HPCOLORRoom321Half 
This option is for sending Half Size plan sheets to scale or other color plots to the 
HP1055CM Plotter in Room 321 on the 3rd level of MaineDOT in Augusta. This plotter was 
intended to be used to share the load of the HPCOLORRoom303. It should be used when 
sending for large color plots. 

US_ pdf-8x11 
This driver will create a black and white 8 1/2 x 11 pdf document provided you are running 
MicroStation version 8.05 or higher.  

US_ pdf-8x11color 
This driver will create a color 8 1/2 x 11 pdf document provided you are running 
MicroStation version 8.05 or higher.  

US_pdf-color-fullsize 
This driver will create a color, full size pdf document provided you are running MicroStation 
version 8.05 or higher. 

US_ pdf-color-halfsize 
This driver will create a color, half size pdf document provided you are running MicroStation 
version 8.05 or higher.  

US_ pdf-fullsize 
This driver will create a full size black and white pdf document provided you are running 
MicroStation version 8.05 or higher.  

US_ pdf-halfsize 
This driver will create a half size black and white pdf document provided you are running 
MicroStation version 8.05 or higher.   
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PRINTER_BW 
Drivers with PRINTER in the name sends the plots to your default 8.5” x 11” printer that you 
have mapped to your computer. If you are sending prints to a color printer, this option will 
print Black and White. If you are using this option and sending to a Black and White Printer, 
all lines (even if you are displaying color) will print black. 

PRINTER_COLOR 
Drivers with PRINTER in the name sends the plots to your default 8.5” x 11” printer that you 
have mapped to your computer. If you are displaying color in your drawing, this option will 
print color. If you are using this option and sending prints to a Black and White Printer, lines 
other than black will be a gray tone. 

PRINTER_STANDARD_DETAIL 
Drivers with PRINTER in the name sends the plots to your default 8.5” x 11” printer that you 
have mapped to your computer. This option is intended but not limited to Standard Detail 
printing and will print Black and White. This option produces thicker weights than the 
PRINTER_BW. Compare the results of the two drivers and choose the one that suits your 
needs. 

Hearing_PRINTER 
Drivers with PRINTER in the name sends the plots to your default 8.5” x 11” printer that you 
have mapped to your computer. This driver is used by the Public Hearing Section, however 
can be used by anyone. Test and compare the results of this driver with other printer drivers 
and choose the one that suits your needs. 
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REGIONAL OFFICE PLOTTERS (HP750C AND 
OCE PLOTTER) 

Overview 
All of the Regional offices are equipped with an HP750C color plotter and an OCE Plotter in 
addition to any Laser Jet printers. These plot drivers are located in the 
/!msV8iconf/standards/plotdrv/divisions/RegionName folder. 

Use the printer and PDF drivers in the plotdrv folder for printing to a Laser Jet (8.5 x 11) 
printer or to PDF. Use the drivers in your specific “divisions” folder for all plots going to 
your HP750C or OCE plotter. 

US_FULL750C_???_GR 
Default full-size black and white plot driver. Sends plots to the HP750C plotter. 

 If you need to map this printer as a Windows Printer for submitting from software 
other than MicroStation (i.e. Adobe, Excel, ESERI, Paint, E-Plans), click one of the 
links below depending on the Region.  

Region 1 click here \\Dot1dts1fsscr01 then double click the SCR750C plotter in the list. 

Region 2 click here \\Dot2dteaqpr001 then double click the HP750C plotter in the list. 

Region 3 click here \\Dot3dtd4fsdix01 then double click the HP750C plotter in the list. 

Region 4 click here \\Dot4dtb7fsbgr01 then double click the HP750C plotter in the list. 

Region 5 click here \\Dot5dtp1fspqi01 then double click the HP750C plotter in the list. 

US_HALF750C_???_GR 
Default half-size black and white plot driver. Sends plots to the HP750C plotter. 

US_Long_750C_???_GR 
This option sends black and white plots longer than our normal plan sheet is tall (24”+/-). 
Currently, we have 4 different lengths available: 5ft, 10ft, 15ft, and 20ft. We use this in 
conjunction with clip boundaries of the same size to achieve a plot that is to a desired scale. 

US_PLOTCHP_??? 
This option is for sending color plots to the HP750C plotter.  

 There may be other drivers in your “divisions” folder that have been created by users. 
Some may work and others may not. If you need assistance with drivers contact 
CADD Support. 
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US_OCE9400FULL 
This is a high speed, full size, black and white plotter that sends plots to the OCE plotter (if 
available) in your Regional Office. 

The plots exit on the tray table that will stack plans based on the order they were printed 
resulting in reverse order. When using the Print Organizer, click on the Name column to sort 
in descending order.  

 If you need to map this printer as a Windows Printer for submitting from software 
other than MicroStation (i.e. Adobe, Excel, ESERI, Paint, E-Plans), click here 
\\Dot2dteaqpr001 then double click the Region 2 – Oce 9400 plotter in the list. 

US_OCE9400HALF 
This is a high speed, half size, black and white plotter that sends plots to the OCE plotter (if 
available) in your Regional Office. 

The plots exit on the tray table that will stack plans based on the order they were printed 
resulting in reverse order. When using the Print Organizer, click on the Name column to sort 
in descending order.  

US_OCE9400LONG 
This option sends black and white plots longer than our normal plan sheet is tall (24”+/-) to 
the OCE plotter (if available) in your Regional Office. Currently, we have 4 different lengths 
available: 5ft, 10ft, 15ft, and 20ft. We use this in conjunction with clip boundaries of the 
same size to achieve a plot that is to a desired scale. 

US_OCETDS400FULL 
This is a high speed, full size, black and white plotter that sends plots to the OCE plotter (if 
available) in your Regional Office. 

 If you need to map this printer as a Windows Printer for submitting from software 
other than MicroStation (i.e. Adobe, Excel, ESERI, Paint, E-Plans), click one of the 
links below depending on the Region.  

Region 1 click here \\Dot1dts1fsscr01 then double click the SCR OCE PLOTTER in the 
list. 

Region 3 click here \\Dot3dtd4fsdix01 then double click the OceTDS450 plotter in the list. 

Region 4 click here \\Dot4dtb7fsbgr01 then double click the OceTDS450 plotter in the list. 

Region 5 click here \\Dot5dtp1fspqi01 then double click the PQI OCE Plotter in the list. 

US_OCETDS400HALF 
This is a high speed, half size, black and white plotter that sends plots to the OCE plotter (if 
available) in your Regional Office. 
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US_OCETDS400LONG 
This option sends black and white plots longer than our normal plan sheet is tall (24”+/-) to 
the OCE plotter (if available) in your Regional Office. Currently, we have 4 different lengths 
available: 5ft, 10ft, 15ft, and 20ft. We use this in conjunction with clip boundaries of the 
same size to achieve a plot that is to a desired scale. 
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PEN TABLES 
Overview 
Pen tables are used in combination with certain Plot Drivers, to accomplish a desired output 
to a printer or plotter. Each pen table does something different to your drawing at plot time. 
Some will require testing with your type of drawing; others have been established for specific 
types of drawings.  

!pentable.tbl 
This is the default pen table for plan production. This is used for all plans being submitted to 
Contracts with the exception for Title sheets for Highway users.  

We have combined four old pen tables into this default pen table. It substitutes certain text 
items (username, division, date, file name, etc.) into standard MaineDOT borders. 

This pen table lets you print out survey elements in a gray tone. Elements are changed to gray 
if they are in a reference file that has one of the following logical names: 

Topo, Text, Points, Contours, Topoadd1, Topoadd2, and Topoadd3. 

Gray elements, like Cross Section and Profile grids, are prioritized to plot underneath all 
black elements. Elements in these files that are weight 0 are changed to weight 1. 

As-Built.tbl 
This pen table will be used when sending electronic As-Built drawings to the one of the color 
plotters. All existing elements will be grayed, proposed will be black and As-Built elements 
will be red. 

BORINGLOG.tbl 
This is used by Geotech to produce desired plots of their Boring Log sheets. 

ENV_PRINTER_COLOR 
This is used by Environment to produce the desired plots for 8 1/2” x 11” color Wetland 
Mitigation plans. 

Graysurvey_wetlands.tbl 
This is used by Environment to produce plans of Wetland delineation. This makes the 
Wetland bold so that they stand out on the plots. 

Heavytopo.tbl 
This plots out the existing survey in black as opposed to graying it out as does the !pentable.  
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MHPC.tbl 
This is used by Environment to produce a color plan set for plans to be submitted to MHPC. 
Use this pen table when sending for plots that utilize Level Symbology Overrides. 

MHPCplan-No Symbology 
This is used by Environment to produce a color plan set for plans to be submitted to MHPC. 
This pen table doesn’t use Level Symbology Overrides.  

Prelim_plan_color.tbl 
This is used by the Bridge Program to produce a colored preliminary plan. 

Title.tbl 
This is used by the Highway Program when printing a Title Sheets that has a Plan Layout. 
This adjusts dashed lines in the topo drawings so that they can still be displayed at the 
smaller scale. 

Hearing_Thicker.tbl 
These were set up for our Hearing Section in order to increase the weights of lines, by one 
stroke, at plot time.  

Hearing_Thinner.tbl 
These were set up for our Hearing Section in order to decrease the weights of lines, by one 
stroke, at plot time. 

PublicHearing.tbl 
These were set up for our Public Hearing Section to speed up the coloring process of metric 
projects. 

usPublicHearing.tbl 
These were set up for our Public Hearing Section to speed up the coloring process of U. S. 
Customary projects. 

Laserjetblack.tbl 
This option will force every color in your drawing to black. This was intended to be used 
with a Laser printer. 

Rowblack.tbl 
This option adjusts the processing order and forces all color to black except for color 46. 
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SINGLE SHEET PLOTTING (FENCE PLOTTING) 
Overview 
This procedure is for sending a single Plan Sheet to a plotter or printer at a desired scale 
using a fence. It requires that you are using a standard border drawing that has a predefined 
boundary shape. All border designed for (8.5 x 11) use a similar boundary string. 

Step One: Place a fence 

  
Click on the Place Fence icon and set the Fence Type to Element and the Fence Mode to 
Inside (Figure 1-25). 

 
Figure 1-25: Place Fence Options 

Click on the boundary shape  

Step Two: Select Print/Plot 
From the main menu select File > Print option. 

On the Print dialog, press the Magnifying Glass button or go to the menu and select File > 
Bentley Driver… (Figure 1-26). 

 
Figure 1-26: Plotter Driver on the Print Dialog 
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You should see a list of plot driver files pop up for you to select from. If you do not see the 
standard plot drivers, please browse to: C:\!msV8iconf\standards\plotdrv. Select the plot 
driver that you want to plot to.  

 For a complete list of drivers, refer to page 1-74. 

Step Three: Select Pentable (If Necessary) 
Select the pen table if necessary. The default table (!pentable.tbl) should be loaded, however 
if you want a different one, select Pentable > Attach from the menu and select the desired 
pen table. If you do not see the standard pen tables, please browse to 
C:\!msV8iconf\standards\tables\pen. 

 Refer to page 1-81 for a complete list of Pen Tables. 

Step Four: Modify Attributes (Optional) 
You now have the ability to modify attributes through the Print Dialog. In the past you 
would have to select Settings > View Attributes from MicroStation to turn off Construction 
Elements on single sheet printing. Now you can select Settings > Print Attributes… from 
the Print Dialog menu and toggle things on and off without effecting the display in your 
main view. 

Step Five: Preview Print (Optional) 
From your Print Dialog, you can preview your plot by either selecting from the menu File > 
Preview, clicking on the Preview icon (Figure 1-27) next to the Print icon, or you can 
simply expand the dialog by clicking the Show Preview to the right top of the dialog (Figure 
1-27). 

 
Figure 1-27: Preview Icon 

Step Six: Show More Details 
You can also get more information by selecting the Show Details expansion button in the 
lower right hand corner of the Print Dialog (Figure 1-28).  
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Figure 1-28: Show Details 

Step Seven: Check Scale 
When you expand the dialog you will see information about your Print Size/Scale and Print 
Position (Figure 1-29).  

 If the scale seems to be out of whack when switching the units then you may need to 
reopen the file or close out of MicroStation and come back in to see the correct factor. 

 
Figure 1-29: Print Scale and Position 

The Print Position settings displayed in the prior caption are fine as displayed. 

 When doing a fence plot and picking your plot driver you should not have to worry 
too much about the settings for Print Size/Scale or Print Position. 
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Step Eight: Print 
If everything looks fine then hit your Print icon or File > Print… and send your print. 
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PLOTTING SHEET FILES (PRINT ORGANIZER) 
Overview 
This procedural manual will lead you through some routines involved in plotting sheet files 
(files named in the form of “001_HDPlan1.dgn” that contain standard borders.) 

Step One: Making a Batch Print Job 
The Print Organizer utility (File > Print Organizer) is MicroStation’s “one-stop shopping” 
for plotting. It’s going to make sure our plots are made to the right scale, to the right plotter, 
and with the right elements showing or not showing. It will also allow us to plot out files one 
by one, in specific groups, or all at once. Naturally, this takes a little bit of setup... 

First, select File > Print Organizer. This brings up the Print Organizer dialog (Figure 1-30).  

 
Figure 1-30: Print Organizer Dialog 

This dialog allows you to create a Print Set. A Print Set has two parts: a list of files and a list 
of specifications. The files are simply the .dgn files that Print Organizer is going to plot for 
you, and they’ll be listed at the right side of the dialog.  

The Specifications control how these files are going to be plotted, the extents to be plotted, 
Paper Size, etc.  

Step Two: Add Design Files 
Next, select the files you want to include in your Plot Set. Click the Add Files to Set button 
(Figure 1-31) on the Plot Organizer dialog.  

 
Figure 1-31: Add Files to Set Button 

This brings up the Create Print Definitions dialog (Figure 1-32). 
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Figure 1-32: Create Print Definitions Dialog 

 

Click the Add button on the Create Print Definitions dialog.  This will bring up the Select 
Files dialog (Figure 1-33). 

 
Figure 1-32: Select Files Dialog 
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Navigate to the appropriate folder and select the files you want to add to the Plot Set from the 
Select Files dialog. Click the Add button on the Create Print Definitions dialog.  This will 
bring up the Select Files dialog (Figure 1-34). 

 
 Figure 1-33: Use the Shift and/or Ctrl buttons on your keyboard to select multiple files.   

Click the Add button on the Select Files dialog to populate the list of files at the bottom of 
the dialog.  Click the Done button when you are finished. 

Step Three: Set Specifications 
From the Create Print Definitions dialog, select the Browse from the Print definition creation 
options portion of the dialog 
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Figure 1-34: Browse for Print Styles 

This will bring up the Apply Print Style dialog (Figure 1-37). The Print Style defines the 
settings for the plot, e.g., plot shape, scale, etc. Select the appropriate Print Style from the 
Apply Print Style dialog and click the OK button. 

 
Figure 1-35: Apply Print Style Dialog 
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Click the OK button on the Create Print Definitions dialog 

(  

). This will bring back the Print Organizer dialog populated with the MicroStation Design 
files you selected to Print.  You can reorder the plots by using the Move Up and Move Down 
icons. 

 

To save the Plot Set, select the File > Save command from the Print Organizer drop-down 
menus.  This will bring up the Save Print Set dialog (Figure 1-37). 
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Figure 1-36: Save Job Set File Dialog 

To make it easier to use this .pset for the duration of the project type in a name that reflects 
both the sheet size and the plot location. For convenience, keep the .pset file in your 
workgroups \msta directory of your project folder (this should be the default option.) When 
you’ve named the .pset file, press OK. You have now successfully created a Print Set. 

Step Four: Printing with Batch Print 
 MicroStation allows the user to sort their files in ascending or descending order based 

on their file name. Click the Name column (acts like a toggle) to sort in either 
direction. Depending on the plotter you are sending it to will determine how you want 
to sort them. 

 Refer to the plotter listing on page 1-74 to determine whether or not the plots will 
come out in ascending or descending order. 

Now you can select one or more sheets to be plotted (using Ctrl key to pick and choose or 
Shift key to select a range). If you want to print all files, push print without selecting any 
files. 

Click the Print icon or select File > Print… 
The Print dialog will open (Figure 1-38). If the Printer Name is not correct, click the Printer 
Setup button and select a different Printer Name. If you made a selection, you will be 
prompted as such or if you did nothing, the all button will be defaulted. If you meant to select 
all, you can pick it now. After you make a selection, press OK. 
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Figure 1-37: Print Dialog 

As the plots are being sent to the plotter, the progress will be displayed in another dialog. 
Wait until this is complete before trying to do anything else in your drawing. 

Print Set Troubleshooting 
Print Organizer also generates information in the MicroStation Message Center that can be 
used for troubleshooting purposes when plotting. 

. 
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PRINTING FROM AN EXISTING PRINT SET 
Once a Print Set has been created for a project, printing is much more streamlined. 

To print a file (or a group of files) that is part of a Print Set, first open the Print Organizer 
dialog from File > Print Organizer.  

Choose the existing .pset or legacy .job file (Figure 1-39) you want to print from and press 
OK. 

 
Figure 1-38: Open Print Set Dialog 

On the Print Organizer dialog, select the file or files you want to plot (Figure 1-40).  

 
Figure 1-39: Pick Files to Print 

If you want to print all files, push print without selecting any files.  
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From the Print dialog, you have the option of printing All files, or just the Selection of files 
you made in the previous step (Figure 1-41).  

 
Figure 1-40: Plot Selection 

Once you make a selection, push the OK button. As the plots are being sent to the plotter, the 
progress will be displayed in another dialog. Wait until this is complete before trying to do 
anything else in your drawing. 
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CREATING LONG PLOTS 
Step One 
Select the Settings > Drawing Scale and pick the scale you want to plot to (i.e., 1 in.=25 ft. 
or 1 in.=50 ft.).  From Task Menus, select your Workgroup > Plan > Long Plots > [5 foot/ 
10 foot/ 15 foot/ 20 foot/Plan Sheet HP Plotter/Plan Sheet OCE Plotter] 

 It is important that you remember which border size you used in order to set your paper 
size when you print. 

Step Two: Placing the Cell 
You should see the plot boundary on your cursor. You will place it with two clicks. The first 
places the origin of the cell. The second allows you to spin the cell around the origin point 
(Figure 1-42).  

 
Figure 1-41: Long Plot Boundary 

Step Three: Rotate View 
Before we can print, we have to rotate our view. Select the Rotate View button in the corner 
of window 1 (Figure 1-43).  

 
Figure 1-42: Rotate View Button 

Select the 3 Points method from the Rotate View Window (Figure 1-44).  



mdot MicroStation 

08/8/12 

MaineDOT MicroStation & 
InRoads Procedures 

1-97 

 
 

 
Figure 1-43: 3 Points Method 

The “three points” specify the x origin, positive x direction and positive y direction of your 
view. Choose your first two points by snapping to the two corners of the boundary.  

 Always define the two points in a left to right motion. 
Your third point defines the positive y direction. Snap to an area of the screen that would be 
above the left to right selection of the two previous points. 

 Picking these points in the wrong order can result in flipping your design upside down. 
Correct this by Rotating the view again, setting your Method to Top (Figure 1-42). 

It is recommended to rotate your view horizontally as shown in (Figure 1-45). 

 
Figure 1-44: Vertical Long Plot View 

Step Four: Printing 
Place a fence on the boundary you just rotated. 

From the main menu select the File > Print option. 

In the Print dialog select File > Bentley Driver… or the Magnifying button (Figure 1-46).  
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Figure 1-45: Plot Driver on the Print Dialog 

You should see a list of plot driver’s display for you. Select a driver that matches the type of 
plot you are sending. Use a driver with “LONG” in the name for 5, 10, 15 or 20 foot long 
plots, or use a driver with “FULL or HALF” in the name for “Plan Sheet” size clips.   

The possible plot boundary shapes allow for a maximum plot size of 20 feet. There is no 
reason to change your Paper: size in the Printer and Paper Size area of the dialog (Figure 
1-47). Leave it set to the defaulted 20FTPLOT for any size. 

 
Figure 1-46: Page Setup on the Print Dialog 

 Based on the rotation you used in your view, it may be necessary to toggle the Rotate 
90 on or off to plot correctly (Figure 1-48). 



mdot MicroStation 

08/8/12 

MaineDOT MicroStation & 
InRoads Procedures 

1-99 

 
 

 
Figure 1-47: Print Rotate 90 

 The processing time for long plots will be a little longer than a normal plot but we still 
need to be prompt in retrieving our plots so that they don't jam the plotter and also 
doesn't end up all over the floor. 
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FENCE PLOTTING TO SCALE 
It is easy to create a scaled print by placing a fence in the area you want. In the following 
example we are going to print an area to 1 in. = 25 ft. 

Step One: Place Fence 
Place a fence around the area you would like to print (Figure 1-49). 

 
Figure 1-48: Place Fence 

Step Two: Setting Scale 
Select File > Print from the Main Menu. Expand the Print dialog so you can see the Print 
Size/Scale area, in the lower left hand corner of the dialog. In (Figure 1-50) we have our 
Scale: options set to “’:” to 1 FT”, this means we need to apply an absolute scale of “300” 
(12 in. x 25 = 300) to get a 25 scale plot (Figure 1-51). You could change this option to “’:” 
to 1 IN.” by selecting Settings > Units> inches from the Print menu. This would allow you 
to set the Scale: to “25” (Figure 1-52). 

 You are only allowed to change the scale option to a larger number than what is 
displayed when opening the Print Dialog. If you cannot get the desired scaled print 
you want then consider either making the fence smaller or changing paper size. 

If you have set your desired scale then select either the Print icon or File > Print… from the 
menu. 
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Figure 1-49: Scaled Printing by Fence 

 
Figure 1-50: Scale Change Master Units 

 
Figure 1-51: Scale Change Sub Units 



mdot MicroStation 

08/8/12 

MaineDOT MicroStation & 
InRoads Procedures 

1-102 

 
 

COLOR PLOTTING 
Using a combination of file referencing techniques it's possible to make plans that will print 
out in full color. It requires that you put all of your color-filled areas in a single file, then 
reference that file to your border along with your line drawings. Use a color plotter (i.e. 
US_HPCOLORRoom303.plt) plot driver to make your final printout. 

File Setup 
Start by making a new file to put your coloring in. It's probably quickest to start by opening 
the file you want to color, then from the menu, select File > Save As or by selecting File > 
Make Sheetz. Name your file beginning with a "c_" prefix to point out that the file is color. 
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PLOTTING TO PDF 
Create MicroStation PDFs 
 A .pdf file is only a “snapshot” of the file at its present state. Any changes made to 

the MicroStation file will not be represented in the .pdf without recreating it. Without 
the PDF writer software, you can’t add and remove .pdf sheets as they change, you 
would have to re-create the whole multi-page .pdf or send them as single sheets. 

 Option One: Creating a single PDF 
Creating a .pdf is as easy as printing to a plotter. A single file can be created as a .pdf by 
placing a fence around the drawings plot boundary and picking the plot driver pdf-fullsize 
(select the US version for US Customary project) from the plotdrv folder. The file will be 
created in your active MSTA directory. It is recommended that a user create a separate folder 
for the single .pdf and replace older ones as changes to the drawings are made. 

 Option Two: Print Organizer to a Multi-page PDF 
When using the Print Organizer, select the pdf-fullsize printer configuration file (.pltcfg) 
from by clicking the Printer Setup button. Add the files you want to print, select pdf_bw-
Fullsize from the available printers and select print. When the Print dialog opens (Figure 
1-53), add a file name and .pdf extension (i.e. FinalPlans.pdf) in the filename portion of the 
dialog.  

 
Figure 1-52: Print Batch dialog. Add the filename with the .pdf extension. 

The file will be created in your active MSTA folder.  
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Printing PDF 
A user can print a PDF document as Full Size or Half Size, in reverse order and request 
multiple copies. When there are vertical sheet internally to the PDF, these sheets will need to 
be rotated 180 degrees in the hard copy plan set. To bypass this issue, the sheets can be 
rotated electronically to appear as landscape sheets along with the rest of the internal pages. 
This can only be done by someone with PDF Writer software. Either the Reproduction staff 
or someone with this Adobe Professional software can finalize the PDF for printing or simply 
rotate the stack of sections manually. 

 Rotate Vertical Pages with Adobe Professional (Optional) 
Vertical Cross Section pages need to be rotated 90 degrees counter-clockwise so that they are 
printed correctly with the binding edges matching all the other pages in the plan set. 

Select the Pages tab and locate the vertical pages (if any exist). Select the first sheet that 
requires rotating. While holding the Shift key, scroll to the last vertical page. Release the Shift 
key. Right-click on the selected pages and select Rotate Pages… (Figure 28-10). 

 
Figure 1-53: Right-click and select Rotate Pages 

In the Rotate Pages dialog (Figure 28-11), adjust the Direction to Counterclockwise 90 
degrees. Verify that the Page Range is set to Selection. Click OK. 
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Figure 1-54: Rotate Pages dialog 

 Save the PDF Document 
Select File > Save from the main menu. 
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PLOTTING TO PLT 
Create MicroStation PLTs 
 A plot file is only a “snapshot” of the file at its present state. Any changes made to 

the MicroStation file will not be represented in the plot file without recreating it. It is 
recommended that a user create a separate folder for the plot files and replace older 
ones as changes to the drawings are made. 

 Option One: Single Sheet Printing to .plt 
Creating a plot file is as easy as printing to a plotter. A single file can be created as a plot file 
by placing a fence around the drawings plot boundary and picking the plot driver 
PLOT2FILE (select the US version for US Customary project) from the plotdrv folder. The 
file will be created in your active MSTA folder. This is a full size plot .plt (.000). 

 Option Two: Print Organizer to .plt 
When using the Print Organizer, select the PLOT2FILE printer from available printers. The 
files will be created in your active MSTA folder.  
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ELEMENT ATTRIBUTES 
Setting Attributes 
Every element placed in your MicroStation design file is placed with Attributes, including 
color, level, style, and weight. These are reflected in your Attributes Tools Box (Figure 
2-1). 

 
Figure 2-1: Attributes Tool Box 

When you go to change or match an Element’s Attributes, you can see these Active 
Attributes, along with other settings for your Active Class and Template (Figure 2-2). 

 
Figure 2-2: Change Element Attributes Setting 

 Element Attributes can be matched by using the icon for Match Element Attributes. 
Making elements a Class of Construction is a way of marking “junk” lines in 
MicroStation as. This makes it easy to avoid plotting them. You can turn off the 
display of Construction elements from the View Attributes dialog (Settings > View 
Attributes).  

Tasks Menus 
You can let the Tasks Menus take care of all these Element Attributes for you.  

For example, choose your Workgroup > Plan > Roadway > Edge Shoulder from Tasks 
Menus. 
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Figure 2-3: Pick a Task 

This not only launches the SmartLine command, it also sets your active color, style, weight 
and level for proper placement of edge of shoulder lines (Figure 2-4). 

  
Figure 2-4: Edge Shoulder Setting 

Level Display 
The Level Display (Figure 2-5) can be launched from the main menu by selecting Settings > 
Levels > Display, Ctrl+E or click the Level Display on the Primary Tools tool box. 
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Figure 2-5: Level Display Dialog 

This is a simple overview of some of the management options using the Level Display.  
If the Reference Files or the active file is not displayed, Click on the + before the file, or the 
Show Target Tree icon to expand the file tree.  

To toggle the display of levels in a file, Click a level if being used (blue highlight with a dot 
in the Used column) it will turn the level off and changes the blue to white. If the level is off 
when clicked the change will be from white to blue and turned on. All levels can be toggled 
by Right Clicking on a level and selecting All On or All Off from the menu. To turn off 
levels graphically, select the Off by element tool.  In the Level Display dialog, select the 
Change Level (Figure 2-5) icon, then choose Level: Display Off from the Change Level 
Dialog (Figure 2-6) and Data Hit the Element on the screen. 

 
Figure 2-6: Change Level Dialog 

Level Manager 
The Level Symbology is now manipulated with the Level Manager (Figure 2-7). The Level 
Manager shown below does not display all of the columns available. By Right Clicking on 
the Used column header a menu appears showing other unchecked columns available. The 
Level Manager is displayed by clicking on the Active Level on the Status Bar, Ctrl+L or the 
Level Manager icon on the Primary Tool Box.  
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Figure 2-7: Level Manager Dialog 

Most of our element symbology is set using the Task Menus. On occasion for viewing or 
plotting color, weight, or style needs to be manipulated without making actual changes to the 
element symbology. If necessary the File Tree can be expanded by clicking on the + beside 
the Active File in the Level Manager Dialog. Elements Symbology on every level of each file 
can be changed by selecting the file on the left and the level from the right of the Display 
Manager. By clicking the checkmark in the Global Display column (right-click on the Used 
column header to enable this column, if it is not already displayed) the graphic display of that 
level will be toggled on or off. 

To use symbology by level switch the Symbology option to ByLevel. Click the desired 
Level Name, change the Color, Style and/or Weight and click OK to accept the change. 

To override the symbology of a level switch the Symbology option to Override. Right 
Click on a level will bring up a menu with other options.  

To view the symbology changes, Check on Level Overrides and Apply in the View 
Attributes dialog (Settings > View Attributes or Ctrl+B). When the toggle is disabled, the 
element attributes will return to normal. 
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SNAPS 
Enable Snapping (on by default) 
Most of the elements placed are connected to previously placed elements. Snaps are use to 
accurately place points on a drawing. To tentative hit on an element Snap Lock has to be 
toggle on. To view the Locks (Figure 2-8) from the main menu Settings > Locks > Full or 
click the Lock on the Status Bar and select Full.  

 
Figure 2-8: Locks Dialog 

A Snap Mode can be locked by changing the Mode: in the Snap field of the Locks Dialog or 
by holding down the Shift key and selecting the Snap Mode from the Status Bar. To use the 
snaps for one snap, use AccuDraw shortcuts for some or select the snap from the Status Bar.  

 For a complete list of AccuDraw shortcuts, click in the AccuDraw and type “?” 
(Shift+?).  

Snapping Modes Defined 
To view all the available Snap Modes: Settings > Snaps > Button Bar or click the Snap 
Mode on the Status Bar and select Button Bar. Right Click on one of the icons on the Snap 
Mode Dialog (Figure 2-9) and a menu of all the snap mode which can be toggled will appear. 
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Figure 2-9: Snap Mode Dialog 

Below is view and brief description of the available snap modes. 

 

AccuSnap 
By hovering near a Keypoint of an element with the curser AccuSnap will display that point, 
the element, the type, level name and allow a Data Point to be placed at that point without a 
Tentative Snap (Figure 2-10).  
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Figure 2-10: AccuSnap 

AccuSnap can be toggled from the Snap Mode Dialog or the AccuSnap Setting Dialog. More 
settings are available with the AccuSnap Setting Dialog Element and Feel tabs.  

Keypoint 
Keypoint is used to snap to point on arcs or lines. The number of Keypoint on an element is 
set in the Keypoint Snap Divisor Dialog (Figure 2-11). The dialog can be open by typing K 
in your AccuDraw Window. The division can also be set from the main menu Settings > 
Design File > Snaps. 

 
Figure 2-11: Keypoint Snap Divisor 3 

Intersection  
The Intersection Snap is used to locate the intersection of two elements. Locate one of the 
elements with a tentative snap which will highlight the element and just hover over the 
intersecting element with the curser and accept with a data snap when the AccuSnap appears 
on the screen. If AccuSnap is toggled off two tentative snaps, one on each element and a data 
snap to accept the point will be needed. You can continue snapping until the desired 
intersection is found; the last two tentative snaps define where the intersection point lies. 

If the two elements do not actually intersect a point will be a projection where one or both 
elements would intersect.  

Center 
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The center snap can be used to snap to the center of a line, shape, circle, cell, etc. It requires 
one tentative. The tentative has to be placed on the outside of the shape – do not try to 
eyeball it and snap near the middle. (Eyeballing actually will work with circles, but not with 
other shapes.) If AccuSnap is on, hover near the element and data hit when the AccuSnap 
appears. 

Nearest 
The nearest snap is used when you absolutely, positively have to get a point on an element, 
but you don’t care (or don’t know) exactly which point. 
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VIEW CONTROL 
Overview 
There are a number of view controls that you will use on a daily basis. You might want to 
edit your Function Keys to give you quick access to them. They include Zooming, Fit View, 
View Previous and View Next.  

More Advanced view controls deserve another look. 

Rotate View 
Choosing the Rotate View (Figure 2-12) command gives you a number of choices.  

 
Figure 2-12: View Rotation Methods 

The majority of these Methods relate to 3D view control. Remember that Top view is the 
default and always a safe starting point. 

3 Points is the method of choice for rotating a view to something other than the default. The 
3 points that you enter correspond to a xy axis. The first point is xy of zero (the coordinate 
origin). The second point defines the direction of the positive x-axis. The final point defines 
the direction of the positive y-axis.  

 It is beneficial to have ACS Plane turned on for this operation.  

3D Troubleshooting 
Sometimes you will get unexpected results when you are working with 3D files. There are a 
couple of tricks that you can try out.  

Flattening is always a good start by using the File > Export > 2D command from the Main 
Menus.  You have to use the File > Open command to open the 2D file that was just 
exported. 

Also make sure to rotate your view to “Top.”  
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COMPLEX CHAINS AND SHAPES 
Overview 
Adjacent lines and arcs can be grouped together into Complex Chains and Shapes. 

Creating Complex Chains 
Use the Create Complex Chain tool to combine adjacent lines and/or arcs into a linear (non-
closed) element. 

 This allows you to measure length and construct distances along the combined 
element. It also speeds up modification and manipulation. 

Activate the Create Complex Chain tool either from your Task Menu (Figure 2-13) or 
from your main menu by selecting Group > Groupings > Create Chain. 

 
Figure 2-13: Create Complex Chain 

Using the Manual option, MicroStation prompts you to “Create Complex Chain > Identify 
Element.” Pick each element you’d like to add to the chain, in order, until you have selected 
the entire chain.  

 Make sure to Accept the final element in the chain. 
Reset to complete the chain. 

Using the Automatic option, MicroStation will prompt you to “Automatic Create Complex 
Chain > Identify Element.” Once you have picked that element, just Data Point to Accept it 
and MicroStation will automatically highlight the next element in the chain.  

 MicroStation will jump gaps to complete these chains. Set the Max Gap value to tell 
it how far to look. 
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Keep Accepting until MicroStation completes the Chain.  

If there is a fork in the path, MicroStation will highlight one possible path and prompt you 
with the statement “FORK – Accept or reset to See Alternative.” Send a Reset if you don’t 
like the path MicroStation has chosen. 

Creating Complex Shapes 
Use Create Complex Shape to combine adjacent lines and/or arcs into a closed (non-linear) 
shape. 

 This allows you to measure length and area and construct distances along the element. 
You can also fill, pattern, or hatch the resultant area. It also speeds up manipulation 
and modification of the element. 

Choose Create Complex Shape from the Task Menu  (Figure 2-14) or choose Group > 
Groupings > Create Shape from your main menu. 

 
Figure 2-14: Create Complex Shape 

Note that you have some of the same options here that you had in the Create Complex 
Chain Tool Settings Window.  

Manual and Automatic creation procedures are much the same for Shapes as they are for 
Chains.  

One notable difference is the fact that Shapes are only complete when they are closed. As 
soon as a Shape is closed by Manual or Automatic creation, the creation is immediately 
completed.  

 If the end of the final segment does not correspond to the beginning of the first 
segment, MicroStation will draw a line that makes that connection. 
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 Area 
There are two choices for Area when you are creating a Complex Shape. They are Solid and 
Hole.  

 This property is only relevant to Hatching. Hole elements cannot contain Hatching or 
Patterning elements.  

It is strongly recommended that you do not ever place Hole elements in your drawing. It only 
leads to unnecessary confusion. 

 Fill Type 
If you would like your resultant Shape to be either Outlined or Opaque you can make that 
selection here before you create the Shape. 

Troubleshooting 
Creating Complex Chains and Shapes is a fussy business: sometimes just a slight error can 
lead to unexpected results. 

 Extra Elements 
Probably the most common mistake in creating Complex elements happens when the user 
Resets before the element is entirely finished. They realize they haven’t created the entire 
Chain, and they go back to the beginning and re-create it.  

The problem with this is that even though the first chain wasn’t complete, it is still a 
legitimate element and MicroStation doesn’t know that the user doesn’t want it. 

This ends up leaving all kinds of partial chains kicking around in your file. 

 As a rule of thumb, don’t forget to Undo your aborted efforts at creating Chains and 
Shapes before you go back and do it again. 
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COMPLEX REGIONS 
Overview 
While Complex Chains and Shapes are created by combining single, entire, simple elements, 
Complex Regions are Closed elements created through a more complicated interaction of 
multiple and potentially complex elements. 

Launching the Tool 
Choose Create Complex Region from you Task Menus (Figure 2-15) or from your menu 
by choosing Group > Groupings > Create Region. 

 
Figure 2-15: Create Complex Region 

Complex Region Methods 
In your Tool Settings Window you have four Methods to choose from. Starting from the 
circles and line in Figure 2-16, these four methods have the following effect: 
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Figure 2-16: Starting Point 

 Intersection 
Intersection creates a Complex Region out of the area where the two shapes overlap. 

Choosing the two circles, the Intersection looks like Figure 2-17. 

 
Figure 2-17: Intersection 

 Union 
Union creates a Complex Region out of the outermost boundary of the shapes chosen. 

Choosing the two circles, the Union looks like Figure 2-18. 
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Figure 2-18: Union 

 Difference 
Difference creates a Region that is the outside of the first chosen element, minus the outline 
of the subsequently chosen shapes.  

Choosing first the top circle, then the bottom, the Difference looks like Figure 2-19. 

 
Figure 2-19: Difference 

 Flood 
Flood defines an area by searching for enclosing elements around a Data Point sent by the 
user.  

Sending a Data Point into the right side of the area where the two circles overlap looks like 
Figure 2-20. 
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Figure 2-20: Flood 

Fill 
Note you have the same Fill options with Create Complex Region that you had with Create 
Complex Shape. 

Keep Original 
The examples above show the behavior of Create Complex Region with Keep Original 
disabled. Every element that contributes a piece to the resultant Region is deleted. 

If you do not want these elements deleted, enable Keep Original from the Tool Settings 
Window (Figure 2-21). 

 
Figure 2-21: Keep Original 

Tips and Tricks for Flood 
In congested areas on the drawing, it is sometimes difficult to use the Flood Method. Often, 
MicroStation will not find the correct Enclosing Region.  

 Element Selection 
To simplify matters, start by using Element Selection to pick only the elements that make up 
the outline you want to create a region from. Use Flood and data point somewhere in this 
area. Flood will look only for highlighted elements when it looks for an enclosing region. 

 Adjust Max Gap 
If MicroStation can’t find an enclosing region, you may have some slight gaps between 
elements. Try changing your Max Gap value to a higher number (Figure 2-22). If you have 
to set it higher than .1, you may need to make sure that your file is flat and that you have 
selected all of the elements that make up your boundary. 
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Figure 2-22: Create Region dialog – Max Gap 

 Check Flattening your Active File on page 2-90. 

 Elevation to Zero 
Prior to V8i, the available MicroStation macro of “Set/Lock Z” will help make sure that you 
are measuring on the same plane and get the correct area measurement.  This macro is 
located at Macros > Set/Lock Z in the older workspace.  In the newer version of 
MicroStation, the Depth Lock has been removed and the ACS Plane Snap lock was added.  
When using 3D MicroStation design files, you can draw at elevation zero by keying az=0 
into the Key-in dialog, pressing Enter, and click in the CAD View.  This changes the 
Auxillary Coordinate System (ACS ) Z value to 0. To further hold the elevation, enable the 
ACS Plane Snap lock by selecting Settings > Locks > ACS Plane Snap from the 
MicroStation menus.  This will help make sure that you are measuring on the same plane and 
get the correct area measurement.  You can also draw at different elevation by using the same 
technique, except key-in az= and specify the elevation you want after the “=”. 
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  IINNTTRROODDUUCCTTIIOONN  TTOO  TTHHEE  TTAASSKK  MMEENNUUSS  
The Task Menus are our one-stop-shopping for establishing standard MicroStation 
procedures and properties. We are going to use it to develop everything from standardizing 
text height to launching macros.  
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STRUCTURE OF THE TASK MENUS 
The Task Menus works kind of like a menu structure: it contains hierarchy of tasks sorted by 
groups of tasks. A Task can be a single standard tool, a custom tool, or mixture of both types. 
Tasks are grouped into categories that make it easier to find the Tasks you are looking for.  
For example, if you want to dimension something on a plan, you would select the task group 
named Plan and the sub-group named Prop. Text and Dims.  When you select a tool from the 
Prop. Text and Dims group, it will automatically select the appropriate tool and set the 
correct color, weight, level and other setting associated with placing proposed text and 
dimensioning.  

The Many Faces of the Tasks Menus 
When you start MicroStation, the Tasks Menus will appear on the left side of the 
MicroStation interface.  It will look like what is shown below (Figure 2-23). Your 
WorkGroup will be automatically listed as one of the tasks groups.  In this example, 
BridgeGroup is listed as the WorkGroup. 

 
Figure 2-23: Tasks Menus 

The Tasks Menus can be pinned to the side of the MicroStation. To access the Tasks sub-
groups, simple single left click on the appropriate Task group, e.g., BridgeGroup, etc. This 
will open another set of Tasks groups. Two examples of selecting the Task sub-groups are 
shown in red below. The first example is shows selecting the Task sub-group named 
BridgeGroup.  The adjacent example is shows selecting a BridgeGroup task sub-group 
named Structural Detail (Figure 2-24).  
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Figure 2-24: Navigating Down Sub-group Tasks - Examples 

You can single left click the Task sub-group name to return to that level of the Tasks groups 
hierarchy (Figure 2-25).  When you hold your cursor over the Task sub-group, it will turn a 
white color. 

       
Figure 2-25: Navigating Up Sub-group Tasks - Examples 
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When you have selected the bottom of the Tasks sub-group hierarchy, the individual Tool 
groups will be shown and can be selected with a single left click (Figure 2-26).  To close the 
view of the tools, click another Task sub-group or Tool group. 

 
Figure 2-26: Tasks Menus - Tools 

Tool groups can be opened as a Toolbox by right-clicking on any tool and selecting Open 
“Tool group name” as Toolbox (Figure 2-27). The Toolbox can be docked into the 
MicroStation interface. 
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Figure 2-27: Tasks Menus – Tool Group Shown as Toolbox 

Opening the Tasks Menus 
The Tasks Menus are autoloaded depending on the work group and the working units of the 
file, if the file is opened using the File Open and a PIN is selected. Other work group task 
menus can be opened at anytime by selecting Maine DOT WorkGroups  > <Pick Work 
Group>.  Multiple menu’s can be opened at the same time if needed, also dock them over 
top of each other and then click from tab to tab to quickly access a work groups tools.  If 
finished with a work group toolset, close and continue using your standard menus. 
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DRAWING SCALE 
One of the primary functions of the Scaling tool is to help us standardize text and dimension 
size. It can also help us make sure that our symbols and cells all come into our drawings at 
the right size. This is accomplished through careful manipulation of the Settings Drawing > 
Scale.  

Real World Size vs. Paper Size 
There is some confusion over the concept of drawing “One to one” or “Full Size” and how 
that impacts the scale of the drawing. If you’re drawing one to one, how could you possibly 
have a scale applied? Isn’t everything full size?  
The answer is “yes -- but there is more than one kind of full size.” 

How is that possible?  

The AutoCAD terminology for this calls the two sizes “Paper Space” and “Model Space.”  

When you’re detailing up an abutment, you want to make sure that a 3 foot wing measures 3 
foot on the drawing -- that’s “Model Space” -- your “Model” of the abutment measures the 
same size in your file that it will measure out in the field. 

But what about when you want to annotate the abutment? You know that when you get your 
finished plot back from the printer you want your annotation text to be 0.5 inches high. But 
what does that 0.5 inches high mean to your 3-foot wing? Nothing -- because those 0.5 
inches are in “Paper Space” instead of “Model Space.” 

So how do you reconcile the two? That’s where the Drawing Scale comes in.  

Selecting a Scale 
Navigate to Settings > Drawing Scale (Figure 2-28). 

 
Figure 2-28: Drawing Scale 

This opens up the Drawing Scale Dialog (Figure 2-29). 
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Figure 2-29: Select Drawing Scale Dialog 

Let’s say we select 1in. = 25 ft. (1:300) as our scale.  

What does this change? 
What does this do for us? All this does is change the scale of the items created using the 
Tasks Menus. From here on out, anything tool we use from the Tasks Menus is going to 
know that it needs to be at the selected scale. We’ll see the impact of this when we use the 
Tasks Menus to place text and dimensions, as well as certain cells, line styles and borders. 
Changing the Drawing Scale can change the size of text, cells, and dimensions in your 
drawing.  Normally, all elements in the drawing are placed using a single Drawing Scale.  If 
you need to place elements in another scale, create a new Design file and reference that file 
to the Design file using different Drawing Scale. 

 Note again that this may have an impact on items already placed in the drawing.  

This is not at all like changing our Working Units. Drawing Scale uses its internal scale 
settings only to help you place new text and cells at the right size. Once your text and cells 
has been placed, changing the Drawing Scale will change the size of the text and cell that 
have already been placed.    



mdot MicroStation 

08/8/12 

MaineDOT MicroStation & 
InRoads Procedures 

2-27 
 

  FFEENNCCEESS  &&  GGRROOUUPPSS  
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SELECTION SETS 
Select All 
From your main menu, choose Edit > Select All. MicroStation will pick every element in 
your file. 

 Even elements that are not currently displayed will be selected. This includes 
construction elements and elements on levels that have been turned off. 

Select None 
To clear a Selection Set, you can always choose Edit > Select None from your main menu. 

Element Selection 
The Element Selection tool (Figure 2-30) can be used to pick single or multiple elements for 
processing.  

 
Figure 2-30: Element Selection 

 Use of Element Selection changes the order in which you pick commands. Generally 
you pick your command first, then the element you want to affect. Using any element 
selection tool, you pick your elements first, then the command to alter them. 

To select more than one element, hold down the Ctrl key when you click on new elements. If 
you select the wrong element, hold down the Ctrl key and click on it again to remove it from 
the Selection Set.  

 Notice that when you add elements to a Selection Set, MicroStation displays the 
number of elements you have selected. This number is displayed in the right corner of 
your Status Bar as shown in Figure 2-31. 

 
Figure 2-31: Count of Elements 



mdot MicroStation 

08/8/12 

MaineDOT MicroStation & 
InRoads Procedures 

2-29 
 

To select elements over a wide area, click in empty space and drag. This will create a box. 
Elements entirely inside this box will be added to the Selection Set. 
If you hold down Ctrl + Shift and drag the same box, it will add all elements overlapping the 
box to the Selection Set.  

Element Selection 
The Element Selection (Figure 2-32) tool is a more powerful way of quickly assembling 
Selection Sets.  

 
Figure 2-32: Element Selection    

By changing Methods and Modes, elements can be added, subtracted, or inverted to a 
Selection Set. 

Methods 
By changing your Method, you can identify items singly, by block, shape or line.  

Individual: selects graphically one element at a time  

Block:  elements inside the block are selected 

Shape:  elements inside a shape are selected  

Circle:  elements inside the circle are selected  

Line: selects elements that intersect a line  

Modes  
New: clears the current selection set and starts a new set. 

Add: adds elements to a selection set 

Subtract: subtracts elements from a selection set 

Invert: toggles the selection status of an element  

Clear/Select All: deselects all selected elements, or selects all elements if no elements are 
currently selected. 

 Block and Shape Methods can be switched from Overlap to Inside just by clicking 
again on the respective icon in the Tool Settings Window.  

“Permanent” Grouping 
Once you have elements gathered together into a Selection Set, you might want to “cement” 
them together. 
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With the elements selected, pick Edit > Group.  

Notice that once you have grouped elements together, the number of elements in your 
Selection Set drops to “1”.  

These elements have been joined together the same way elements of a cell are joined 
together. The only difference is that these “cells” don’t have cell names. MicroStation refers 
to them as Orphan Cells. They can be modified and manipulated exactly the same way cells 
are. To drop these Orphan Cells back to their original independent state, use the Drop 
Complex tool.  
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ADVANCED ELEMENT SELECTION 
Setup 
There is a little arrow in the lower right-hand corner of the Element Selection Dialog (Figure 
2-33). 

        
Figure 2-33: Show Extended Settings              Figure 2-34: Expanded Element Selection 

To expand the Element Selection click on the Show Extended Settings arrow to reveal the 
Attribute tabs (         Figure 2-34). 

Tabs 
Level: select levels from a list  

Color: select the required colors from a list (plus ByLevel). 

Line Style: select the required line styles from a list (0–7 plus custom line styles present) 

Line Weight: select the required line weights from a list (0–31 plus ByLevel). 

Element Type: select the required element types from a list. 

Element Class: select the required element classes from a list. 

Element Template: select the required element template from a list. 

Adding Elements 
Say you want to add all elements in a level to your Selection Set.  
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Start by choosing Level tab from your Tool Settings Window. 

Now Click the Level Name from the list of level names. Notice that the elements are 
highlighted and the level name moves to the top of the Level list (Figure 2-35). 

         
Figure 2-35: Level Dialog                       Figure 2-36: Color Dialog 

All elements on S_Roadway_Centerline level have been added to your Selection Set.  
Now add all elements of color 2 to the set by choosing Color tab from the Element Selection. 
Notice that Color 15  is at the top of the list (Figure 2-36). 

The Color 15 is the color of elements already selected (elements on the 
S_Roadway_Centerline level that was selected above from the Level tab). To add color 2 to 
this list, Click the cursor in the “color 2”. Notice in (Figure 2-37) number 2 moved to the top 
with 15. All the elements with the color 2 have been added to the Selection Set. 
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Figure 2-37: Colors 2 and 15 Selected 

 This does not mean that all elements of color 2 and 15 are selected: it only means that 
there are elements of these colors in this Selection Set. 

Subtracting Elements 
You can also use this feature to remove specific colors, levels, styles and weights from your 
selection set. Start by selecting all Levels that have elements, either by choosing Edit > 
Select All or by Clicking on the first level that is not highlighted and dragging to display all 
of the levels and release. Now check out the Level tab, all the levels that are present in the 
Selection Set (Figure 2-38) have elements. 
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Figure 2-38: All Levels Picked 

Clicking on the level name will remove all the elements on that level from the Selection Set.  

Color, Style, Weight, Type and Class 
By Clicking on the list from Color, Style, Weight, Type and Class tabs the elements can be 
manipulated the same way as the Levels. 
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SELECT BY ATTRIBUTES 
Overview 
Select By Attributes is an extremely useful tool for making focused alterations to a design 
file. You could use it to help accomplish any of the following: 

• Move all text to MINOR. 

• Delete all lines that are Color 5 and Weight 4. 

• Change all elements on PBSUPER to be Construction elements. 

The Select By Attributes tool allows you to specify certain Element Criteria. It then searches 
through the file and selects elements that match those search criteria. 

The Select By Attributes dialog (Figure 2-39) can be opened from the main menu by 
selecting Edit > Select By Attributes. 

 
Figure 2-39: Select By Attributes Dialog 

Standard Methods 
The simplest application of the Select By Attributes tool uses the default settings. 

In the Levels, Symbology and Types areas of the Select By Attributes dialog pick your 
search criteria. The example in (Figure 2-40) shows what the dialog would look like if you 
wanted to pick all text in levels PRPTY ENVRN and RIGHT OF WAY that is also of color 
5. 
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Figure 2-40: Select By Attributes Dialog 

 Note that since Style and Weight are not selected, this process will identify elements 
of any style or weight. 

Push the Execute button and MicroStation will add all elements that match these criteria to a 
Selection Set. 

Element Type Hints 
• The Types are of the Select By Attributes Dialog is not always straight forward. Here 

are a few hints that should make it easier to select the elements you want. 

• Multi-line text is Text Node type. Single-line text is the Text type. Typically, if you want 
one, you want both of them. 

• For circles, the Type you want to choose is Ellipse. 

• To pick SmartLines with arcs in them, choose the Complex String type. 

• Similarly, any closed area with arcs would be the Compels Shape type. 

• SmartLines without arcs are Line Strings.  

• All closed polygons (squares, triangles, rectangles, etc.) are Shapes.  

• Leaders placed by the Place Multi-Line Note tool are Dimension types. 

• Right-clicking in the Levels and Types fields Select By Attributes Dialog gives the 
option to Select All, Select None or Invert Selection. 

• Elements grouped together by selecting Edit > Group are Cells. 
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ADVANCED SELECT BY ATTRIBUTES 
Overview 
Up until now, we have only used the default Mode settings of the Select by Attributes tool. 
These are good enough to get you where you need to go 90% of the time. But there are a few 
things you might want to do that you’ll need some extra help with. For example, you might 
want to: 

• Pick all elements except text. 

• Delete all color 5 lines from one part of your drawing. 

• Move all filled elements to level CENTERLINE. 

• Delete all text of font 24. 

Modes 
The first thing to look at is the Modes section of the Select By Dialog. There are two areas 
we’ll focus on. The first allows you to select either Inclusive or Exclusive modes (Figure 
2-41). 

 
Figure 2-41: Inclusive/Exclusive  

Inclusive, the default setting, means that all elements that match your criteria will be 
affected. 

Exclusive means that all elements except those that mach your element criteria will be 
selected.  

 Therefore, to pick all elements except text, set your Type field to Text and Text 
Node, set your Mode to Exclusive and push Execute. 

The other parts of the Mode allow you to choose how you want to act on the elements you 
have selected (Figure 2-42). 

 
Figure 2-42: Selection/Location/Display 

Selection, the default settings, adds the identified elements to a Selection Set.  
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Location allows you to “lock down” elements other than your identified elements. Only 
elements that match your criteria will be accessible to MicroStation commands. This will 
prevent you from copying, matching, or deleting any but your identified elements. 

Display makes all other elements invisible. Only elements that match your criteria will show 
up on your window. 

 Using the Display mode will have minor adverse effects on “dynamic” displays. This 
means fences, selection sets and other “rubber-banding” affects may not display as 
you’d expect. All the tools still work as normal, though. 

Properties 
At the bottom of the Select By Attributes Dialog you will find the Properties button 
(Figure 2-43). 

 
Figure 2-43: Properties 

Pushing this button gives you access to more element selection criteria via the Select By 
Properties Dialog (Figure 2-44). 

 
Figure 2-44: Select by Properties Dialog 

Two parts of this dialog are likely to be useful to you. 

From the Properties portion, you can place a Check next to the Non-Filled option and 
choose to select by whether or not an element is Filled. 

From the Class area, you can select whether you want to pick Construction or Dimension 
elements. 

 Even after you drop Dimensions into their component elements, those elements are 
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still in the Dimension Class and can be selected together by the Class portion of the 
Select By Properties Dialog.  

More Properties 
From the Select By Attributes Dialog, you can open up four more dialogs that control 
settings for specific kinds of elements under the Settings Menu (Figure 2-45). 

 
Figure 2-45: Settings Menu Properties 

These options allow you to select cells and text by very specific element attributes. 

Set Select By From Element 
If you don’t know exactly what attributes you want to select by, but you know of an element 
on your drawing that is an example of those criteria, you can choose Tools > Set Select By 
From Element from the Select By Attributes Dialog Main Menu.  

This brings up the Set Select By Dialog (Figure 2-46). 

 
Figure 2-46: Set Select By 

Toggle on or off each item on the dialog depending on whether you want to select based on 
that criteria, then identify the element in your file to match.  



mdot MicroStation 

08/8/12 

MaineDOT MicroStation & 
InRoads Procedures 

2-40 
 

FENCES 
Discussion 
With all the capability of the Element Selection tools, you could ask if there is really any 
need for another way of grouping elements. 

Fences are more of an old-fashioned way of working in MicroStation, and they are not as 
necessary for day-to-day drawing as they used to be. 

There are, however, some important reasons to keep fences in your arsenal. 

One is processing time. If you have to move a lot of elements, it is usually quicker to fence 
them than to select them. This is because the selection tools require more redrawing of the 
elements to the views. 

Another reason to use fences is to clip elements by setting your Fence Mode to either Clip or 
Void-Clip. 

A less common application would be to use the Void mode to process all elements outside the 
fence boundary. 

Fence Types 
When you choose the Place Fence tool (Figure 2-47) you have a number of options of what 
kind of Fence you would like to place (Figure 2-48). 

                
Figure 2-47: Place Fence       Figure 2-48: Fence Types 

• Block allows you to define two corner of a rectangle. 

• Shape allows you to define up to an unlimited number of vertices of a polygon. 

• Circle allows you to define a center and radius for a multi-vertex polygonal 
approximation of a circle. 

 This is not really a circle, but it’s pretty close. Use it accordingly. 

• Element allows you to pick an element. MicroStation will approximately overlap the 
Element’s outline with a fence. 
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• From View will place a fence that matches the view outline. 

• From Design File will pick all elements in the design file. 

• From Flood sets a fence to include the (minimum) area enclosed by a set of elements. 

Fence Modes 
Once you have placed a fence, you can change your Fence Mode to affect elements that are 
either Inside or outside your fence, Overlapping it or not, or even Clipping elements at the 
point that the fence crosses them (Figure 2-49). 

 
Figure 2-49: Fence Modes 

• Inside affects only elements entirely inside the fence. 

• Overlap affects elements with any part in the fence. 

• Clip affects all elements inside the fence, cutting elements where they cross the fence 
boundary. 

• Void affects all elements entirely outside the fence. 

• Void-Overlap affects all elements with any part outside the fence. 

• Void-Clip affects of all elements outside the fence, cutting elements where they cross the 
fence boundary. 

 Area of Influence 
Selection Sets specifically identify particular elements. No matter how you process them, you 
never will process elements other than the ones you initially selected. This is not the way 
Fences work.  

Fences always affect the elements that lie within their selection area (bearing in mind your 
active Fence Mode.) Every time you move or copy a fence from one location to another, you 
are defining a new area of influence, and can potentially be picking up new elements to 
process. 

 Deactivating Fences 
The way to deactivate a fence is to choose the Place Fence tool. This immediately clears 
your active fence. 
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GRAPHIC GROUPS 
Overview 
 Graphic Groups are common even if you don’t create them yourself: they are often the 

by-product of translations or custom applications. Be aware of their functionality. 
Graphic Groups are yet another way to bunch elements together for quick processing. They 
are more like Selection Sets than fences, since they single out specific elements rather than 
affecting all elements in a specific are the way fences do. 

Graphic Groups have one special capability: elements in Graphic Groups can be moved 
independently or simultaneously depending on the current status of your Graphic Group 
Lock. 

Graphic Group Lock 
Graphic Groups rely on the Graphic Group Lock. This can be toggled on and off from the 
Locks portion of your Status Bar (Figure 2-50). 

 
Figure 2-50: Locks in the Status Bar 

When the Graphic Group Lock is turned on, all elements in the same Graphic Group are 
grouped together much like a single cell or Selection Set: they can be copied, rotated, moved 
or deleted as one. 

However, when the Graphic Group lock is turned off, the elements are all affected 
completely independently of each other.  

Adding Elements to a Graphic Group 
Elements can be added to a graphic group either singly or by Selection Set.  
To add elements one at a time, choose Group > Groupings > Add to Graphic Group from 
your main menu, or pick the Add to Graphic Group tool from your Task Menus (Figure 
2-51). 
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Figure 2-51: Add to Graphic Group 

Once the tool is activated, pick all the elements you’d like to add to the group.  

To add a bunch of elements to a Graphic Group, add them to a Selection Set (by Element 
Selection, for instance). Then choose the Add to Graphic Group command and Data Point 
to accept the action. 

Removing Elements from a Graphic Group 
Graphic Groups can be dropped either singly or all at once. To drop elements from a 
Graphic Group one-at-a-time, make sure your Graphic Group Lock is turned off. Pick the 
Drop from Graphic Group command from your Task Menus (Figure 2-52) or select 
Group > Groupings > Drop from Graphic Group from your menu. 
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Figure 2-52: Drop from Graphic Group 

Once you have chosen the tool, pick the elements you’d like to remove from the Graphic 
Group. 

To drop an entire Graphic Group, follow the same routine as above, making sure that 
Graphic Group Lock is turned on instead of off. 

Adding Elements to an Existing Graphic Group 
You may want to add a couple of elements to an existing Graphic Group.  

Choose the Add to Graphic Group tool. When it prompts you to “Add to Graphic Group > 
Identify Element” start by picking an element that is already in the Graphic Group you want 
to add to. Then go on to select the elements you would like to add to the Graphic Group.  
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  AACCCCUUDDRRAAWW  
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FUNDAMENTALS OF ACCUDRAW 
 See page 2-53 for a detailed example of using AccuDraw. 

Introduction 
Launch AccuDraw from the Primary Tools toolbox by pressing the Start AccuDraw 
Button (Figure 2-53). 

    
Figure 2-53: AccuDraw Start  Figure 2-54: Rectangular AccuDraw Window 

Somewhere on your screen you’ll see the AccuDraw window (Figure 2-54). 

The window may be in its Distance/Angle format as well (Figure 2-55). 

 
Figure 2-55: Polar AccuDraw Window 

It’s also possible that the AccuDraw window will be docked (Figure 2-56). 

 
Figure 2-56: Docked AccuDraw Window 

When you place a data point in the drawing, it will bring up the AccuDraw Compass. In 
Figure 2-57, you can see AccuDraw in Rectangular mode.  

 
Figure 2-57: AccuDraw's Rectangular Compass 

 Use the Rectangular mode to draw xyz distances as well as slopes expressed as xy. 

In Figure 2-58 you can see AccuDraw in its Polar mode.  
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Figure 2-58: AccuDraw’s Polar Compass 

 Use Polar mode to draw lines at a fixed angle or bearing. 

Press your [Spacebar] key to toggle back and forth between distance and angle mode. 

Shortcut Keys for Construction 
O allows you to place the AccuDraw Compass at a specific point without placing a 
Datapoint.  
RQ allows you to spin the AccuDraw Compass. 

V rotates the AccuDraw Compass to be aligned with the view. 

A locks the angle in  
X, Y and Z lock the corresponding AccuDraw Axis.  

[Enter] locks the AccuDraw Axis along whatever axis the user is gesturing. 
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ACCUDRAW SETTINGS 
You can access AccuDraw’s settings by typing GS into your AccuDraw Window or from the 
Main Menu Settings > AccuDraw. This will bring up the AccuDraw Settings Dialog 
(Figure 2-59). 

 
Figure 2-59: AccuDraw Settings Dialog 

Operation Tab  

Auto Load: If on (the default), when MicroStation is started loads AccuDraw automatically 

Floating Origin: If on (the default), the origin moves to the last point placed  

Context Sensitivity: If on (the default), enables tools to provide “hints” to AccuDraw to 
override its default behavior for smoother operation  

 Context Sensitivity won’t do anything without Floating Origin turned on. 

Smart Key-ins: If on (the default), AccuDraw interprets a number as positive or negative, 
depending on the direction of the pointer from the compass. In rectangular mode only, causes 
AccuDraw to move the focus to either the x or the y field depending on pointer position. 

Auto Point Placement: When on, places data points automatically when they have been 
fully constrained (default is off) 

Sticky Z Lock: If on (default is off), when you lock the Z axis, for example, where you want 
to draw on the one plane (that is, you want to lock Z=0), while snapping to elements that are 
on another plane  the Z value will remain locked until you turn it off. 

Always Show Compass: If on (default is off), when is activate AccuDraw, the compass 
displays before placing a data point for the current operation. 

Auto Focus Fields:  If on (the default), the <A> and <D> AccuDraw shortcuts set focus to 
the selected field and lock the current value. If off, the <A> and <D> AccuDraw shortcuts 
lock the current value without affecting the focus. 

Default Origin: Lets you choose the default origin. When a tool starts AccuDraw and there 
is no origin currently defined, then this setting specifies the default location of the AccuDraw 
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drawing plane origin. Options are: 

View Center on active Z: The AccuDraw origin is centered in the view, at the   
          Active Z depth 

Global origin: The AccuDraw origin at the Global Origin of the file 

Global origin on active Z: The AccuDraw origin at the Global Origin of the file   
           and at the Active Z depth] 

Display Tab  

 
Figure 2-60: AccuDraw Settings Display Tab Dialog 

X axis, Y axis, Hilite, Frame, & Fill: The colors on the AccuDraw compass, via an option 
menu can be changes for the X axis, Y axis, negative X and Y axis and compass frame. 

 
Delayed Update: If on (default is off), the coordinates are updated in the AccuDraw window 
when pointer is at rest. If off the coordinates are continuously updated, as the pointer move. 

Display Coordinates:  If on (default is off), a coordinate display at the pointer shows the 
increments in the x, y, and z (for 3D) directions from the previous data point. 

Show Negative Angles: If on (default), AccuDraw displays negative angles (+/-180°) 

Pop-up Confirmation: If on (default), AccuDraw displays shortcut pop-ups.  
Shortcut Key-ins: Opens dialog that lists AccuDraw shortcut keys. 

Coordinates Tab 
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Figure 2-61: AccuDraw Settings Coordinates Dialog 

Rotation: The AccuDraw compass can be rotated: Top, Front, Side, View, Auxiliary and    
      Complex. Context lasts only for the current drawing tool. 

Type: Sets AccuDraw Compass to Rectangular or Polar. 

Unit Roundoff: This works like a grid, that helps place “freehand” drawings to a specific 
    Distance and Angle. 

 

Indexing: The Distance required to move the pointer from the indexed Axis is controlled by 
      the Tolerance setting. 

 Tolerance is measured in screen pixels, 1-99 allowed 
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ACCUDRAW SHORTCUT COMMANDS 
AccuDraw shortcut commands are invoked by typing either the single letter or combination 
of two letters as outlined in the AccuDraw Shortcuts dialog (Figure 2-62).  

 
Figure 2-62: AccuDraw Shortcuts Dialog 

 Note that these shortcuts will only run if AccuDraw has focus. For a complete list of 
shortcuts, type (Shift+?). 
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Figure 2-63: AccuDraw Docked - Focus OFF 

Note also that the Tool Settings Window has Focus (like the Place SmartLine window in 
Figure 2-63) and AccuDraw is grayed. The Esc key toggles focus back and forth between 
AccuDraw and the Tool Settings Window. If I were to hit the Esc key (located in the upper 
left of my keyboard), the Focus will change to the AccuDraw (Figure 2-64) and the Place 
SmartLine window is grayed. 

 
Figure 2-64: AccuDraw Docked - Focus ON 

Some Important Shortcut Keys 
Try to get used to using the K, N, C, O and I shortcuts to activate your Keypoint, Nearest, 
Center Origin and Intersection snap modes. 
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ACCUDRAW EXAMPLE: ROADWAY TEMPLATES 
Calculating Slope 
AccuDraw can be used to calculate your cross slopes easily. The basic theory is to figure the 
“drop” for the distance and slope of your lane. Mathematically, to know how far a 3.3 m lane 
will “drop” at a -2% slope, you would multiply 3.3 * .02. This results in a .066 m drop. 
AccuDraw can do this for you in one easy step. 

First select the SmartLine and place the first point. 

Move your cursor in the X direction so that AccuDraw sets its focus in the X field. Input your 
lane width 3.3 meters as a horizontal distance (Figure 2-65).  

 
Figure 2-65: Enter Width in AccuDraw 

Move the cursor in the Y direction, shifting the “focus” of the AccuDraw window 
accordingly. (For a negative slope move the cursor down or up for a positive slope.)  

Enter the horizontal distance again, 3.3m. Then, using [SHIFT 8], evoke the multiplication 
function of AccuDraw and enter .02. By entering your slope in decimal form, you will be 
multiplying the lane width by the slope to calculating the drop (Figure 2-66). 

 
Figure 2-66: Calculate Vertical Drop Based on Slope 

By accepting this position, you have just placed a line that extends the width of your lane and 
drops according to your decimal slope. If you then hit the “V” on your keyboard, the 
AccuDraw compass will rotate parallel to the view and you can continue placing a shoulder 
without quitting the SmartLine command. 

Placing AccuDraw’s Origin 
You can change the origin of your line and make it relative to a position on the screen. This 
comes in handy when drawing typicals from scratch. For instance, if you drew the finished 
grade using the distance/slope method described earlier, you could use the Origin function of 
AccuDraw to lay your pavement lines. 

First, snap to the place that you want to move your origin from. 
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In this example, you would start with the smart line command and then snap on the centerline 
position of the finished grade (Figure 2-67). 

   
Figure 2-67: Tentative on the Centerline  Figure 2-68: AccuDraw Origin 

Without accepting that position, hit the “O” on your keyboard to invoke the Set Origin 
function of AccuDraw (Figure 2-68). 

This will allow you to move your cursor without actually drawing a line. If you move your 
cursor in the Y direction, you can then input the exact distance you want to move away from 
your snap point and begin drawing. So if you wanted to move down 50 mm and start drawing 
again, you would move your cursor down and then type in -0.05. By accepting that position 
with a data point you can begin to draw again (Figure 2-69). 

 
Figure 2-69: Free to Draw 

Likewise, you can use multiple Origins to move first in one direction, and then another. With 
this functionality, you will hardly ever have to use construction lines. The AccuDraw Origin 
will allow you to move around and position your cursor almost anywhere in relation to other 
elements in your design file. 
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DRAWING IN SUB-UNITS 
Sometimes, it is easier to draw in sub-units. With the introduction of the metric system, the 
conversion to master units is made quite easy.  

1000 mm = 1m  

500 mm = 0.5m  

30 mm = 0.03m  

…and so on and so on. But still, there will be times when you will want to draw in sub units, 
especially for U. S. Customary jobs. 

This is done easily and simply with AccuDraw. All you need to do is choose your starting 
point for your line and then input the distances using a colon or semicolon (: or ;) before the 
numbers (Figure 2-70).  

 
Figure 2-70: Subunits in AccuDraw 

This tells AccuDraw that you will be using the sub-units. For instance, if you were working 
in an U. S. Custom job (ft, in) and wanted to draw a line that is 6.25 inches long; all you 
would have to do is input that distance in your AccuDraw window with :6.25 (Using the 
proper X,Y, Z depending on what direction you want to move in).  
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DRAWING BY COORDINATES 
Using the Data Point Keyin 
Sometime you may want to draw a line, place a cell or other type of element at certain 
coordinates in a drawing. Some files are at their intended State Plane Coordinate System (i.e. 
topo, contours, highway, bridge, alignment, etc.) and others are not dependent on the 
coordinate system (i.e. 3 digit prefix plan sheets and z files). 

Start a command that will utilize a point placement method (i.e. Place Line, Place Active 
Cell, etc). When ready to enter a coordinate position, verify that you have focus in AccuDraw 
and type “P” to activate the Data Point Keyin dialog.  

 
Select Absolute (xy=) from the pull down. Enter the coordinate’s points for the X, Y and Z 
values separating them by commas. If you need the dialog for multiple points, type “MI” for 
multiple keyin points. 

 Please refer to MicroStation’s HELP menu for more information about the 
different methods of the Data Point Keyin. 

Locking AccuDraw's Compass at 0,0 
By default, your AccuDraw compass is setup to reside at the last point that is selected in a 
file by clicking a data point. If a line is drawn, the AccuDraw compass is at the end of the 
line, rotated along the line so that a user can draw easily draw a perpendicular line from the 
last point or an arc that is tangent to the line just drawn.  

At times you may want to set AccuDraw at 0,0 so that the lines, arcs, cells or text placement 
can be relative to 0,0 in your file. You can adjust your AccuDraw settings so that the 
compass is locked at 0, 0 and doesn’t follow (Float) or move to the last data point or to the 
end of a line. To lock your AccuDraw compass at (0, 0) in your drawing, go to Settings > 
AccuDraw and while displaying the Operation tab, uncheck Floating Origin. Now go to 
Utilities > Key-in and type in AccuDraw Setorigin 0, 0, 0. This keyin can be added to a 
Function Key for quick activation. Sometimes you may want to temporarily move your origin 
to the end of a line so that you can draw lines based on an angle or bearing. You can still 
move this origin by using the AccuDraw shortcut key “o” (origin) and the “RQ” (rotate 
quick) functionality or “T” (top rotation) to rotate the compass to a top view (+Y = north). 
Reset your origin to 0, 0 in the file by typing the keyin again. 

 Refer to previous pages in this chapter for more information about AccuDraw’s 
shortcut keys, setting its origin and floating origin. 
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COORDINATE READOUT 
Control the display of your working units from your Main Menu by selecting Settings > 
Design File > Working Units (Figure 2-71). 

 
Figure 2-71: Design File Working Units 

This area is going to control how MicroStation displays linear and angular measurements to 
you.  

Linear Units, Accuracy 
In the Linear Units area of this dialog, choose Format (Figure 2-72) and Accuracy (Figure 
2-73).  

                          
Figure 2-72: Coordinate Format                                Figure 2-73: Coordinate Accuracy 

The Format should be set to Master Units for working in metric drawings. 
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 The only time you would set Format to other than Master Units would be for U S 
Custom work. You might set it to Sub Units to display Imperial projects in feet and 
inches (whereas keeping it set to Master Units in Imperial will display data in 
decimal feet.) 

Set your Accuracy to reflect how many decimal places you want your measurements 
displayed to. 

Angle Accuracy and Mode 
From the Angles Readout category of the Design File Settings Dialog you can control the 
Format (Figure 2-74), Mode and Accuracy (Figure 2-76) of MicroStation’s angular display. 
Choose whether you want the Format of your angular display to be in decimal degrees or in 
degrees, minutes and seconds. 

                 
Figure 2-74: Angle Format 

 Note that if your Format is DD MM SS, then your Accuracy is the number of 
decimal Seconds you want displayed. 

Choose whether you want your Mode to be Azimuth, or Bearing. Azimuth angles start with 
0° at 12:00, increasing clockwise (90° would be at 3:00). Bearing angles are expressed in 
terms of North/South X° East/West (Figure 2-75). 
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Figure 2-75: Angle Mode 

Set your angular accuracy to as many decimal places as you want (Figure 2-76). 

 
Figure 2-76: Angle Accuracy 

 



mdot MicroStation 

08/8/12 

MaineDOT MicroStation & 
InRoads Procedures 

2-61 
 

MEASURING PART 1 
You can access all measuring commands from your Main Menu by selecting Measure 
(Figure 2-77). 

 
Figure 2-77: Measure Menu 

Circle Radius, Length, Area, and Volume require that you simply identify one element.  

 Circle Radius can be used to measure the radius of arcs and ellipses as well. 

Angle and Distance > Minimum require that you identify two elements.  

 Perpendicular measuring sometimes gives unexpected results in 3D files. If you 
encounter this, flatten your file and try again or try the Measure Distance Between 
Points command while using AccuDraw to get the Perpendicular distance. 
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MEASURING PART 2 
Measuring Areas 
With a basic understanding of Region Creation, measuring areas becomes straightforward. 

From your Task Menus, select Measure Area (Figure 2-78) or choose Measure > Area 
from the Main Menu. 

   
Figure 2-78: Measure Area                  Figure 2-79: Measure Area Methods 

A brief look in the Tool Settings Window should reveal some familiar Methods (               
Figure 2-79). 

Element: measures the area of a single closed element 

Fence: measures the area of a fenced area. 

Intersection: measures the area where two or more closed elements overlap. 

Union: measures the total area encompassed by two or more closed elements. 

Difference: measures the area of a single closed element with “bites” taken out by other   
         closed elements. 

Flood: finds an enclosing region around a data point. 
Points: measures the area of a polygon entered by the user. 

Look at Measure > Area Tools for measuring and labeling areas in one fell swoop. 
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MEASURING AREAS AND PLACING TEXT 
Step One: Lock “Z” to Zero 
From the Main Menu, select Settings > Locks > ACS Plane Snap.  Key-in az=0 in the Key-
in dialog and press Enter. Click in the CAD View. 

 This will prevent MicroStation from jumping to elements at different depths in the 
file. 

Step Two: Set the Drawing Scale 
From the Main Menu, select Settings > Drawing Scale.  From the list of available scales, 
select the scale that you intend on plotting your sheets.  

Step Three: Set the Text Attributes 
From the Tasks Menus, select your Workgroup > Plan > Prop. Text and Dims > Text Note 
or Standard Text (Normal). This will set your text to the correct height, width, color, level, 
style and weight. 

Step Four: Open Measure Area Tools 
Select Measure > Area Tools from the Main Menu. A new set of tools should open. 

In the rightmost tool in the Tool Box (Figure 2-80), set some Parameter Settings. 

 
Figure 2-80: Area Parameter Settings 

 Part One: Set the Default Text Font 
While in the Text tab, set the Font to 123 dotitalics (Figure 2-81). This is the only setting 
necessary on the tab. 
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Figure 2-81: Adjust Text Font to 123 dotitalics 

 Part Two: Set the Default Prefix 
Click on the Prefix tab (Figure 2-82). Add a prefix that you would like to use. (i.e., Wetlands 
= ). You’re limited to ten characters. 

 
Figure 2-82: Add a prefix 

 Part Three: Set the Default Suffix 
Click on the Suffix tab (Figure 2-83). Add a suffix that you would like to use. (i.e., s.f.). 
You’re limited to ten characters. 

 
Figure 2-83: Add Suffixes 
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Step Five: Select Measure Area Tool 
From the Area Tools toolbox (Figure 2-84), select Measure Area. 

 
Figure 2-84: Measure Area Tool 

Configure area tool for the method, prefix and suffix. Select one of the methods available. If 
using the Flood method, use the Element Selection and select all bounding elements. If there 
is a gap in any of the connections, correct it or use the Flood method in the Measure Toolbox 
as it allows the jumping of gaps. Click inside the area or on the element (based on the method 
you picked). 

This should label your area. The orientation of the text will be horizontal to your current 
view window which means you will have to rotate and possibly move text. Use the Rotate 
Element tool and set method to either 2 points or 3 points. Follow the prompts. 

 If you cannot see the text for your areas, check that you have done all the steps in this 
section. 

Step Six: Select None 
Select Edit > Select None to unselect any elements that may be currently selected.  
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TIPS AND TRICKS 
We have a number of tools and tips to make the measurement of areas easier. 

Measuring with Flood Method  

 Element Selection  
If you are working in a crowded area, you will have a hard time using the Flood method to 
pick exactly the area you want to measure. This is because Flood is confused by lots of 
crossing lines. To simplify matters, start by using the Element Selection to pick only the 
elements that make up the outline you want to measure. Now use Flood and data point 
somewhere in this area. Flood will look only for highlighted elements when it looks for an 
enclosing region. 

 
Figure 2-85: Measure Area by Flood Options 

 Adjust Max Gap 
If MicroStation can’t find an enclosing region, you may have some slight gaps between 
elements. Try changing your Max Gap value to a higher number (Figure 2-85). If you have 
to set it higher than .1, you may need to make sure that your file is flat and that you have 
selected all of the elements that make up your boundary. 

 Check Flattening your Active File on page 2-90. 

Lock Z to Zero  
From the Main Menu, select Settings > Locks > ACS Plane Snap.  Key-in az=0 in the Key-
in dialog and press Enter.  Click in the CAD View. 
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REFERENCES DIALOG 
From the Main Menus, select File > Reference (DOT) > Dialog. This will open the 
Reference Dialog (Figure 2-86).  

 
Figure 2-86: Reference Dialog 

List box 
Slot: The a number of a File referenced 

File Name: The name of the DGN being attached 

Model: The name of the Model that contains the elements displayed 

Description: A description of the file reference 

Logical: A name assign to the file being referenced 

Presentation: The Display Mode of the graphics 

Display: By clicking the checkmark turns the graphics in the file On or Off 
Snap: When checked On snapping to an element is possible 

Locate: When checked On allows elements to be copied into the Active File 
You must first select a reference file in the List Box before you can change a setting or select 
a tool. However, you can change the Display, Snap, and Locate settings for DGN files simply 
by clicking in that column. 

 

 

 



mdot MicroStation 

08/8/12 

MaineDOT MicroStation & 
InRoads Procedures 

2-69 
 

Icons  

Show Hierarchy: Opens up an additional pane to show the references files in a tree 
schematic 

Attach Reference: Used to attach a reference to the active file 

Clip Reference: Used to display only graphic inside a fence boundary 

Mask Reference:  Used to display only graphic outside a fence boundary 

Delete Clip: Deletes the clip boundary of a reference 

Set Ref Front Clip Z: Sets the front clipping plane for a 3D reference 

Set Ref Back Clip Z: Sets the back clipping plane for a 3D reference 

Reload Reference: Reloads all references, allowing you to see changes made since being 
loaded 

Move Reference: Moves a reference 

Copy Reference: Copies a reference 

Scale Reference: Scales a reference 

Rotate Reference: Rotates a reference 

Mirror Reference: Mirrors a reference 

Copy/Fold Reference: Copies the selected reference, then attaches a view of the reference 
by folding it about an orthogonal axis or a line defined 

Set Reference Presentation: Changes the display: Wireframe, Smooth, etc.  

Detaches Reference: Detaches a reference 

 

Hilite Mode 
Highlighted and/or surrounded a reference by a border when placed in the active file. 

None: Does not place a dashed border or highlight the select reference. 

Boundaries: Places a dashed border around the select reference. 

Hilite: Highlights the selected reference. 

Both: Places a dashed border and highlights the selected reference. 

Main Menu (Tools) 
Attach: Used to attach a reference to the active file 

Detach: Detaches a selected reference  

Detach All: Detaches all references 

Reload: Reloads a reference, allowing you to see changes made since being loaded      
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Reload All: Reloads all references 

Exchange: Toggles from the master file to an attached reference 

Open in New Session: Starts a new session of MicroStation and opens the selected reference 
file 
Activate: Activates the selected reference for in-place editing. A black dot indicates it is 
activated column. Only references that are not open for editing in another session can be 
activated. 
Deactivate: Deactivates a Reference file that was previously Activated 

Move: Moves a reference 

Copy: Copies a reference 

Scale: Scales a reference 

Rotate: Rotates a reference 

Merge Into Master: Merges reference models to the active file 

Make Direct Attachment: Promotes the nested attachment to a direct attachment so it can 
be modified. The nested attachment becomes redundant with the newly created direct 
attachment. Quotation marks under Display, Snap, and Locate indicate a redundant 
attachment. 

Create Drawing Title: Opens the Create Drawing Title window. Click OK to create a 
drawing title with the default drawing title name. 
Mirror Horizontal: Mirrors a reference about the horizontal axis. 

Mirror Vertical: Mirrors a reference about the vertical axis. 

Clip Boundary: Used to display only graphic inside a fence boundary 

Clip Mask: Masks a part of a reference that is inside a fence boundary 

Delete Clip: Deletes the clip boundary of a reference 

Clip Front: Sets the front clipping plane for a 3D reference 

Clip Back: Sets the back clipping plane for a 3D reference 

Main Menu (Settings) 
Attachment: Opens the an Attachment Settings Dialog that is used to set attachment 
information for references 
Update Sequence: Opens the Update Sequence Dialog used to change the order of display 
for references 
Adjust Colors: Opens the Adjust Reference Colors dialog, which modifies or adjusts the 
color table for references 
Reprojection: Opens the Reference Reprojection Settings dialog, which defines the 
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reprojection settings for the selected reference(s). This menu item is disabled if the 
Georeferenced mode is not set to Reprojected. 
Hilite > Boundaries: Places a dashed border around the reference 

Hilite > Hilite: Highlights the reference 

Auto Arrange Icons: If on, icons in the dialog's tool bar wrap when the dialog is resized 

Level Manager: Opens the Level Manager dialog, which is used to manage levels for the 
active model and its references. 
Level Display: Opens the Level Display dialog, which is used to turn on and off levels in the 
active model and its references. 
Presentations: Opens the Set Presentation Dialog used to set presentation for references 
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REFERENCES ATTACH 
Most of the files will already be attached. From time to time files will need to be attached. To 
attach a reference from the same PIN without Browsing: File > Reference (DOT) > Attach. 
This will open up the Attach Reference dialog (Figure 2-87). This is an automated routine to 
look at where you entered MicroStation thru the projects list and place you into the proper 
directory tree. 

 
Figure 2-87: Attach Reference 

Browse to the SURVEY\MSTA directory and select the file and Click OK. If File > 
Reference (DOT) > Attach is not used be sure that you are browsing in the proper directory 
because MicroStation remembers the last place you went to attach a reference file.  

This brings up the Attach Reference Settings Dialog (Figure 2-88). 



mdot MicroStation 

08/8/12 

MaineDOT MicroStation & 
InRoads Procedures 

2-73 
 

 
Figure 2-88: Attach Reference Settings Dialog 

For now work is done in the Default Model. Type in a Logical Name (topo), select 
Orientation (Coincidental-World Global Origin align with Master File), Scale (Master:Ref) 
1:1 and True Scale Checked. Push the OK button. Push Fit View (on the lower left of the 
window border) to see all your reference files. Nested Attachments (Figure 2-89) will be 
grayed if no files are attached to the file being referenced.  

 
Figure 2-89: Nested Attachments 
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Nested Attachments 
Nesting describes how nesting of references is handled. 
No Nesting: References attached to the file being referenced will not be displayed 

Live Nesting and Copy Attachments: References attached to the file being referenced will 
        be displayed and appear in the list of reference 

Depth 
0: References only the file being attached 

1: References the file and any files being reference to it 

2: References the file, any files being reference to it and references any files attached to those 
and so on 

For example, Live Nesting: File B is attached to file A. Further, file B also has file C 
attached. If you detach file C from B, file C will no longer appear as attached to file A. 

Where Copy Attachments:  File A has an attachment, file B which also has an attachment, file 
C, if file C is detached from B, file C will still appear as attached to A unless C has been 
explicitly removed. 

Display Raster References 
When a raster image is attached to a file the Display Raster References icon can be disabled 
to not display the image. 
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REFERENCE FILE MOVING 
Everyone likes to have some control on how the plan appearance looks. You have the ability 
to move your reference files around in your border. 

Select: File > Reference to open the References Dialog box (Figure 2-90). 

 
Figure 2-90: Reference Dialog 

Highlight the reference file or files that you want to move. From the Reference Dialog box, 
select Tools > Move.  

MicroStation will prompt you (in your Status Bar) to “Move Reference File > Enter Point to 
move from.” Enter a data point. MicroStation will now prompt you to “Move Reference File 
> Enter point to move to.” Enter another data point. MicroStation will move all the reference 
files you selected from the first point to the second point. 
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REFERENCE FILE ROTATION 
MicroStation 3D files allow for reference file rotation in the X, Y, and Z-axis. When 
working in a plan view, reference file attachments will only need to be rotated around the Z-
axis.  

Select: File > Reference. This will open the References Dialog box (Figure 2-91). 

 
Figure 2-91: Reference Dialog 

Let’s begin by selecting the file or files you want to rotate. From the Reference Files dialog, 
select Tools > Rotate. This will open up the Rotate Reference File Dialog. Set the angle to 
rotate around the Z-axis and send a data point to your screen. After rotating you may want to 
move the reference files to a more precise location on your border. 
 Refer to Reference File Moving, page 2-75. 
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ATTACHING A RASTER IMAGE TO SCALE 
Determine Image Size 
Before the image is placed in MicroStation, create a rectangle the same dimensions as the 1:1 
paper image multiplied by the original scale of the image. Doing this will insure that the 
Image will be to scale. To do this, open Windows Explorer and browse to the image. Next, 
Rt+click the image and select Properties. Select the Summary tab and click the Advanced 
button. You should see the width and height in pixels and the horiz. and vert. resolution 
(should be the same) (Figure 2-92).  

 
Figure 2-92: Windows Explorer 

Divide the dimensions by the resolution to get the image size in inches. Using the numbers in 
the example above (Figure 2-92), divide 6906 by 200 & 4450 by 200 to get the width and 
height in inches (34.53 x 22.25). Now we have to multiply these dimensions by the original 
scale of the image. If the scale is 1”=25’, the dimensions, both width and height, will need to 
be multiplied by the absolute scale which is 300 (12”x25’). You can calculate these 
dimensions now or use AccuDraw’s built in calculator to calculate the dimensions on the fly. 
In this example, the rectangle will have to be 10,359’ x 6,675’ to be 1:1 (actual size) in 
MicroStation (i.e. 34.53 x 300 = 10,359’ & 22.25 x 300 = 6,675’). 

 If the image will open with Paint, check Image > Attributes for size in inches. 

 The Reproduction Room scans images at 300 dpi’s (dots per inch). 

Place Block 
Start MicroStation, select the Place Block and place the first point. Move your cursor in the 
X direction so that AccuDraw sets its focus in the X field. Input colon :34.53 (subunits) using 
[SHIFT 8], evoke the multiplication function and enter 300 for the horizontal distance. Move 
the cursor down in the Y direction, shifting the “focus” of the AccuDraw window 
accordingly. Enter the horizontal distance :22.25 * 300 for the Vertical distance and enter a 
data point to finish the rectangle.  
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Attach Raster Image 
To attach a Raster Image, select File > Raster Manager. This will open up the Raster 
Manager Dialog (Figure 2-93). 

 
Figure 2-93: Raster Manager Dialog 

From the main menu of the Raster Manager Dialog select File > Attach. When the Attach 
Raster Reference Dialog (Figure 2-92) opens, browse to select the Image File. Enable the 
Place Interactively and Open Settings Dialog options and click OK.  The Raster Attachment 
Options dialog (Figure 2-95) will appear. Adjust the settings accordingly and click Attach. 

 
Figure 2-94: Attach Raster Reference 
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Figure 2-95: Raster Attachment Options Dialog 

MicroStation will ask for Enter Origin, see Status Bar. Place a Data Point at the upper left 
corner of the rectangle previously created for the Enter Origin point. Next place a Data 
Point, in the lower right corner of the rectangle to enter the Enter Corner point. The scale of 
the image can be changed by Scaling the rectangle and detaching and reattaching the image: 
File > Detach and File > Attach. 

To change the Raster Attachment Options after the Raster file is attached, select the Element 
Information icon and click the border of the attached Raster file. This will open the Element 
Information dialog (Figure 2-96).  The Raster Attachment Options can be changed using this 
dialog. 
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Figure 2-96: Element Information 
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GEOREFERENCED IMAGES 
Overview 
MicroStation has the ability to attach Raster Images that have spatial extents. This means that 
the image has a “world” or a “sister” file that contains the X and Y coordinates of where the 
image should sit on the face of the earth. Because of many different potential coordinate 
systems, it is very important that you know what coordinate system your project is based on.  

Browse to your projects directory on the Y: drive (\\oit-
teaqasdtiis.mdot.w2k.state.me.us\pcpin1). Your project’s Survey\MSTA folder contains a 
Status.doc or Status.rpt file. The Status file indicates what the units are for your project and 
the coordinate system used. Any images will have to be “projected” to this same coordinate 
system for the MicroStation graphic and the image to line up. 

Preferences 
Some of the “out of the box” preference will need to be adjusted also for the image to display 
properly and in the correct location. Go to Workspace > Preferences… and select Raster 
Manager from the Category list (Figure 2-97). Adjust your settings to look like the settings 
in the dialog box. This will allow images to be placed in your drawing based on its World 
File or Sister File. The units may have to be adjusted base on the image units. 

 
Figure 2-97 User Preference dialog – Raster Manager Preferences 
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PLOTTING BY STATION AND OFFSET 
Plotting elements along a centerline is fairly simple when you’re on a straight portion of the 
alignment. AccuDraw performs this task very easily. Drawing a perpendicular line off a 
centerline on a radius is fairly easy, however plotting a point or placing a cell at a specific 
“odd” station along the curved alignment is a cumbersome task. We have created a macro 
that make this easy… once you get the hang of it. The Pointalong macro is going to make it 
possible for us to construct points at a specific distance along an existing alignment. From 
these points, we’ll be able to draw a line perpendicular to the alignment at a specific distance. 

Starting Point 
Run the Pointalong macro by selecting your Workgroup > Plan Graduate > Distance and 
Offset from the Tasks Menus (ROW workgroup users have global Function Key menus in 
which by selecting the F12 key will start the macro). You will be prompted to “Identify Point 
to Construct Distance From.” (Figure 2-98)  

 
Figure 2-98: StartPoint Along Status Prompts 

The Macro is expecting a data point on your “alignment.” Using the Keypoint snap, 
Intersection snap or AccuSnap, snap to the middle of a station tick mark. Once this point is 
selected, either the tick mark or the centerline may be highlighted. You want the centerline 
highlighted. Right-click until it is highlighted and click your left mouse button to Accept. 

Entering the Distance and Direction 
Once you’ve entered a data point telling the macro the start point, it will prompt you to 
“Enter Distance Along Element.” (Figure 2-99)  

 
Figure 2-99: Input Distance 

If you were trying to construct Station 1+35.240 from a tick mark at Station 1+20.000, the 
distance to construct would be 15.240. Enter in your desired value and press the OK button. 
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Choosing the Direction 
This next step is very important. The macro isn’t smart enough to know whether or not you 
want to construct a point to the left or to the right of the point that you just chose. Look down 
in your Status Bar to see that the macro is now prompting you to “Identify Direction for 
Construction.” (Figure 2-100)  

 
Figure 2-100: Status Bar Message 

What it is asking for is a data point either to the left or to the right, or, in the case of a vertical 
line, above or below the first point you entered. Put your cursor on the baseline near the first 
point, but clearly to one side or the other (Figure 2-101) and enter in a data point (left 
button). There is no need to snap to enter this point.  

 
Figure 2-101: Identify Direction for Construction 

When you enter a data point, MicroStation will start drawing a line at the specified offset and 
direction from the first point you entered (Figure 2-102).  

 
Figure 2-102: Point Constructed 

It will also put the AccuDraw compass on the line, rotated to make it easy for you to 
construct a line perpendicular to your centerline. 

Choosing the Offset Distance 
Now that we are drawing a line, we can choose to go either to the right or to the left of the 
centerline. Just put your cursor graphically near where you want the line to go. Keep your 
cursor near the axes of AccuDraw and it will ensure that you are drawing perpendicular to 
the baseline. 
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Enter your Offset into the Distance field of your AccuDraw window (Figure 2-103).  

 
Figure 2-103: Constructing a Distance off the Baseline 

Notice that the angle is 0°. Enter a Data Point to complete the command. Reset to stop 
drawing lines. 

Troubleshooting 
There is a Warning Dialog (Figure 2-104) that you will get from time to time when you 
construct distances using this macro.  

 
Figure 2-104: Pointalong Warning Dialog 

It lets you know that the point you are trying to construct cannot be constructed because your 
Element is too short. This could happen for a couple of reasons. 

1) You may have just chosen the wrong direction to construct from. Your baseline may run 
16 kilometers to the right and only 16 centimeters to the left of your offset point. You can’t 
construct a point 10 meters to the left of that first point. 

2) You may have picked the wrong element to construct the distance along (i.e. tick mark). 
Choose the point again and make sure that you Accept only the element you want to construct 
along.  

3) You may have used the Drop Element tool to drop Complex Status of the baseline. This 
would have broken up the lines and arcs that are joined together in a “complex chain” of a 
baseline, leaving only individual lines and arcs. The resulting elements are much shorter than 
a typical baseline.  
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You can put dropped baselines back together using the Create Complex Chain tool. Set your 
method in the Tool Settings Window to Automatic. 

 Refer to 2-12 for using the Complex Chain Tool  
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HOTSWAP 
Overview 
This macro helps you navigate to specific elements in reference files.  

Launch the HotSwap Macro 
From the main menu, select File > Reference (DOT) > HotSwap. 

Identify the Element 
MicroStation will prompt “HotSwap > Identify Element.” Click on the element with a 
Datapoint. 

 MicroStation will not allow you to identify Dimensions to swap to the reference file. 
Pick a line, arc, circle, text, or some other basic element type.  

 MicroStation will also not allow you to identify elements in your active file. 
Once you have picked an element, MicroStation will highlight the element and prompt you 
“HotSwap > Follow Element? (Accept/Reject).” Datapoint to Accept and MicroStation will 
open up the file of the indicated element. 

Set Zoom Level 
Once MicroStation has opened the target file, it will center your view window on the 
indicated element and open the HotSwap Zoom Dialog (Figure 2-105). 

 
Figure 2-105: HotSwap Zoom Dialog 

This dialog allows you to Zoom In or Zoom Out centered on the indicated element. 

Press the Done button when you are finished zooming. 

Tips 
The easiest way to get back to your previous file is from your File menu.  

At the bottom of the menu, right below Protection there should be a list of files. File number 
1 is your active file. File number 2 is your previous file.  

Open your previous file from the main menu by choosing File > 2 [Filename…] form the list 
of files. 
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LABEL SLOPE BY POINTS 
Overview 
This macro was created to make it easier to label roadway lines with the appropriate slope 
value. 

Setup 
Set your text up to the proper style and scale by using your Drawing Scale dialog. 

Run the Macro 
From the Tasks Menus, select your Workgroup > Plan > Prop. Text and Dims > Slope %. 
MicroStation will prompt you in the status bar “SlopeByPoints > Enter First Point.” Snap and 
Accept to a point on the slope you wish to define. 

MicroStation will prompt you in the status bar “SlopeByPoints > Enter Second Point.” Snap 
and Accept to another point on the slope you wish to define. 

You will get a positive slope if your first point is below your second point. You will get a 
negative slope if your first point is above your second point. 

 For roadway slopes, snap to an inner point before an outer point. 

Once you have defined your points, MicroStation will bring up the text dialog with your 
slope all typed in.  

 You can edit the text at this point, if you desire. You could change the sign, degrees 
of accuracy, etc. 

MicroStation will prompt you to “Place Text Above Element > Identify Element.” 

Datapoint on the line you want to label, near the point you would like the text to be. The text 
will appear, highlighted, above the element you selected. Datapoint to Accept, or Reset to 
choose another point for text placement. 
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FLATTENING YOUR ACTIVE FILE 
The Export 2D command is used to create a 2D file from a 3D file.  It’s like pressing a leaf in 
a book: it takes all of the peaks and valleys and presses them down. 

When to Flatten 
Try to keep InRoads files 3D. 

There are a couple of symptoms that may occur in your file to lead you to believe that you 
have a 3D problem. If you measure the distance between two points and find that it is much 
greater than you were expecting, perhaps those points are at different elevations. If you 
measure the length of a short line and find that it is hundreds of meters long, the line may be 
spanning two elevations. 

How to Export 2D 
From the Main Menu, select File > Export > 2D. This will open the Export 3D to 2D dialog 
(Figure 2-106). Select the appropropriate folder and key-in a new filename. You cannot use 
the same filename as the 3D file. Click the OK button. All the reference files that were 
attached to the 3D file will be automatically attached to the 2D file after the export. The 
reference files will not be converted to 2D during the export.  You have to use the File > 
Open command to open the 2D file that was just exported. 

  
Figure 2-106: Export 3D to 2D dialog 

The Preserve Z Range option may be enabled to be able to retrieve the original elevations of 
the file at a later time. The Ignore View Rotation should be enabled if the View has been 
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Rotated. The Ignore View Rotation setting preserves the X-Y geometry coordinates and 
discards the Z information.  
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STEEL MACRO 
Overview 
The Steel macro draws standard steel shapes for the user. Selection is made in a graphic 
dialog box based on shape type. The user has the option of placing shapes by any of nine 
points of origin, i.e., top left, bottom right, etc. 

Step Zero: Preparation for the Macro 
This macro is not going to set any appropriate level, color, style or weight. Before you launch 
the macro, use your Tasks Menus and pick the most appropriate setting (i.e., BridgeGroup > 
Bridge > Structural Detailing > Superstructure.) 

Step One: Launch the Macro 
Launch the macro from the main menu by selecting Macros > Steel. This will bring up the 
Steel Toolbar (Figure 2-107).  

 
Figure 2-107: Steel Toolbar 

Step Two: Set Steel Section Parameters 

On the right side of the Steel Toolbar is the Steel Section Parameters icon.  The 
Steel Section Parameters dialog (Figure 2-108) can be used to change the display of the 
steel sections and hatching. If you want to use the Attributes set by the Tasks (Color, Weight, 
and Level), disable the options for each Attribute. If the Attributes options are enabled, the 
setting you define will be used to display the Steel Section. 

 
Figure 2-108: Steel Section Parameters Dialog 
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Step Three: Choose an Origin 
Now you need to make a decision about how you want to place this shape. You can change 
the Justification of the different Section Types by selecting the appropriate Section Type and 
clicking on the Justification field (Figure 2-109). 

 
Figure 2-109: Steel Section Parameters Dialog – Setting the Justification 

In the Justification section of this dialog, there are nine options that you can press to set the 
justification. Your choice will depend on the detail you are working on. 

Changing the settings in the Steel Section Parameters dialog will be applied to the Steel 
Section that will be placed.  

You can keep the Steel Section Parameters dialog open and change the settings while you 
are placing Steel Sections. 

Step Four: Place the Shape 

On the right side of the Steel Toolbar is the Place Steel Section icon.  The Place 
Steel Section command is used to place the Steel Sections based on the Settings in the Steel 
Section Parameters dialog.  Clicking the Place Steel Section icon will bring up Place 
Section in the Tool Settings Window (Figure 2-110).   

 
Figure 2-110: Place Section Dialog 

Start by selecting the appropriate Type from the list (Figure 2-111). 



mdot MicroStation 

08/8/12 

MaineDOT MicroStation & 
InRoads Procedures 

2-94 
 

 
Figure 2-111: Place Section Dialog – Select Type 

Continue by then selecting the appropriate Name from the list (Figure 2-112). 

 
Figure 2-112: Place Section Dialog – Select Name 

Finally, select the needed Hatching from the list (Figure 2-113) 

 
Figure 2-113: Place Section Dialog – Select Hatching 

You can make the Steel Section a cell by enabling the Create Cell option. If the Create Cell 
option is disabled, the Steel Section will be a complex shape.  

The Steel Section should appear at the location of your cursor and will be placed where ever 
you click in the MicroStation View (Figure 2-114). 
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Figure 2-114: Placed Steel Section 

 Notice the cursor at the right of the top flange in Figure 2-114. This is the Origin 
point that was assigned .  

Option One: More of the Same 
If you want to keep placing more shapes like the one you just placed, just keep Datapointing. 
Until you Reset, MicroStation will continue to drop a shape wherever you Datapoint.  

Option Two: Undo 
If you have placed a shape in the wrong place, you can Undo the placement. From your main 
menu, select Edit > Undo Other > To Mark.  

 This uses built-in MicroStation functionality related to setting Marks in your drawing 
– kind of like bookmarks – that allow you to Undo back to a specific point. You can 
set your own marks by choosing Edit > Set Mark.  
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WELD MACRO 
Overview 
The Weld macro was written to make it easier to place consistent weld symbols on structural 
details. It prompts you to enter two Datapoints: one for the location of the weld, the second 
for the location of the symbol. Then you fill out a dialog box full of options and the macro 
places the weld symbol for you! 

Step One: Launch the Weld Macro 
Run the Weld macro from your main menu by choosing Macros > Weld. This will bring up 
Machining Toolbar (Figure 2-115). 

 
Figure 2-115: Machining Toolbar 

Step Two: Start the Place Welding Symbol Tool 

Select the Place Welding Symbol tool.   It is the fourth icon in the Machining 
Toolbar.  This will bring up the Place Welding Symbol dialog (Figure 2-116). 

 
Figure 2-116: Place Welding Symbol Dialog 

Step Three: Fill out the Dialog 
The Place Welding Symbol dialog consists of three “push” buttons, numerous text entry 
fields, and several pull-down list boxes.  

The three “push” buttons are marked below in red outlines (Figure 2-117).  The default 
settings for these buttons are “grayed out” and are shown below.  This means that the 
symbols they represent will not be shown when the Welding Symbol is placed.  



mdot MicroStation 

08/8/12 

MaineDOT MicroStation & 
InRoads Procedures 

2-97 
 

 
Figure 2-117: Place Welding Symbol Dialog – Three Push Buttons 

There are three modes for the push button that looks like a flag.  They modes are no flag 
displayed, flag displayed with fill, or flag displayed with no fill.  The modes are displayed 
below respectively (Figure 2-118). 

 
Figure 2-118: Place Welding Symbol Dialog – Flag Push Button Modes 

There are two modes for the push button that looks like a circle on the left.  They modes are 
no circle displayed, or circle displayed.  The modes are displayed below respectively (Figure 
2-119) 

 
Figure 2-119: Place Welding Symbol Dialog – Circle Push Button Modes 

There are three modes for the push button that looks like a circle/tail on the right.  They 
modes are no circle/tail displayed, tail displayed, or circle displayed.  The modes are 
displayed below respectively (Figure 2-120). 

 
Figure 2-120: Place Welding Symbol Dialog – Circle/Tail Push Button Modes 
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The Place Welding Symbol dialog has two drop-down lists to select the appropriate welding 
symbol.  This is outlined in red below (Figure 2-121). 

 
Figure 2-121: Place Welding Symbol Dialog – Welding Symbol Drop-down Lists 

Selecting the appropriate welding symbol on the top will display that symbol on the top.  
Selecting the appropriate welding symbol on the bottom will display that symbol on the 
bottom.  The welding symbol choices are shown below (Figure 2-122). 

 
Figure 2-122: Place Welding Symbol Dialog –Welding Symbols 
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There are two drop-down lists for welding contours of the weld as shown outlined in red 
below (Figure 2-123) 

 
Figure 2-123: Place Welding Symbol Dialog – Welding Contours Pull-down Menus 

There are three weld contours as shown below (Figure 2-124). 

 
Figure 2-124: Place Welding Symbol Dialog – Welding Contours Symbols 

There are numerous text boxes on the Place Welding Symbol dialog.  Key in the desired 
text. If you select the circle/tail push button, an addition text box will be revealed at the 
bottom of the dialog. The tail note can be keyed in inside that text box as shown below 
(Figure 2-125).  If additional room is needed, you can insert spaces in the text boxes to 
spread out the orientation of the welding symbol. 
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Figure 2-125: Place Welding Symbol Dialog – Text Boxes 

This example (Figure 2-125) will produce a welding symbol as shown below (Figure 2-126). 

 
Figure 2-126: Place Welding Symbol Example 

Step Four: Set the Scale and Place the Welding Symbol 
Use the Settings > Drawing Scale to select the appropriate scale before you place the 
Welding Symbols. The scale controls all of the welding symbol display.  

To place a welding symbol, snap to the location of arrow head to be placed. Then, you can 
select as many leader segments as needed by clicking at the desired vertex of the leader 
segment.   

Step Five: Saving the Weld Symbols 
You can save up to five welding symbol configurations for future use. Simply configure the 
welding symbol as described in this section and select File > Save > Weld 1-5 from the 
Place Welding Symbol dialog.  The configuration you are currently using will stay set until 
you exit MicroStation.  To bring back a saved Welding Symbol configuration, select File > 
Load > Weld 1-5. See Figure 2-127. 
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Figure 2-127: Place Welding Symbol Dialog – Save Weld 

Undo It 
Similar to the Steel Macro, the Weld Macro sets a Mark before it begins to draw. If you 
want to Undo the creation of a Weld symbol, simply choose Edit > Undo Other > To Mark 
from your main menu. 
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!MSINROADSCONF VS. !MSV8ICONF 
Overview 
The migration to InRoads design software was an opportunity to take advantage of some of 
the new capabilities of MicroStation. The initial upgrade had various configuration files 
located on the users hard drive at !msInRoadsconf folder.  The latest upgrade will have the 
newest files located at !msV8iconf folder.  As you transition to newer projects and older 
ones are completed, you will see increased use of your !msV8iconf folder.  Many changes 
have been made to the newer workspace so ensure you are using then newer files for the 
newer projects.  If unsure of which version you should be using, contact CADD support.  In 
order to take advantage of the new enhancements and continue working with projects 
developed to date, users need to keep older projects separate from new projects developed 
for use with InRoads V8i. 

Anatomy of a MicroStation/InRoads Design File 

 Level Structure 
Originally MicroStation was limited to 63 levels for elements to be drawn on. MicroStation 
now provides an unlimited number of levels. This provides the opportunity to have a 
separate level for each group of elements or features. This separation of elements by level 
provides additional functionality within InRoads. 

 DGN Library Files 
Management of the new level structure is accomplished using a .dgnlib file. This is an empty 
library file that contains the level structure consistent with MaineDOT standards. This is 
important for the management of the level structure. When a change to the level structure is 
necessary, then all new MicroStation files will automatically synchronize themselves to the 
library file. 

 Maximum Drawing Extents 
Older files had a limitation to the maximum cube size. The extents of the cube were 
dependent on the accuracy of the file. To develop a cube big enough to encompass the state 
of Maine, MaineDOT had to compromise accuracy in the files. An inch in an old file was 
broken into127 parts. New V8i files do not have this limitation so we can increase the 
accuracy. Now an inch is broken up into 25,400 parts. 

 Survey Feet vs. International Feet 
Prior versions of MicroStation used English units based on the International Foot. Survey 
data was, and still is processed based on the U.S. Survey Foot. The MX Change procedure 
projected the data to the correct coordinates within an International Foot file. Future work in 
InRoads and MicroStation will use the U.S. Survey unit of measurement for consistence. 
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 (1) International Foot = 0.3048 meters; (1) U.S. Survey Foot = 0.30480061 meters. 
This difference can amount to a 2-3 foot difference across the state of Maine. 

Custom MicroStation Files and Drawings 
The master MicroStation for InRoads customization files are on the network in a blind share. 
This means that they are in a secure location that isn’t normally seen when mapping a drive 
letter. After upgrading to the V8i software, users should have a local copy of the 
customization on their C: or D: drive called !msV8iconf. Updates to the configuration are 
handled with a newer version of the Update Utility tool. This utility does a date check of 
your local customization and updates files if changes were made to the master copy. 
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UPGRADING OLDER FILES TO NEW FORMAT 
Overview 
Occasionally it is decided that an older project will be re-designed in InRoads. In most 
cases, the alignment and the design will all be recreated through InRoads and result in the 
new InRoads file format (levels, units, precision, etc.).  

At some point, CADD Support is informed and the existing directory that was setup for MX 
is renamed from the decimal extension to “XX”. The new directory structure is created with 
the new InRoads seed files. 

Anyone that has worked previously on the project will be responsible for determining what 
files and/or folder should be migrated from the older directory (i.e. “XX”) to the new 
directory (i.e. “00”). Any MicroStation files that contain graphics to be used again in the 
InRoads directory will need to be Upgraded to the new file format. Master files like 
RWPlan, EnvPlan, UTPlan, Geoplan, etc. will all need to be upgraded.  In most cases the 
recommended workflow will be to upgrade the master files themselves and then re-cut the 
individual sheets (i.e., 001_RWPlan01) from the upgraded master files.   

Step One: Open Windows Explorer and Browse 
Open Windows Explorer and browse to the XX directory of the PIN on the Y: drive (i.e. 
Y:\pin\11060\XX\ROW\MSTA) (Figure 3-1). 

 
Figure 3-1: Browse to "XX" folder within Windows Explorer. 

Step Three: Copy files to Clipboard 
Select the files you wish to preserve and migrate to the new directory structure setup for 
InRoads and Copy. 

 Please note, it is not necessary to copy empty files that do not contain graphics 
within the actual file. There is no need to migrate empty files, simply re-create them 
within the MicroStation V8i environment. If you feel the need to migrate the file, you 
must draw a line in the empty file for the program to work. 
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Step Four: Paste in new Directory 
Browse to your Workgroups MSTA folder within the new decimal folder (i.e., “00”) and 
select Paste. At this point, you will most likely be asked to “overwrite” files. If you haven’t 
done anything to the new files within the InRoads folder structure, select YES. 

Step Five: Open MicroStation V8i 
Launch the MicroStation V8i icon located on your desktop. 

Step Six: Pick your Project 
Click the Project drop down list in the Workspace area of the dialog and select your project 
from the list (Figure 3-2). 

  
Figure 3-2: Select project from Project pull down. 

 This will direct the File Open dialog to the new InRoads project directory on the 
network (i.e., Y:\pin\11060\00\ROW\MSTA\) (Figure 3-3). 

 
Figure 3-3: Project directory set by project pick. 

Select one of the files you wish to upgrade (i.e., RWPLAN.dgn). 

Step Seven: Warning Message 
An Information panel will display (Figure 3-4) showing that the RWPLAN.dgn that was 
opened was created for the MX Platform. Here you will have the opportunity to correct the 
units of resolution for the InRoads platform. Click OK. 
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Figure 3-4: Warning message saying that file is setup for MX platform. 

Step Eight: Run UOR Fix 

 Part One: Launch Update UOR and Units Macro 
Select Macros > Update UOR and Units from the MicroStation menu (Figure 3-5).  

 
Figure 3-5: Launch UOR fix from MicroStation menu. 

 Part Two: Click Proceed 
A warning dialog (Figure 3-6) will appear giving the user the opportunity to Quit or Proceed 
if the user is unsure of the need to convert. All MicroStation files created with the previous 
MicroStation configuration will need to be converted to the new InRoads units of resolution. 
Click Proceed. 
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Figure 3-6: Warning message when updating UOR fix. 

 The file may display some unusual graphics while it is being converted. 

Once the program has run a Successful Completion message will appear (Figure 3-7). Click 
OK. 

 
Figure 3-7: Update successful dialog. 

 A back up file is automatically created of the original file prior to being converted.  
This file is located in the project folder and has the extension of .bak. 

 Part Three: Check Results 
Check the Global Origin of the file. Type GO=$ into the MicroStation Key-in to get the 
results of the current global origin location offset from the design center plane in the status 
bar (Figure 3-8). 

 
Figure 3-8: Check results of Global Origin. 

If it is desired to set the global origin, Type GO= to get the Global Origin dialog.  Select 
Center mode and enter a data point. 

 
Figure 3-9: Global Origin Center Mode dialog. 

 Part Four: Fit View 
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Fit the view using the MicroStation view controls. 

Troubleshooting 
If you receive an error message, it could mean that there were no elements in the file or that 
the file is already the correct units. Checking the Global Origin in Part Three is the real test 
to see if the file was upgraded. Contact CADD Support for assistance if necessary. 
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DESKTOP ICONS 
Overview 
During the InRoads installation, a new MicroStation icon (MicroStation V8i), a new 
InRoads icon (InRoads Suite V8i) and a new Update Utility (MDOT Update InRoads 
MicroStation V8i) will be copied to a user’s Desktop to help keep the two configurations and 
projects separate.  Older desktop shortcuts can remain during this time of transition. 

 Survey data and files within the folder structure have to be processed on older 
projects if the intention is to use InRoads to design them. 

MicroStation V8i for New InRoads Projects 
A MicroStation V8i icon will be copied to the users Desktop during the InRoads 
installation process. This icon is used to access MicroStation drawings developed 
specifically for an InRoads project. When MicroStation is launched from the new Desktop 
icon, the User will be defaulted to InRoads_network_V8i.  Once in the MicroStation session, 
an Application menu item is available to Activate InRoads products manually.   

 

Step One: Launch the MDOT Update InRoads MicroStation 
V8i Utility 

 Part One: 
Locate the MDOT Update InRoads MicroStation V8i on your Desktop. This will update 
user’s local copy of the configuration from the network.  Note, the older workspace would 
use the original Update Utility icon as it compares to the !msInRoadsconf folder. 

 Your project directory contains some of the same files. This utility does not update 
files within your project 

 Part Two: 
Let’s review the Options and decide which are necessary to select at this time (Figure 3-10). 
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Figure 3-10: MDOT Update InRoads MicroStation V8i Dialog- Options. 

Option 1: Copies down changes to the MicroStation and InRoads configuration from a 
protected location on the server to your local hard drive.  

Option 2: Copies a MicroStation license from the server to you local hard drive. This 
license points to the server so it isn’t for use off line. 

 Option 3: Copies an InRoads license from the server to you local hard drive. This license 
points to the server so it isn’t for use off line. 
Option 4: Copies the default set of icons that were installed originally from the InRoads 
disk in the event they were deleted. 

Option 5: Copies the mslocal files into the Bentley folder structure. This one file Tells 
MicroStation and InRoads to look to the !msV8iconf folder (older projects will remain 
looking to the !msInRoadsconf folder) for all its customization. 

Option 6: This allows a user to modify their User Configuration file for either additional 
names of others sharing your PC or if there is a change in your workgroup. 

Option 7: Installs the training project and PCF file so a user can have keep up on their skills 
while waiting for an official InRoads project to work on. 

Option 8: Creates a !msproj folder locally and copies down the initial list of PCF files. 

Option 9: Installs/Updates the InRoads menu and Project Defaults if a change was required 
globally for all users. A message will be sent in the event a change is necessary. 
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Option 10: Installs/Updates any changes necessary to the import and export specifications 
necessary to process data. A message will be sent in the event a change is necessary. 

Option 11: Installs/Updates InRoads Style Sheets used for reporting. As additional custom 
reports are created, users will be notified to run this option. 

 Part Three: 
Click OK and then click Next to begin the process.  

Step Two: Refresh Copies in Project Directory 

 Part One: 
Using Windows Explorer, browse to the C:\!msInRoadsconf\standards\InRoadsSTD 
folder (Figure 3-11).  

Select the mdot_US_V8i.xin and the template_V8i.itl files. Select Copy from Windows 
Explorer. 

 
Figure 3-11: C:\!msInRoadsconf\standards\InRoadsSTD  Folder. 

 Part Two: 
 Using Windows Explorer, browse to your C:\PIN\#####\00\InRoadsSTD folder (or 
Y:\PIN\#### for network projects). Select Paste from the menu (Figure 3-12). When 
prompted to overwrite, select yes. 
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Figure 3-12: Paste InRoads Files into PIN Folder. 

 Part Three: 
Close Windows Explorer. 

MicroStation for MX Projects 
There will still be the need to work with older project developed prior to the implementation 
of InRoads. Users will still have an original MicroStation icon for this purpose. When the 
icon is launched, the File Open screen will display the User as Normal. Another indication 
of the older configuration will be an MXChange menu present on MicroStation’s main 
menu. 

MicroStation V8 Update Utility 
There will still be an Update Utility for the older configuration of MicroStation, while 
projects are completed in MX.  Also, this is needed to remain in use and available for the 
older InRoads projects using InRoads version 8.9.  Newer projects will use InRoads version 
8.11 software and also take advantage of a newer Update Utility V8i tool, mentioned earlier 
in this chapter. 
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STANDARD INROADS FOLDER STRUCTURE 
Overview 
Project PIN creation should be requested through your CADD support staff. This will assure 
that every project is setup with the correct folder structure, permission groups, correct seed 
files and a Project Configuration File (PCF). Project team members can request the PIN at 
any time, however it’s typically created after survey has the data ready to be placed on the 
network. If you don’t see your PIN on the network, most likely survey has not been done 
yet. 

Standard Folder Structure 
When a PIN is created, a default folder structure is created on the network (i.e., 
Y:\PIN\12345\00\) from a set of master project files. The structure contains workgroup 
folders and default files used by both MicroStation and InRoads. 

Step One: Open Windows Explorer 
Open Windows Explorer (Windows +E) and browse to the C: or Y:\PIN\#####\00 folder 
(Figure 3-13). Multiple workgroups may be working on a project. The folders and the files 
within these folders are the deliverables given to the design staff at the start of an InRoads 
project. 

 
Figure 3-13: Pin Workgroup Folders. 
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 Review the Contents of the Highway, Survey, and Topo Folder 

Step Two: Review the InRoadsSTD Folder 
Open the InRoadsSTD folder (Figure 3-14).  

  
Figure 3-14: InRoadsSTD Folder Contents. 

A set of default InRoads files are copied to the InRoadsSTD folder for every InRoads PIN 
on the Y: drive. These files have been modified in accordance with MaineDOT standards. 
As CADD Support develops additional functionality, some of these files may become “out-
of-date”. Two files specifically (template_V8i.itl and mdot_US_V8i.xin) live in a state of 
constant development, and will be updated periodically. 

A local copy of the InRoads V8i standards files are copied to a folder 
(C:\!msV8iconf\standards\InRoadsSTD) on your hard drive that contains both the 
MicroStation V8i and the InRoads V8i configuration files. The user can manually refresh 
these files by running the MDOT Update InRoads MicroStation V8i desktop icon. This does 
not update the files within your project directory!  It is recommended that this update be run 
once a week. Notification via The Message of the Day will inform a user when it is 
absolutely necessary to run this update utility to get the latest standard configuration files to 
copy to your project’s InRoadsSTD folder. 

 Use caution when updating your project’s Template Library (ITL) and Preference File 
(XIN). If you have developed templates that you want to preserve, rename your 
working template library before overwriting it. Also, as we start using the Quantity 
manager, you may add item numbers to the Styles within InRoads and do not want to 
lose work previously done. 

Permissions 
When a PIN is created, CADD permissions groups are programmatically set for the project 
structure. This gives users read/write access only to the files in their workgroup and the 
Topo folder. This minimizes the possibility of files getting changed or overwritten when a 
user copies files locally for off-line work and later copies them back to the master copy on 
the network, overwriting the original files. 

Project Configuration File 
When a PIN is created, a Project Configuration File (PCF) is created on the network in the 
y:\msworksp\!msproj folder. The PCF file points to a project’s standard folder structure on 
the network. A local copy of this folder can be found on the root of your C: drive 
(c:\!msproj). This is used when unplugged from the network to point to projects copied 
locally. During an InRoads installation, the local copy of the !msproj folder is wiped clean 
with the exception of a sample training project’s PCF. This narrows down the local list of 
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PCF files to just those you intend on working on. If you work on projects locally (unplugged 
from the network), you will need to manually copy the PCF for the project from the 
y:\msworksp\!msproj folder to your c:\!msproj folder. 

The available PCF files are listed in the Project pull down which appears in the Workspace 
portion of the File Open dialog (Figure 3-15). 

  
Figure 3-15: The Project pull down lists the available PCF files. 

 The PCF file also contains project specific information that is used by MicroStation 
to automatically fill in title block information on drawings with a border. 
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ADJUSTING A USER’S WORKGROUP (IF 
NECESSARY) 

Overview of UCF files 
Each MicroStation/InRoads user has their own User Configuration File (UCF) which 
identifies the location where MicroStation will open a file whether on the network (y:\PIN) 
or a user’s local hard drive (d:\PIN). MaineDOT has some Regional Offices with poor 
network connection speed and Surveyors that are working unplugged from the network. 
These users will need to work on a local copy of the network project. Additionally, they will 
need to work on files on the network. To streamline things, we are providing an easy way to 
switch between working on a project locally or on the network. Two UCF files are copied to 
the user’s hard drive during the install, one (InRoads_network_V8i) is for network projects 
and the other (InRoads_local_V8i) for local projects.   

The UCF also identifies which workgroup folder the user will be working in (i.e., Highway, 
Bridge, Survey, ROW, etc.). During the install of InRoads, the user has the opportunity to 
pick which workgroup they belong to from a pull down list. Should the user’s workgroup 
discipline change or if the user works in more than one workgroup on a project, they can 
easily add additional UCF files or change the existing workgroup defined in the UCF file. 

Step One: Editing “.UCF” Files  
Using Windows Explorer, browse to the 
c:\!msv8user\Your.Name\MSTAUSER\config\users folder. Double click the 
InRoads_network_V8i.ucf file to open it. If the “.ucf” file is not opened directly, Windows 
may not recognize this file extension and ask you to Select a program to open the file with.  
If prompted, use Notepad (Figure 3-16) Place a checkmark in the box to Always use the 
selected program to open this kind of file. Click OK. 

 
Figure 3-16: Select Notepad as the preferred program to open this file. 
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Step Two: Adjust the Workgroup (If necessary) 
Locate the line in the files that says “WKGROUP =”. Copy and paste from the list of valid 
groups to overwrite the current workgroup (i.e., HIGHWAY).This must be all CAPITAL 
letters and there may be a space between the “=” and the value as in the examples provided 
in the file (Figure 3-17). This is the only change you should make in this file. Save this file 
and exit Notepad. 

 
Figure 3-17: User Configuration File - WKGROUP 

If you need to work locally in the new workgroup, then you should open the 
InRoads_local_V8i.ucf and change that WKGROUP variable also. 

Step Three: Assign User’s Menu Availability (If necessary) 
The Assign Users Menu Availability can be adjusted to make menus available from different 
work groups.  The valid groups are shown in (Figure 3-18).  The groups must be all 
CAPTAL letters and there may be a space before or after the “=”. 

 
Figure 3-18: User Configuration File – Menu On 
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ADDING ADDITIONAL UCF FILES 
Overview 
Occasionally a user may work in multiple workgroups on projects. A user’s primary 
workgroup should be set in the InRoads_network_V8i.ucf and InRoads_local_V8i.ucf. If 
necessary, you can add additional UCF files for secondary workgroups. 

Step One: Copy an Existing UCF 
Using Windows Explorer, browse to the 
c:\!msv8user\Your.Name\MSTAUSER\config\users folder. Select the two files 
InRoads_network_V8i.ucf and InRoads_local_V8i.ucf. Select Copy from the Windows 
Explorer menu. Select Paste. This will place a “Copy of” the files in the same folder. 
Rename these files to something that makes sense in regards to your secondary workgroup 
and location of projects (i.e., InRoads_ROWnet_V8i.ucf and InRoads_ROWlocal_V8i.ucf.) 

Step Two: Adjust Workgroup 
Adjust the workgroup to provide quick access to that workgroup folder on the network or 
locally. 

 Refer to page 3-19 for more information on Adjusting the Workgroup 

 This doesn’t automatically give the user read/write access to the new workgroup 
folder. They would have to request new CADD permissions to the folder through their 
CADD support personnel. 
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INROADS SURVEY PROJECT SETUP UTILITY 
Overview 
After the survey data has been collected in the field, it needs to be downloaded to a laptop or 
desktop computer (PC), checked for accuracy and processed through InRoads to create the 
Ground Surface. Since most Survey personnel perform this work in the field “unplugged” 
from the network, they will need to do the work locally. The Survey Project Setup is the 
recommended setup procedure for creating a PIN structure locally because it 
programmatically standardizes the creation the folder structure. 

Step One: Run Survey Project Setup Program 
Use Survey Project Setup program to create the folders and files needed to process the data 
on the local (D:\) drive. Double click the InRoads Survey Project Setup icon (Figure 4-1) 
on your desktop. 

 
Figure 4-1: InRoads Survey Project Setup Icon on your Desktop 

Step Two: Fill in Town, PIN and Path 
In the setup panel, fill in the town name, pin number, and decimal extension of the pin 
number. Select the appropriate drive letter for the local PIN directory (i.e. D:\Pin\). Select 
the Units of Measure (Figure 4-2). Click Create. 

 
Figure 4-2: Survey Project Setup dialog. 
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 At this time there has not been any customization for the Metric platform.  
Therefore, the Meters option has been grayed out and cannot be selected. 

The Output window at the bottom (Figure 4-3) will display the steps that were completed. 
When done, select Quit. 

 
Figure 4-3: Survey Project Setup dialog's Output Window 

The file structure created in the local project directory will appear as seen in Figure 4-4 (i.e. 
D:\Pin\Town12345\00\Survey\MSTA). 

 
Figure 4-4: Folder Structure in Windows Explorer 

The InRoadsSTD folder contains the *.xin file, that provides the customized MaineDOT 
standards and settings for each InRoads project. 

The SURVEY\MSTA folder is the working location for InRoads. This is where copies of 
the “original” files from data collector will be processed and edited using Survey Fieldbook. 
A “blank” dgn file named SURVEY.DGN is used as the entry *.dgn for InRoads. 

Step Three: Launch MicroStation 
Launch MicroStation V8i from your desktop icon. The first dialog to open is the File Open. 

Step Four: Change User 
In the Workspace area of the dialog, select the pull down next to the User field and select 
InRoads_local_V8i. This will direct MicroStation/InRoads to a local copy of the project 
directory (Figure 4-5). 

 Refer to page 3-19 for more information on User Configuration files.  
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Figure 4-5: File Open dialog when working locally. 

Step Five: Select Your Project 
Pick your project from the “Project” pull down. This will open that project’s files on the d: 
drive in the user’s MSTA directory based on their workgroup. 

Step Six: Open a File 
Select Survey.dgn from the directory. Click OK. 

Step Seven: Launch InRoads 
Select Applications > InRoads Group > Activate InRoads Survey from the Main Menus. 

 At this point, the InRoads splash screen should open momentarily and then the 
InRoads menu dialog will open and wait for input. 

 Consider creating an .RWK file to automatically attach the files you will be 
working with in the future. Refer to page 13-25 for instruction on Managing Your 
RWK. 
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OPTIONAL NETWORK USE 
Overview 
The default User Configuration File (UCF) file that InRoads uses when a user launches 
InRoads from the desktop icon is the InRoads_network_V8i.ucf. This directs 
MicroStation/InRoads to the network location for project files. This is the recommended 
workflow for a few major reasons. All files on the network are backed up nightly and these 
files can be accessed by any of the project team members. 

 Refer to page 3-19 for more information on User Configuration files.  

Step One: Launch MicroStation  
Launch MicroStation V8i from your desktop icon. The first dialog to open is the File 
Open.. The File Open dialog will open (Figure 4-6). In the Workspace portion of the dialog, 
the User is defaulted to InRoads_network_V8i and the directories will be pointing to the 
network (y: drive) for project PINs. 

 
Figure 4-6: File Open dialog when working on the network. 

Step Two: Select Your Project 
Pick your project from the “Project” pull down. This will open that project’s files on the 
network (y: drive) in the user’s MSTA directory based on their workgroup. 

Step Three: Open a File 
Select the Survey.dgn from the directory. Click OK. 
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Step Four: Launch InRoads 
Select Applications > InRoads Group > Activate InRoads Survey from the Main Menus. 

 At this point, the InRoads splash screen should open momentarily and then the 
InRoads menu dialog will open and wait for input. 

 Consider creating an .RWK file to automatically open the InRoads files you will be 
working with in the future. Refer to page 13-25 for instruction on Managing Your 
RWK. 
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OVERVIEW 
See the MaineDOT Survey group for “InRoads Survey Editing Procedures” documentation. 
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GENERAL INFORMATION 
Standard Naming 
The department has a standard naming convention for drawing files. The main reason for this 
is that many of our standard plan view type drawings for the department have the existing 
topography information referenced into them by default. This default reference only works 
when the files are named correctly and when they exist in the correct location.  

Please follow procedures outlined below to adhere to these standards. The standard file 
names for existing Survey information residing in the Topo folder are Topo, Text, Contours, 
Points and Wetlands. These are the only five files that should permanently live in the Topo 
folder. Click this link for the MDOT Standard File Naming Convention at: 

 www.maine.gov/mdot/caddsupport/msinroads/inroadsnaming.htm 

Preserving Original Files 
The Survey\Msta Folder is where the “Original” Survey files are stored. The folder will act 
as the topographical history for any given project. A user can open the folder and tell what 
was done for original survey, and all subsequent topoadds. The folder is Read-Only to 
everyone except for the Survey Editors, therefore, MicroStation Survey clean up will be done 
in the Topo folder. If network speed is an issue because of proximity to the server, then copy 
the necessary files locally.  

 Refer to page 13-5 for documentation on working with files locally. 

The End Result 
The end result is to make the Topo and Text drawings, which exist in the Topo folder, a 
combination of all Survey topography and text for the project (including Aerial Mapping 
data). This would leave no question as to which drawings need to be referenced to display all 
of the existing, cleaned up topography for the project. 

http://www.maine.gov/mdot/caddsupport/msinroads/inroadsnaming.htm�


mdot MicroStation 

01/01/12 

MicroStation Survey 
Cleanup 

 

6-4 
 

INITIAL TOPOGRAPHY CLEANUP 
Quick Punch List 

• Copy files from Survey/MSTA to Topo folder 
• Rename files 
• Cleanup Files 
• Add note to Cleanlog.txt file 

 This punch list is to give an overview of what is to be done with original survey files. 
If the topography is needed prior to the cleanup, copy the files to the topo folder and 
rename them to Topo, Text, Contours and Points. 

Determine Direction of Proposed Alignment 
This step is very important. If you haven’t already, take necessary steps to determine who the 
Project Manager is for the project. Ask which direction that they anticipate the alignment to 
be laid out. If this is unknown, do not cleanup this drawing until it’s been established. 

Step One: Open Windows Explorer 
Open Windows Explorer (Start > Programs > Accessories > Windows Explorer) and 
browse to your project on the y: drive. 

Regional Offices or users with a poor network connection should copy the project folder to 
your local D:\PIN folder and continue with the steps in this document, substituting your D: 
drive where the document says Y: drive. This process can done utilizing a Windows 
Briefcase. 

 Refer to page 13-6 for information on creating a Windows Briefcase. 

 Survey Editors may already have the folder locally if they have run the InRoads 
Survey Project Setup utility. 
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Figure 6-1: Browse with Windows Explorer 

Step Two: Open the Topo Folder 
In the example above (Figure 6-1), double click the Topo folder to display its contents. This 
folder should be empty. If it is, proceed to the next step.  

 If this folder already contains files, someone may have started Survey cleanup on this 
project. Do not overwrite these files with the next step. Open the Cleanlog.txt file to see 
if there are any “cleanup” notes. Skip to Step Four: Open MicroStation. 

Step Three: Copy Files from Survey\Msta to Topo Folder 

 Part One: Browse to Survey\Msta 
With Windows Explorer still open, browse to the Survey\Msta folder, displaying its contents 
in the rightmost window. 

 Part Two: Select Files 
Select the following files (Hold Ctrl to select more than one at a time): 
3DtopoMMDDYY.dgn, 3DmappingMMDDYY.dgn (if one exists), Origtext.dgn, 
Contours.dgn and Points.dgn.  

 If there are more than one 3DtopoMMDDYY.dgn files, this indicates that there has 
been topoadds done for this project. Select the most recent file based on its date. If no 
cleanup has been done, cleanup up the latest dated file and you will be taking care of 
every topoadd, including the original topo. All topography is displayed in the latest 
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3DtopoMMDDYY.dgn file. Always check the Cleanlog.txt file to see what has been 
cleaned up. 

 Part Three: Copy 
From the Main Menu, select Edit > Copy (Figure 6-2). 

 
Figure 6-2: Select and Copy files from Survey\MSTA folder 

 Part Four: Paste 
Click on the Topo folder. From the Main Menu select Edit > Paste (Figure 6-3). 
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Figure 6-3: Paste files from Survey\MSTA folder to Topo folder 

 Part Five: Rename Topo, Text and Mapping 
Select 3DtopoMMDDYY.dgn. From the Main Manu, select File > Rename. Begin typing 
the new name, which is Topo.dgn. Hit Enter to accept this name. 

Select Origtext.dgn. From the Main Menu select File > Rename. Begin typing the new 
name, which is Text.dgn. Hit Enter to accept this name. 

Select 3DmappingMMDDYY.dgn. From the Main Menu select File > Rename. Begin 
typing the new name, which is Mapping.dgn. Hit Enter to accept this name.  

 Part Six: Add Notes to Cleanlog.txt File! 
As a courtesy to others, always add a note to the Cleanlog.txt file located in the Topo 
directory as progress is made during the cleanup process. Here are a few examples of 
informative cleanup notes.  

03/04/02 John Doe - Started Topo.dgn cleanup. 

03/04/02 John Doe - Started Mapping.dgn cleanup. 

03/07/02 John Doe - Finished Topo.dgn cleanup. 

03/07/02 John Doe - Started/Finished Text.dgn cleanup. 

 Regional Office employees that copy the project locally should browse to the Y:drive 
PIN folder and make the edits to the network copy of the Cleanlog.txt file so that 
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other employees can check the status of the project. If you make the comments to 
your local Cleanlog.txt file, no one else can see this but you. 

Step Four: Open MicroStation 
Open MicroStation by clicking the “MicroStation V8i” icon on your desktop. When the File 
Open window appears, pick your project from the Project pull down. Browse to the Topo 
directory by double clicking your project number’s decimal folder (i.e. pin\12671\”00” 
folder), then double clicking the “Topo” folder.  

 If you are working locally (on your D: drive), select the User pull down and change 
to InRoads Local. Select your project from the Project pull down. If it isn’t there, 
copy the .pcf file from the Y:\msworksp\!msproj folder to your c:\!msproj folder. 
Reopen MicroStation. 

 If the project pull down does not take you to your project, contact your CADD 
Support personnel.  

  
Figure 6-4: Select the topo.dgn and click OK 

You should see four or five drawings on the left. Select topo.dgn (Figure 6-4) and click OK. 

Once the file is open, click Fit View  from Window 1’s view control toolbar. Close 
Window 2, Window 3and Window 4 if necessary and maximize Window 1. 

 If the Topo directory is empty, go back to Step Three and copy files. 
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Step Five: Attach Reference Files 
The topo and text drawings do not have any reference files attached by default. Even though 
you can only edit one file at a time, it is helpful to have both drawing displayed. Select File > 
Reference (DOT) > Attach from the Main Menu. Select the Text.dgn, browsing to the 
Topo folder if necessary. Click OK. It is not necessary to enter a Logical or Description. 
Attach by Coincident World method. Repeat this process for the Points.dgn and 
Contours.dgn drawings. To shut off the display of these two reference files, open the 
Reference File dialog (File > Reference from the Main Menu), click the “checkmark” in the 
Display column of the reference files you wish to shut off. 

Step Six: Turn Off Line Weights (Optional) 
Some users prefer to have line weights shut off. To do this, select Settings > View 
Attributes (Ctrl+B) from the Main Menu. Disable the Line Weights options. Close View 
Attributes Window. 

Step Seven: Adjust Level Display (Optional) 
Adjusting levels may not be necessary if the Survey Editor used the correct filter that doesn’t 
display the Ground Elevations or Traverse Points.  Directions are here in the event it does 
not happen. You may want to shut off levels S_Control_Traverse_Point and 
S_Ground_Elevation in the topo.dgn. These are the Traverse Points and the Ground 
Elevation strings. No Cleanup is required on these elements, and shutting them off reduces 
the clutter on the drawings. This is done by selecting Settings > Level > Display (Ctrl+E) 
and deselecting the levels you don’t want to be displayed. 

Refresh the view if necessary. Close the dialog box. 

 When the Survey Editors create the file, they should be using a Filter that wouldn’t 
bring these elements into the topography file. 

Step Eight: Load Clean-up Tools (Optional) 
From the Main Menu, select Tools > Tool Boxes… 
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Figure 6-5: Tool Boxes dialog 

Scroll down the list and click to place an “X” in the Survey Editing box (Figure 6-5). Click 
OK. A new set of tools should appear. 

 
Figure 6-6: Survey Editing Toolbox 

These Survey Editing tools (Figure 6-6) are dockable and will auto-load next time you enter 
MicroStation.  

 If you do not have these tools as an option, contact your CADD Support. 

 Element Selection Tool: Can be used to select individual elements or multiple 
elements by holding the Ctrl key. (Also located in the Main Tool Tasks.) 

 Change Curve Direction Tool: Use this to reverse a custom line style direction. (i.e., 
Trees and Bushes). (Also located in the Modify Tool Tasks.) 

 Edit Text: Says it all. (Also located in the Text Tool Tasks.) 

 Change Text Attributes: Used to change the text to the MAINEDOT standard height 
and width. (Also located in the Text Tool Tasks.) 

 Partial Delete: Used to delete part of an element. (Also located in the Modify Tool 
Tasks.) 
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 Extend Element to Intersection: Used to extend an element. (Also located in the 
Modify Tool Tasks.) 

 Rotate: Used to rotate individual elements (i.e., text and cells) around a user-defined 
point or origin point. (Also located in the Manipulate Tool Tasks) 

 For a detailed description of any tool, select Help>Contents and then Help>Tracking. 
Click on each tool, one at a time, and look to the Help window for a description. 

Step Nine: Adjust Ditch Arrows (May be Necessary) 

 General Information 
Adjusting the direction of existing ditches will need to be done manually in InRoads until a 
solution has been worked out, whether it’s the field crew picking up the points according to 
the direction of flow or it’s done programmatically. 

 Part One: Adjust Display of Topo.dgn to Isolate Ditch and Culverts 
(Optional) 
All ditch lines must be checked to see that the arrows point in the direction of the flow of 
water. To isolate the ditch lines, open the Level Display by selecting Settings > Level > 
Display (Ctrl+E). With topo levels displayed, Right Click anywhere in the Levels area and 
select All Except Element (Figure 6-7).  
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Figure 6-7: Right Click and Select All Except Element 

Click on any ditch line or culvert pipe. Click to select the element, then, click to accept it. 
Only the “S_Drainage_Ditch_Line” items will be displayed. Close the dialog. 

 Part Two – Option A: Using Elevation to Determine Direction 
An accurate way to determine flow direction is to check the elevation at both ends of the 
ditch line. All elements are 3 dimensional.  

Shut off Depth Lock by selecting Settings > Locks > ACS Plane from the Main Menu. Use a 
Keypoint snap (default snap) with your middle mouse button and click on one end of ditch 
line. Look to the Status bar located in MicroStation’s status bar (Figure 6-8). 

 
Figure 6-8: X, Y and Z coordinate displayed in MicroStation Status bar 

The elevation (Z) is the rightmost set of numbers (or look in the Z field of AccuDraw). Click 
on another vertices of the line to determine which direction the ditch is flowing. Use the 
Reverse Directions tool to change direction if necessary. An example of using the tool is in 
the next step. 

 Part Two – Option B: Using Contours to Determine Direction 
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Turn on the display of your Contours.dgn (File > Reference from the Main Menu) to 
quickly determine flow direction. Place a “check mark” in the display area for contours.  

 
Figure 6-9: Example of ditch arrow in wrong direction 

In the Example above (Figure 6-9), the ditch arrow is pointing from the 27.00 +/- to 29.00 +/-
, which is uphill and therefore wrong. 

 Part Three: Click the Change Curve Direction Tool   
Click the tool and follow the prompts in the bottom left status bar.  

 Part Four: Select the Ditch line 
Click the ditch line with the left mouse button. An arrowhead will appear (Figure 6-10) 
displaying the current direction of the line.  

 
Figure 6-10: Reverse Direction tool in action 

 Part Five: Accept or Reject 
Click the arrowhead to change the direction of the arrowhead.  Then, click again anywhere in 
the view window with a left mouse button to Accept or a right mouse button to Reject. 
 (Figure 6-11).  
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Figure 6-11: Change Curve Direction results 

 Part Six: Adjust Level Display (If You Adjusted it to Isolate Ditches) 
Turn on the levels that you shut off. From the Main Menu, select Settings > Level > Display 
(Ctrl+E). With the topo levels displayed, Right Click anywhere in the levels area and select 
All On. Select the S_Control_Traverse_Point and S_Ground_Elevation levels to shut off 
these two levels. Close Window. 

Step Ten: Determine Direction of Proposed Alignment 
This step is very important. Take necessary steps to determine who the Project Manager is 
for the project. Ask which direction that they anticipate the alignment to be laid out. If this is 
unknown, do not cleanup this drawing until it’s been established. 

Step Eleven: Adjust View and Save Settings (Optional) 

 Rotate the View Window 
If your project is not running from left (West) to right (East), you may want to rotate your 
view window so that the majority of the project is horizontal across your screen. Select 
Rotate View from Window 1’s View Controls (Figure 6-12). 

  
Figure 6-12: Rotate View Tool 

 Rotate View as often as necessary to get the majority of elements horizontal in your 
view. It is best not to snap to elements in your file while performing this command, 
unless you lock your “Z” prior to doing so.  To lock your “Z”, from the Main Menu, 
select Settings > Locks > ACS Plane Snap.  Key-in az=0 in the Key-in dialog and 
press Enter. Click in the CAD View. A slightly skewed view may result if the 3 
elements snapped to are at different elevations.  
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When the Rotate View dialog appears, set method to 3 points. First point (0/0), click on 
screen where you want the lower left corner of the new window to be. Second point (+X 
direction), click where you’d like the bottom right corner of the view window to be. Third 
point (+Y direction), click to define the top left corner of the view window (Figure 6-13). 

 
Figure 6-13: Rotating Your View 

 Graphic Group Unlock 
Disable Graphic Groups by selecting Settings > Locks > Graphic Group from the Main 
Menu or click the padlock on the status bar and click Graphic Groups to remove the 
checkmark.  

 Save Settings 
To save these settings as your default view for the file, select File > Save Settings.  

 If Save Settings is grayed out, this means that your current preferences are to save 
settings on exit. It will accomplish what this step is intended to do.  
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Step Twelve: Change Curve Direction 
There are many other directional elements (like ditches) that may require reversing in the 
Topo.dgn. Use the Change Curve Direction Tool to reverse tree lines, bush lines, house 
lines, curbing lines, guardrail strings, wetland lines, river and water lines and other 
underground utility lines, to correctly display each element. 

Tree lines, Bush lines and Gardens should have the “rounded” side towards road. The 
rounded cell in the line is representing the canopy or outer edge of the wooded area. 

The heavier line of a house and river line style represents the outer edge of that object. 
House lines may have two or more segments to reverse.  

Underground utility lines and wetland lines have text imbedded in them that may require 
reversing. Water lines, for example, may need to be reversed to show the ‘W’ symbol aligned 
correctly with the centerline or plan sheet.  

Curbing lines may need to be reversed so that the symbol will fall closest to the edge of 
pavement or dashed edge of concrete, gravel or planting.  

Guardrail lines may need to be reversed so that the posts are away from the roadway. 

Click on Change Curve Direction Tool and reverse the string(s) (may have more than one 
segment to reverse). 

 Part One: Click the Change Curve Direction Tool  
Click the tool and follow the prompts in the bottom left status bar.  

 Part Two: Select the Line (Identify the Element) 
Click on the line with a left mouse button. An arrowhead will appear displaying the current 
direction of the line. 

 Part Three: Accept or Reject 
Click the arrowhead to change the direction of the arrowhead. Then, click again anywhere in 
the view window with a left mouse button to Accept or a right mouse button to Reject. 

 You may have trouble reversing closed elements (shapes, blocks, etc.) and elements 
that go in both directions. Try deleting a small portion of the element using the Delete 

Partial tool.  Click on the Partial Delete Tool. Click anywhere on the string, then 
without moving the cursor away from the center of AccuDraw’s compass, click 
where you originally clicked forming a partial deletion of the line that is unnoticeable.  
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Step Thirteen: Rotating Topography Cells 

 General Information: What to Rotate 
Iron Pins - Rotate so that the text in the cell runs parallel with the roadway. Iron pin rotation 
will vary from pin to pin, so it’s better to rotate these individually. 

Power, Telephone and light poles - Poles that have a line through them should be rotated so 
that the line is perpendicular to the centerline of the roadway. A light pole would have its 
mast over parking lots or the roadway. 

 The point that a Pole is picked up in the field is its face closest to the centerline of the 
roadway. While cleaning up the poles, consider moving the pole so that the intersection 
of the line and circle is represented as the face of the pole closest the roadway. Make a 
note in the CleanLog.txt file. 

Single Post Street signs - The flat side of the sign should be facing the oncoming lane of 
traffic, unless it is a ‘No Parking’ sign or an entrance to a business. These will be facing the 
street (as seen in real life). 

Double Post Signs - Double posted signs are created with a line style. This line style is 
directional and may need to be reversed to face traffic or the roadway. 

Mailboxes - The short, flat side of mail box cell should be parallel to centerline, with the two 
pointed ends away from the road. 

Catch basins & Drop Inlets - The “grate lines” should be perpendicular to curb / edge of 
pavement (so a bicycle wheel won’t drop into them). 

Hydrants - Rotate so that the spout is facing the roadway (as seen in real life). 

Sill Elevations on buildings - The letters “Sill El” should generally be perpendicular to the 
building wall.  If on the front face of building, rotate them so they are perpendicular and 
inside the building. 

 Global vs. Individual Rotation Introduction 
Most cells will come in from the cell library at the same orientation (with the exception of 
Iron Pins and sill shots) and will need to be rotated around their individual origins to align 
with the centerline at that specific location on the project. 

One pass Globally, using selection sets through the entire project will align the majority of 
cells correctly. The cells that it doesn’t correct will most likely be an even 90-degree 
increment away from being correct. 

 This method works best on the straight portions of your project. Areas on a curve can 
be dealt with by using smaller selection sets or simply by using individual rotation 
methods.  

Utilize the Individual rotate command for Iron Pins, signs and other item that need final 
tweaking. Intersections of Side Roads require a bit more attention in this respect. 
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 Global Rotation: Select Multiple Cells to Rotate 
Identify a portion of your project that is fairly straight. If your project is one big curve use 
small selection sets so that global rotation will be effective. 

To set your editing filter to only cells in your file, go to Edit > Select By Attributes. 

 
Figure 6-14: Select By Attributes set to locate cells only 

In the Types portion of the dialog, select Cell. In the Modes section of the dialog, change 
Selection to Location (Figure 6-14). Hit Execute. Now you are only able to edit (rotate) cells 
in your file for the time being. If the dialog gets in the way, you can close it and click OK to 
keep the edit filtering “on” (Figure 6-15). When done editing cells, open Select By 
Attributes again and hit cancel to stop filtering. 

 
Figure 6-15: Select By Attributes Alert Message 

Using the Element Selection - The Element Selection command works well for selecting 
single or multiple cells because of the various selection methods. You can also add and 
subtract from your selection set easily. Choose Shape method and choose the “+” in the 
mode field (Figure 6-16). 



mdot MicroStation 

01/01/12 

MicroStation Survey 
Cleanup 

 

6-19 
 

   
Figure 6-16: Element Selector set to shape 

Left click to form a shape around the cells you want to rotate, returning back to the beginning 
point to close the shape. You should see them highlight.  

 To create new selection sets, hit your “spacebar” to clear the current selection set 
(while focus is in Element Selection dialog) and place a shape around the new set of 
cells. 

 Refer to page 2-29 for more information on the Element Selection tool. 
Click the Rotate tool from the Survey Editing tool box or the Main tool tasks (Figure 6-17). 
Place a checkmark in the About Element Center box (Figure 6-18) of the dialog box. 

 
Figure 6-17: Rotate Element Button 

 
Figure 6-18: Rotate Element’s About Element Center box 

Active Angle method: Take a rough guess of what the angle would be between the cell and 
the roadway. In the Angle field, type in the angle. If you don’t have any idea what the angle 
might be, try using a 5-degree rotation and click multiple times on the screen to continue 
rotating this amount. (Type in a “-“ for a clockwise rotation.) 

2 Points method: Click on the screen and you are dynamically rotating the cells around their 
origins. Move your cursor around the AccuDraw’s compass until the majority is rotated 
correctly. Click to Accept this rotation. Right-click to stop rotating. 

 Individual Rotation 
To perform individual rotations, rotate the cells around the point established by the Survey 
Crew, which is also the center/origin point of most cells.  
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 Click the Rotate tool from the Survey Editing tool box or Task Menus. In the 
Tools Setting box, place a checkmark in the About Element Center box of the dialog 
box. Click near the cell (the actual pivot is set to the cells origin based on the tool 
setting). The cell will rotate dynamically as you move the mouse around AccuDraw’s 
compass. Left click again to define the amount of rotation. Right-click to stop rotating 
the cell. 

Step Fourteen: Moving Vertices 
You may need to connect any storm sewer pipes, sanitary pipes, water lines and other 
underground utilities. Do this only if absolutely certain that the like-sized pipes that point 
towards each other actually connect underground. A field inspection or correspondence with 
town or city utility companies by the Project Manager may be necessary in an urban 
situation.  

Use the Modify Element tool to move one end of the line to the center of the desired utility 
manhole, catch basin or water gate. 

Delete duplicate lines. 

Step Fifteen: Adjust and Save Changes (Courtesy To 
Others) 

Rotate Window 1 back to a top view. Click on Rotate View and set the Method to Top. Click 
in the view to accept the new rotation. Select File > Save Settings. 

 If Save Settings is grayed out, this means that your current preferences are to save 
settings on exit. It will accomplish what this step is intended to do.  

Step Sixteen: Add Note to Cleanlog.txt File! 
Make a comment to the Cleanlog.txt to let people know that the topo has been cleaned up. 

 Regional Office employees that copy the project locally should browse to the Y:drive 
PIN folder and make the edits to the network copy of the Cleanlog.txt so that other 
employees can check the status of the project. If you make the comments to your 
local Cleanlog.txt file, no one else can see this but you. 

Step Seventeen: Repeat for Mapping.dgn (Projects that 
Utilizes Aerial Mapping) 

 Cleanup Mapping.dgn 
If the Survey/MSTA folder has a 3DmappingMMDDYY.dgn, you must clean up this file as 
well. Follow the same steps as outlined in the “Initial Topography Cleanup” section. 
Substitute mapping.dgn where it asks for the topo.dgn.  
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 Some older projects may have mapping in a separate folder. Files may not follow the 
naming described in this manual. Contact CADD Support for assistance. 

 Merge Mapping.dgn into Topo.dgn 
Once the Mapping.dgn cleanup has been completed, open the topo.dgn file from the Topo 
folder. Select File > Reference (DOT) > Attach from the Main Menu and select the 
Mapping.dgn, browsing to the Topo folder if necessary. Click OK. It is not necessary to 
enter a Logical or Description. Attach by Coincident World method. 

From the Reference File dialog, select the Mapping.dgn file. Then select Tools > Merge 
Into Master. Following the prompts, click in your view window. This dialog will come up 
(Figure 6-19) warning you that you are about to merge the Reference file into your current 
file.  

 
Figure 6-19: Merging Reference File Alert 

If everything looks good, click OK to proceed. 

Hit Refresh. 
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INITIAL TEXT CLEANUP 
Determine Direction of Proposed Alignment 
This step is very important. If you haven’t already, take necessary steps to determine who the 
Project Manager is for the project. Ask which direction that they anticipate the alignment to 
be laid out. If this is unknown, do not cleanup this drawing until it’s been established. 

Step One: Open the Text.dgn (From the Topo Folder) 
Open MicroStation by clicking the “MicroStation V8i” icon on your desktop. When the File 
Open window appears, pick your project from the Project pull down. Browse to the Topo 
directory by double clicking your project number’s decimal folder (i.e., pin\12671\”00” 
folder), then double clicking the “Topo” folder. 

 If you are working locally (on your D: drive), select the User pull down and change 
to InRoads Local. Select your project from the Project pull down. If it isn’t there, 
copy the .pcf file from the Y:\msworksp\!msproj folder to your c:\!msproj folder. 
Reopen MicroStation. 

 If the project pull down does not take you to your project, contact your CADD 
Support personnel.  

  
Figure 6-20: Select Text in the File Open Dialog 

You should see multiple drawings on the left. Select Text.dgn and click OK (Figure 6-20). 
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Once the file is open, click Fit View  from Window 1’s view control toolbar. Close 
Window 2, Window 3 and Window 4 if necessary and maximize Window1. 

Step Two: Reference Topo.dgn 
Select File > Reference (DOT) > Attach. Browse to the Topo folder if necessary and select 
topo.dgn. It’s not necessary to enter a Logical or Description. Attach by Coincident World 
method. 

Step Three: Rotating Text 

 General Information 
Most text should be rotated to read from west to east (parallel to centerline), and/or from 
south to north (perpendicular to centerline). In tight situations, a 45-degree rotation is 
acceptable. 

All rotated text, if perpendicular to the centerline, should be legible from the right side of the 
plan sheet. This enables a person to read the text from a stapled set of plans with the most 
ease. 

Text on buildings should be rotated either parallel or perpendicular with the building face. 

Text for drives should run parallel to the drive unless it identifies a wide parking area/lot. 

 Global vs. Individual Rotation Introduction 
All text in the text.dgn comes in at the same angle. 

One pass Globally, using selection sets through the entire project will align the majority of 
text elements correctly. The text that it doesn’t correct will most likely be an even 90-degree 
increment away from being correct. 

 This method works best on the straight portions of your project. Areas on a curve can 
be dealt with by using smaller selection sets or simply by using individual rotation 
methods.  

Utilize the Individual rotate command for text blocks that need final tweaking. Intersections 
of Side Roads require a bit more attention in this respect. 

 Global Rotation: Select Text Blocks to Rotate 
Identify a portion of your project that is fairly straight. If your project is one big curve use 
small selection sets so that global rotation will be effective. 

Using the Element Section Tool - The Element Selection tool works well for selecting 
single or multiple text blocks because of the various selection methods. You can also add and 
subtract from your selection set easily. Choose Shape method and choose the “+” in the 
mode field (Figure 6-21). 
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Figure 6-21: Element Selection  set to shape 

Left click to form a shape around the text blocks you want to rotate, returning back to the 
beginning point to close the shape. You should see them highlight.  

Click the Rotate tool from the Survey Editing tool box or the Task Menus (Figure 6-22). In 
the Tools Setting dialog, place a checkmark in the About Element Center box of the dialog 
box (Figure 6-23). 

 
Figure 6-22: Rotate Element tool 

 
Figure 6-23: Rotate Element’s About Element Center box 

Active Angle method: Take a rough guess of what the angle would be between the text 
block and the roadway. In the Angle field, type in the angle. If you don’t have any idea what 
the angle might be, try using a 5-degree rotation and click multiple times on the screen to 
continue rotating this amount. (Type in a “-“ for a clockwise rotation.) 

2 Points method: Click on the screen and you are dynamically rotating the text blocks 
around their origins. Move your cursor around the AccuDraw’s compass until the majority is 
rotated correctly. Click to Accept this rotation. Right Click to stop rotating. 

 To create new selection sets, hit your “spacebar” to clear the current selection set 
(while focus is in Element Selection dialog) and place a shape around the new set of 
text blocks. 

 Refer to page 2-29 for more information on the Element Selection tool. 

 Individual Rotation 
To perform individual rotations, rotate the text block around the point established by the 
Survey Crew, which is also the center/origin point of the cell it identifies. 
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Click the Rotate tool from the Survey Editing tool box or Tasks Menus. In the 
Tools Setting dialog, place a checkmark in the About Element Center box of the 
dialog box. Click near the text block (the actual pivot is set to the text block’s origin 
based on the tool setting). The text block will rotate dynamically as you move the 
mouse around AccuDraw’s compass. Left click again to define the amount of 
rotation. Right-click to stop rotating the text block. 

Step Four: Moving Text 
After text is rotated, it may also require moving. Text should be kept out of and away from 
roadway as much as possible. Use common sense when moving items nearest the cell that 
they describe so the plan “looks good”. Use the Move Element tool to move single text 
blocks. 

 Snapping to text (middle mouse) will show you what the text is describing. This 
works well in areas where text is on top of text making it difficult to distinguish. 
Identify what the text is describing and move it to a better location until all elements 
are clearly identified. 

Step Five: Editing Text (Optional) 
Text for similar elements should be consistent. Examples of inconsistent labels are 
GRAV.DR., GR.DRIVE, GRAVEL DR.. Adjust these to read GRAVEL DRIVE. (If in a 
tight area, abbreviations may be unavoidable.) Use the Edit Text tool to do this. Click the tool 
and then identify the text. Click once more to Accept and the text will appear in the Text 
Editor window. Make your changes and hit Apply. Right click to stop editing that text 
block.  

Abbreviations or making the text appear on two lines may be necessary in order to squeeze 
long descriptions in highly congested areas. Like items close to each other, may be labeled 
once. To do this, edit the text using the Edit Text tool. Click on the text, once more to Accept 
and it should appear in the Text Editor window. Make your changes and hit Apply (i.e., 5 – 
400 to 500 mm CEDAR SHRUBS). 

Step Six: Labeling With Arrows (Optional) 
It may be necessary to create an arrow line pointing to the cell it represents. Here are a few 
steps to accomplish this. 

 Part One: Select Arrow Line 
From the Tasks Menus, select your Workgroup > Plan > Prop. Text and Dims > Arrow 
Lines command. 
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 Part Two: Smart Match Text Block 
Select Qualities > Match > Level from the MicroStation’s Main Menu and click on the text 
block that the arrows belong to. Click again in the view window to Accept the selection. 

 Part Three: Make Lines 
Click to the left of the text block with the left mouse button. Type RQ (Rotate Quick) and 
align your AccuDraw axis along the text block and click your left mouse button. Enter the 
distance that you want your line to be from the text, 3 feet (1.0 m) is usually good and click 
your left mouse button to Accept. Point to the cell that you are annotating (Figure 6-24). Do 
the same for the other side if necessary. 

 
Figure 6-24: Example of annotating with arrows 

Step Seven: Adjust and Save Changes (Courtesy To 
Others) 

Rotate Window 1 back to a top view. Click on Rotate View and set the Method to Top. Click 
in the view to accept the new rotation. Select File > Save Settings. 

 If Save Settings is grayed out, this means that your current preferences are to save 
settings on exit. It will accomplish what this step is intended to do.  

Step Eight: Add Note to Cleanlog.txt File! (Courtesy To 
Others) 

Make a comment to the Cleanlog.txt to let people know that the text has been cleaned up. 

 Regional Office employees that copy the project locally should browse to the Y:drive 
PIN folder and make the edits to the network copy of the Cleanlog.txt so that other 
employees can check the status of the project. If you make the comments to your 
local Cleanlog.txt file, no one else can see this but you. 
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ADDITIONAL TOPOGRAPHY CLEANUP 
Quick Punch List 

• Copy topoadd_# files from Survey/MSTA to Topo folder 
• Rename files (remove the “Orig”) 
• Cleanup Files 
• Blend the two Files 
• Merge file into topo.dgn 
• Add note to Cleanlog.txt file 

 This punch list is to give an overview of what is to be done with additional 
topography files. If the topoadd are needed prior to the cleanup, copy the files to the 
topo folder temporarily. 

 If there are more than one 3DtopoMMDDYY.dgn files, this indicates that there has 
been topoadds done for this project. If no cleanup has been done on the whole project, 
cleanup up the latest dated file and you will be taking care of every topoadd, 
including the original topo. All “ground survey” topography is displayed in the latest 
3DtopoMMDDYY.dgn file. Always check the Cleanlog.txt file to see what has been 
cleaned up. 

 Supply your topoadd number where you see a “#” sign. 

Step One: Copy/Rename Origtopoadd_#, Origtextadd_#, 
Contours and Points 

Copy Origtopoadd_#, Origtextadd_#, Contours and Points from the Survey\Msta folder into 
the Topo folder using Windows Explorer. You will be prompted to overwrite Contours and 
Points. Say Yes.   
Select Origtextadd_#.dgn. From the Explorers Menu, select File > Rename. Remove the 
Orig from the file name. Repeat for Origtopoadd#.dgn (i.e., topoadd_1.dgn and 
textadd_1.dgn.)  
 Refer to page 6-4 in the Initial Topography Cleanup portion of this manual for 

more detailed instruction if necessary. 

 The original 3DmappingMMDDYY.dgn file contains all Aerial Mapping data. No 
additional Aerial mapping is ever done. If there is more than one 
3DmappingMMDDYY.dgn, it means that additional ground survey has been taken in 
the form of an Origtopoadd_#.dgn. Survey re-creates a 3DmappingMMDDYY.dgn to 
indicate where the ground survey fits in. This area(s) is encompassed by a boundary 
string. 
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Step Two: Add Note to Cleanlog.txt File! 
As a courtesy to others, always add a note to the Cleanlog.txt file located in the Topo 
directory as progress is made during the cleanup process. Here are a few examples of 
informative cleanup notes.  

03/04/02 John Doe - Started Topoadd_#.dgn cleanup. 

03/07/02 John Doe - Finished Topoadd_#.dgn cleanup. 

03/07/02 John Doe - Started/Finished Textadd_#.dgn cleanup. 

 Regional Office employees that copy the project locally should browse to the Y:drive 
PIN folder and make the edits to the network copy of the Cleanlog.txt so that other 
employees can check the status of the project. If you make the comments to your 
local Cleanlog.txt file, no one else can see this but you. 

Step Three: Open Topoadd_# 
Click the MicroStation icon on your desktop and pick your Project from the pull down. 
Browse to the Topo folder. Select Topoadd_#.dgn and click OK. 

 If the project pull down does not take you to your project, contact your CADD 
Support personnel.   

Step Four: Attach Reference Files 
Select File > Reference (DOT) > Attach from the Main Menu. Select the Textadd_#.dgn, 
browsing to the Topo folder if necessary. Click OK. It is not necessary to enter a Logical 
name or description for any attachments to this file. Attach by Coincident World method. 
Repeat this process for the Topo.dgn and Text.dgn drawings. Shut off the display of Topo 
and Text unless you need to see the “big” picture. 

Step Five: Refer to Step 6 through Step 16 in the “Initial 
Topo Cleanup” portion of this manual 

Follow the same steps that were followed when doing an Initial topo cleanup. Many steps 
may be skipped depending on the type of information in the Topoadd_# file. 
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ADDITIONAL TEXT CLEANUP 
Determine Direction of Proposed Alignment 
It should be apparent which way alignment is going to be laid out from the current Topo and 
Text drawings. Rotate accordingly. 

Step One: Open the Textadd_#.dgn (From the Topo Folder) 

Step Two: Reference Topoadd_#.dgn 
Select File > Reference (DOT) > Attach. Browse to the Topo folder if necessary and select 
Topoadd_#.dgn. It’s not necessary to enter a Logical or Description. Attach by Coincident 
World method. Repeat this process for the Topo.dgn and Text.dgn drawings. Shut off the 
display of Topo and Text unless you need to see the “big” picture. 

Step Three: Refer to Step 3 through Step 8 in the “Initial 
Text Cleanup” portion of this manual 

Follow the same steps that were followed when doing an Initial text cleanup. 
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BLENDING NEW TOPO AND TEXT WITH OLD 
General Information – Blending Tips 
Topoadd1 and Textadd1 features take precedence in the Topo file, therefore, most of the 
work will be done in the topo.dgn file. Edit topo.dgn and text.dgn to accommodate the new 
topography (topoadd1.dgn and textadd1.dgn) to be merged. 

Use a combination of MicroStation’s tools to accomplish the task of “blending” the updated 
Topography with the Topo.dgn and the Text.dgn file. The areas of additional survey should 
stand out from the previous surveys if you use Level Symbology. 

Aerial Mapping Projects or Portions Modified 

 Part One: Open Topo.dgn – Attach Topoadd_# 
Open the Topo.dgn. Select File > Reference (DOT) > Attach from the Main Menu. Browse 
to the Topo folder if necessary and select Topoadd_#.dgn. It’s not necessary to enter a 
Logical or Description. Attach by Coincident World method. The Topoadd_#.dgn takes 
precedence in the drawing. This will replace any Mapping Survey elements that exist in the 
topo.dgn. There should be a boundary element around the additional ground survey elements. 

 Part Two: Place Fence By Element 
Select the Place Fence tool. Change Fence Type to Element. Set Fence Mode to Clip. Click 
on the boundary element. The element will highlight indicating the fence was placed. 

 Part Three: Delete fence Contents 
Select the Delete Fence Contents tool. Set the Fence Mode to Clip. Click in your view to 
Accept the command. This should remove the old elements that were picked up through 
Aerial Mapping methods to make room for the newly surveyed information. 

Adjust Colors for Easy Editing - Level Overrides (Optional) 
Adjusting colors of the drawings will make it easier to distinguish the old Topography and 
the updated Topography. Adjust colors to your personal preference. You may want to follow 
the same steps outlined below for the topo.dgn, text.dgn, and the Topoadd_#.dgn, so while in 
that drawing, your colors are the same throughout all of the files you need to edit. The 
example below is adjustments to make while in the topo.dgn. 

 Part One: Open Topo.dgn and Attach Topoadd_#.dgn and 
Textadd_#.dgn 
Open topo.dgn from the \topo folder. Select File > Reference (DOT) > Attach. Browse to 
the Topo folder if necessary and select Topoadd_#.dgn. It’s not necessary to enter a Logical 
or Description. Attach by Coincident World method. Repeat this process for the 
Textadd_#.dgn drawing. 
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 Part Two: Open Topo and Turn On Level Overrides 
From the Main Menu, select Settings > View Attributes (Ctrl + B).  

 
Figure 6-25: View Attributes using Level Overrides 

Enable the Level Overrides option (Figure 6-25).  

 Part Three: Assign Colors to the Active Design File (i.e., Topo) 
Open the Settings > Level > Manager dialog from the Main Menu. 
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Figure 6-26: Level Manager Dialog 

In the leftmost window, click to highlight Topo (Figure 6-26) which is the active file you are 
in. Right-click in the rightmost window and pick Select All (Figure 6-27). All Levels will 
highlight (Figure 6-28). 

 
Figure 6-27: Right Click and select Select All 

Right-Click again and select Properties (Figure 6-28). 
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Figure 6-28: Right Click and select Properties 

In the Level Properties dialog, adjust the Symbology Overrides to look like the dialog in 
Figure 6-29. (Ignore the Symbology: ByLevel area.) Hit OK. 

 
Figure 6-29: Symbology Overrides section of Level Properties 
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 Part Four: Repeat for Text.dgn 
Repeat the same process for the text.dgn. Be sure to select the text.dgn on the left side of the 
dialog to display its levels. If you don’t see the text drawing, expand the tree by clicking the 
“+” sign next to topo.dgn. Use the same color you used for topo. 

 Part Five: Assign Colors to the Topoadd# 

 
Figure 6-30: Right Click and pick Select All 

In the leftmost window, click to highlight Topoadd_1.dgn. Right-click in the rightmost 
window and pick select all (Figure 6-30). All Levels will highlight. 

Right-click again and select Properties. 
In the Level Properties dialog, adjust the Symbology Overrides to look like the dialog in 
Figure 6-31. (Ignore the Symbology: ByLevel area.) Hit OK. 
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Figure 6-31: Symbology Overrides section of Level Properties 

 Part Six: Repeat for Textadd_#.dgn 

 Part Seven: Refresh View 

  Click on the paintbrush in the View Controls tools to Refresh the view. 

 Part Eight: Save Settings 
From the Main Menu, select File > Save Settings. 

 File Swapping (Handy Tip - Optional) 
While editing the Topo file, you may need to swap back and forth between it and the 
Text.dgn and/or the Topoadd_1.dgn. Try using File > Reference (DOT) > HotSwap. 
Follow prompts as the macro takes you to the element you select in any of the reference files 
you have attached. This gives you the capability to edit it. Also, use File > 2 (Alt+F+2) to 
swap to the file you just came from. 

Hilite Display of Reference Files (Optional) 
In the Reference File dialog, set your Hilite Mode to Hilite. Select a reference file to 
highlight it. 
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Update the Reference File Sequence (Optional) 
Some people may want to change which file is displayed on top of which file. In the 
Reference File dialog, select Settings > Update Sequence. This determines which file is 
displayed first.  
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MERGING NEW TOPO AND TEXT WITH OLD 
Step One: Open Topo.dgn and Attach Topoadd_#.dgn 
Open topo.dgn from the \topo folder. Select File > Reference (DOT) > Attach. Browse to 
the Topo folder if necessary and select Topoadd_#.dgn. It’s not necessary to enter a Logical 
or Description. Attach by Coincident World method. 

Step Two: Merging Topoadd_# File 

 Part One: Select Reference File to Merge 
Once the Topo file has been edited to allow for incorporation of the new topography, open 
the File> Reference (DOT) > Dialog. 
From the Reference File dialog, select the Topoadd_#.dgn file. Then select Tools > Merge 
Into Master. Following the prompts, click in your view window. This dialog will come up 
(Figure 6-32) warning you that you are about to merge the Reference file into your current 
file. 

 
Figure 6-32: Merging Reference File Alert 

If everything looks good, click OK to proceed. 

Hit Refresh. 

 Part Two: Adjust and Save Changes (Courtesy to Others) 
Rotate Window 1 back to a top view. Click on Rotate View and set the Method to Top. Click 
in the view to accept the new rotation.  
If Level Symbology was used, select Settings > View Attributes and disable the Level 
Symbology option. Close the View Attributes dialog. 

Select File > Save Settings. Exit MicroStation. 
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Step Three: Open Text.dgn and Attach Textadd_#.dgn 
Open text.dgn from the topo folder. Select File > Reference (DOT) > Attach. Browse to the 
Topo folder if necessary and select Textadd_#.dgn. It’s not necessary to enter a Logical or 
Description. Attach by Coincident World method. 

Step Four: Merging Textadd_# Files 

 Part One: Select Reference File to Merge 
Once the Text file has been edited to allow for incorporation of the new text, open the File > 
Reference (DOT) > Dialog. 
From the Reference File dialog, select the Textadd_#.dgn file. Then, select Tools > Merge 
Into Master. Following the prompts, click in your view window. This dialog will come up 
(Figure 6-33) warning you that you are about to merge the Reference file into your current 
file. 

 
Figure 6-33: Merging Reference File Alert 

If everything looks good, click OK to proceed. 

Hit Refresh. 

 Part Two: Adjust and Save Changes 
Rotate Window 1 back to a top view. Click on Rotate View and set the Method to Top. Click 
in the view to accept the new rotation.  
If Level Symbology was used, select Settings > View Attributes and disable the Level 
Symbology option. Close the View Attributes dialog. 

Select File > Save Settings. Exit MicroStation. 

Step Five: Moving Topoadd_# and Textadd_# 
Using Windows Explorer, move the Topoadd_#.dgn and the Textadd_#.dgn files you just 
edited and merged from the Topo folder to the ADDSDONE folder located in your project’s 
Topo folder. 
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 If Topoadd and Textadd drawings still exist in the Topo folder, this should tell a user 
that the clean up and merging is not yet complete. 

Step Six: Add Note to Cleanlog.txt File! 
Follow steps previously outlined in this document. Add a note saying that the two files have 
been merged. 

 Regional employees make changes to this file on the Y: drive.  

Step Seven: Copy Contents of Topo folder to Y:drive 
(Regional Employees) 

If you are a Regional Employee or did the cleanup on your C: or D: drive, copy the contents 
of the Topo folder on your hard drive to the Y: drive Topo folder of your PIN number. As in 
similar procedures outlined in this manual, use the Edit > Copy and the Edit > Paste 
commands in Windows Explore. 

If you used Window’s Briefcase, synchronize the project to the y:\ drive. 

 For more information on synchronizing your briefcase, refer to page 13-13. 
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  WWEETTLLAANNDD  SSUURRVVEEYY  CCLLEEAANNUUPP  
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GENERAL INFORMATION 
Standard Naming 
The department has a standard naming convention for drawing files. The main reason for this 
is that many of our standard plan view type drawings for the department have the existing 
topography information referenced into them by default. This default reference only works 
when the files are named correctly and when they exist in the correct location.  

Please follow procedures outlined below to adhere to these standards. The standard file 
names for existing Survey information residing in the Topo folder are Topo, Text, Contours, 
Points and Wetlands. These are the only five files that should permanently live in the Topo 
folder. Click this link for the MDOT Standard File Naming Convention at: 

 www.maine.gov/mdot/caddsupport/msinroads/inroadsnaming.htm 

. 

Preserving Original Files 
The Survey\Msta Folder is where the “Original” Survey files are stored. The folder will act 
as the topographical history for any given project. A user can open the folder and tell what 
was done for original survey, and all subsequent “survey adds”. The folder is Read-Only to 
everyone except for the Survey Editors, therefore, MicroStation Survey clean up will be done 
in the Topo folder. If network speed is an issue because of proximity to the server, then copy 
the necessary files locally.  

 Regional Office users should refer to page 13-5 for documentation on working with 
files locally in a Windows Briefcase. 

The End Result 
The end result is to make the wetlands.dgn, which exist in the Topo folder, a combination of 
all wetlands lines and text for the project. This would leave no question as to which drawing 
needs to be referenced to display all of the cleaned up wetlands for the project. 

http://www.maine.gov/mdot/caddsupport/msinroads/inroadsnaming.htm�
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INITIAL WETLANDS CLEANUP 
Quick Punch List 

• Copy files from Survey/MSTA to Topo folder 
• Rename files 
• Cleanup Files 
• Add note to Cleanlog.txt file 

 This punch list is to give an overview of what is to be done with original wetlands 
file. If the wetlands are needed prior to the cleanup, copy the file to the Topo folder 
and rename it.   

Step One: Open Windows Explorer 
Open Windows Explorer (Start > Programs > Accessories > Windows Explorer) and 
browse to your project on the y: drive. 

 Regional Offices or users with a poor network connection can copy the project folder 
to your local D:\PIN folder and continue with the steps in this document, substituting 
your D: drive where the document says Y: drive.  

 
Figure 6-34: Browse to your PIN’s topo folder 

Step Two: Open the Topo Folder 
In the example Figure 6-34, double click the Topo folder to display its contents. This folder 
should not have a wetlands.dgn file in it. If it does, skip the next step.  
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 If this folder already contains files, someone may have started Wetlands cleanup on 
this project. Do not overwrite this file with the next step. Open the Cleanlog.txt file to 
see if there are any “cleanup” notes. Skip to Step Four: Open MicroStation. 

Step Three: Open the Survey\MSTA Folder - Copy Files to 
Topo Folder 

 Part One: Browse to Survey\MSTA 
With Windows Explorer still open, browse to the Survey\MSTA folder, displaying its 
contents in the rightmost window. 

 Part Two: Select Files 
Select the OrigWetlands.dgn. If there have been additional wetland areas added to this 
project (i.e., wetlandsadd_1.dgn) and no cleanup has been done on any of it, select these also. 

 Part Three: Copy 
From the Main Menu, select Edit > Copy (Figure 6-35). 

 
Figure 6-35: Copy OrigWetlands.dgn from the Survey\MSTA folder 

 Part Four: Paste 
Click on the Topo folder. From the Main Menu select Edit > Paste (Figure 6-36). 
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Figure 6-36: Paste OrigWetlands.dgn into the Topo folder 

 Part Five: Rename OrigWetlands.dgn 
Select OrigWetlands.dgn. From the Main Manu, select File > Rename. Begin typing the 
new name, which is wetlands.dgn. Hit Enter to accept this name. 

 Part Six: Add Notes to Cleanlog.txt File! 
As a courtesy to others, always add a note to the Cleanlog.txt file located in the Topo 
directory as progress is made during the cleanup process. Here are a few examples of 
informative cleanup notes.  

03/04/02 John Doe - Started wetlands.dgn cleanup. 

03/07/02 John Doe - Finished wetlands.dgn cleanup. 

03/07/02 John Doe - Started/Finished wetlands.dgn cleanup. 

 Regional Office employees that copy the project locally should browse to the Y:drive 
PIN folder and make the edits to the network copy of the Cleanlog.txt so that other 
employees can check the status of the project. If you make the comments to your 
local Cleanlog.txt file, no one else can see this but you unless you have your project 
Briefcased. In this case, be sure to synchronize this file also. 
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Step Four: Open MicroStation 
Open MicroStation by clicking the “MicroStation V8i” Icon on your desktop. When the File 
Open window appears, pick your project from the Project pull down. Browse to the Topo 
directory by double clicking your project number’s decimal folder (i.e., pin\11060\”00” 
folder), then double clicking the “Topo” folder.  

 If you are working locally (on your D: drive), select the User pull down and change 
to InRoads_Local_V8i. Select your project from the Project pull down. If it isn’t 
there, copy the .pcf file from the Y:\msworksp\!msproj folder to your c:\!msproj 
folder. Reopen MicroStation. 

 If the project pull down does not take you to your project, contact your CADD 
Support personnel.  

   
Figure 6-37: Select wetlands.dgn from your list of available files 

You should see your drawing on the left. Select wetlands.dgn (Figure 6-37) and click OK. 

Once the file is open, click Fit View  from Window 1’s view control toolbar. Close 
Window 2, Window 3and Window 4 if necessary and maximize Window 1. 

 If the Topo directory is empty, go back to Step Three and copy the file(s). 
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Step Five: Attach Reference Files 
The wetlands drawing doesn’t have any reference files attached by default. Even though you 
can only edit one file at a time, it is helpful to have other drawings displayed. Select File > 
Reference (DOT) > Attach from the Main Menu. Select the alignments.dgn, browsing to 
the Highway or Bridge\MSTA folder if necessary. Click OK. It is not necessary to enter a 
Logical or Description. Attach by Coincident World method. 

 If an alignments.dgn file is not found, take necessary steps to determine who the 
Project Manager is for the project. Ask which direction that they anticipate the 
alignment to be laid out. If this is unknown, do not cleanup this drawing until it’s been 
established. This will determine which direction you adjust the line styles for 
readability. 

Step Six: Adjust View and Save Settings (Optional) 

 Rotate the View Window 
If your project is not running from left (West) to right (East), you may want to rotate your 
view window so that the majority of the project is horizontal across your screen. Select 
Rotate View from Window 1’s View Controls (Figure 6-38). 

  
Figure 6-38: Rotate View tool 

When the Rotate View dialog appears, set method to 3 points. First point (0/0), click on 
screen where you want the lower left corner of the new window to be. Second point (+X 
direction), click where you’d like the bottom right corner of the view window to be. Third 
point (+Y direction), click to define the top left corner of the view window (Figure 6-39). 
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Figure 6-39: Rotating View with 3 point method 

 Rotate View as often as necessary to get the majority of elements horizontal in your 
view. It is best not to snap to elements in your file while performing this command, 
To lock your “Z”, from the Main Menu, select Settings > Locks > ACS Plane Snap.  
Key-in az=0 in the Key-in dialog and press Enter. Click in the CAD View. A slightly 
skewed view may result if the 3 elements snapped to are at different elevations.  

 Graphic Group Unlock 
Disable Graphic Groups by selecting Settings > Locks > Graphic Groups from the Main 
Menu or click the padlock on the status bar and click Graphic Groups to remove the 
checkmark.  

 Save Settings 
Select File > Save Settings to save these settings as your default view for the file. 

 If Save Settings is grayed out, this means that your current preferences are to save 
settings on exit. It will accomplish what this step is intended to do.  

Step Seven: Reverse Wetland Line style Direction 

 Objective 
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Wetland lines have text imbedded in the line style. Ultimately, we want the text to be legible 
when the plans are cut into sheets. The text should be readable from left to right in 
accordance to the direction of the alignment. 

 Part One: Click the Change Curve Direction Tool  
The Change Curve Directions tool is located in the Modify Curves toolbox or from the Main 
Menu select Qualities > Change > Directions. Click the tool and follow the prompts in the 
bottom left status bar.  

 Part Two: Select the Line (Identify the Element) 
Click on the line with a left mouse button. An arrowhead will appear displaying the current 
direction of the line. Click the arrowhead again to change the direction of the line. Click 
again to Accept the change. 

Here is an example of a wetland line before clean up (Figure 6-40). Notice only part of the 
line reads correctly. 

 
Figure 6-40: Example before reversing elements 

 Part Three: Accept or Reject 
Click anywhere in the view window with a left mouse button to Accept or a right mouse 
button to Reject. 
Here is an example of a wetland line after clean up (Figure 6-41). Notice that all portions of 
the line read correctly. A partial delete had to be done to get accomplish this.  
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Figure 6-41: Example of a cleaned up wetland line 

 You may have trouble reversing closed elements (shapes, blocks, etc.) and elements 
that go in both directions. Try deleting a small portion of the element using the Delete 

Partial tool which is located in the Modify toolbox.  Click on the Partial Delete 
Tool. Click on a vertex of the string, then without moving the cursor away from the 
center of AccuDraw’s compass, click where you originally clicked forming a partial 
deletion of the line that is unnoticeable.  

Step Eight: Moving Vertices 
You may need to adjust wetland lines because the line may not have been drawn correctly. 
Use the Modify Element tool to move a vertex from one location to another. 

Step Nine: Changing Line style (if necessary) 
If the wetland Line style is incorrect, select the line and select your WorkGroup > Survey > 
Wetland/Rare Vegetation > ?Type? from the Tasks Menus. Select Quality > Change > 
Symbology from the Main Menu and click in the view window. 

Step Ten: Add Wetland Lines (if necessary) 
Use the Tasks Menus to place new wetland lines if necessary. Select your WorkGroup > 
Survey > Wetland/Rare Vegetation > ?Type? from the Tasks Menus. Draw the line using 
AccuDraw’s abilities. If there are Station and offsets available, consider using the Point 
Along macro. 

 Refer to page 2-84 for instructions for entering station and offset values for plotting 
wetland lines manually.  
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Step Eleven: Rotating Text 

 General Information 
It is up to the discretion of the individual or their unit as to rotate the wetland flags or not. 
Since other units will most likely shut off the wetland “flag” text, it’s important to know that 
you are doing this for your biologist’s checking purposes only. 

Most text should be rotated to read from west to east across your screen (parallel to 
centerline), and/or from south to north (perpendicular to centerline). In tight situations, a 45-
degree rotation is acceptable. 

All rotated text, if perpendicular to the centerline, should be legible from the right side of the 
plan sheet. This enables a person to read the text from a stapled set of plans with the most 
ease. 

 Global vs. Individual Rotation Introduction 
All text in the wetlands.dgn comes in at the same angle. 

One pass Globally, using selection sets through the entire project will align the majority of 
text elements correctly. The text that it doesn’t correct will most likely be an even 90-degree 
increment away from being correct. 

 This method works best on the straight portions of your project. Areas on a curve can 
be dealt with by using smaller selection sets or simply by using individual rotation 
methods.  

Utilize the Individual rotate command for text blocks that need final tweaking. Intersections 
of Side Roads require a bit more attention in this respect. 

 Global Rotation: Select Text Blocks to Rotate 
Identify a portion of your project that is fairly straight. If your project is one big curve use 
small selection sets so that global rotation will be effective. 

Using the Element Selection tool - The Element Section tool works well for selecting single 
or multiple text blocks because of the various selection methods. You can also add and 
subtract from your selection set easily. Choose Shape method and choose the “+” in the 
mode field (Figure 6-42). 

  
Figure 6-42: Element Selection set to shape 

Left click to form a shape around the text blocks you want to rotate, returning back to the 
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beginning point to close the shape. You should see them highlight.  

Click the Rotate tool from the Survey Editing tool box or the Task Menus (Figure 6-43). In 
the Tools Setting box, place a checkmark in the About Element Center box of the dialog box 
(Figure 6-44). 

 
Figure 6-43: Rotate Element tool 

 
Figure 6-44: Rotate Element’s About Element Center box 

Set Method to 2 Points. Click on the screen and you are dynamically rotating the text blocks 
around their origins. Move your cursor around the AccuDraw’s compass until the majority is 
rotated correctly. Click to Accept this rotation. Right Click to stop rotating. 

 To create new selection sets, hit your “spacebar” to clear the current selection set 
(while focus is in Element Selection dialog) and place a shape around the new set of 
text blocks. 

 Refer to page 2-29 for more information on the Element Selection tool. 

 Individual Rotation 
To perform individual rotations, rotate the text block around the point established by the 
Survey Crew, which is also the center/origin point of the cell it identifies. 

 Click the Rotate tool from the Survey Editing toolbox or Task Menus. In the 
Tools Setting dialog, place a checkmark in the About Element Center box of the 
dialog box. Click near the cell (the actual pivot is set to the cells origin based on the 
tool setting). The cell will rotate dynamically as you move the mouse around 
AccuDraw’s compass. Left click again to define the amount of rotation. Right-click to 
stop rotating the cell. 

 

Step Twelve: Moving Text 
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After text is rotated, it may also require moving. Use common sense when moving items 
nearest the vertex that they describe so the plan “looks good”. Use the Move Element tool to 
move single text blocks. 

 Snapping to text (middle mouse) will show you what the text is describing. This 
works well in areas where text is on top of text making it difficult to distinguish. 
Identify what the text is describing and move it to a better location until all elements 
are clearly identified. 

Step Thirteen: Add Note to Cleanlog.txt File! 
Make a comment to the Cleanlog.txt to let people know that the wetlands have been cleaned 
up. 

 Regional Office employees that copy the project locally should browse to the Y:drive 
PIN folder and make the edits to the network copy of the Cleanlog.txt so that other 
employees can check the status of the project. If you make the comments to your 
local Cleanlog.txt file, no one else can see this but you. 
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ADDITIONAL WETLANDS CLEANUP 
Quick Punch List 

• Copy wetlandsadd_# file(s) from Survey/MSTA to Topo folder 
• Cleanup Files 
• Blend the two Files 
• Merge file into wetlands.dgn 
• Add note to Cleanlog.txt file 

 This punch list is to give an overview of what is to be done with additional wetland 
files. If the wetlandsadds are needed prior to the cleanup, copy the files to the topo 
folder temporarily. 

 Supply your wetlandsadd number where you see a “#” sign. 

Step One: Copy Wetlandsadd_# 
Copy wetlandsadd_#.dgn from the Survey\Msta folder into the Topo folder using Windows 
Explorer. 

 Refer to page 6-43 to see how it was done in the Initial Wetlands Cleanup portion 
of this manual. 

Step Two: Add Note to Cleanlog.txt File! 
As a courtesy to others, always add a note to the Cleanlog.txt file located in the Topo 
directory as progress is made during the cleanup process. Here are a few examples of 
informative cleanup notes.  

03/04/02 John Doe - Started Wetlandsadd_#.dgn cleanup. 

03/07/02 John Doe - Finished Wetlandsadd_#.dgn cleanup. 

03/07/02 John Doe - Started/Finished Wetlandsadd_#.dgn cleanup. 

 Regional Office employees that copy the project locally should browse to the Y:drive 
PIN folder and make the edits to the network copy of the Cleanlog.txt so that other 
employees can check the status of the project. If you make the comments to your 
local Cleanlog.txt file, no one else can see this but you. 

Step Three: Open Wetlandsadd_# 
Click the “MicroStation V8i” icon and pick your Project from the pull down. Browse to the 
Topo folder. Select Wetlandsadd_#.dgn and click OK. 

 If the project pull down does not take you to your project, contact your CADD 
Support personnel.   
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Step Four: Attach Reference Files 
Select File > Reference (DOT) > Attach from the Main Menu. Select the Wetlands.dgn, 
browsing to the Topo folder if necessary. Click OK. It is not necessary to enter a Logical 
name or description for any attachments to this file. Attach by Coincident World method. 
Select the alignments.dgn, browsing to the Highway or Bridge\MSTA folder if necessary. 
Click OK. Attach by Coincident World method. 

Step Five: Refer to Step 6 through Step 13 in the “Initial 
Wetlands Cleanup” portion of this manual 

Follow the same steps that were followed when doing an Initial wetlands cleanup. 
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MERGING NEW WETLANDS WITH OLD 
Step One: Open Wetlands.dgn and Attach 

Wetlandsadd_#.dgn 
Open wetlands.dgn from the \topo folder. Select File > Reference (DOT) > Attach. Browse 
to the Topo folder if necessary and select Wetlandsadd_#.dgn. It’s not necessary to enter a 
Logical or Description. Attach by Coincident World method. 

Step Two: Merging Wetlandsadd_# Files 
Once the Wetlands file has been edited to allow for incorporation of the new wetlands, open 
the File > Reference (DOT) > Dialog. 
From the Reference File dialog, select the Wetlandsadd_#.dgn file. Then select Tools > 
Merge Into Master. Following the prompts, click in your view window. This dialog will 
come up (Figure 6-45) warning you that you are about to merge the Reference file into your 
current file. 

  
Figure 6-45: Merging Reference File Alert 

If everything looks good, click OK to proceed. 

Hit Refresh. 

Step Three: Moving Wetlandsadd_# 
Using Windows Explorer, move the Wetlandsadd_#.dgn file(s) you just edited and merged 
from the Topo folder to the ADDSDONE folder located in your project’s Topo folder. 

 If Wetlandsadd drawings still exist in the Topo folder, this should tell a user that the 
clean up and merging is not yet complete. 

Step Four: Add Note to Cleanlog.txt File! 
Follow steps previously outlined in this document. Add a note saying that the two files have 
been merged. 
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 Regional employees make changes to this file on the Y: drive.  

Step Five: Copy Contents of Topo folder to Y:drive 
(Regional Employees) 

If you are a Regional Employee or did the cleanup on your D: drive, synchronize your files in 
the briefcase (if one was used) or copy the contents of the Topo folder on your hard drive to 
the Y: drive Topo folder of your PIN number. As in similar procedures outlined in this 
manual, use the Edit > Copy and the Edit > Paste commands in Windows Explorer.
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Quick Punch List 
Create a Title Sheet Using Make Sheetz 

Edit Headings Using Border Macro 
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CREATE A TITLE SHEET 
Step One: Open MicroStation V8i 
To begin, double click on your MicroStation V8i icon and select your project from the project 
pull down. Open any file. 

Step Two: Create Title Sheet 
Select File > Make Sheetz from the Main Menu. 
Use a numbered prefix. The default is 001_ which makes this the first sheet in your final plan 
set. 

 If for some reason you will need two title sheets for this project, add the suffix “1” to 
avoid having two files with the same root file name. 

 Refer to page 1-57 for help making sheets. 

Step Three: Editing Text Headings 
Do not manually edit the text in your title sheet. Use Workspace > Edit Project Data (PCF) 
to change all of the variables in your drawing. Variables are any text in your drawing that has 
a “$” or “@” symbol in it. The text that remains can be edited by using the Edit Text tool or 
by selecting Text > Edit Text from the Main Menu. 

 To learn more about editing variables in your PCF file, refer to PCF Editing on 
page 1-67. 
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CREATING A LAYOUT (HIGHWAY PROJECTS WITH 
A SURVEY & DESIGN) 

Introduction 
Once the proposed design file (i.e. highway.dgn) has been created, follow these steps to 
create a layout drawing to be placed on the title sheet. 

Step One: Create a Layout Drawing 
Open any drawing in your PIN directory if you’re not already in one. From the Main Menu, 
select File > Make Sheetz. Create a drawing called z_layout.dgn.  

 Check page 1-57 for more about creating drawings using the Makesheetz macro. 

Step Two: Place a North Arrow 
Do a Fit View. The default View orientation should be Top which means North is up. From 
the Tasks Menus, select your Workgroup > Plan > Symbols & Linestyles > North Arrow 
True. In the Tool Settings dialog, enter 90 degrees in the Active Angle field, click on the 
padlock to lock the X, Y, and Z fields. (Figure 7-1)  

 
Figure 7-1: Adjust Active Angle, Padlock locked 

Type 300 in the X field, followed by a (Shift+8), then, enter the total number of clip 
boundaries on the main line for your project (your referenced hdplan.dgn boundaries) in the 
layout drawing. This will size the cell appropriately for the title sheet. (Figure 7-2) 

 
Figure 7-2: Using AccuDraw’s Calculator  

Set the cell down close to the boundaries in your layout drawing, with a Datapoint. 
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Step Three: Rotate Your View 
Rotate your view using the 3 points method until the graphics in your view are aligned the 
way you want to see them on your title sheet. 

 To make clip boundary horizontal: snap and accept to the lower left and lower right 
corners of your boundary. These two points define the X-axis. Snap and accept to the 
upper left corner of the boundary to provide the final point (positive Y direction 
according to your first point).  

Step Four: Create a Saved View 
From the Tasks Menus, select your Workgroup > Plan > Create Plan Sheets > Create 
Saved View. Now define the rectangle for your saved view. Be sure to encompass all clip 
boundaries and your north arrow. Read the dialog and follow the prompts.  

A dialog will appear asking for a name of your saved view. Name it “layout.” A description 
is not necessary.  

Leave the Add Shape box unchecked. 

Click Make. (Figure 7-3) 

 
Figure 7-3: Saved View Dialog Settings 

Step Five: Reference the view into the Title Sheet 
Open the title sheet (i.e., 001_title.dgn). 

Go to File > Reference (DOT ) > Attach. 
Select z_layout and hit OK. 

In the Attach Reference Settings dialog, select the named view called “layout”.  
Determine how many clip boundaries (plan sheets) on the main line for your project (your 
referenced hdplan.dgn boundaries) in the layout drawing. Multiply this number by the scale 
in which the sheets were cut (i.e., 300). Enter this number in the right most field of the scale 
(Master:Ref) portion of this dialog to scale your layout file appropriately. (i.e., 12 sheets x 
300 = 3600) (See Figure 7-4). 

 If after attaching you decide that you want to the area is too large to fit on the title 
sheet, you can adjust the attachment with a series of commands or simply detach and 
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reattach adding a one to your number of sheets. (i.e. 1 + 12 sheets (13) x 300 = 3900) 

 
Figure 7-4: Sample Setting for Attaching Layout 

  

Set the Nested Attachments: to Copy Attachments with a Depth set to “1”. This will attach 
the layout drawing and everything it has attached with it. 

 Check page 2-74 for an explanation of Reference Nesting. 
Click OK and you should see a rectangle on your cursor. Left click to place it down on the 
title sheet. You can move it if necessary in the next step. 

Fit View. 
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 If you aren’t seeing the same thing you saw in your layout.dgn, place a fence around 
the border and select File > Reference (DOT) > Clip > Boundary > All. Set the 
Method to Active Fence, place a check in the Use References Dialog List and click in 
the view window (Figure 7-5). 

 
Figure 7-5: Set the Clip Boundary Tool Settings dialog 

Step Six: Tweaking the Layout Placement 
Once the layout is placed, you can still manipulate the reference files.  

Go to File > Reference (DOT) > Dialog. Select all reference files in the dialog. 

In the Reference Dialog, choose Tools > Move or Tools > Scale or Tools > Rotate if things 
need to be moved, rotated or scaled again. You can repeat this function as many times as you 
want, being sure that all reference files are selected before manipulating. You may need to 
move other things around in your Title sheet to make room for it (i.e., scales, location map 
box, etc).  

 When rotating the referenced saved view, rotate it in the “Z” value only. 

Step Seven: Stationing the Layout 

 Introduction 
The alignment drawing that is attached is most likely too small to read on your Title sheet. It 
is also centered in your roadway which is going to be filled in, identifying the new pavement 
area. The alignment is a temporary attachment to be used as a guide for the next step and can 
be shut off eventually. 

 Part One: Open z_layout.dgn 
Open your z_layout drawing and turn off your graphic group lock (Settings > Locks > 
Graphic Groups). 

 Refer to page 2-42 for a description of working with graphic groups. 

 Part Two: Copy Alignment String 
Copy your alignment element into the z_layout file using the copy tool. It isn’t necessary to 
copy in the station or tick marks.  

 Part Three: Graduate – Create New Tick Marks 
Measure a rough distance from the centerline to a point just outside of the proposed 
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pavement area to determine how long the tick mark will have to be to still be visible once the 
pavement is filled in. 

From the Tasks Menus, select your Workgroup > Plan > Graduate and depending on the 
proposed pavement widths, select a tick mark that will be long enough to be visible outside 
of the shaded pavement area. Current commands are 20’, 25’, 40’ 50’ and 60’ for US 
Customary projects. 

A new toolbox should be on your screen. (Figure 7-6) Click on the Place cell along tool.  

 
Figure 7-6: Pace Cell Along Tool 

When the dialog opens, enter the desired spacing for the tick marks. Defaults are 100’. 
(Figure 7-7) 

 
Figure 7-7: Place Cell Along Dialog 

Snap to the beginning of your centerline to see how your ticks are going to be placed. Click 
to accept or reject the placement. If your alignment does not start at an even station, delete a 
portion of the “copied” center line to force it to start at an even station.  

 The normal text for stationing is 100 feet, but if you have a really long job, maybe 
you might want to space them at 1000 feet or another even increment. Be sure that the 
Offset and Angle are both set to “0”.  (Figure 7-7) 

 Part Four: Adding Text for Stations 
Open your 001_title.dgn. It’s best to station the alignment in the Title Sheet to produce 
standard size text. 

From the Drawing Scale dialog, set the Scale to Full Size 1 = 1 (Figure 7-8).  

 
Figure 7-8: Set Scale 

From the Tasks Menus, select your Workgroup > Plan > Prop. Text and Dims > Standard 
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Text (Normal). Start placing your station text. For long jobs, it may make sense to place 
your stations every 1000 feet. 

 Use AccuDraw’s functionality of  “o” (origin) and “rq” (rotate quick) to place the text 
at different angles along your project’s centerline. 

Step Eight: Shading the Layout Drawing 

 Introduction 
This step will shade all proposed pavement areas. Due to certain limitations, you will have to 
do this in sections as opposed to one large filled shape. Shading should be done in the 
z_layout drawing. It is important that your proposed design (Highway.dgn) has been 
flattened to “0” along with the z_layout drawing. 

 On large projects, shading may not be necessary because the layout is scaled down so 
small that when printed, the proposed pavement lines themselves are so close together 
that they appear to be one solid line. Print out a test plot of the Title Sheet to 
determine if shading is necessary. 

 Part One: Open z_layout 

 Part Two: Create Temporary Lines 
Use the SmartLine tool to create lines across (perpendicular) the roadway every 1000 to 2000 
feet (100 to 200 meters) or so to break the shading into manageable areas. Straight portions 
of the alignment may allow you to shade larger sections at a time. 

 The highway.dgn typically needs to have lines draw on it to signify the match points 
on the beginning and ending of the main line and the limit of work on the side roads. 
Do this work in the highway.dgn by Smart Matching the shoulder or travelway line 
then drawing a line connecting the opposite shoulders at the beginning and ending of 
the project. 

 Part Three: Flatten 
Flatten the drawing by selecting File > Export > 2D from the Main Menu. You have to use 
the File > Open command to open the 2D file that was just exported. 

 Part Four: Select Boundary Lines of Area to be Shaded 
Using your Element Selection or similar means, select the lines that define the boundaries of 
area to be shaded (i.e. edge of pavements, and 2 junk lines you created earlier).   

 Part Five: Create Regions 
Select Group > Groupings > Create Regions from the Main Menu or pick the Create 
Regions tool from the Groups tool box. Set the dialog to look like Figure 7-9. 
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Figure 7-9: Create Region Settings 

The color you select is optional. All colors, with the exceptions of 10-16, will print black. 
Colors 10-16 will print a shade of gray. 

The Level that you place the shading is optional. It is a good idea to select a Level that is not 
being used. 

 Part Six: Flood Area 
Click anywhere inside of the area you Selected. Click again to Accept. This should fill the 
area.  

 If you get a warning that says “No Enclosing Region Found”, you can adjust the Max 
Gap to a larger number so the tool will jump gaps in the lines. 

 If you get a warning that says “Shapes are not coplanar”, it could mean that the 
Highway.dgn or possibly the z_layout.dgn isn’t flattened. Re-flatten both drawings 
and try again. 

If all else fails, change your Method to Points and use data points to create the filled shape, 
however, this doesn’t work so well around curves. 

Contact your CADD Support for assistance.  

Step Nine: Adjusting the Layout Scale 

 U.S. Customary Projects 
To adjust the scale, you will need to take in account what scale you placed the Layout into 
your title sheet. In Step 5, we counted the number of clip boundaries (12) and multiplied that 
by 300 to get 3600. Divide this number by 12 to get the scale per inch of your Layout 
drawing. In this example your scale per inch would be 300.  

You can also find out what scale factor you used by opening the File > Reference dialog and 
double clicking on one of the attachments and looking to the Scale (Master:Ref) portion of 
the dialog. Divide the reference scale by 12.  
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Use Text > Edit Text from the Main Menu to edit the text in the bar scale Figure 7-10.  

 
Figure 7-10: U.S. Customary Layout Scale Example 

Step Ten: Place Text on the Title Sheet 
From the Tasks Menus, select your Workgroup > Plan > Prop. Text and Dims > Standard 
Text (Normal) to enter text labels for Side Roads, Town Lines, Sheet Numbers, etc.  
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OVERVIEW 
Whether you use the typical section program to draw your lines or not, there is a certain 
strategy to keep in mind. First of all, you should draw all your lines first, as the program 
would have you do. Then you should trim up all the lines, adding cells if necessary. Then add 
the dimension, text, notes and cells for station to station range and quantities. 

 Use the Section Task Menu to draw new lines.  

 Draw the typical completely before you move on to labeling and dimensions. This 
will help you keep the elements in the right levels without needing to Match Element 
Attributes all the time. 

Freehand Template Techniques 
 Refer to page 2-53 for an example of using AccuDraw to draw roadway sections. 

InRoads Template used as a Typical Section 
InRoads can “Display” a template that is in the Template Library with dimension (not real 
dimension type elements) and text in a MicroStation drawing. InRoads does not add the end 
conditions that are applied, only the relative Components in the template.  
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CREATING A TYPICAL SECTION DRAWING FILE 
Step One: Open MicroStation V8i 
To begin, double click on your MicroStation V8i icon and select your project from the project 
pull down. Open any file. 

Step Two: Create a New Drawing(s) 
Select File > Make Sheetz to create a new numbered prefix file for every typical sheet you 
will need. If there will be more than one, be sure to add a suffix in the make sheets dialog 
(Figure 8-1). 

 
Figure 8-1: Selecting a Suffix for Multiple Drawings of the Same Type 

  Refer to page 1-57 for help creating files. 
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CREATING TYPICALS USING THE TEMPLATE 
MACRO (OPTION 1) 

This macro was created for the Bridge Program to make drawing templates on Cross Sections 
easier. This can be used for Typical Sections as well. It allows you to place guardrail and 
curbing (based on the offset from centerline), and remembers your setting should you need to 
make more than one (Figure 8-2). 

 
Figure 8-2: Typical U.S. Customary Template Information Dialog 

The Guardrail and Curb placement requires that you give the offset from the centerline to the 
cell. Look to the Standard Details for the proper offsets or ask your designer. 
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CREATE TYPICALS FROM INROADS TEMPLATES 
(OPTION 2) 

Overview 
The saved “project specific” templates that are in your Template Library can be used to begin 
your Typical Sections for your project. End conditions are not components, so these do not 
get created through this process. 

 You cannot use edited Template Drops from the Roadway Designer, only what is 
saved in the Template Library. 

Step One: Open Template Library 
Open your template library used for your project or your .rwk that loads your default 
template library. Select Modeler > Create Template from the InRoads main menu. 

Step Two: Browse to Template Folder 
Expand your project specific template folder (Figure 8-3). 

 
Figure 8-3: Expand folder that contains your project's templates. 

Step Three: Right Click and Display 
Right click on a specific template in the library and select Display… (Figure 8-4). 
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Figure 8-4: Right click the template and select display. 

Step Four: Verify Global Scale Factor 
Select Tools > Global Scale Factors… from the InRoads menu. Set the scale factors to 60, 1 
and 60. 

Step Five: Click Apply 
The Display Template dialog opens with all the defaults preset (Figure 8-5). Click Apply and 
then place a data click within the typical section border. 
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Figure 8-5: Display Template dialog with defaults preset. 

Repeat for the other typicals for the project. The results are shown in Figure 8-6. 

 
Figure 8-6: Example of a Template placed as a Typical Section. 

 The dimensions are displayed in decimal feet instead of Feet and Inches. The 
dimension lines can be shut off prior to clicking Apply or deleted afterwards. The 
End Conditions are not displayed. It is recommended that the dimensions are placed 
through the Tasks Menus tools. 
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DIMENSIONS, TEXT, AND NOTES  
 Always use the Tasks Menu when placing dimensions and text. This is especially 

helpful in keeping your elements on the correct levels. 

Step One: Set the Drawing Scale 
Use the Drawing Scale dialog to select the proposed scale of the drawing (i.e., 1 in = 4 ft.). 

Step Two: Place Text and Dimensions 
From the Tasks Menus, select your Workgroup > Plan >  Prop. Text and Dims and pick 
the desired option from the right side.  
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USING ESTIMATOR 
Introduction 
This is a description of how to use the Estimator for producing a cost sheet for pricing a 
project. 

Step One: Getting into Estimator 
First you will need to double click on the icon on your desktop. Once in you will need to log 
in. For that you will need to know the user name and password. Those are Beta for the user 
name and User for the password (Figure 9-1).  

 
Figure 9-1: Log In to Estimator 

Note: you must capitalize the first letter of each in order to get in. 

 Contact CADD Support if you do not have an icon. Experienced users: Map any drive 
letter to \dot0dta1fsaug01\$Com-ProgMan\Highest\ folder. Create a shortcut on your 
desktop by right clicking the Highest.exe program and selecting Send To>Desktop 
(create shortcut). 

Step Two: Starting a new Estimator Project 
Once in you will need to open a catalog of items. There are a couple of selections. Select the 
catalog based on the units in your project. To do so simply go to File > Open Catalog and 
select your catalog (Figure 9-2). 
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Figure 9-2: Select your Catalog 

Next you will have to either select an existing file or you will have to create a new file. To 
open an existing file just simple choose File > Open and retrieve the file of interest. If it is a 
new file you will need to do File > New and an Edit Project Header box (Figure 9-3) will 
appear and you will need to supply some information about your project. 

 
Figure 9-3: Edit Project Header 

The type of information need is as follows: 

Project Name ( Town Name ) 

Contract Number ( the Pin # ) 

Letting Date ( Construction Begins) 

Work Type ( SB, LB, etc. ) 

Select County 

Checked By ( can be left blank ) 

Approved By ( can be left blank ) 

Note: You will find a list of work types on the last page of this document. 
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Once you have provided the information, click O.K. and you will see the Project Header Box 
(Figure 9-4) pop up. 

 
Figure 9-4: Project Header 

Step Three: Adding items to the List 
First you will need to double click on the $0.00 and you will see another box pop up (Figure 
9-5).  

 
Figure 9-5: Empty Project Item List 

Next you need to go to the menu at the top and select Edit > Add this will open up another 
box (Figure 9-6) which will allow you to start selecting the items pertaining to the project 
specified. 
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Figure 9-6: Add Project Item 

Once you select an item you will then need to either hit in the Quantity field with your mouse 
or tab to it, in either case you will need to put a quantity there and then hit Add More to 
continue inputting item numbers and quantities.  

When you are done completing your list just hit O.K. and Cancel, this should then bring you 
back to the list of items within the Project Item List as shown in Figure 9-7. 

 
Figure 9-7: Project Item List 

As you might have noticed that the list is not in numerical order. This is not a problem, you 
can easily fix this problem by simply going to the menu on top and selecting Utilities > Sort 
and this will bring up another dialog box that gives you numerous ways of sorting the item 
list. The most common selection would be sorting by Item Code - Ascending Order as shown 
in Figure 9-8. 
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Figure 9-8: Sort Item List 

Step Four: Editing Existing Data 
It is fairly simple to edit existing quantities already in place and Unit Prices ( ? ) that may 
not come out of the history of the item selected. To do this just click on the value you want to 
change and a box will appear to allow you to edit as shown in Figure 9-9 and Figure 9-10. 

 
Figure 9-9: Project Item List 

 
Figure 9-10: Edit Project Item Quantity 

Step Five: Printing and Saving 
To print go to the menu at the top and select File > Print and you should receive a display 
like Figure 9-11. 
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Figure 9-11: Print Estimator Detailed Estimate 

You should verify your system printer is correct and you will notice that the default range is 
All, hit O.K. and off to the printer it will go.  

You also can use this item list for the front of your Estimate Book by checking off the 
selection for Do Not Include Prices and printing the document. 

When complete always remember to save your document. The preferred naming convention 
is typical to our PIN structure. For example 00567890.he. Also pay attention to the location 
that the file is being saved to. The process should point to the correct directory automatically, 
but on a rare occasion things do get messed up. The proper directory structure that the file 
should be in is :\Highest\00567890.he 

Project Work Type Codes 
I = Interstate Highway Projects 

R = Rural Highway Construction 

U = Urban Highway Construction 

HOV = Hot Bituminous Overlays 

LOV = Light Bituminous Overlays 

LB = Large Bridge Construction ( 15 m or over ) 

SB = Small Bridge Construction ( Incl. Pipes ) 

BH = Bridge Rehabilitation 

SIG = Traffic Signals 

LIT = Lighting and Signing 

L = Landscape 

Additional Information 
People should be aware that if they have an item that does not appear in the catalog selection 
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set that they should notify the Estimator System Manager so that the item can be established 
into the program. 

If you are having difficulty getting access to the program then you will need to speak to the 
appropriate support person to correct the problem. 
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Quick Punch List 
Add Items To Estimator (If Necessary) 

Export Items from “Estimator” 

Make Estimate Sheet Using Make Sheetz 

Import Items from CSV file 

Adjust Lump Sum Items (If Necessary) 
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EXPORTING QUANTITY ITEMS FROM THE 
ESTIMATOR  

Introduction 
This is a description of how to export a list of Quantities for the purpose of filling out the 
Estimated Quantities sheet. This assumes that all or most of the items have been previously 
entered into the Estimator program. 

 For information on using the Estimator program, refer to page 9-2. 

Step One: Getting into Estimator 
First you will need to double click on the icon on your desktop. 

 Contact CADD Support if you do not have an icon. Experienced users: Map any drive 
letter to \\dot0dta1fsaug01\$Com-ProgMan\Highest\  folder. Right click the 
Highest.exe and select Send To>Desktop (create shortcut). 

Now log in (Figure 9-12) 

 
Figure 9-12: Log In to Estimator 

“Beta” is the user name and “User” is the password.  

 Usernames and passwords are case-sensitive: you must capitalize the first letter of 
each word. 

Step Two: Exporting (*.he) File 
Once you are in the Estimator program you must select the appropriate file that was created 
by either you or the Designer and open that file. 

Now that you have selected the file, go to File > Export. 
Here is the important part, you must select the Export File Format: and change this to: 
Lotus (Category Items) even though we do not use Lotus products (Figure 9-13).  



mdot MicroStation 
01/01/12 

Estimate Sheets 
 

9-12 
 

 
Figure 9-13: Export Dialog 

Next you will need to change the directory to the appropriate PIN directory that you are 
working in. To do this you need to select the drive letter that the PIN is sitting in. In this case 
MAINEDOT standards is the Y drive. 
Once there, double click on the Pin folder, your PIN number and to your workgroups \MSTA 
folder. This is where the macro looks for this file (i.e. y:\pin\9009\00\highway\msta\). 
Now that everything is set, hit the O.K. button and the Estimator will go through its process 
of exporting the document into the MSTA folder in your pin directory. 
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IMPORTING LOTUS.CSV FILE INTO ESTIMATED 
QUANTITIES SHEET 

Step One: Open MicroStation 
To begin, double click on your “MicroStation V8i” icon and select your project from the 
project pull down. Open any file.  

Step Two: Make an Estimate Sheet 
Select File > Make Sheetz and create a numbered drawing (i.e. 003_Estimate.dgn). 

 Check out page 1-57 for more information about making sheets. 

Step Three: Run Estimate Macro 
Once you are in the drawing, you need to activate the macro to begin importing your estimate 
items. To do this, go to Macros > Estimate. You will be prompted to “snap to the upper left 
corner of first table” (Figure 9-14). Accept with a left click. 

 
Figure 9-14: Example of Snap Point “Upper Left Corner of First Table” 

Step Four: Adjust Quantities 
This should have filled out your Estimated Quantity sheet. It will be necessary to edit text on 
a couple of the items that are supposed to be L.S., but because the Estimator requires actual 
quantities for the item, it will require that you change the value to “1”. Use the Edit Text tool.  

The Contract Section would rather not see decimals in the quantities. Edit the text and round 
all decimal number up to the nearest whole number.  

 If you would rather use a different justification on certain text, use Text > Rejustify 
(Macro) and select the text you want to change. When the dialog comes up, pick the 
new justification. 

 If there are changes to the Estimator (*.he) file, you will need to export another 
Lotus.csv file and overwrite the existing one. Then go into the file, delete the existing 
list, and re-run the macro. 
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Additional Sheet Needed? 
Occasionally you may have more items than one Estimate Sheet will hold. In this case, the 
macro writes the additional information off to the right of the border. If your original border 
hasn’t been dropped, copy it and place it with the additional items. (If it has been dropped, 
get a copy from the USBorder/Border cell library.)  

Place a fence around the new border and select Utilities > Development Tools > Fence File 
from the Main Menu. When the new dialog appears, supply the name of an additional 
Estimate Sheet (i.e. 004_Estimate2.dgn) being sure to increment the prefix and suffix. Click 
OK. Click on the screen to Accept the command. Open the new sheet. If all looks good, 
delete the extra border and contents from the original file. Contact CADD Support for 
assistance.
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  DDRRAAIINNAAGGEE  SSHHEEEETT  DDEEVVEELLOOPPMMEENNTT  
Quick Punch List 
Copy Drainage Spreadsheet into PIN directory 

Enter drainage data into drainage.xls. 

Save drainage.xls as a tab-delimited text file. 

Create a Drainage Sheet using Make Sheetz 

Run the Drainage Macro 
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USING THE DRAINAGE SPREADSHEET 
Introduction 
This macro merges data from an excel spreadsheet into MicroStation. There are a couple of 
steps involved. Follow them exactly.  

 Do not attempt to be creative in the naming of your file or create multiple files to 
somehow trick the program. It won’t work. 

Step One: Copy the Spreadsheet 
The drainage.xls spreadsheet is a standard form. The drainage.xls template is located in the 
Y:\msworksp\MDOT MicroStation Utilities\Spreadsheets & Notes folder. Make a copy 
of this file and place it in your workgroup’s MSTA folder before entering your project data. 

 Do not edit the spreadsheet on the Y: drive! 

Step Two: Enter Drainage Data 
Enter your drainage data into the spreadsheet. Do not attempt to reformat the spreadsheet in 
any way. Add all the information to this one spreadsheet even if there isn’t any grid lines 
present in the rows or columns. Save your file. 

 Make sure you save your changes by choosing File > Save. 

Step Three: Save as TXT file 
Our macro cannot access excel data when it is saved in workbook (xls) format. From Excel, 
choose File > Save As… This will open the Save As dialog (Figure 10-1). 
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Figure 10-1: Save As Txt 

From the bottom of this dialog, choose Text (Tab delimited) (*.txt) in the Save as type 
field.  

Check that the file name is DRAINAGE.TXT and select Save button. This will bring up a 
Microsoft Excel dialog warning you about the limitations of tab delimited text (Figure 10-2). 

 
Figure 10-2: Save As Warning  

Tab delimited text files aren’t capable of handling all the formatting options of Microsoft 
Excel. This is not going to be a problem for us.  

Dismiss this dialog by pushing the Yes button. 
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 Notice that you are now editing a file called “Drainage.txt”. This filename is a must 
for the macro to work (Figure 10-3). 

 
Figure 10-3: New File Name 

You are now finished with Excel. Choose File > Exit. You will get a warning dialog like 
Figure 10-4. 

 
Figure 10-4: Save Changes? 

You do not need to save this file again. Dismiss this dialog by pressing the No button.  
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IMPORTING DRAINAGE INFORMATION 
Step One: Open MicroStation 
To begin, double click on your “MicroStation V8i” icon and select your project from the 
project pull down. Open any file. 

Step Two: Make a Drainage Sheet 
Go to File > Make Sheetz and create a numbered sheet with Drainage as the file type (i.e. 
004_Drainage.dgn). 

 Check out page 1-57 for more information about making sheets. 

Step Three: Run the Macro 
From the Main Menu select Macros > Drainage. 

MicroStation will prompt you “Drainage > Snap to upper left corner of first table” Snap to 
the point marked with an “X” in Figure 10-5, and Accept. 

 
Figure 10-5: Upper Left Corner 

MicroStation will place a column of text in every column of the table has information. 

 If you would rather use a different justification on certain text, use Text > Rejustify 
(Macro) and select the text you want to change. When the dialog comes up, pick the 
new justification. 

Multiple Drainage Sheets 
If you have more than 78 lines of drainage information, the macro will start placing another 
column of text to the right of the first table and place an additional border. 

• Place a fence around the new border and select Utilities > Development Tools > Fence 
File from the Main Menu. When the new dialog appears, supply the name of an 
additional Drainage Sheet (i.e. 005_Drainage2.dgn) being sure to increment the prefix 
and suffix. Click OK. Click on the screen to Accept the command. Open the new sheet. If 
all looks good, delete the extra border and contents from the original file. Contact CADD 
Support for assistance.
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  NNOOTTEESS  SSHHEEEETT  DDEEVVEELLOOPPMMEENNTT  
Quick Punch List 
Copy Template from Y: drive to your PIN on the Y: drive 

Open and Edit the Template in Microsoft Office (i.e. Word or Excel) 

Save as new Format (according to specific instructions) 

Open new file, select range of text and Copy to Clipboard 

Open MicroStation, Make Sheetz and set text Style  

Paste (according to specific instructions) 

Edit Sheet Type in title box 

Run Macros > Border Information 
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LOCATION AND EXPLANATION OF TEMPLATE 
FILES 

Introduction 
We are using Microsoft Word for all text arranged in paragraph form, to be pasted into 
MicroStation. Text that is intended to be in columns should be produced in Microsoft Excel. 
We have placed template files in the following directory - Y:\msworksp\MDOT 
MicroStation Utilities\Spreadsheets & Notes. Please copy files from this location into your 
projects PIN directory under your workgroups MSTA folder. Do not edit the files in their 
original location. 

General Notes 
There are a few template files available to be used for generating your General Construction 
Notes. They require editing for every project and should be checked for accuracy.  

Imperial General Notes.doc - This file has a listing of the most common General Notes 
used on U.S. Customary projects. 

Metric General Notes.doc - This file has a listing of the most common General Notes used 
on metric projects. 

Metric Expanded General Notes.doc - This file includes all of the General Notes in the 
Metric General Notes.doc file, plus, an additional 50+ notes that may pertain to more 
complex projects. Check both of these files and decide which one suits your projects needs. 

Summary of Excavation and Borrow 
The Summary of Excavation and Borrow is an Excel spreadsheet. It can be easily pasted into 
a MicroStation drawing for your final plans. The file is called Summary-Excavation-
Borrow.xls. This form is sometimes confusing to do by hand on complicated projects. Just 
enter the figures and the formulas will take it from there. It also allows you to delete the lines 
(rows) that aren’t needed. When doing this, the user must also delete out any lines with an 
“ERR” in them, starting from top of the sheet to the bottom.  

Use the same instructions used when pasting Construction Notes into MicroStation. 

Estimating US Customary Projects (Manually) 
We have a spreadsheet to help do one of the most tedious tasks of Estimating which is 
calculating your Cuts and Fills. Once you supply the stations, without the (+) symbol, the 
sheet will automatically fill in the distances between stations. (Do not enter numbers in the 
shaded cells) After you enter areas or lengths, it will automatically average them and give 
you totals. Each sheet will give you totals that are summarized on the Index of the 
spreadsheet. Right now there are only five pages for the calculations and an index. If more 
pages are needed, ask your support staff to create them and revise the master. Here is a listing 
of files available for English projects. 
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ENGLISH-ESTIMATE-CUYDS.xls - This is for estimating items requiring a cubic yard 
measurement (i.e. Common Excavation, Gravel, etc.). 

ENGLISH-ESTIMATE-SQYDS.xls - This is for estimating items requiring a square yard 
measurement (i.e. Loam, Sod, etc.).  

ENGLISH-INDEX.xls - This is for indexing your estimate book that you turn in with your 
project. Many people are not including this with their comps, but if you are, this will make it 
easier. Also you can experiment with exporting a text file from Highest (Estimator) without 
the prices. 

 InRoads can easily produce End Area Volume reports for the project.  

 Refer to page 20-32 for information on End Area Volume reports. 
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GENERAL NOTES SHEETS 
Step One: Copy the Template File 
Using Windows Explorer, browse to the Y:\msworksp\MDOT MicroStation 
Utilities\Spreadsheets & Notes folder. Select the General Notes file that best pertains to your 
project. Copy the file from this location into your projects PIN directory, under your 
workgroups MSTA folder. 

Step Two: Open and Edit Using WORD 
Open and edit the Microsoft Word file, supplying your project specific information. Save the 
file in its native format (.doc). 

Step Three: Save As .txt File 
From the Main Menu, go to File > Save As, Select “Plain Text (*.txt)” in the Save as Type 
pull down (Figure 11-1). Verify that the path of the new file name is pointing to your PIN 
directory. 

 
Figure 11-1: Save as type- Plain Text (*.txt) 

A new dialog will open. Place a check mark in the “Insert Line Breaks” box (Figure 11-2) 
and leave the other defaults as is. Click OK. 
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Figure 11-2: Select Insert Line Breaks 

Close the Word document. 

Step Four: Open and Copy the Text from the New File 
Using Windows Explorer, browse to your projects PIN directory and open the file that you 
just saved with the .txt extension. Select the range of text you wish to paste into 
MicroStation. From the Main Menu, select Edit > Copy. 

 You can select all of your text and manipulate it prior to placing it in the MicroStation 
Text Editor dialog. The Text Editor has the same capabilities as the Notepad text 
editor. You can Copy, Paste and Cut by either Right clicking in the dialog or using 
shortcut keys Ctrl+C (Copy), Ctrl+V (Paste) or Ctrl+X (Cut).  

 If you are familiar with PFE Editor, Right Click the file and select “Open With…” 
then select “Choose Program” and select PFE Editor. You can select up to 100 lines 
of text and still fit it within your border. Notepad doesn’t give you this information.  

Step Five: Open MicroStation 
Open MicroStation by double clicking the “MicroStation V8i” icon on your Desktop and 
pick your PIN number from the project pull down. Open the MicroStation file that you wish 
to place the General Notes in. If necessary, create a new file from the Main Menu using File 
> Make Sheetz. Use a numbered drawing, selecting Notes from the drawing type dialog. 
Consider adding “General” in the suffix to better specify the sheet type (i.e., 
006_Notes_general).   

 See the Make Sheetz documentation on page 1-57. 

Step Six: Set Your Text Size and Font 
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Use the Drawing Scale dialog to select appropriate scale. Normally, General Notes are placed 
on a border that hasn’t been scaled. Select Full Size 1=1 for U.S. Customary projects. From 
the Tasks Menus, select your Workgroup > Plan > Proposed Text and Dims > Text Note. 
This sets your text attributes. 

Step Seven: Paste the Selected Text 
While your Text Editor has focus (active), type Ctrl+V to paste the notes into the window 
or Right Click to bring up the “Right-Click Menu” and select Paste (Figure 11-3). 

 
Figure 11-3: Right Click with mouse - Paste Option 

Step Eight: Placing Text in the File 
Place the text as you would any other text (Datapoint) utilizing AccuDraw and/or tentative 
snaps to place it accurately. 

If the text you pasted will not fit inside of your border, use the Edit Text tool and click on the 
text. In the Text Editor dialog, select the extra text that isn’t fitting within the border starting 
from the bottom up and type Ctrl+X. This will “cut” the extra text to the Clipboard. Click 
Apply to accept the changes. Click on the Place Text tool. With your cursor in the Text Editor 
dialog, type Ctrl+V to paste the remaining text. Place it down using AccuDraw to place it 
accurately. Continue until all of the text fits within the border. Create a second sheet if 
necessary. 

 If you have over 200 lines of text, the text block may not display when you do a fit view. 
This is normal due to the limitations of multi-line text (text nodes). Zoom in to see the 
text. 

Step Nine: Editing Text 
Edit text like you would any other text by selecting the Edit Text tool from the Main tool 
frame. 



mdot MicroStation 
01/01/12 

Note Sheets 
 

11-8 
 

CONSTRUCTION NOTE SHEETS 
Introduction 
Depending on who generated the construction notes, you may be working with an Excel 
Spreadsheet, reports generated from InRoads software or hand written hard copies. 

These instructions are not intended to explain how to use Excel, but instead, it explains how 
to take a construction note file and paste it in to MicroStation.  

If you are using reports generated from InRoads, these are usually web type files that can be 
easily converted into Excel files. 

Importing Reports into Excel (Informational/Optional) 
If you are building the spreadsheet from .prn reports, select Data > Import External Data > 
Import Data from Excel’s main menu. Browse to your workgroups MSTA folder and select 
the .prn file. Click OK. A text import dialog will open. Select Delimited. (Figure 11-4) Click 
Next. 

 
Figure 11-4: Text Import Wizard 

In the next dialog, make an additional selection for “Space” as your delimiter (Figure 11-5). 
The other selections by default do not need changing. Click Next. 
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Figure 11-5: Select “space” as your delimiter 

 In the final dialog of importing text you have the opportunity to format cells in the 
spreadsheet. “General” is normally good for this setting. If you wish to omit a column, click 
on the column header and click on the “Do not import column (skip)” button. Click Finish 
(Figure 11-6). 

 
Figure 11-6: Import Wizard column formatting 

Step One: Open Spreadsheet 
Locate and open the spreadsheet (.xls file) in your PIN directory that has the Construction 
Notes in them.  
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 Right click in your MSTA folder and select New > Microsoft Excel Worksheet if 
you need to create one. Name it appropriately and add in your information. 

Step Two: Save as Formatted Text (Space delimited) 
If you have to make any changes to the spreadsheet, make the changes and save them.  

Select File > Save As… from Excel’s main menu. Change the File As Type pull down to 
Formatted Text (Space delimited) (*.prn) (Figure 11-7). Notice that your file name now 
has a new extension. Click Save. 

 
Figure 11-7: Save as Type Text (Tab delimited) (*.txt) 

 If you have multiple sheets in one Excel Spreadsheet, you will need to go into each 
sheet and save them individually as a different file name (i.e. Construction-Note1.prn, 
Construction-Note2.prn). The .prn format cannot handle multiple pages all at once. 

 The .prn extension will allow the user to adjust the widths of the columns in Excel 
and carry over the changes into the text document (.prn).  

Step Three: Warnings 
You will get a series of warnings. First one saying the format doesn’t support multiple sheets. 
Click OK. (Figure 11-8) 

 
Figure 11-8: Warning One – Click OK 

At the next warning click Yes. (Figure 11-9) 
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Figure 11-9: Warning Two – Click Yes 

Close the Excel session. When asked to save the document, click NO (Figure 11-10). You 
have already created the .prn documents as a separate file and do not need to save the 
changes in the Excel workbook.  

 If you had made changes after saving it as a .prn file, do a Save As… and change the 
“Save as type” back to .xls 

 
Figure 11-10: Warning when closing the file – Click NO! 

Step Four: Open MicroStation 
Open MicroStation by double clicking the “MicroStation V8i” icon on your Desktop and 
pick your PIN number from the project pull down. Open the MicroStation file that you wish 
to place the Construction Notes in. If necessary, create a new file from the Main Menu using 
File > Make Sheetz. Use a numbered drawing, selecting Notes from the drawing type 
dialog. Consider adding “Construction” in the suffix to better specify the sheet type 
(007_Notes_construction).   

Step Five: Set Your Text Size and Font 
Use the Drawing Scale dialog to select appropriate scale. Normally, Construction Notes are 
placed on a border that hasn’t been scaled. Select Full Size 1=1 for U.S. Customary projects. 
From the Tasks Menus, select your Workgroup > Plan > Proposed Text and Dims > 
Monospaced Text. This sets your text attributes. 

Step Six: File>Import>Text 
Go to File > Import > Text from the Main Menu. Select the file that you created with the 
.prn extension. Place the text with a data point, utilizing AccuDraw to place it accurately 
amongst other notes on your sheet. 

Step Seven: Editing the Text 
After placement, you will notice that there may be some adjustment necessary. Use the Edit 
Text tool in your Tasks Menus or use the Main Menu and select Text > Edit Text. Click the 
text and adjust as necessary. 

 The original .xls file is a handy document because it can be used to generate item lists 
in your Estimate Book that we turn in to Contracts. It’s up to the team as to whether or 
not you keep the master .xls file up to date or edit the changes within MicroStation 
only.
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CREATING PLAN SHEET DRAWINGS 
Step One: Open your group’s ??plan.dgn 
Open MicroStation and choose your PIN. 

 Refer to page 1-56 for more information on opening files. 
Locate the ??plan.dgn that is in your groups MSTA directory (i.e., hdplan.dgn, bdplan, 
geoplan, envplan, etc). 

Step Two: Reference in Survey Data 
From the main menu, choose File > Reference to open the Reference dialog.  

Check to see that the appropriate files are attached to this drawing (i.e., contours, topo, 
points, and text). Wetland data will eventually be in a file called wetlands.dgn. If it exists in 
the topo directory, attach it. 

By default, all Survey files should be attached. If these files are not attached, you will have to 
attach them manually. To reference all files needed for you plan sheets into this file, select 
File > Reference (DOT) > Attach. Browse to the Topo directory of your current project 
(Figure 12-1). 

 
Figure 12-1: The Topo Directory 

 It is important that you attach files from the topo directory and not the survey 
directory. The files in the survey directory are to be used as backups for the survey 
section only.  

Pick any one of these files from the Topo directory and push OK. 
This brings up the Attach Reference Settings dialog. Below file name and path is the Model 
drawing that you will be attaching. Typically this will show the attachment of the Default 
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model. 

Next, type in a Logical Name (either “topo”, “contours”, “text”, “wetlands” or “points”) for 
the file.  

Now pick Coincident – World as your Orientation. This will always line up your drawings 
based on the coordinates of those files. 

Leave the Scale (Master:Ref) set to 1:1 and True Scale is enabled.  

If the Nested Attachments area grays out on you then that is a good indication that there is 
no files attached to the file you are currently attaching. If this portion does not gray out then 
you will need to set this to No Nesting or change the Copy Attachment Depth value to 0 
(Figure 12-2). 

 
Figure 12-2: Reference Settings 

 Check page 2-72 for an explanation of Reference File Attachment settings. 
Push the OK button.  

Now repeat these steps until you have attached all the survey files you need to attach.  
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Step Three: Attach Proposed Design and Alignment  
If the plans you are creating require the proposed design and alignment, attach them using the 
same method as above. Depending on type of project, bridge or highway, browse to the 
necessary workgroups \MSTA folder and attach the two files. 

Push Fit View (Figure 12-3) to see all your reference files.  

 
Figure 12-3: The Fit View Button 

 If you fit view and the graphics zoom way out and does not maximize in your view 
window, there may be some problems with a file or files that you have attached. 
Attempt to correct this before you continue. One common problem is that maybe you 
attached the file base on Coincident instead of Coincident – World. Shut off the display 
of your reference files one at a time, fitting view after each one is shut off to try and 
isolate which file is causing the problem. Once you have isolated the file in question, 
detach and try reattaching based on the method described previously.  

Step Four: Place Clip Boundaries 
At this stage we are going to be placing rectangles along the alignment that will correspond 
to our sheets. We will be using the Tasks Menus to accomplish this. 

 Part One: Set the Drawing Scale 
Use the Drawing Scale dialog to set your scale (i.e., 1 in.=25 ft. or 1 in.=50 ft. for U.S. 
Customary projects or 1:250. 

 Part Two: Place the Cells 
From the Tasks Menus, select your Workgroup > Plan > Create Plan Sheets > Place Clip 
Boundary.  

This selects our sheet boundary cell and activates a cell placement command that will make it 
easy to place a bunch of these rectangles along the alignment.  

Notice the box on the end of your cursor. When you send a Datapoint to MicroStation, the 
box will be placed at that location.  

 It’s best not to snap to elements in your file. If the two elements you snap to are at 
different elevations, you might end up with a slightly skewed view. 

The box you just placed will immediately begin to rotate by the origin point (the point you 
just entered.) Move your mouse around and notice how it spins. When it is aligned with the 
roadway, enter another datapoint and it will immediately prompt you to place the next 
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boundary.  

 Don’t worry if they’re not in exactly the right place. You can go back and clean up 
any placement later by using the move and rotate tools.  

 It is important that you place these boundaries in the order that you want your sheets 
to be numbered. We have a routine that automatically creates the plan files for us, and 
it will number them in the same order that you place these clip boundaries. 

Step Five: Placing North Arrows 
Start by rotating the view to “top” if not already in a top view.  

 Refer to page 2-11 for help with view controls. 
From the Tasks Menus, select your Workgroup > Plan > Symbols and Linestyles > North 
Arrow True.  
North is up in your view. It may be necessary to enter 90 degrees in the Place Active Cell 
dialog to orientate the North Arrow to a vertical position. Place the north arrows inside of 
your clip boundaries in a place that is out of the busy area of your plan (preferably the top 
center of each sheet). 

Step Six: Create Cut Sheets 
Now that you have placed all your sheet boundaries, we are going to run a macro that will 
create new plan files for us. From the Tasks Menus, select your Workgroup > Plan > 
Create Plan Sheets > Create Cut Sheets. This macro is going to create saved views in 
??plan.dgn that are aligned with the clip boundaries we just placed then create new drawings 
and attach the saved view from the ??plan.dgn. 

The macro asks you what number you want to use for the starting number of the plan sheets 
(Figure 12-4). 

 
Figure 12-4: Start Numbering At? 

 Depending on your workgroup, you may have a different starting numbers by default. 
The number you see is set based on the estimated number of plan sheets that will be 
placed before these sheets in your plan package. You do have the option to change 
this number at this point in the macro if you have a good feel for your plan 
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package set. We will go back later and re-number all the sheets once the complete 
plan package is ready. 

When the program is finished, it will drop you back into ??plan.dgn and fit the view in a top 
rotation. Open up the files you’ve just created and see how they look! 

Live Nesting 
What is Live Nesting? This is a new method in MicroStation V8i of attaching a file with 
references to another file like our border sheets. By using Live Nesting you no longer need to 
use the old methods of Batch > Attach and Batch > Settings to manipulate the way you 
want your cut sheets to appear for plotting purposes. Now if you want to turn off certain 
levels, adjust displays of reference files or attach/detach additional reference files, you can 
simply do this in your source drawing (i.e., HDPlan, BDPlan, etc.) and all of your border 
files will be displayed in the same manner.  

Troubleshooting 
If you open a plan sheet drawing and the graphics within the sheet are not correct, it could 
mean a couple of things.  

It could mean that some of the drawings that are referenced in are not at the same Global 
Origin as the rest of your drawings. See your Support Staff for assistance if needed or read 
the documentation on Flattening drawings and shifting the global origins.  

Or, it could mean that the clip boundary was placed incorrectly. You can fix this without 
rerunning the “Create Cut Sheets” part of the plan sheet process by following these steps.  

1) Open the incorrect plan sheet. Go to File > Reference - to open reference dialog. 

2) Tools > Detach All to detach the existing reference files.  

3) Now Tools > Attach and be sure to browse to your PIN and select ??PLAN.  

4) When the Reference File Settings dialog comes up, select the “Saved View” from the 
Orientation area you need (i.e., 011) and set Nested Attachments method to Live Nesting. 
Now the saved view will be on your cursor.  

5) Set it down as close to being in the center of your border as possible. 

 It is not necessary to give a description or logical name. 

Adjusting Saved Views 
You can adjust (re-define) the area of the reference files on your plan sheet by using the 
reference file dialog Tools in combination with the Place Fence command.  

Place a fence around your sheet frame and highlight all of the reference files. Choose Tools > 
Clip Boundary. This will expand the area of your original saved view to the extents of your 
fence. 

Also, use the Tools > Clip Mask to remove parts of a reference file or files. 
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Re-sheeting 
It is possible to use the macro to recreate these sheeted drawings. The macro will prompt you 
to overwrite duplicate files.  

However, it is not capable of only sheeting up one or two sheets—it’s all or nothing. If you 
need to make a change to ??plan.dgn (move a clip boundary, add a clip boundary, etc.) 
you’re going to have to go through the process of sheeting again. 

Just a reminder, it can only sheet up files in the order that the clip boundaries were placed in 
the file. If you need to add sheets at the beginning of the project, it might be easier to delete 
all your clip boundary cells that you placed and start again from scratch (from the Tasks 
Menus, select your Workgroup > Plan > Create Plan Sheets > Place Clip Boundary).



mdot MicroStation 
01/01/12 

Project Workflow (Design) 
 

13-1 
 

CChhaapptteerr  1133  PPrroojjeecctt  
WWoorrkkffllooww  ((DDeessiiggnn))  



mdot MicroStation 
01/01/12 

Project Workflow (Design) 
 

13-2 
 

  WWOORRKKIINNGG  OONN  TTHHEE  NNEETTWWOORRKK  



mdot MicroStation 
01/01/12 

Project Workflow (Design) 
 

13-3 
 

STARTING INROADS 
Overview 
The default User Configuration File (UCF) file that InRoads uses when a user launches 
InRoads from the desktop icon is the InRoads_network_V8i.ucf. This directs 
MicroStation/InRoads to the network location for project files. This is the recommended 
workflow for a few major reasons. All files on the network are backed up nightly and these 
files can be accessed by any of the project team members. Managing files that are copied 
from the network to a user’s computer will present the possibility of overwriting files that 
have had work done on them.   

 Refer to page 3-19 for more information on User Configuration files.  

Step One: Launch MicroStation 
Launch MicroStation from the MicroStation V8i icon. The File Open dialog will open 
(Figure 13-1). In the Workspace portion of the dialog, the User is defaulted to 
InRoads_network_V8i and the directories will be pointing to the network (y: drive) for 
project PINs. 

 
Figure 13-1:  File Open dialog when working on the network. 

Step Two: Select Your Project 
Pick your project from the “Project” pull down. This will open that project’s files on the 
network (y: drive) in the user’s MSTA directory based on their workgroup. 
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Step Three: Open a File 
Select a .dgn from the list of files in the directory. Each workgroup has at least one file in 
their project directory for entry purposes (i.e., HDPlan.dgn, BDPlan.dgn, RWPlan.dgn). 
Click OK. 

 At this point, the InRoads splash screen should open momentarily and then the 
InRoads menu dialog will open and wait for input. 

Step Four: Launch InRoads 
Select Applications > InRoads Group > Activate InRoads from the Main Menus. 

Step Five: Create a Working Drawing 

 Overview 
It is recommended that users create a “working drawing” to develop the alignment, profile, 
proposed design and view preliminary cross sections. In this file users can test multiple 
horizontal and vertical alignment scenarios. It can also be used for writing “temporary” 
design features to graphics and viewing preliminary cross sections based on theoretical 
alignments. The idea is that if users work in the deliverable drawings (i.e., alignments, 
highway or bridge drawings) while in a testing phase, others automatically see this data if it 
exists on the network and may begin to do their work based on the preliminary work. 
Reserve creating the deliverable drawings until you are somewhat ready to post them to all 
(ROW, Environment, Public Hearing, etc.). 

 Part One: Create Working Drawing 
Select File > Make Sheetz from the MicroStation main menu. Select a No Prefix drawing 
and select a file name such as bridge or highway and provide the suffix working to the file 
name (i.e., bridge_working or highway_working, multimode_working, etc.). 

 Refer to page 1-57 for more detailed instructions on making new drawings. 
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CREATE A BRIEFCASE 
Overview 
MaineDOT has some Regional Offices with poor network connection speed and Surveyors 
that are working unplugged from the network. These users will need to work on a local copy 
of the network project.  

The Windows Briefcase software provides a method of comparing project files on the 
network with project files copied locally. A briefcase is simply a folder with intelligence. In 
the event a file is modified, added to a project, or deleted from a project, it is possible to 
know when and possibly by whom. 

 Sometimes Windows thinks that you have a file open if the Explorer window has a 
folder open in the Briefcase. To avoid this, simply close the Explorer window or click 
on another folder. Figure 13-2 is a typical message you will see if you are accessing 
the briefcase through Windows Explorer. 

 
Figure 13-2: Open Briefcase 

Step One: Create D:\PIN folder 
Open Windows Explorer and browse to your D drive. Verify that you have a folder named 
PIN at the root of the D drive. If it does not exist, create one (Right click and select New > 
Folder).  

Step Two: Create a Briefcase 
Click on your D:\PIN folder on the left side of the Explorer window. Right click on the right 
side of Explorer (anywhere except on a file or folder) and select New > Briefcase (Figure 
13-3). 
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Figure 13-3: Creating New Briefcase 

Step Three: Rename the Briefcase 
Right click on the Briefcase and select Rename. Type the PIN number of the project you 
want to work on locally and hit enter (i.e., 12745). It’s crucial to stick with the same name as 
it appears on the y: drive. 

Step Four: Open the Briefcase 
Double click on the briefcase. 

 The first time you open the briefcase, the Briefcase Wizard will open giving you brief 
instructions. Click Finish. 
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ADDING PROJECTS TO YOUR BRIEFCASE  
Overview 
One way to add files to your briefcase is to add all file types. This will make a full copy of all 
files in the project directory. This is the easiest way of creating a synchronized copy in your 
briefcase. 

Step One: Adding Network Files To Your Briefcase 
Browse Windows Explorer to the Y:\PIN directory and navigate to your PINs folder. Select 
your project’s decimal folder. Select Edit > Copy To Folder… from the Windows Explorer 
menu (Figure 13-4). 

 
Figure 13-4: Select Copy To Folder… 

In the Copy Items dialog, navigate to the briefcase you just created on your D: drive (i.e. 
D\PIN\12745) Figure 13-5. Select Copy. 
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Figure 13-5: Navigate to your PINs briefcase on your D: drive. 

You will begin Updating Briefcase evident by the dialog (Figure 13-6) and the progress bar. 
When the process is complete, the dialog will disappear.  

 
Figure 13-6: Updating Briefcase dialog while processing. 

 The time it takes to process depends on your network connection and the speed of 
your computer. The initial synchronization will take longer than updates that you will 
do in the future. 

 When there is a database (.mdb) on the network, you may get a few warnings along 
the way. The warnings are intended for reasons described below.  

Step Two: Synchronizing Databases 

 Synchronize Your Databases (Read/Write Permissions) 
If the briefcase encounters a database that you have permissions to edit, you will be prompted 
with a few warning dialogs. 
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First Warning: Creating a Replica 
The briefcase will handle synchronizing a database and will create a copy locally (Figure 
13-7). If you intend on working on this database offline, select Yes. If not, select No and 
refer to page 13-11 for instructions on manually updating the briefcase. 

 
Figure 13-7: Creating a replica of the database locally. 

Second Warning: Creating a Backup 
The briefcase will now recommend creating a backup of the original database on the network 
as it prepares it to be the Design Master (Figure 13-8). Only one of the databases will be able 
to modify and save the design of the database (add additional fields, formatting, change 
Queries, etc.). This is referred to as a Design Master. 

 
Figure 13-8: Creating a backup of the database. 

Third Warning: Pick the Design Master 
Select the copy of the database that you want to be the Design Master (Figure 13-9). If most 
of the changes to the design of the database are going to be done locally, select the Briefcase 
Copy. Otherwise, select the Original Copy. 
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Figure 13-9: Select which database has the ability to make design changes. 

 Synchronizing Others Databases (No Permissions) 
If the briefcase encounters a database that you do not have permissions to edit, a single 
dialog will open (Figure 13-10) stating that it may be already open by someone else or that 
you do not have permissions to edit it. In this case, the only option is to click OK. Refer to 
page 13-11 for instructions on manually updating the briefcase. 

 
Figure 13-10: Briefcase can't open the database - No permissions. 

Step Three: Remove Database(s) from Synchronize List 
If you told the briefcase not to create a replica or permissions prevented you from having 
access to the database, you will have to finish the original synchronization manually. Now 
you will have the opportunity to skip those databases from being updated in your briefcase.  

 Manually Update the Decimal Folder 
In Windows Explorer select your PINs decimal folder. Select Briefcase > Update All from 
the Windows Explorer menu. In the Update dialog (Figure 13-11), scroll and locate any 
databases (.mdb) that you do not want to synchronize. The left portion of the dialog is your 
briefcase location and the rightmost portion is the network file. Right-click near the arrow 
and “Create” text in the center of the dialog between the database and the network location. 
Select Skip from the list. Repeat as necessary. When finished, click Update. 
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Figure 13-11: Update project dialog waiting for input. 
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SYNCHRONIZE YOUR BRIEFCASE 
Update Briefcase and Network 

 Overview 
As you work on your project on your local hard drive, any files that you make changes to 
will be tracked in your briefcase. Likewise, if files are changed on the network, your 
briefcase will identify them. Synchronizing the briefcase with the network will allow the user 
to select which files to update and perform the updating. Users should synchronize their 
briefcase with the network weekly. The network is backed up nightly and is meant to store 
the master copy of all project files. 

 Step One: Open Your Briefcase 
Open Windows Explorer. Make sure that Explorer is displaying all details (View > Details). 
Click on your project’s Briefcase on the left side of the Explorer window to display the 
contents on the right. 

 Step Two: Update All Files (Recommended) 
From Windows Explorer’s main menu, select Briefcase > Update All. The briefcase will 
compare the files in on your hard drive with the network copies and display the results 
(Figure 13-12). 

 
Figure 13-12: Update dialog with default action. 
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The left column displays the file name in question, the next column displays the briefcase 
files information, the next column displays the default action to take in order to update both 
locations and the right column displays its counterpart’s information on the Y: drive. 

The default action can be adjusted at any time by right clicking the file and selecting a new 
action to be preformed to the file. Below is a breakdown of the actions. 

 Replace Option 
When a file has been modified in one or the other location, the briefcase prompts you to 
replace the unmodified file. This is most likely what you want to do.  

However, there may be an instance when the file you were working on was corrupted or 
changes performed are unwanted, you could get a new copy by replacing the file in your 
briefcase. If you right click the file, you get these possible alternatives (Figure 13-13). Notice 
that you also have the option of skipping the update. 

 
Figure 13-13: Update Options 

 Skip (both changed) Option 
When the file in the briefcase and the file on the network have both been modified, the 
briefcase prompts you to “skip” updating the file. This is when communication will need to 
take place. Open Windows Explorer and browse to the Y: drive and locate your PIN. Open 
the folders to the location of the common file (i.e. Y:\pin\ 12745\00\Highway\MSTA). Open 
the dgnuse.log file. This file keeps a record of who has opened the files on the network and 
possibly made changes. Look for an entry in the log for the file in question. The log provides 
you with the time, date and name of the person who had opened the file (Figure 13-14). 

 
Figure 13-14: The dgnuse.log file provides valuable information. 

 Find out from this person if any work was done to the file. Once it is determined which file 
takes precedence, you can Right Click the file and change which direction that the file will 
be copied (Figure 13-15). 
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Figure 13-15: Options when both files have been modified. 

 If it is undetermined which file should be preserved, select skip until the files can be 
compared with one another. 

 The “dgnuse.log” can be misleading. The dgnuse.log on the network tells you who 
opened the file on the Y: drive only, it doesn’t tell you if this person has made 
changes to the file. If a person uses the preference “Immediately Save Design 
Changes” this will change the modified date regardless if changes are made. When a 
person synchronizes their briefcase, a dgnuse-local.log gets copied to the network, 
giving a record of who is adding files from a briefcase.  

 Delete Option (File Removed) 
The Delete option lets you know when a file was deleted in either of the two locations. If a 
file is no longer needed and is deleted, the briefcase gives you the opportunity to make both 
locations identical (Figure 13-16). 

 
Figure 13-16: Options when a file(s) has been deleted. 

If you Right Click on the file, you get these possible alternative actions (Figure 13-16). The 
briefcase gives you the opportunity to delete the file, create (copy) the file again in the 
location it was deleted from or simply don’t delete the file. The dgnuse.log won’t help you to 
find out who deleted this file, however it may tell you who has been working on this project 
on the network, and that itself may open the lines of communication.  

 Create Option 
If a new file was created in either location, the briefcase will give you the option to create the 
file in the other location (Figure 13-17). 
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Figure 13-17: Create options. 

 It is common that other users may be adding files on the network as well as in you in your 
briefcase. Survey, for example, may have additional topography that you need locally. The 
default action (create) is the normally the one you want. You can right click the file for 
alternative actions. The only other action for create is “skip”.  

 Renaming Files in Your Local Briefcase 
It is recommended that all file renaming (i.e., Sheet Renumbering Utility) be done locally in 
your briefcase. The intelligence of your briefcase allows you to take the renamed files and 
create them on the network and at the same time it will also delete the files that were 
associated to these files from the network. This allows for no confusion or duplication of files 
on the network with different names. 



mdot MicroStation 
01/01/12 

Project Workflow (Design) 
 

13-17 
 

REMOVING A PROJECT FROM THE BRIEFCASE 
Once final plans have been delivered to the Contracts for printing, you can remove it from 
your briefcase. Prior to removing it, do one last synchronization on the PIN and manually 
copy any “orphan” files to the network. Orphan files are additional file types that reside only 
in your briefcase. 

 If you added additional file types or created the briefcase with all file types, there may 
not be any orphan files. 

Step One: Open Briefcase and browse to the MSTA folder 
Open Windows Explorer and browse to your project’s MSTA folder on your local hard drive. 

Step Two: Sort by File Status and copy to Clipboard 
Click on the Status heading in Windows Explorer to group the like files together. Highlight 
the orphan files (Figure 13-18) and select Edit > Copy. 

 
Figure 13-18: Adding Orphan Files 

Step Three: Paste files into the appropriate folder on the Y: 
drive 

Open your Explorer to the Y: drive and browse to the folder that contains the project files 
(i.e. Y:\PIN\9045\00\Highway\MSTA). Select Edit > Paste to copy them to this location. 

Step Four: Delete the Project 
After all project files have been synchronized and orphan files copied to the network, you can 
highlight your briefcase and select File > Delete to delete the PIN and free up space on your 
hard drive. 
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STARTING INROADS 
Overview 
The default User Configuration File (UCF) file that MicroStation uses when a user launches 
MicroStation from the desktop icon is the InRoads_network_V8i.ucf. This directs 
MicroStation and InRoads to the network location for project files. This is the recommended 
workflow for a few major reasons. All files on the network are backed up nightly and these 
files can be accessed by any of the project team members. Managing files that are copied 
from the network to a user’s computer will present the possibility of overwriting files that 
have had work done on them. 

MaineDOT has some Regional Offices with poor network connection speed and Surveyors 
that are working unplugged from the network. These users will need to work on a local copy 
of the network project.  

The Windows Briefcase software provides a method of comparing project files on the 
network with project files copied locally. A briefcase is simply a folder with intelligence. In 
the event a file is modified, added to a project, or deleted from a project, it is possible to 
know when and possibly by whom. 

Step One: Launch MicroStation 

 Part One: 
Launch MicroStation from the MicroStation V8i icon. The File Open dialog will open. (This 
could also be done from within your current session of MicroStation by using the 
Applications menu)  

 Part Two: 
Pick the User to your desired preference (network vs. local) using the pull down. 

 Part Three: 
Pick your ##### from the “Project” pull down.  

 Part Four: 
Select your HDPlan.dgn from the list of files in the directory.  

 Part Five: 
Select Applications > InRoads Group > Activate InRoads from the Main Menus. 

 At this point, the InRoads splash screen should open momentarily and then the 
InRoads menu dialog will open and wait for input. 

Step Two: Verify Project Defaults 
From the InRoads menu select File > Project Defaults. 
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The Configuration Name text box (Figure 13-18) should reflect MDOT. 

 
Figure 13-18: Set Project Defaults dialog to MDOT 

If it does not, the user will need to use the drop-down list to select the MDOT configuration 
name. Click Apply and then Close. 

Step Three: Activate Locks Tool Bar 

 Adding Locks Toolbar 
Select Tools > Locks > Toolbar from the InRoads main menu (Figure 13-19). 
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Figure 13-19: Adding the Locks toolbar to the InRoads dialog 

 
LOCKS 

• Feature Filter List 

• Feature Filter Lock (On/Off) 

• Feature Highlight Lock (On/Off) 

• Style Lock (On/Off) 

• Pencil/Pen (Mode) 

• Delete Ink Lock (On/Off) 

• Locate Features/Locate Graphics (Mode) 

• Point Snap Lock/No Snap/Element Snap Lock 

• Station Lock (On/Off) 

• Report Lock (On/Off)  

• Cogo Audit Trail Lock (On/Off) 

 For more information on these tools and their functions, please refer to the 
InRoads internal Help (Help > Contents). 
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BRIEF OVERVIEW OF PROJECT WORKFLOW 
Overview 
This portion of the manual outlines the basic workflow of a common InRoads project. These 
topics are broken down in more detail in subsequent Chapters. These Chapters are referenced 
with page numbers. 

Starting an InRoads Project 

 Launching InRoads 
 Refer to page 13-3 for instructions on entering a project correctly. 

 Make Working Drawing 
 Refer to page 13-4 for instruction on creating a working drawing. 

 Attaching the Ground Surface 
 Refer to page 13-25 for instructions on opening a surface. 

 Attaching Template Library 
 Refer to page 15-13 for instruction on how to attach the standard MaineDOT 

template library. 

Creating a Geometry Project 

 Create a Geometry Project 
 Refer to page 14-2 for instructions on creating a Geometry Project. 

 Create a Horizontal Alignment 
 Refer to page 14-4 for instructions on creating a Horizontal Alignment. 

 Create a Vertical Alignment 
 Refer to page 14-24 for instructions on creating a Vertical Alignment. 

 Design Your Horizontal and Vertical Alignment 
 Refer to page 14-8 for instructions on designing your horizontal and vertical 

alignments. 

 Create Alignment Deliverables 
 Refer to page 14-19 for instructions on creating the alignment drawing. 

Creating a Template 
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 Attach MaineDOT’s Standard Template Library 
 Refer to page 15-13 for instructions on attaching MaineDOT’s Standard Template 

Library. 

 Create Project Specific Template Folder 
 Refer to page 15-29 for instructions on creating a project specific template folder. 

 Create Project Specific Templates 
 Refer to page 15-29 for instructions on creating a project specific template(s). 

Creating a Corridor within Roadway Designer 

 Create a Design Corridor 
 Refer to page 16-4 for instructions on creating and Managing Corridors. 

 Drop and Run a Template down the Corridor 
 Refer to page 16-6 for instructions on applying a Template Drop(s) on a Corridor 

 Adjust Transitions 
 Refer to InRoads HELP or Bentley instructional manuals for this item until further 

documentation is accomplished. 

 Design Superelevation 
 Refer to page 16-17 and the InRoads HELP for instructions on adding and 

adjusting Superelevations. 

 Design Drives and Side Roads 
 Refer to instruction manuals used by Bentley instructor for more information on 

complex side road design. 

Creating a Design Surface 

 Create the Deign Surface 
 Refer to page 16-36 for instructions on creating a design surface. 

 Editing the Design 
Edit the design in the Roadway Designer to maintain the model (surface) integrity. Changes 
made in MicroStation will not appear in the design surface. 

 Refer to InRoads HELP or Bentley instructional manuals for this item until further 
documentation is accomplished. 

 Create Highway or Bridge Design Deliverables 
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 Refer to page 16-37 for instructions on creating a design drawing. 

Drainage Development 
This area still needs development. We will eventually be taking advantage of the InRoads 
Drainage product and toolset, however, setup is not yet complete. Drainage will need to be 
developed using the resulting sections and design plan. Consider creating a separate file for 
drainage features and reference the design so that if the design needs to be re-written to 
graphics, the drainage won’t be lost. When the design is set in stone, merge the drainage into 
the design file. 

Geometric Curb Layout 
This area still needs development. Each curb and/or gutter feature will need to be made into 
an alignment (Use File > Import Geometry), reports derived and provided in table format. 
We will be developing custom reports, filters and sheet up routine in the near future. 
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MANAGING YOUR INROADS PROJECT (RWK) 
Overview 
An .RWK file is an easy way of automatically loading all the Surfaces (.dtm), Alignments 
(Geometry Projects .alg), the Template Library (.itl), Roadway Designer file (.ird), Survey 
Field Book (.fwd) and Preference file (.xin) for your project instead of having to load them 
individually. You can have multiple .RWK files based on the task at hand. You can set the 
.RWK file to automatically update (save) these same files before you close InRoads. 
Anything newly created will need saved first, and then you can append the .RWK for future 
use in your next InRoads session.  

Creating and Saving an .RWK 

 Overview 
The Template_V8i.itl and the mdot_us_V8i.xin should be in the project directory by 
default. The mdot_us_V8i.xin is automatically loaded when you enter InRoads correctly. 
The Ground.dtm is available when Survey has completed the Survey Editing and has 
created the deliverables. Below is an example of creating an .RWK with the basics, then later 
adding the other aspects as you create them. 

 Step One: Open InRoads 
Open InRoads via Applications > InRoads Group > Activate InRoads. Select your project 
from the Project pull down. Enter a file. 

 Step Two: Open the Ground.dtm 
Select File > Open from the InRoads main menu. Change the Files of Type pull down to 
Surfaces (*.dtm) and browse to the Survey\MSTA folder. Select the Ground.dtm, click 
Open and then Cancel to close the dialog. 
Tip: You can also browse to the Surface tab (or other tabs for that matter), in InRoads 
Explorer. Right click on the word Surfaces and select Open… (Figure 13-19) Browse to the 
Survey\MSTA folder, and select Ground. Click Open and then Cancel to close the dialog. 

 
Figure 13-19: Sub menu for opening a surface. 
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 Step Three: Open Template.itl 
Select the Template tab, right click on the Template Library and select Open. If necessary, 
browse to the InRoadsSTD folder within your project.  

 Step Four: Save As… Design.rwk 
Select File > Save As… from the InRoads main menu. If necessary, change the File Type 
pull down (Figure 13-20) to Projects (*.rwk). Supply a name for the .RWK (i.e., Design or 
Survey depending on the user). 

 
Figure 13-20: Adjust the Save as Type pull down to Projects (*.rwk) 

 Step Five: Select Options Button 
Select the Options button (shown in Figure 13-20). Select the Surfaces tab. Place an “X” in 
the Add box (Figure 13-21). Add means this file will “Open” if the RWK is opened. 

 
Figure 13-21: Project Options when saving an .RWK as Add only 
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 Depending on permissions, you may not be able to write to the Survey\MSTA folder.  

Select the Template Library tab. Place an “X” in the Add and Update boxes (Figure 13-22). 
Update means this file will “Save Down” if the RWK is saved.  In summary, Add means 
Open, Update means Save, but only if the RWK is utilized. 

 
Figure 13-22: Project Options when saving an .RWK as Update and Add 

Click OK. Select the Save button then select Cancel to close the Save As dialog. 

Adding to a RWK 
As a user creates each aspect of an InRoads project, they will need to add it to the .RWK. For 
example, when creating a Geometry Project (alignment container), first a user would have to 
save the .ALG by selecting File > Save > Geometry Project. Click Save and then Cancel to 
close the dialog. 
Then, select File > Save As > Project… and select the Design.rwk or Survey.rwk 
depending on your workflow. Click the Options button and select to the Geometry Project 
tab. Place an “X” in the Update box. This will also place an “X” in the Add box as well. 
Click OK to dismiss the Project Options dialog. Select Save to save the .RWK. You will be 
prompted to overwrite the original .RWK file. If this is your intention, click Yes. 

Manually Editing a RWK 

 Overview 
When you create an .RWK, it hard codes the path to the files. If you happened to be working 
on the D:\ drive when you saved your .RWK, it will remember the path to your project 
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located on the D: drive. The .RWK wouldn’t work once the project is copied to the Y: drive. 
Once an .RWK is established, it can be easily copied and edited to point to the project on the 
Y: drive or visa-versa.  

 Edit with Notepad 
Using Windows Explorer, browse to your Workgroup’s MSTA folder within your PIN. 
Locate the .RWK file. Highlight the file, select Edit > Copy. Select Edit > Paste to paste a 
copy within the same directory. Select File > Rename and enter a new name for the file (i.e. 
Design-network.rwk). 

 Double click it to Open the file for editing.  If Windows can’t open the file but will give you 
an option to Open With, pick this option (Figure 13-23) and select Notepad to open this file 
type. 

 
Figure 13-23: Select a program to open the .rwk extension (Notepad) 

Once the file is open, you will notice that the paths are pointing to the D:  drive (Figure 
13-24).  

 
Figure 13-24: RWK file pointing files the D: drive 

Replace the D: with a Y: so that the paths to the files are directed to the network (Figure 
13-25). Save the file. 
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Figure 13-25: RWK file adjusted so that it points for files on the Y: drive
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CREATE A GEOMETRY PROJECT 
Overview 
To create an alignment in InRoads, you first must create a Geometry Project. A Geometry 
Project is nothing more than a container for your horizontal and vertical alignment. InRoads 
stores an alignment as an .ALG file. You can have multiple Geometry Projects open, but 
only one active.  

Create Highway_working.dgn 
Create a Highway_working or Bridge_working file to work in and Start InRoads Suite V8i. 

Step One: Create a Geometry Project 

 Part One: 
Using the “arrow” buttons on the InRoads Explorer dialog (highlighted in red in Figure 
14-1), browse to the Geometry tab. Right click the words Geometry Project and select 
New… (or select File > New… from the InRoads main menu). 

 
Figure 14-1: Create a new Geometry Project 

 Part Two: 
Supply the name MainLine for your Geometry Project as seen in Figure 14-2. Add a 
description if you think it would be helpful, but it’s not necessary. Click Apply. Don’t close 
the dialog yet. 
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Figure 14-2: Name the Geometry Project 

Step Two: Create a Horizontal Alignment (Container) 

 Part One: 
With the New dialog still open, change the pull down to Horizontal Alignment (Figure 14-3). 

 
Figure 14-3: Create a new Horizontal Alignment 

 If you’ve closed the dialog, right click the Geometry Project you just created and 
select New… or select File > New… from the InRoads main menu. 

 Part Two: 
Supply MainLine_Horiz for the name of your Horizontal Alignment as seen in Figure 14-4. 
Add a description that you would want to use for the road name. Later on we can extract it 
with Drafting Notes. 
Change the Style to D_Roadway_Centerline. Click Apply. Don’t close the dialog yet. 
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Figure 14-4: Name the Horizontal Alignment 

Step Three: Create a Vertical Alignment (Container) 

 Part One: 
With the New dialog still open, change the pull down to Vertical Alignment (Figure 14-5). 

 
Figure 14-5: Create a new Vertical Alignment 

 If you’ve closed the dialog, right click the Horizontal Alignment you just created 
and select New… or select File > New… from the InRoads main menu. 

 Part Two: 
Supply MainLine_Vert as the name of your Vertical Alignment as seen in Figure 14-6. Add 
a description if you think it would be helpful, but it’s not necessary.  

Change the Style to D_Roadway_Centerline. Click Apply and then click Close. 
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Figure 14-6: Name the Vertical Alignment 

Step Four: Save Geometry Project 
There is more than one way to save the project. Right click on the Geometry Project and 
select Save (Figure 14-7). The directory should be defaulted to your Workgroup’s MSTA 
folder. Select Save and click Cancel to close the dialog. 

 
Figure 14-7: Save the Geometry Project at the InRoads Explorer dialog 

Another method is to select File > Save > Geometry Project from the InRoads main menu 
(Figure 14-8). The directory should be defaulted to your Workgroup’s MSTA folder. Select 
Save and click Cancel to close the dialog. 
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Figure 14-8: Saving the project via the main menu 

Step Five: Add to RWK 
Now would be a good time to add the Geometry Project to your RWK. Select File > Save 
As… and adjust the Save as Type to Projects (*.rwk) and adjust the Options button to Add 
and Update the new Geometry Project. 
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DESIGN HORIZONTAL ALIGNMENT 
Overview 
Anyone who has done alignments in the past (with MX or any other software) will find the 
tools very familiar in name and operation. InRoads HELP menu will provide a good 
definition of the types of tools available.   

 The section below highlights the Element toolset to create horizontal geometry.  The 
other toolset is the PI toolset and the main difference is the alignment has to be 
continuous from start to stop for those tools to be used.  A designer might need to rely 
on both methods to fully define the needed geometry, so it is advantageous to know 
what both can do.   

InRoads Help 

 Overview 
InRoads provides tool specific help on each tool. The help is also available on specific topics 
in the Table of Contents.   
Before using the tools reviewed below, let’s review the three types of elements and then 
you’ll better understand how they are to be placed: 

o Fixed Horizontal Elements are fully defined in shape and position, enough 
information is available to lock the piece of geometry in place.  It could be considered 
independent of other existing elements.  Lines will be defined by information such as 
Start points and End points or a Start point with a direction and distance.  Curves will 
be defined by Two Points and Radius or Three Points. 

o Floating Horizontal Elements are linked and attached on one end to an existing 
element.  That existing element will serve as a base for the proposed element.  Once 
placed, it will become a fixed element.  When connecting to an existing curve or line, 
the element will adjust to the best fit solution.  Lines will be defined by a Point or 
Direction and the resulting floating line will be a best fit.  Curves follow the same 
workflow and the existing element responds by adjusting itself to meet the new 
solution.  Curves will be defined by Point and Radius or Point and Direction. 

o Free Horizontal Elements are linked to two existing elements and they must fit in 
between them.  Free Elements cannot be at start or end of alignment.  They simply 
connect to other elements at both ends.  The Free Curve needs the user to enter a 
Radius.  The Free Line connects to the adjacent curve elements. 

When defining Vertical Geometry using the Element tools, the same general constraints 
apply, but with vertical geometry parameters.  Vertical Element tools are covered later in this 
chapter. 

 

 



mdot MicroStation 
01/01/12 

Alignment Design 
 

14-9 
 

 Part One: 
Select Help > Contents from the InRoads main menu. 

 Part Two: 
Select Reference Information on the left of the directory tree. Select the Geometry link on 
the right (Figure 14-9).  

 
Figure 14-9: Civil Help – Reference Information 
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HORIZONTAL ELEMENT METHOD 
Method One: Add Fixed Line… 
Select Geometry > Horizontal Element > Add Fixed Line… from the InRoads menu.  This 
will bring up the Add Fixed Horizontal Line dialog Figure 14-10. 

 Part One: Add Fixed Horizontal Line – By Two Points 
To create a Fixed Horizontal Element by two points, enable Point 1 and Point 2. Key in the 
appropriate Northing and Easting values (Figure 14-10) or you could click the Target Button 
and snap to a MicroStation graphic to set the location.  Click Apply and Left Mouse Button 
to accept. Remember to follow the prompts in the bottom left of the MicroStation window.  

 
Figure 14-10: Add Fixed Horizontal Line Dialog – Mode: By Two Points 

 Part Two: Add Fixed Horizontal Line – By Point, Direction and 
Distance 
To create a horizontal element by point, direction and distance, change the Mode to By Point, 
Direction and Distance. Key in the appropriate Northing and Easting values (this is where 
the line will start). Key in the appropriate Direction and Distance (Figure 14-11). Click 
Apply and Left Mouse Button to accept. 
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Figure 14-11: Add Fixed Horizontal Line Dialog – Mode: By Point, Direction and Distance 

 Informational Example 
You can layout alignments with the fixed horizontal line graphically as well. Just disable all 
options within the dialog (Figure 14-12). Click Apply and follow the prompts as provided in 
the lower left corner of the MicroStation graphic window. 

          
Figure 14-12: Add Fixed Horizontal Line Dialogs – All Options Disabled 

Method Two: Add Free Horizontal Curve… 
Select Geometry > Horizontal Element > Add Free Curve… from the InRoads menu. This 
will bring up the Add Free Horizontal Curve dialog (Figure 14-13). 

 Part One: Add Free Horizontal Curve… 
Enter values for the Radius and click Apply to begin the command. A negative value will 
create a circular curve in a counter clockwise direction and a positive value will produce a 
clockwise circular curve. Remember to follow the prompts in the bottom left of the 
MicroStation window. 
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Figure 14-13: Add Free Horizontal Curve Dialog 

Identify first element; identify second element and Left Mouse Button to accept the circular 
curve between the two fixed elements. Right Mouse Button to end this process. 

Method Three: Add Floating Horizontal Curve… 
Select Geometry > Horizontal Element > Add Floating Curve… from the InRoads menu. 
This will bring up the Add Floating Horizontal Curve dialog (Figure 14-14). 

 Part One: By Point and Radius 
To create a floating horizontal curved element by point and radius, change the Mode to By 
Point and Radius.  Key in the appropriate Northing and Easting values (this is the location 
where the curve will end) or you could click the Target Button and snap to a MicroStation 
graphic to set the location.  . Key in the appropriate Radius (Figure 14-14). Click Apply; 
identify element with a Left Mouse Button and Left Mouse Button to accept the floating 
circular curve off the beginning element. Right Mouse Button to end this process. 

 This tool, like many others, allows for the use of Spirals in the Leading and Trailing 
Clothoid fields.  However, MaineDOT does not regularly use Spirals. 

 
Figure 14-14: Add Floating Horizontal Curve Dialog – By Point and Radius 

 Part Two: By Point and Direction 
To create a floating horizontal curved element by point and direction, change the Mode to By 
Point and Direction. Key in the appropriate Northing and Easting values (this is the 
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location where the curve will end). Key in the appropriate Radius. Key in the appropriate 
Direction (this is an imaginary line where the curve will be tangent). See Figure 14-15. 

 
Figure 14-15: Add Floating Horizontal Curve Dialog – By Point and Direction 

Click Apply; Identify preceding element with a Left Mouse Button and Left Mouse Button 
to accept the floating circular curve element. Right Mouse Button to end this process. 

Method Four: Add Fixed Horizontal Curve… 
Select Geometry > Horizontal Element > Add Fixed Curve… from the InRoads menu.  
This will bring up the Add Fixed Horizontal Curve dialog. 

 Part One: By Two Points and Radius 
To create a fixed horizontal curved element by two points and radius, change the Mode to By 
Two Points and Radius.  Key in the appropriate Northing and Easting values (this is the 
location where the curve will begin and end) or you could click the Target Button and snap to 
a MicroStation graphic to set the location.  Key in the appropriate Radius. See Figure 14-16.  
Click Apply and Left Mouse Button to accept. 
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Figure 14-16: Add Fixed Horizontal Curve – By Two Points and Radius 

 Part Two: By Three Points 
To create a fixed horizontal curved element by three points, change the Mode to By Three 
Points.  Key in the appropriate Northing and Easting values (this is the location where the 
curve will begin and end; Point 2 is a pass-through point). See Figure 14-17. Click Apply 
and Left Mouse Button to accept. 
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Figure 14-17: Add Fixed Horizontal Curve – By Three Points 

Method Five: Add Floating Horizontal Line… 
Select Geometry > Horizontal Element > Add Floating Line… from the InRoads menu. 
This will bring up the Add Floating Horizontal Line dialog. 

 Part One: By Point 
To create a floating horizontal line by point, change the Mode to By Point. Key in the 
appropriate Northing and Easting values (this is the location where the line will end) or you 
could click the Target Button and snap to a MicroStation graphic to set the location.  See 
Figure 14-18. 

 
Figure 14-18: Add Floating Horizontal Line – By Point 

Click Apply.  Identify the curve element with a Left Mouse Button and Left Mouse Button 
to accept the floating horizontal line. Right Mouse Button to end this process. 
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 Part Two: By Direction 
To create a floating horizontal line by direction, change the Mode to By Direction. Key in the 
appropriate Direction (this is the direction of the line).  See Figure 14-19. 

 
Figure 14-19: Add Floating Horizontal Line – By Direction 

Click Apply; Identify the curve element with a Left Mouse Button; Move your mouse to the 
side of Mainline you just identified, which will show the floating line alignment and Left 
Mouse Button to accept the point; Left Mouse Button again to accept the floating line. 

Method Six: Add Free Horizontal Line… 
Select Geometry > Horizontal Element > Add Free Line… from the InRoads menu. This 
will bring up the Add Free Line dialog.  

 Part One: Add Free Line 
This tool has no dialog just simply follow the prompts; it does require that you select the 
preceding and following element to make the appropriate connection. Select the first element 
with a Left Mouse Button; select the second element with a Left Mouse Button and Left 
Mouse Button to accept the free horizontal line. 



mdot MicroStation 
01/01/12 

Alignment Design 
 

14-17 
 

ADJUSTING START STATION 
After completing the horizontal alignment it is recommended to adjust the start station of 
your alignment. To do this select Geometry > Horizontal Curve Set > Stationing… from 
the InRoads main menu. See Figure 14-20. 

 
Figure 14-20: Geometry > View Geometry > Stationing Command 

Select the Horizontal Alignment name; pick the Northing and Easting point by using the 
target button and graphically selecting the start location and then type the desired Starting 
Station.  Click Apply. See Figure 14-21. 

 
Figure 14-21: Stationing Dialog 
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EDITING HORIZONTAL ALIGNMENT 
Overview 
There are a few different ways to manipulate your horizontal alignment. The list below is 
how you can manipulate your horizontal alignment short of deleting and recreating portions 
of it. The following does require you have integrity within your alignment. 

• Geometry > Horizontal Curve Set > (Add PI, Insert PI, Move PI or Delete PI) 

• Geometry > Horizontal Curve Set > Define Curve… 

• Geometry > Horizontal Curve Set > Table Editor… 
If there are discontinuities then you may choose to fix the problem by checking the integrity 
of the alignment and deleting the problem element or by using: 

• Geometry > Horizontal Element > Check Integrity… 

• Geometry > Horizontal Element > Edit Element… 

• Geometry > Horizontal Element > Delete Element… 
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ANNOTATING HORIZONTAL ALIGNMENTS 
Overview 
With MaineDOT’s setup standards for InRoads we have made it really simple to annotate 
your alignment. The final deliverable requires that you create an Alignments.dgn file for 
your final alignments. 

When creating a horizontal (or vertical) geometry from scratch, the Geometry > View 
Geometry > Options tool allows for annotation to show automatically while creating the 
geometry itself.  See Figure 14-22. The Default preference turns on 3 horizontal tools and 1 
vertical tool.  When you define the geometry, if the Style matches one of the tools available 
preference set names (case-sensitive), then the link is defined and the annotation will show 
automatically which saves multiple steps and improves workflow efficiency.   

 
Figure 14-22: Geometry Options 

Other preferences are available and allow user to see only horizontal annotation, only 
vertical, or turn off all toggles.  In review, just because the toggles are turned on, doesn’t 
mean it will work.  The Horizontal Alignment Style needs to match an available preference 
set name within the tool toggled on (i.e. D_Roadway_Centerline).  See Figure 14-23. 

 
Figure 14-23: Preferences Dialog 

Step One: View Alignment 
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 Part One: Create File 
Select File > Make Sheetz from the MicroStation main menu and create a no prefix drawing 
called Alignments.dgn. Cancel the dialog once the file is created. You will notice you are in 
the new drawing by looking at the top left of the MicroStation window. 

 After entering your project file you may want to verify your Global Scale Factors are 
set to the desired scale before displaying your Alignment drawing. 

 If you started your alignment at a station other than an even 100’ increment (i.e., 
10+21.00, 2+20.00), verify your Station Lock is On before annotating your 
alignment. 

 Part Two: View Alignment 
Verify you have the new alignment active that you just created by checking within your 
Geometry Project to see if there is a red square (means it is “active”) around it.  See Figure 
14-24. 

 
Figure 14-24: InRoads Explorer – Active Geometry 

Also check to see if you have the Station Lock on so that you get 100 foot stationing based 
on the even stationing value. This is important only when you may have started the stationing 
with an odd value; however this lock is almost always on.  See Figure 14-25. 

 
Figure 14-25: Station Lock 

Step Two: Annotate Stationing 
Select Geometry > View Geometry > Stationing… from the InRoads main menu. Select 
your Horizontal Alignment: by using the pull down arrow or using the Target button to 
pick it graphically. Click Apply. See Figure 14-26. 
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Figure 14-26: View Stationing Dialog 

Step Three: Annotate Bearings 
Select Geometry > View Geometry > Horizontal Annotation… from the InRoads main 
menu. On the Main tab there is a location for Horizontal Alignments-Include: you can 
place the cursor in this area and select Filter… in the upper right area of the dialog to select 
the alignment, use the Target button to pick your alignment graphically, type the name and 
hit the Tab key on your keyboard, or even use a wild card like * and hit the Tab key on your 
keyboard.  In any case you want to have the dialog look like below (Figure 14-27).  Click 
Apply. 
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Figure 14-27: Horizontal Annotation Dialog 

There will be some cleanup required as far as rotation of the bearings for the alignment. 
Simply use the rotate tool within MicroStation to adjust this. 

Step Four: Annotate Curve Data 
Select Geometry > View Geometry > Curve Set Annotation… from the InRoads main 
menu. Select your Horizontal Alignment: by using the pull down arrow or using the Target 
button to pick it graphically. See Figure 14-28. Click Apply. 
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Figure 14-28: Curve Set Annotation Dialog 

There will be some cleanup required as far as rotation of the curve data for the right side of 
the alignment. Simply use the rotate tool within MicroStation to adjust this. 

Step Five: Flatten the Alignment 
Select File > Export > 2D from the MicroStation menu. Key-in a new filename and click 
OK to flatten all elements in your Alignments.dgn. You have to use the File > Open 
command to open the 2D file that was just exported. 

 By default InRoads should display the alignment at elevation zero unless you display 
a 3D alignment. InRoads will still maintain all information about the vertical 
alignment for reporting.  
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DESIGN VERTICAL ALIGNMENT 
Overview 
Anyone who has done alignments in the past (with MX or any other software) will find the 
tools very familiar in name and operation. InRoads HELP menu will provide a good 
definition of the types of tools available.  

 Before Vertical geometry can be defined, it needs to be a child of its horizontal 
alignment & a working profile needs to be created to work within.  Profile creation is 
covered in the next section. 

 The section below highlights the Element toolset to create vertical geometry.  The 
other toolset is the PI toolset and the main difference is the alignment has to be 
continuous from start to stop for those tools to be used.  A designer might need to rely 
on both methods to fully define the needed geometry, so it is advantageous to know 
what both can do. 

InRoads Help 

 Overview 
InRoads provides tool specific help on each tool. The help is also available on specific topics 
in the Table of Contents. 

 Part One: 
Select Help > Contents from the InRoads main menu. 

 Part Two: 
Select Reference Information on the left of the directory tree. Select the Geometry link on 
the right. 
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VERTICAL ELEMENT METHOD 
Method One: Add Fixed Line… 
Select Geometry > Vertical Element > Add Fixed Line… from the InRoads menu.  This 
will bring up the Add Fixed Vertical Line dialog.   

 Part One: By Two Points 
To create a fixed vertical line by two points, key in the Station and Elevation of the 
beginning and end of the line. See Figure 14-29. 

 
Figure 14-29: Add Fixed Vertical Line Dialog – By Two Points 

Click Apply and Left Mouse Button to accept. 

 Part Two: By Point, Grade and Distance 
To create a fixed vertical line by point, grade and distance, key in the Station and Elevation 
of the beginning of the line. Then, key in the Grade and Distance to the end of the line.  See 
Figure 14-30. 

 
Figure 14-30: Add Fixed Vertical Line Dialog – By Point, Grade and Distance 

Click Apply and Left Mouse Button to accept. 

Method Two: Add Fixed Vertical Curve… 
Select Geometry > Vertical Element > Add Fixed Curve… from the InRoads menu. 
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 Part One: By Two Points and Parameter 
To create a fixed vertical curve by two points and parameter, key in the Station and Elevation 
of the first and last points of the curve. Key in the appropriate Parameters.  See Figure 14-31. 

 
Figure 14-31: Add Fixed Vertical Curve Dialog – By Two Points and Parameter 

Click Apply and Left Mouse Button to accept. 

 Part Two: By Three Points 
To create a fixed vertical curve by three points, key in the Station and Elevation of the first 
and last points of the curve. Key in the Station and Elevation of any point on the curve 
(Station 2 and Elevation 2). See Figure 14-32. Click Apply and Left Mouse Button to 
accept. 

 
Figure 14-32: Add Fixed Vertical Curve Dialog – By Three Points 
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Method Three: Add Floating Vertical Curve… 
Select Geometry > Vertical Element > Add Floating Curve… from the InRoads menu.  
This will bring up the Add Floating Vertical Curve dialog. 

 Part One: By Point and Parameter 
To create a fixed vertical curve by point and parameter, key in the Station and Elevation of 
where the curve ends.  Key in the appropriate Parameters.  See Figure 14-33. 

 
Figure 14-33: Add Floating Vertical Curve Dialog – By Point and Parameter 

Click Apply; identify the preceding element with a Left Mouse Button and Left Mouse 
Button to accept the floating vertical curve off the beginning element. Right Mouse Button 
to end this process. 

Method Four: Add Free Vertical Curve… 
Select Geometry > Vertical Element > Add Free Curve… from the InRoads menu. This 
will bring up the Add Free Vertical Curve dialog. 

 Part One: Length 
To create a free vertical curve by length, key in the appropriate Length of the curve.  See 
Figure 14-34. 

 
Figure 14-34: Add Free Vertical Curve Dialog 

Click Apply; identify the first element with a Left Mouse Button and the second element 
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with a Left Mouse Button; Left Mouse Button to accept the free vertical curve between the 
two elements. Right Mouse Button to end this process. 

Method Five: Add Floating Vertical Line… 
Select Geometry > Vertical Element > Add Floating Line… from the InRoads menu. This 
will bring up the Add Floating Vertical Line dialog. 

 Part One: By Point 
To create a floating vertical curve by point, change the Mode to By Point. Key in the Station 
and Elevation of the end of the line. See Figure 14-35. 

 
Figure 14-35: Add Floating Vertical Line Dialog 

Click Apply; identify the preceding element with a Left Mouse Button and Left Mouse 
Button to accept placement. Right Mouse Button to end this process. 

The Add Floating Vertical Line also has the option to place the line By Grade. For this 
option you would want to verify the exiting grade of the parabola and place this in the Grade 
location of the dialog box and follow the prompts for placement. 

Method Six: Add Free Vertical Line… 
Select Geometry > Vertical Element > Add Free Line… from the InRoads menu. 

 Part One: Add Free Line 
This tool has no dialog just simply follow the prompts; it does require that you select the 
preceding and following element to make the appropriate connection. Select the first element 
with a Left Mouse Button; select the second element with a Left Mouse Button and Left 
Mouse Button to accept the free vertical line. 

Use this tool to fill in the gaps between parabolas previously placed. There should be two 
locations within the vertical alignment that will need this to finalize the vertical alignment. 
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EDITING VERTICAL ALIGNMENT 
Overview 
There are a few ways to edit the vertical geometry that was just placed through the exercise. 
Below is a list of possible ways to edit the vertical alignment. 

• Geometry > Vertical Curve Set > (Add PI, Insert PI, Move PI or Delete PI) 

• Geometry > Vertical Curve Set > Define Curve… 

• Geometry > Vertical Curve Set > Table Editor… 
If there are discontinuities then you may choose to fix the problem by checking the integrity 
of the vertical alignment and deleting the problem element or by using: 

• Geometry > Vertical Element > Check Integrity… 

• Geometry > Vertical Element > Edit Element… 

• Geometry > Vertical Element > Delete Element… 
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ANNOTATING VERTICAL ALIGNMENT 
Overview 
With MaineDOT’s setup standards for InRoads we have made it really simple to annotate 
your vertical alignment. If you want to create a long profile and annotate it for printing the 
following will need to be done. 

Step One: Create File 
Select File > Make Sheetz from the MicroStation main menu and create a no prefix drawing 
called Profile.dgn. Cancel the dialog once the file is created. You will notice you are in the 
new drawing by looking at the top left of the MicroStation window. 

 After entering your project file you may want to verify your Global Scale Factors are 
set to the desired scale before displaying your Annotation. 

 If you started your alignment at a station other than an even 100’ increment (i.e. 
10+21.00, 2+20.00), verify your Station Lock is on before annotating your alignment. 

Step Two: Create Long Profile 
Select Evaluation > Profile > Create Profile… from the InRoads main menu. Verify you 
have the active vertical alignment; select the Source location in the InRoads explorer tree 
and look to the right. See Figure 14-36. 

 
Figure 14-36: Create Profile Dialog – Horizontal Alignment Selection 

Return to the General location and select the Ground surface only. See Figure 14-37. 

 
Figure 14-37: Create Profile Dialog – Surface Selection 

You can limit the length of the profile if your design is only a portion of the overall 
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horizontal alignment. Select the Controls folder and limit the profile from the start to stop.  
See Figure 14-38. 

 
Figure 14-38: Create Profile Dialog – Station Limits 

Click Apply and Identify Location of profile within the view window of MicroStation with 
a Left Mouse Button. 

Step Three: View Alignment 
Verify you have the new alignment active that you just created the profile along by checking 
within your geometry project to see if there is a red square around it (signifies it is ‘active’). 
Select Geometry > View Geometry > Active Vertical. 

Step Four: Annotate Elevations 
Select Evaluation > Profile > Annotate Profile from the InRoads main menu. Verify you 
have the correct Profile Set: picked if there is more than one profile drawing created within 
this file. See Figure 14-39. 

 
Figure 14-39: Annotation Profile – Profile Set Selection 

Select the Preferences… button at the bottom of the Annotate Profile dialog and load the 
Proposed and Existing Elevation preference.  See Figure 14-40. 
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Figure 14-40: Preferences for Annotate Profile Dialog 

Close the dialog. 

Verify your Vertical Alignment: and set the Surface: to Ground.  See Figure 14-41.  

 
Figure 14-41: Annotation Profile – Vertical Alignment and Ground Selection 

Click Apply. 

Step Five: Annotate Vertical Curve Information 
Select Geometry > View Geometry > Vertical Annotation from the InRoads main menu. 
On the Main tab verify you have the correct Horizontal Alignment, Vertical Alignment 
and Profile Set picked.  See Figure 14-42. Click Apply. 

 
Figure 14-42: View Vertical Annotation Dialog 
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  DDRRAAFFTTIINNGG  NNOOTTEESS  
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 USING INROADS DRAFTING NOTES 
Overview 
InRoads Drafting Notes are extremely useful as an analysis tool as well as an annotation tool. 
Use this command to place an annotation note in a Plan, Profile or Cross Section design file. 
Notes can annotate existing or proposed InRoads features too. 

As a drawing production tool, InRoads allows you to place computed or manual text as an 
intelligent note, meaning it does not have to be deleted when changes occur; it can be 
automatically updated, moved, or edited throughout the design process.  

Notes are composed by directly keying text into the text field; selecting keywords for 
computed values; by selecting text from the User Text field; or by a combination of these 
methods. The entire note can be composed directly on the main dialog box.  

MaineDOT Standard Notes.dft file 
InRoads was shipped with a default notes.dft file that contains some basic examples of 
drafting notes. This file is separate from the .XIN (InRoads Preference file). We have defined 
the location of the Drafting Notes file through the Project Defaults. This location is within 
MaineDOT’s InRoads configuration on users C: drive as opposed to within the project’s 
folder structure. In this case, running the Update Utility will update the notes.dft making it 
available for any project. 

As users develop more specific notes for standard MaineDOT notation, we can add them to 
the master notes.dft file and make them available for everyone.    

Step One: Select Alignment and Surface 

 Part One: Open Drafting Notes Dialog 
Select Drafting > Place Plan Note from the InRoads main menu. The Place Plan Note 
dialog opens with the active Horizontal Alignment selected along with the last active Surface.  
See Figure 14-43. 
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Figure 14-43: Place Plan Note Dialog 

 Part Two: Select Alignment and Surface 
Select the centerline that you want to reference from the Horizontal Alignment pull down. 
For training purposes, select the MainLine_Horiz. 
Set your active surface to Design by selecting it from the Surface pull down. 

 Part Three: Global Scale Factor 
 The Global Scale Factor does come into play when using the Drafting Notes. 
Select Tools > Global Scale Factor from the InRoads main menu. Enter the scale factors 
manually based on the type of drawing you are annotating.  See Figure 14-44. 

 
Figure 14-44: Scale Factors Dialog 

OR 

Select File > Project Options from the InRoads main menu. Load the Preference that 
corresponds to the type of drawing you are annotating and the scale it needs to make use of. 
See Figure 14-45. 
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Figure 14-45: Project Options - Preferences 

Plan or Profile Notes = 300, 300, 300 (standard 25 scale) 

Cross Section Notes = 60, 1, 60 (standard 5 scale) 
 Factors are based on absolute scale which gives users the flexibility to design/print/work 

at any scale (i.e. 12 x scale/in. = absolute scale or 12 x 25’/in = 300). 

Step Two: Place Plan Note Folders 
The Plan folder is broken up into two subfolders for ease of locating the type of note being 
placed. Additional folders can be added to further separate the types of notes being placed.  

 Existing Folder 
The Existing folder contains predefined drafting notes intended to be used to annotate 
existing features or items in the existing surface (Ground) in a plan view. The font has been 
set to dot_eng, which is the standard MaineDOT font for labeling existing items. 

 Proposed Folder 
The Proposed folder contains predefined drafting notes intended to be used to annotate 
proposed features or items in the proposed surface (Design) in a plan view. The font has been 
set to dotitalics, which is the standard for MaineDOT font for labeling proposed items. 

Step Three: Existing “Feature Name” Note 

 Review the Settings 
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Expand the folder tree to view the Existing Plan Notes. Select the Feature Name note.  See 
Figure 14-46. 

 
Figure 14-46: Place Plan Note – Feature Name Note 

Select the Settings button to reveal the settings for the note. See Figure 14-47. Review the 
options by clicking the Help button.  

 
Figure 14-47: Drafting Notes Dialog - Settings 
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Close the Help window. Close the Settings dialog. 

 The Settings for a note will control how the note is placed and the symbology of the text. 
Named Symbology controls its appearance. 

 Building the Note 
Select the down arrow to the right of the Place Plan Note dialog. This is where you actually 
build the note. See Figure 14-48. 

 
Figure 14-48: Place Plan Note Dialog – Building a Note  

The Feature Name note was created by typing the word Existing, followed by a space, then 
locating the InRoads coding for the FEATURE_NAME in the Computed Values tree in the 
Inserts portion of the dialog.  

 Drafting Note Inserts and Computed Values 
Expand the Computed Values leaf. Expand General, Geometry and Surface leaves. 
Computed values are keywords which will be interpreted by InRoads and replaced with 
correct values within the note. See Figure 14-49. InRoads provides derived values from 
points in the design file for the following keywords: 
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Figure 14-49: Computed Values 

In the Existing Plan Note > Feature Name, the value “FEATURE_NAME” can be found in 
the Surface leaf. 

 This existing note (FEATURE_NAME) would require the GROUND features to be 
displayed in a design file.  

 Placing Existing FEATURE_NAME Note 
Highlight the FEATURE_NAME note under the Plan > Existing folder. Click Apply and 
then left click on an existing feature graphic in the plan view. Left click again to Accept the 
feature. Place the note with another left click. Notice that InRoads cannot replace the coding 
with the actual value from the topo.dgn file. See Figure 14-50. 

 
Figure 14-50: Placing Note – Missing Computed Value 

Click on one of the features displayed from the design surface. Notice that InRoads could 
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replace the coding with the actual feature name.  Though, it’s not an existing feature and it 
uses the wrong font.  See Figure 14-51. 

 
Figure 14-51: Placing Note – Not an Existing Feature 

Browse to the Plan > Proposed > Feature_Name note. Click on the same proposed feature. 
The text is the correct font. The note does not contain the words Proposed prior to the 
FEATURE_NAME coding. Figure 14-52. 

 
Figure 14-52: Placing Note – Proposed Feature Name 

 Add Proposed to the FEATURE_NAME Note 
Edit the Plan > Proposed > Feature Name note to include Proposed prior to the 
FEATURE_NAME. See Figure 14-53. 

 Remember to add a space between Proposed and Feature_Name. 

 
Figure 14-53: Placing Note – Proposed Feature Name with Correct Spacing 

Adding Numerous Existing Notes 
Before using the drafting notes for annotating various existing surface features, use File > 
Make Sheetz to create the GROUND.dgn.  Then, view the existing surface features in the 
design file so that the drafting notes can obtain the intelligent information. For this 
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example, the user is snapping to the graphic of the surface feature to display feature name 
and elevation.  Use the GROUND. dgn file as a Reference File.  When using the Drafting 
Note tool to add the existing notes, ensure the surface name is Ground.  

Creating Custom Notes 

 Overview 
Custom notes can be created by you at anytime.  This example creates two Proposed Plan 
notes, one for the Begin project note and one for the End project note with the stationing 
being captured with the InRoads coding. 

 Part One: Copy a Note 
Copy the Proposed > Feature Name note and paste it into the same directory.  

 This saves the step of having to setup the Settings.  

 Part Two: Rename Note 
Rename the note that you copied to Begin Project. 

 Part Three: Clear and Rebuild the Note 
Select all the text in the Note section of the dialog and hit delete on the keyboard or use the 
“clear” icon. 

Enter Sta. followed by a space bar or the “space” icon. 

Now expand the Inserts to Computed Values > Geometry and select the Station insert. 
Enter another “space” (or use the space icon). Now add the Alignment Description 
(Primary) Insert followed by the “=” sign. 

Select the Delimiter icon. This will place a line between two rows of text. Enter the text 
“Begin Proj. No. STP-1308(‘700)X”. The results are shown below (Figure 14-54). 

 
Figure 14-54: Revising a Note 

 Notice that there is a single quote after the first parenthesis. This will have to be 
entered in order to trick InRoads into thinking that the contents between the 
parentheses is text. This will have to be manually edited afterwards. 

 Part Four: Create End of Project Note 
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Repeat the steps above to create an End of Project note.  Since the settings were copied, both 
notes should be ready to Apply at the project start and stop. 
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  IIMMPPOORRTTIINNGG  AALLIIGGNNMMEENNTT  FFRROOMM  
GGRRAAPPHHIICCSS  

This portion of the manual needs further development however is documented in the Bentley 
InRoads documentation.
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OVERVIEW 
Sub Assemblies 
Sub Assemblies are a grouping of minor components that form an intelligent portion of a 
template. Without them, some relationships (constraints) between pieces and parts would not 
work correctly when adjusting them in the Roadway Designer utility in InRoads. Until you 
become familiar with necessary constraints, symbology and surfaces, you should try and use 
the ones provided. You can modify them for your specific needs. 

Importance of Feature Based Naming 
Each vertex of a segment or closed shape within a template is relative to a longitudinal 
feature (called a string in MX) in proposed plan view (surface). In order to get the majority of 
strings to automatically connect from typical to typical (template drop to template drop), 
these points have to be named the exact same. For each shoulder to connect, the ES_L from 
one template needs to connect to an ES_L of the next template. Also, when you connect two 
Sub Assemblies together, the points need to match so that they combine correctly. You can 
connect points manually in the event this isn’t possible.  

Affixes 
All of the predefined shoulder Sub Assemblies were built for the left right in order to connect 
properly to the travelway Sub Assemblies. When using these Sub Assemblies, it is 
unnecessary to Apply Affixes. This will allow the component point labels to combine and join 
together correctly. Only Apply Affixes when constructing new templates or Sub Assemblies 
from raw components. 

Reflecting and Mirroring 
Reflecting or Mirroring should not be used when building templates from the predefined Sub 
Assemblies due to the fact that there have been Lt and Rt shoulders provided for each 
shoulder scenario. These options are used when constructing templates from raw 
components.  

Alternate Surfaces and Labels 
The predefined Sub Assemblies are designed so that there are multiple surfaces that can be 
generated on the fly. Not only can you create a surface of the Wearing Course, but you can 
easily generate a surface of the bottom of Wearing Course, bottom of Base Course of 
pavement, and bottom of subgrade. These surfaces can be reported on or displayed for 
various purposes. Some uses include field layout, volume calculations or visualization. Some 
points are set to create Alternate Surfaces by default and others have a Label that can be used 
to control widths, depths and slopes through a station range through Point Controls or 
Parametric Constraints.   
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NHS and Non-NHS Templates 
NHS Travelways are developed for 12’ lane width, with two courses of pavement that are 3” 
thick. The shoulders are developed for an 8’ shoulder with two courses of pavement that are 
3” thick. The subgrade is designed at 18”. Non-NHS template Sub Assemblies have been 
designed similarly with the exception of the width that are designed according to the current 
Highway Design Guide specifications based on the AADT. 

The two top layers can be adjusted to whatever the pavement design requires. The first layer 
can be adjusted and considered 6” of total pavement. The second layer can be considered one 
of the many base course treatments (i.e. Foamed Asphalt, PMRAP, or other) and adjusted 
accordingly. Item numbers will be manually attached to the styles that are being used for the 
layers. The top layer can be reported as square yards and its multiple course depths calculated 
manually to estimate the separate tonnage.  

Adjusting Widths, Slopes and Depths 
Slopes, widths and depths of each component in a Template Drop can easily be manipulated 
in and out of transitions from station to station by adjusting the Parametric Constraints. 
Template points can also be manually edited for permanent change for a specific job. 

 Refer to page 16-30 for more information on Parametric Constraints. 

Positive and Negative 
A positive distance is one that moves from left to right anywhere on the template. Slopes are 
also signed (algebraically measured).  To the right and down is negative, but to the left and 
down is positive. 

 
Figure 15-1: Positive and Negative slopes explained 

Wheel Mouse 
A wheel mouse works well for viewing and manipulating templates. Besides zooming in and 
out, pressing the middle button (wheel) allows you to click and drag to move the template 
around. Using [Ctrl+wheel] will adjust the horizontal exaggeration and [Shift+wheel] will 
adjust the vertical exaggeration. 
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 TEMPLATE POINTS, PARTS AND PIECES 
Open the Template Library 
Select Modeler > Create Template from the InRoads main menu. The Create Template 
dialog opens with a directory of folders on the left.  See Figure 15-2. 

 
Figure 15-2: Create Template Dialog - Folders 

Overview 
The Templates generate the transverse geometry that is the backbone to roadway design. A 
template is comprised of a series of points and components.  The connected points will turn 
into breakline features that are stored in the design surface generated by the Roadway 
Designer command. 

When templates are paired with horizontal and vertical alignments and superelevation, they 
define the surface of a corridor. 

Points 

 Overview 
The points of a template represent breakline features that will be created when the template is 
processed using the Roadway Designer command.  Points have a name and feature style. In 
order to get connectivity from template drop to template drop, the points representing the 
same feature have to be named the exactly same. Once processed in Roadway Designer, they 
are saved to the design surface as features. 
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 Review Common Point Names 
Select the Point Name List icon on the top left of the Create Template dialog’s directory tree 
(Figure 15-3). The list opens displaying all of the seed points and the styles assigned to them. 

 
Figure 15-3: Point Name List Dialog 

These point names were modeled after the MX (previous design software) naming 
convention. The screen captures below are directly from the MX manual (Figure 15-4). 
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Figure 15-4: Example Point Names  

 This MX naming convention was followed as much as possible. In some cases, we 
continued the naming convention from the top layers through to the bottom by adding a 
number increment with the exception of the Subgrade layer. In order to make 
connectivity with multiple like points, we also use Feature Name Overrides that will be 
discussed later. 
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Components 

A component is a set of points that define an open or closed shape. Each component, whether 
open or closed, can represent a different material or area of interest.  Components are named 
and have an assigned feature style. There are 6 types of components created in InRoads: 
Simple, Constrained, Unconstrained, Null Point, End Condition, and Overlay/Stripping. 

Some components are used to quantify volume of a material and others are used to compare 
an area between the component and the existing ground.  

 Activate Non-NHS Template 
Expand the Non-NHS Templates folder and the Minor Collectors <1000 subfolder.  Select 
the 12’ Daylight template. Right click the template and select Set Active (double clicking the 
template sets it active as well). See Figure 15-5. 

 
Figure 15-5:  Setting Templates Active 

 View Components and Points in Non-NHS Template 
Click the Active Template tab at the bottom of the Create Template explorer dialog. This 
displays Components, Points and Rules used in the active template (Figure 15-6).  
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Figure 15-6: Active Template View of the Create Template Dialog 

Expand and explore each folder. Select a Point or Component to view its settings. Notice that 
it’s highlighted in the cross section view of the template. Double click it to make an edit. 

Feature Styles 
The style assigned to a Point or Component controls how the feature behaves in Plan, 
Profile and Cross Section. Styles and their settings have been pre-established and can be 
adjusted to suit your needs if necessary. 

 Open Style Manager 
Select Tools > Style Manager from the InRoads main menu. Select the 
D_Curb_Type_1_Lt and click the Edit button (Figure 15-7). 
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Figure 15-7: Style Manager Dialog 

 View the Symbology 
Select the Symbology leaf (Figure 15-8). Click the Edit button.  

 
Figure 15-8: Style Manager Dialog – Symbology Leaf 

This is where the Style selects a Symbology. The symbology controls the Level, Color, Style, 
Weight, Text, and whether a cell or line is placed in Plan, Profile or Cross Section. Review 
the settings. Close the dialog. 

 Surface Feature 
Expand the Surface leaf of the dialog (Figure 15-9). This is where InRoads will determine 
how the style behaves in Plan, Cross Section and Profile and also where you adjust the Pay 
Item Name for the style in the future. 
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Figure 15-9: Style Manager Dialog – Surface Feature Leaf 

Close the Edit Style dialog. Close the Style Manager dialog. 

Sub Assemblies 
Sub Assemblies are a grouping of minor components that form an intelligent portion of a 
template. Without them, some relationships (constraints) between pieces and parts would not 
work correctly when adjusting them in the Roadway Designer utility in InRoads. Until you 
become familiar with necessary constraints, styles and surfaces, you should try and use the 
ones provided. You can modify them for your specific needs.  Sub Assemblies will be 
discussed in more detail later in the chapter. 
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UPDATE AND ATTACH THE LATEST TEMPLATE 
LIBRARY 

Updates to the Library 
As we develop and modify the template library (template.itl), it will be necessary for users 
to refresh their copy in their project. 

If you have been actively creating templates in the library within your project, use the 
Template Library Organizer to copy templates or folders from one library to another. 

 Refer to page 15-45 for guidance on the Template Library Organizer. 
If you wish to overwrite your library within your project, First run the appropriate Update 
Utility (older or newer version). Next, manually copy the template library from your local 
copy.  Using InRoads version 8.11 in the C:\!msV8iconf\standards\InRoadsSTD folder to 
your PINs InRoadsSTD folder. 

Attaching the Default Template Library 
After launching InRoads, select File > Open from the InRoads main menu (Figure 15-10). 
Change the File Types pull down to *.itl. and browse to your projects InRoadsSTD folder. 

 
Figure 15-10: Open Dialog 

Select the .itl and select Open. Click Cancel to close the dialog.  
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 BUILDING TEMPLATES FROM SCRATCH 
Overview 
Building templates from scratch will require manual work and familiarity with the standard 
point names and styles.  The example below shows the basic workflow to create a road 
template from scratch.  

Step One: Create Project Specific Folder 

 Part One: 
Right click the top-most folder (root of the template library tree) and select New > Folder 
(Figure 15-11). For example, Supply RoadA as a folder name.  

 This should be named your Town_Road name for real project work. 

 
Figure 15-11: Create New Folder 

 Part Two: 
Right click the RoadA folder and select New > Template. Enter DaylightLT-DaylightRT 
as the name of the template. 

Step Two: Template Options 

 Overview 
The Template Options dialog allows some control over building the components and point 
labeling. 

 Open Template Options 
Select Tools > Options from the Template Library main menu (Figure 15-12). 
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Figure 15-12: Template Options Dialog 

Set the Components-Seed Name to From Style. 
Place a check mark in the Apply Affixes box. 

Set the Step Options to X = 0.1000, Y = 0.1000 and Slope = 1.000%.  

 Click Help Button 
Review the Help on this topic and minimize the help screen. 

 The Step Options keep the accuracy to the degree applied. This can be adjusted on an 
individual basis per component.  

Step Three: Dynamic Settings 

 Overview 
The Dynamic Settings is similar to AccuDraw in MicroStation and also gives you control 
over the point names as a component is being placed. The Dynamic Origin can be moved 
around similar to the AccuDraw Origin. 

 Open Dynamic Settings Dialog 
The Dynamic Settings dialog (Figure 15-14) can be open by selecting Tools > Dynamic 
Settings from the Template Library main menu or by selecting the right-most tool in the 
view tools area of the dialog (Figure 15-13). 

 
Figure 15-13: Dynamic Setting Icon 

The dialog is similar to the Template Options dialog and can be adjusted as necessary.  
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Figure 15-14: Dynamic Setting Dialog 

 Explore Help on Dynamic Settings 
Maximize the Help screen and select Dynamic Settings from the directory tree on the left. 
Review and close. 

Step Four: Place Travelway Component 

 Part One: 
Right click in the gridded screen and select Add New Component > Simple (Figure 15-15). 

 
Figure 15-15: Add New Component > Simple Command 

 At this point, we are going to let the point names be created as their default values. We 
will edit the values afterwards. 

 Part Two: 
Now let’s add some values to the component prior to placing it. At the bottom of the Create 
Template dialog (Figure 15-16), enter the following example values: 
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Figure 15-16: Current Component Parameters. 

Name: Leave blank (will use Style as the Name) 

Style: D_Roadway_Edge_TW 

Slope: -2% 

Thickness: .25 

Width: 12 
Right click the gridded screen and place a check in the Mirror option. 

Place the Component(s) in the center of the magenta circle (which should be coordinate 0,0). 
You should see it lock in on this point. Fit the Components into the view. 

 Zoom in if necessary with the wheel of your mouse. 

 To close the context menu, hit escape. 

Step Five: Add the Shoulder and Base Pavement 

 Shoulder Criteria 

Name: Leave blank (will use Style as the Name) 

Style: D_Roadway_Edge_Shoulder 

Slope: -4% 

Thickness: .25 

Width: 4 

 Base Pavement Criteria (TW) 

Name: Leave blank (will use Style as the Name) 

Style: D_Roadway_Pavement 

Slope: -2% 
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Thickness: .25 

Width: 12 

 Base Pavement Criteria (Shoulders) 

Name: Leave blank (will use Style as the Name) 

Style: D_Roadway_Pavement 

Slope: -4% 

Thickness: .25 

Width: 4 
The result should resemble the capture below (Figure 15-17). 

 
Figure 15-17: Example Results 

Step Six: Merge Components 
Right click the vertical lines between the travelway and shoulders. Select Merge 
Components. Repeat for the vertical lines at the centerline of the template. The results are 
displayed in the capture below (Figure 15-18). 

 
Figure 15-18: Merge Component Results 

Step Seven: Add Subgrade 
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 Part One: 
Right click in the gridded screen and select Add New Component > Constrained. Supply 
the D_Roadway_Subgrade style.  

 Part Two: 
Right click and uncheck Mirror. Starting from left to right, click the bottom three points of 
the travelway to begin placing the subgrade component. The point will highlight “white” 
when you are on the point in question. 

 Part Three: 
For the bottom of subgrade points, we’ll use Dynamic Settings to accurately place these 
points.  

While still in the placement mode, right click the edge of travel way point in the base 
pavement and select Set Dynamic Origin and place the origin on the point as seen below 
(Figure 15-19). 

 
Figure 15-19:  Set Dynamic Origin 

With the Dynamic Settings dialog open, enter 1.5 for X and Y. Pick SE for the point name. 
Ensure NODISPLAY is the Style (Figure 15-20). 

 
Figure 15-20:  Dynamic Settings Example 

 You may have to zoom out in order to make the 1.5’ depth below pavement layer. 

Move the cursor down below the point and it will try to lock in on the depth you specified. 
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Make sure it is directly below the point by verifying the X value to the left in the Dynamic 
Settings dialog is 0.000. 

Right click the centerline point at the base pavement layer and select Set Dynamic Origin. 
Place the origin at this point. Pick the Point Name to SG. Drag the cursor down below the 
point and click when the X = 0.000 and the Y = -1.5. 

Lastly, set the Dynamic Origin at the left travelway point at the base pavement layer and set 
the Point Name to SE. Right click and select Finish. 
The results are shown below (Figure 15-21). 

 
Figure 15-21: Subgrade Example Results 

Step Eight: Add Daylight Subgrade (LT and RT) 

 Daylight Subgrade Criteria 

Add Constrained Component 

Style: D_Roadway_Subgrade 

Point Name: SS 

Step Nine: Edit SS Points 
Double click the SS_L points and change Constraint 1 of the constraints to a Slope constraint 
from the edge of shoulder point and enter 1:3 in the Value field. Hit Tab key (Figure 15-22). 

 
Figure 15-22: Constraint 1 Values  
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Change the Constraint 2 to a Vector Offset from points SE_L to SG with a 0.00 Offset. Hit 
the Tab key and click Apply (Figure 15-23). 

 
Figure 15-23:  Constraint 2 Values 

 This will keep the subgrade the same slope as the travelway. 

Step Ten: Edit SS_R Point 
Change the Constraints for point SS_R.  

Slope Value: -1:3 

Vector Offset Points: SE_R and SG. 

Step Eleven: Edit Points/Styles of Wearing Course 

 Part One: 
Double click the Centerline Point (Figure 15-24). This is the only point in the template that 
should be “green” in color. Pick MC from the drop down arrow as the point Name and 
change the Style to D_Roadway_Centerline. Click Apply. 

 
Figure 15-24: Point Properties Dialog – Changing Point Names of Wearing Course Example 

 Part Two: 
Using the Target icon next to the Name pull down, pick the left travelway point (Figure 
15-25). Change the Name to CE_L. Verify the Style is set to D_Roadway_Edge_TW. Click 
Apply. 
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Figure 15-25: Point Properties Dialog – Changing More Point Names of Wearing Course Example 

Repeat for right side supplying CE_R.   

 Part Three: 
Edit the left edge of shoulder. Change the point Name to ES_L and the Style to 
D_Roadway_Edge_Shoulder. Click Apply. 
Repeat for right side supplying ES_R. See Figure 15-26. 

 
Figure 15-26: Point Properties Dialog – Changing More Point Names of Wearing Course Example 

 Step Twelve:  Edit Remaining Points 

 Bottom of Wearing Course 

Point Name: Increment naming from above point (i.e., ES1_L, MC1, etc.) 

Style: NODISPLAY 

Alternate Surface: WearCourse 

 
Figure 15-27: Point Properties Dialog – Changing More Point Names of Wearing Course Example 
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 Bottom of Base Pavement 

Point Name: Increment naming from above point (i.e., ES2_L, MC2, etc.) 

Style: NODISPLAY 

Alternate Surface: BaseCourse 

 
Figure 15-28: Point Properties Dialog – Changing More Point Names of Wearing Course Example 

 Bottom of Subgrade 

Point Names: SS_L, SE_L, SG, SE_R, SS_R 

Style: NODISPLAY 

Alternate Surface: Subgrade 

 
Figure 15-29: Point Properties Dialog – Changing More Point Names of Subgrade Course Example 

Step Thirteen: Add Labels 

 Overview 
Labels can be applied to certain points so that they can easily adjusted by altering the values 
globally using Parametric Constraints. They re-define the constraints on these points. 

 Part One: 
Edit point CE_L. Add a Label to the Slope constraint called TWSlopeLT. Add a Label to 
the Horizontal constraint called TWWidthLT. See Figure 15-30. Click Apply.  
Repeat for CE_R but supply RT in the values. 
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Figure 15-30: Constraint Labels 

 Part Two: 
Edit point ES_L. Add a Label to the Slope constraint called SHSlopeLT. Add a Label to the 
Horizontal constraint called SHWidthLT. Click Apply. 
Repeat for ES_R but supply RT in the values. 

 
Figure 15-31:  Constraint Labels 

Step Fourteen: Add Vertical Labels 

 Add Vertical Label to Bottom of Wearing Course 
Edit points ES1_L, CE1_L, MC1, CE1_R, ES1_R. Add a Label called TWwcDepth to the 
vertical Constraint. 

 Add Vertical Label to Bottom of Base Pavement 
Edit points ES2_L, CE2_L, MC2, CE2_R, ES2_R. Add a Label called TWbcDepth to the 
vertical Constraint. 

Step Fifteen: Add End Conditions 

 Part One: 
Right click the gridded screen and select Add New Component > End Condition. See 
Figure 15-32. Set the Style to D_Roadway_SlopeLines.  
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Figure 15-32: End Conditions Component Parameters 

 Part Two: 
Utilize the Dynamic Setting dialog to help draw this End Condition. Click the Set Dynamic 
Origin button and place the “origin” on the ES_R point. Left click on the ES_R point to 
begin the placement of the component.  

 The Dynamic Settings dialog adapts to End Conditions giving a few more options on the 
fly. 

 Part Three: 
Adjust the Dynamic Settings dialog by toggling the X, Y to X, Slope.  See Figure 15-33. 
Enter a distance of 8 in the X Step and enter 1:3 in the Slope Step.  
Enter ID in the Point Name field. Set the Point Style to D_Drainage_Ditch_Line_High. 
Place a check in the Apply Affixes box. Your dialog should resemble the one below. 

 
Figure 15-33: Dynamic Setting for End Conditions 

 You may have to zoom out to place the second point. 
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Left click to place the second point.  

 Part Four: 
Right click the gridded screen and select Set Dynamic Origin and place the origin at the 
second point (ID_R). Adjust the Dynamic Settings so that the X Step Value is set to 5 and the 
Slope Step is set to 1:2. Move cursor to the right to define the back slope point. Left click to 
place the final point then right click and select Finish to end the command. See Figure 15-34. 

 
Figure 15-34: Dynamic Setting for End Conditions - Example 

 Part Five: 
Edit the End Condition component by double clicking the line. Adjust the Rounding Length 
to 4. Click Apply and then Close. 

 
Figure 15-35: End Conditions Property Parameters 

 Part Six: 
Change the Slope Constraint on point SS_R to be a Vector Offset using points ES_R and 
ID_R. Make this value 0.00.  
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Step Sixteen: Repeat for Left End Condition 

 Left End Condition Criteria 

ES_L to ID_L Slope: 1:3 

ES_L to ID_L Horiz: 8.0000 

ID_L Style: D_Drainage_Ditch_Line_Low 

ID_L to IC_L Slope: 1:2 

ID_L to IC_L Horiz: 5.0000 

Rounding Length: 4.0000 

Step Seventeen: Test End Condition 

 Part One: 
Select the Test button on the right, just below the view window. A new dialog will open. 

 Part Two: 
Click the Draw button and move the cursor into the view window. Use the Shift + Wheel on 
the mouse to adjust the exaggeration. Left click to place the line representing the existing 
ground in the view.  

Change the slope percentage to 5%. Click Draw again. Try it at 10%. 

Step Eighteen: Save Template Library 

 Part One: 
Select File > Save from the Template Library main menu. 
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BUILDING TEMPLATES FROM SUB ASSEMBLIES 
Overview 
After reviewing the points, components and styles used in the making of templates, it may be 
evident that a lot goes into building one from scratch. In the event you need to create one, 
there is a sub folder called components beneath each sub assembly groupings with the raw 
pieces and part used to build the sub assemblies.  

 Raw Components 
Some of the Template Library folders have Component subfolders.  

 NHS Templates 
NHS Travelway and NHS shoulder folders contain Sub Assemblies that have been designed 
to the “default” NHS standards. Travelway width is 12’ with a 2% slope. Shoulders are 
designed at 8’ with a 4% slope. Widths and Slopes can be adjusted easily to your project 
needs. 

 NON-NHS Templates 
These types of projects have some pre-built templates already constructed based on the 
AADT. They contain two end conditions in one template. Turn on Display All Components 
in order to see both scenarios. These are intended for evaluation purposes only and will still 
need to be adjusted for pavement depths and maximum 3:1 slope offset from centerline. 
These templates will evaluate the possible needs for Guardrail on the project. Once this is 
determined, either delete the scenario not needed or build a template that will be used for the 
specific area. Review the folder to see if these suit your needs or build them manually 
according to the following instructions. 

 “Typical” Strategies 
It’s a good idea to create the multiple templates (typical sections) that you foresee being used 
on your project. Maybe it’s a sidewalk on the Left with curb type 1 in the urban section and 
curb type 3 in the rural section with daylight and possible guardrail on the right. Maybe there 
is need for a truck lane or an island in one portion of the project. Template Drops can be 
placed roughly where the area of need is and transitions or adjustments made later. 

 Base Pavement Flexibility 
There are certain cases where the base pavement continues from the Travelway and into the 
shoulder. Sometimes the base pavement is carried into the shoulder from 6”, up to 24” or 
possibly full width of the shoulder. These points defining the width and slope of this base 
layer will need to be adjusted after connection to the Travelway. They are designed as 24” by 
default and 3” in depth. The width and depth can ultimately be adjusted with the Parametric 
Constraints or manually edited. The base pavement layer can be considered “Foamed 
Asphalt”, “PM Rap” or a “Reclaimed” material in a grinding situation. Eventually the Style 
can be tied to any Item Number you desire for quantification. 
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Step One: Example Template One 
Select Modeler > Create Template… from InRoads main menu. Right click on the top 
folder in the Template Library directory tree and select New > Folder (Figure 15-36).  Enter 
RoadB.  

 
Figure 15-36:  Create Template Dialog - Create New Folder 

 This will make it easy in the future to copy templates from one project with a similar 
design to another or when provided back to CADD Support in order to update the 
master template library. 

Step Two: Create a Template 
Right click on the folder you created and select New > Template (Figure 15-37). Supply a 
name that describes the template (i.e. 4:1 Daylight LT SW RT). 

 
Figure 15-37: Create New Project Specific Template 
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Step Three: Add Travelway Sub Assembly 

 Part One: Turn On Dynamic Settings 
Go to Tool > Dynamic Settings. This will open the Dynamic Settings dialog (Figure 15-38). 
Make sure that it is set to the X: Y: mode. Set the Step values to 0.1000. This precision 
allows you to place features to the nearest tenth of a foot.  Check to make sure the Dynamic 
Origin is at 0,0 before proceeding. 

 
Figure 15-38: Dynamic Settings Dialog 

 Part Two: Uncheck Apply Affixes 
All Travelway should be placed without affixes. The points have been assigned a _L or _R 
already.  

 Part Three: Expand Folder 
Double click the NHS (or Non-NHS) Travelway folder to expand it.  

 Part Four: Drag and Drop Travelway 
While hovering your mouse over the word Travelway, drag and hold the Travelway Sub 
Assembly into the “gridded” template window. While holding down your left mouse button, 
right click to get to the placement options menu. Verify that the Sub Assembly is not mirrored 
or reflected. Hit your ESC key to clear the menu. Release your left mouse when the Sub 
Assembly is near and “snapped” to the magenta colored box in the center of the screen 
(Figure 15-39).  
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Figure 15-39: Travelway Sub Assembly placed at the Dynamic Origin 

 The magenta colored square is the Template Origin or centerline point that the section 
is based on. You can set this origin in other locations when an offset centerline is 
desired. 

Step Four: Add Shoulder Sub Assemblies 

 Overview 
Similar to the pre-built Non-NHS templates, there are some shoulder Sub Assemblies that 
have been built for evaluation purposes only (Ditch/GR). They are used to determine areas 
that will require Guardrail and or ditching. They contain two end conditions in one template. 
Turn on Display All Components in order to see both scenarios. These are intended for 
evaluation purposes only and will still need to be adjusted for pavement depths and 
maximum 3:1 slope offset from centerline. These templates will evaluate the possible needs 
for Guardrail on the project. Once this is determined, either delete the scenario not needed or 
build a template that will be used for the specific area. 

There are two points on every shoulder Sub Assembly that will require manual constraints 
once connected to the Travelway. These points can be identified by the Green points BD (or 
BD2) and points SS or (SS1). This will allow the shoulder to break correctly for 
Superelevation. 

 Part One: Turn Off Apply Affixes 
From the Create Template menu, select Tools > Options…and remove the check mark in the 
Apply Affixes box (Figure 15-40). Click OK.  
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Figure 15-40: Template Options – Uncheck Apply Affixes 

 Part Two: Drag and Drop Shoulder 
Double click to expand the NHS (or Non-NHS) Shoulders folder. Pick the shoulder Sub 
Assembly that you would like to use for the starting point of your alignment. While hovering 
your mouse over the shoulder (i.e. 4:1 Ditch Round BkSlope LT) drag and hold the Sub 
Assembly into the “gridded” template window. While holding down your left mouse button, 
right click to get to the placement options menu. Verify Reflect and Mirror is unchecked. 
Hit ESC to close the sub menu. Release the Sub Assembly on CE point at the edge of 
Travelway. The point will turn white when exactly on top of the point. Repeat for the 
opposite shoulder picking the type of shoulder required. 

 Part Three: Adjust Shoulder Width or Depth (if necessary) 
Double click the ES points (_L or _R) to adjust the horizontal width of your shoulder. All 
points below this point will follow the new width. All NHS shoulders are defaulted to 8’ in 
the templates. Adjust the ES1 and MC1 points to adjust the depth of the wearing course. 
Adjustments can be made manually or by using the Parametric Constraints utility inside of 
Roadway Designer as described later. 

 Part Four: Adjust Base Pavement Width or Depth 
Double click base pavement point BD (_L or _R). By default these points are extended 2’ 
into the shoulder. Set a Horizontal constraint to the CE point and adjust the width if 
necessary. Now apply a Vector-Offset constraint to points CE1 and MC1 (Figure 15-41). This 
will set the slope of the base pavement layer to follow the slope of the Travelway. Click 
Apply. Repeat for the opposite shoulder. 
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Figure 15-41: Constrain point BD with a Horizontal and Vector-Offset 

If the base pavement layer will be the full width of the shoulder, right click the BD or BD2 
points and select Delete Constraints. Right click the point again and select Move. Move the 
points to the ES1 point. Right click this point and select Merge Points. There will be up to 
three points in this location. Select the points BD and BD1 (one at a time) to merge the point. 
The result should be a single point labeled ES1 for connectivity between templates. 

To adjust the base depth, double click base pavement point ES2 or ES3 (_L or _R). By 
default the base pavement depth is 3”. Set the Vertical constraint to be the depth required. 
Adjust points CE2 and MC2 to the same depth as well. 

 Part Five: Adjust points SS 
 Double click subgrade point SS or SS1 (_L or _R). These points will require a second 
constraint that could not be added until connected to the travelway. These points need to 
follow the same slope as the subgrade in the travelway. Set the second constraint as a Vector-
Offset to points SE and SG (Figure 15-42). This will set the slope of the subgrade in the 
shoulder to follow the slope of the Travelway. Click Apply. Repeat for the opposite 
shoulder. 
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Figure 15-42: Constrain point SS with two Vector-Offsets for Daylight sections. 

 Other Adjustments (optional) 
There are other points in a template that you may want to adjust. Certain shoulder Sub 
Assemblies or Non-NHS templates contain Rules based on certain criteria such as offset to the 
Toe of slope. To give the offset a tangible value, double click the points IC or IF and apply a 
horizontal value from the MC (centerline) point in your template. If the ROW line is parallel 
to the centerline at a 3 Rod (33’) offset, adjust your maximum offset of the flatter slopes to 
32’ or so to keep the limits inside of the ROW line. Let the maximum slope allowed govern 
encroachment into the ROW.  

You can make manual adjustments to the template you just created by double clicking on the 
points and adjusting their values, however they can be adjusted using the Parametric 
Constraints utility inside of Roadway Designer described later. 

 Refer to 16-30 for more information of Parametric Constraints and the Roadway 
Designer. 

Step Five: Add Underdrain 



mdot MicroStation 
01/01/12 

Templates 
 

15-35 
 

 Overview 
The drainage features are available to add to your templates. They are based on standard 
depths which can be adjusted manually in a Template Drop based on the Point feature or a 
3D line draped on the proposed plan surface. Eventually, we will be exploring the Drainage 
and Sanitary utility in InRoads. 

 Part One: Turn On Apply Affixes 
From the Create Template menu, select Tools > Options… and place a check make in the 
Apply Affixes box. Also verify that the suffix _L and _R are going to be applied to the 
underdrain Sub Assemblies. Click OK. 

 Part Two: Drag and Drop Underdrain 
Double click to expand the Underdrain folder. Pick the underdrain Sub Assembly that you 
would like to use for the starting point of your alignment. While hovering your mouse over 
the underdrain (i.e., 12” UD LT) drag and hold the Sub Assembly into the “gridded” template 
window.  Release the Sub Assembly on point SS which is the edge of subgrade. Repeat for 
the opposite side if desired.  Note, the 12UD3_L point might need some editing with a vector 
offset constraint to follow a vector offset which follows the subgrade line, repeat for the right 
if desired. 

Step Six: Save Template Library 

 Part One: 
Select File > Save from the Template Library main menu. 

 
Figure 15-43: Underdrain Example 
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Template Creation 
This example continues to address typical workflows needed to create and adjust a template 
built from sub assemblies. 

Step One: Example Template Two 

 Part One: 
Create a New Template in the RoadB folder by right clicking the folder and selecting New 
> Template. Enter Curb LT-Sidewalk RT and hit enter on your keyboard. 

 Part Two: 
Open Dynamic Settings dialog if not already open (Figure 15-44). Toggle the X, Slope to X, 
Y. Set the X Step and the Y Step to 0.1000. Remove the Point Name and ignore the Point 
Style. Uncheck Apply Affixes. 

  
Figure 15-44: Dynamic Settings Dialog 

 All Sub Assemblies already have affixes applied so this must be unchecked so multiple 
affixes are not applied. 

 Part Three: 
Expand the NHS Travelway folder. Drag the Travelway into the gridded display and drop 
onto the Dynamic Display Origin which is signified by the magenta box. 

Important: If the template centerline point is not at 0, 0 within the gridded display, but you 
used the magenta box, the Dynamic Origin is the issue.  You can reset the Dynamic Origin 
to 0,0 and/or set the Template Origin (Figure 15-45) by right clicking the centerline point 
(MC) and selecting Change Template Origin. 
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Figure 15-45: Change Template Origin 

 This will move the template to 0, 0. The Dynamic Origin is back where you left it and 
you can move it again if desired. 

 Part Four: 
Place an Auxiliary Lane RT travelway onto point CE_R. This point will become “white” 
when you have hit the point exactly. 

 Part Five: 
Expand the NHS Sidewalks folder and place the BoxCurb Type1 w/SW RT Sub Assembly 
onto point CA_R.  See Figure 15-46. 

 
Figure 15-46: Place BoxCurb Type1 w/SW RT 

 Part Six: 
Expand the NHS Shoulders folder and drag and drop the BoxCurb Type1LT Sub Assembly 
and place it on to CE_L. See Figure 15-47. 
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Figure 15-47: Place BoxCurb Type1 w/SW LT 

Step Two: Edit Points/Constraints 

 Adjust Base Pavement (Full Width) 
Zoom in on the right shoulder where the base pavement extends into the shoulder. Right click 
the top point on point BD_R and select Delete Horizontal Constraint (Figure 15-48).  

 
Figure 15-48: Delete Horizontal Constraint 

Right click BD_R and select Move Point. Move this point to ES1_R which is the bottom of 
the wearing course of pavement where it meets the curb.  

Now right click the BD_R/BD1_R/ES1_R point and select Merge Points. The Delete Point 
dialog opens prompting for which point you want to delete (Figure 15-49). Select the BD1_R 
point. 

 
Figure 15-49: Delete Point Dialog 

 When there is more than 2 points on top of each other, you will be prompted to select one 
of the remaining two points. 



mdot MicroStation 
01/01/12 

Templates 
 

15-39 
 

Then select the BD_R point from the Merge BD1_R With Point dialog. The result is two 
points still exist at the same location. See Figure 15-50. 

 
Figure 15-50: Merge Point Dialog 

Right click the BD_R/ES1_R point and select Merge Points. The Delete Point dialog opens 
prompting for which point you want to delete (Figure 15-51). Select the other BD_R point. 

 
Figure 15-51: Delete Point Dialog 

Step Three: Final Adjustments 

 Part One: Base Pavement Layer LT 

BD_L: Release Horiz Constraint 

Move BD_L to ES1_L 

Merge BD1_L into BD_L 

Merge BD_L into ES1_L 

 Part Two: Adjust SS_L and SS_R 

Add Vector Offset to SE_L and SG, 0.00 Offset 

Add Vector Offset to SG and SA_R, 0.00 Offset 

 Part Three: Adjust Widths 

Adjust Left and Right Shoulder Widths to 5’ 

Adjust Left and Right Travelway Widths to 11’ 

Adjust Auxiliary Lane Width to 11’ 

Step Four: Save Template Library 

 Part One: 



mdot MicroStation 
01/01/12 

Templates 
 

15-40 
 

Select File > Save from the Template Library main menu. 

 
Figure 15-52: Completed Example Template 
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BUILDING MEDIANS  
Overview 
Currently there is only one median type available called Curb Type 5. There are Travelway 
templates designed to connect to the median for the left and right lanes. The width of the 
median can be controlled by Point Controls defined by an element drawn in a plan view.  

Step One: Place the Median 
Create a new template in your RoadB folder called MedianTest. Double Click to expand the 
Medians folder. Select the median and place it without Affixes at the center point in the new 
template.  

 Refer to 15-30 for more detailed instructions that are similar to placing a Median 
Sub Assembly. 

Step Two: Place Travelways 
Place the Travelway LT (Median) as you would place a shoulder Sub Assembly (without 
Affixes) connecting it to the respective point. Repeat for the right Travelway. 

 Refer to 15-30 for more detailed information that is similar to placing the 
Travelway Medians. 

Step Three: Add Shoulder Sub Assembly 
Drag and drop shoulder Sub Assembly on the CE point of the Travelway LT (Median). 

 Refer to 15-31 for more detailed information on placing the shoulders for a median 
section. 

Step Four: Variable Width Medians 

 Part One: Draw Median in Plan View 
Using MicroStation tools, draw the median in plan view. It is recommended that the median 
is split down the center and drawn in two sections. One represents the face of curb on the LT 
side of the median and one representing the face of curb on the RT.  

 Part Two: Select Lt Side(s) of Median(s) 
Select all the LT portions of the medians (regardless if it crosses centerline). 

 Part Three: Import Geometry 
Select File > Import > Geometry from the InRoads main menu. In the From Graphics tab 
(Figure 15-53), set the Type to Horizontal Alignment. Supply a name (i.e., MedianLT). Set 
the Style to D_Curb_Type_5_Lt.  Click Apply and accept the selection set. Repeat for the 
RT side of the medians. 
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Figure 15-53: Import the LT and RT portions of the medians From Graphics. 

The face of curb points in the median templates have a Style Constraint that will 
automatically follow the geometry (alignments) you just imported from graphics (Figure 
15-54). 

 
Figure 15-54: Style Constraint field in Template Point Properties. 
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AUXILIARY LANES 
Overview 
It isn’t necessary to use an auxiliary lane Sub Assembly unless the lane is intended to use a 
different cross slope than the normal Travelway lane. Instead, simply adjust the Parametric 
Constraints to adjust your right or left Travelway width (or both) from station to station and 
also to adjust your transition in and out of the lane.  

Step One: Place Travelway 
Create a new template in your RoadB folder called ParametricTest. Place the Travelway 
without Affixes on the center point of the template. 

 Refer to 15-30 for placing a Travelway Sub Assembly. 

Step Two: Place Auxiliary Lane 
Place Auxiliary Lane as you would place a shoulder Sub Assembly connecting it to the 
respective point. 

Step Three: Add Shoulder Sub Assembly 

 Part One: Turn off Apply Affixes 
Uncheck the Apply Affixes box of the Dynamic Settings dialog. 

 Part Two: Place Shoulder Assembly 
Drag and drop shoulder Sub Assembly on the outer portion of the Auxiliary Lane.  

 Part Three: Adjust Transitions 
Save template and close Template Library.  Set up the Roadway Designer to use just one 
template drop.  Adjust the transition in and out of the auxiliary lane using Parametric 
Constraints found at Tools > Parametric Constraints. 
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IMPORTING TEMPLATES FROM GRAPHICS 
Overview 
It is possible to import graphics from MicroStation into InRoads as a Template. All the curb 
types, underdrain and guardrail in the default template library were imported from existing 
MicroStation graphics. There are some steps that need to be done to make it possible. 

Step One: Drop Cells, Complex Lines and Shapes 
Cells and Complex Shapes must be dropped. Select Qualities > Drop > Complex and click 
on the cell or elements to be imported.  

Step Two: Select the Components 
Select the components by using the Element Selector or other selection method. 

Step Three: Import the Template/End Condition 
Select File > Import Template from the Create Template dialog in InRoads.  Typically the 
Style can be left alone and addressed after the template is created inside the Template 
Library.  Select the appropriate Type as it will help setup component properties and 
constraints during the import.  If the graphics are vertically stretched, that can be addressed 
now too.   

Step Four: Define the Template Origin 
Define the origin with data click. This will locate the 0,0 value in the template. 

Step Five: Connect the Dots 
The Import Template command will bring the elements into your Template Library as line 
segments. Create new components (connect the dots) using the InRoads template tools to 
make single components with the correct symbology.  Since the points are in the correct 
location, it is a matter of setting constraints and defining components as needed. 
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COPY TEMPLATES FROM ONE LIBRARY TO 
ANOTHER 

Step One: Open Destination Template Library 
Select File > Open from the Create Template dialog menu. Browse to the library you want to 
copy other templates to. This is the destination library. 

Step Two: Open Template Library Organizer 
Select Tools > Template Library Organizer (Figure 15-55). 

 
Figure 15-55: Template Library Organizer Dialog 

Step Three: Browse to Library Copying From 
On the right side of the dialog, click the browse button (button with 3 dots) and browse to the 
source library you are copying from.  Typically you will copy from another Template Library 
file, however you could browse to an InRoads Roadway Designer (*.ird) file instead. 
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Step Four: Drag and Drop Templates or Folders 
Drag and drop Templates or Folders from the Library on the right side of the dialog to the 
library on the left. When finished, click OK and you will be prompted to save changes to the 
library(s). See Figure 15-56. 

 
Figure 15-56: Template Library Organizer Dialog – Drag and Drop 
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PREREQUISITES 
Geometry - Alignment (Horizontal and Vertical) 
You must have a horizontal and vertical alignment to use the Modeler.  

 Refer to InRoads Help menu for more information on creating an alignment. 

Ground Surface 
As part of normal workflow, the Survey Group within the Property Office will be providing 
an existing ground surface as a standard deliverable. The existing surface is called 
Ground.dtm and is located in the Survey/MSTA folder in your project directory. 

Template Library 
It’s a good idea to generate the templates or Template Drops (typical sections) that you 
foresee using on your project (i.e., Sidewalk RT, Daylight LT). You need at least one 
template to drop on your alignment in order to process against your existing ground surface.  

 Refer to 15-29 for more information on creating a template. 
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CORRIDORS AND TEMPLATE DROPS 
Overview 
The Roadway Design file (.ird) contains most of your custom design options for your 
project. It contains the corridor, arrangement of templates used, the custom end conditions, 
any editing done to a particular station, parametric constraints, superelevation, etc.  The 
following section walks you through an example of using the Roadway Designer. 

Step One: Open Roadway Designer 
Select Modeler > Roadway Designer from the InRoads main menu. This opens a New File. 
Select File > Save from the Roadway Designer menu. Enter Design as your file name. 
Select Save.  See Figure 16-1. 
This will be the “container” for all of your Corridors (MainLine with its alignment and 
template drops & Side Roads with their alignments and template drops). 

 
Figure 16-1:  Save Roadway Design As Dialog 

Once saved, you can update your Project File (*.rwk).   

Step Two: Create a MainLine Corridor 
Select Corridor > Corridor Management from the Roadway Designer menu. Enter 
MainLine as the Name of the corridor. Set the Surface Symbology to 
D_Roadway_Centerline.  Set the Type to Alignment. Set the Horizontal Alignment to the 
MainLine_Horiz and set the Vertical Alignment to the MainLine_Vertical.  Enable the 
Station lock use 1+00 and 16+50 as the limits and click Add. See Figure 16-2. 
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Figure 16-2: Manage Corridors Dialog 
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 ADD A TEMPLATE DROP 
Open Template Drop Dialog 

 Part One: 
Select Corridor > Template Drops… from the Roadway Designer main menu. Expand the 
folder structure for the Library Template that is loaded. This RoadB folder has two saved 
templates.  See Figure 16-3. 

  

Figure 16-3: Template Drops Dialog 

 Part Two: 
Select the Curb LT-Sidewalk RT template from the RoadB folder. Change the Interval to 
50.0000. Click the Add button and then Close. 

 Part Three: 
In the Roadway Designer window, select Process All. Now look at the cross section view by 
clicking the forward arrows.  Before continuing, lock the Active Surface as GROUND so 
that all processed models in this session are run against the existing surface (Figure 16-3).    
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Figure 16-4: Lock the Active Surface 

 



mdot MicroStation 

01/01/12 

Roadway Design 
Development 

16-8 

 

 ADJUST PARAMETRIC CONSTRAINTS 
Overview 
We applied a template that contains the right side auxiliary lane throughout the project. Now 
we want to adjust the start and stop of the additional lane. Adjusting the Parametric 
Constraints will minimize the number of template drops needed to do this. 

Step One: Open Parametric Constraints Dialog 
Select Tools > Parametric Constraints from the Roadway Designer menu. Let’s look at 
the possible adjustments that can be made in the Constraint Label pull down (Figure 16-5). 

 
Figure 16-5: Parametric Constraints Dialog – Select Label 

Step Two: Adjust Auxiliary Travel Lane Width 

 Overview 
For this example, it was decided that the Auxiliary Lane is necessary from Sta. 4+25 
through Sta. 14+00. There will be a 175’ transition into the lane and a 125’ transition back 
to a single lane. 
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 Part One: 
Change the Constrain Label to the ATWWidthRT (Auxiliary Travelway Width Right). By 
default, the width of the Auxiliary Lane is 11’ as a Start and Stop value (Figure 16-6). 

 
Figure 16-6: Parametric Constraints Dialog – Default  Start and Stop Values 

 Part Two: Single Lane Limits (Beginning) 
Adjust the Start Value and Stop Value to 0.0000.  
Adjust the Station Limits Start value to 1+00.00. 
Adjust the Station Limits Stop value to 2+50.00.  
Click the Add button.  See Figure 16-7. 

 
Figure 16-7: Parametric Constraints Dialog – Setting  Start and Stop Values 

 Part Three: Transition to 2 Lanes 
Adjust the Start Value to 0.0000.  
Adjust the Stop Value to 11.0000. 
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Adjust the Station Limits Start value to 2+50.00. 
Adjust the Station Limits Stop value to 4+25.00.  
Click the Add button.  See Figure 16-8. 

 
Figure 16-8: Parametric Constraints Dialog – Setting  Start and Stop Values for Transition 

 Part Four: Transition to One Lane 
Adjust the Start Value to 11.0000.  
Adjust the Stop Value to 0.0000. 
Adjust the Station Limits Start value to 14+00.00. 
Adjust the Station Limits Stop value to 15+25.00.  
Click the Add button.  See Figure 16-9. 

Note, no entry from 4+25 to 14+00 is needed, it is already 11’ by default.  

 
Figure 16-9: Parametric Constraints Dialog – Setting  Start and Stop Values for Transition 
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 Part Five: Single Lane Limits (Ending) 
Adjust the Start Value and Stop Value to 0.0000.  
Adjust the Station Limits Start value to 15+25.00. 
Adjust the Station Limits Stop value to 16+50.00.  
Click the Add button.  See Figure 16-10. 

 
Figure 16-10: Parametric Constraints Dialog – Setting Start and Stop Values 

 Part Six: Export as Parametrics.txt 
Select the Export button at the bottom of the Parametric Constraints dialog and save this as 
Parametrics.txt in your MSTA location. Select Close to close the Parametric Constraints 
dialog. 

 Saving the Parametric Constraints in a text file will allow you to recover these settings in 
the future if need be.  The can also be edited and then imported back in, but make sure to 
delete the previous list to avoid getting duplicate lines. 

Step Three: Review with Roadway Designer 

 Process All 
Select the Process All button at the bottom right of the Roadway Designer dialog (Figure 
16-11). Step through the stations in the cross section view using the forward arrow. Notice 
the auxiliary lane expand and contract in the station range due to the Parametric Constraints 
you applied. 

 
Figure 16-11: Roadway Designer – Process All 
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 Enter Stations 
Select the station text and type in the station 2+50 (250 can be entered without the “+” sign) 
followed by the “tab” key on your keyboard. This is where the auxiliary lane will start.  

Enter 2+51 and hit the “tab” key on your keyboard.  Zoom in on the edge of travelway. The 
auxiliary lane begins to appear. 

Enter 3+00.  Notice the green box (parametrically controlled point) continues adjusting 
outward (Figure 16-12).  

 

 
Figure 16-12: Parametric Constraint Marker 

Enter station 4+25. Hover over the component that defines the auxiliary lane. It says it has 
an 11’ width with a slope of -2%. 

Enter station 14+00. Hover over the component that defines the auxiliary lane. It says it has 
an 11’ width with a slope of -2%. 

Enter station 15+25. This is where the auxiliary lane should be back to zero width. 
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 DISPLAY REFERENCES 
Display ROW in Roadway Designer 

Overview 
The existing Right of Way lines can be displayed in the plan view portion of the Roadway 
Designer as well as in the cross section view defined by vertical dashed lines.  

 When existing Right of Way is done completely in InRoads the design staff won’t have 
to create the surface. 

Part One: 
Minimize the Roadway Designer dialog. Open the HDPlan.dgn from your list of files in 
your PIN MSTA directory or attach RWPLAN.dgn as a reference file to the current file you 
have open. 

Part Two: 
Select File > Import > Surface Advanced… from the InRoads main menu (Figure 16-13). 
In the Import Surface Advanced dialog, add a name for the new surface (i.e., EROW) and 
select All from the Load From pull down. The Intercept Surface should be set to Ground.   

 
Figure 16-13: Import Surface Advanced Dialog 

Now select the predefined rule called EROW from the Rule Set pull down. This sets the 
selection criteria for the existing ROW lines and also sets their new symbology within the 
new surface. Click Apply. 
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Part Three: 
Verify that there are features in the EROW surface by returning to the InRoads main menu 
and browsing to the Surfaces tab. Select the EROW surface in the InRoads Explorer 
portion of the dialog. The right pane should show the total number of Breakline Features of 
the surface (Figure 16-14). 

 
Figure 16-14: Breakline Features Totals 

 If this doesn’t work the first time, make sure the levels are turned on (i.e. make sure 
“E_ROW_Line” is on so it can be found).  If still having failure, double click the EROW 
LINE rule and browse to the General portion of the Selection Criteria leaf. Click on the 
Highlight Matching Elements button. The Existing Right of Way elements should 
highlight. If not, it means that they were placed on the wrong level. Use the Match 
Element Properties button and click on an Existing Right of Way line. 

Part Four: 
Maximize the Roadway Designer. Select Corridor > Display References… from the 
Roadway Designer menu. Select the Filter radio button and then the EROW surface from 
the Surface pull down above. Pick EROW Lines from the Filter pull down. Place a check 
mark in the box to Display as Right of Way and click the Add button  (Figure 16-15). Click 
Close to exit the dialog. 
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Figure 16-15: Display References Dialog 

The plan view portion of the dialog should now contain the ROW lines (Figure 16-16). 

 
Figure 16-16: Roadway Designer Plan View with ROW Lines Displayed 
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The cross section view of the Roadway Designer should now display the ROW lines as 
dashed vertical lines (Figure 16-17).  

 
Figure 16-17: Roadway Designer - ROW Lines in Cross Section View 
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 DISPLAY SUPERELEVATIONS 
Step One: Add Superelevation 

 Overview 
There are a lot of options and adjustments that can be performed in the Superelevation 
dialog. The dialog seems intimidating at first, but you will eventually see that it’s not so 
difficult. Use InRoads Help on the more intricate details.  

 Part One: 
Verify that your Corridor is set to your MainLine and Active Surface is set to Ground. 

 Part Two: 
Select the Display Mode of Superelevation (Figure 16-18). Select Process All. The view 
window inside of the Roadway Designer changes to display different aspects of the 
Superelevation. 

 
Figure 16-18: Roadway Designer - Superelevation Display Mode 

 Part Three: 
Select Superelevation > Create Superelevation Wizard > Table…. MaineDOT has the 
Superelevation in the format of a Table (Figure 16-19). 
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Figure 16-19: Create Superelevation Wizard - Table 

 Part Four: 
Select the Browse button and browse to the 
C:\!msV8iconf\standards\InRoadsSTD\Superelevation\ folder. Select the Superelevation 
table that suits your needs. In this case, we will be using the MeDOT_06_35.sup table. 

 The tables are listed by maximum Superelevation percentage and posted speed (i.e., 
MeDOT_06_35.sup would be a 6% max super with a design speed of 35 mph). 

 
Figure 16-20: Table Wizard – Load Values 

Select Load Values From Table then select Next (Figure 16-20). 

 Part Five: 
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Select the Add button (Figure 16-21). 

 
Figure 16-21: Superelevation Section Definitions Dialog 

 Part Six: 
Enter MC as the Crown Point. Set the Left Range Point to CE_L and Right Range Point to 
CA_R.   See Figure 16-22. 

 
Figure 16-22: Edit Superelevation Section Dialog 

Click OK. Select Next to proceed in the wizard. 

 Part Seven: 
The Superelevation Section Definitions dialog allows for some adjustments. Additional 
Sections can be added or the Sections can be edited for max super, runoff distance and 
runoff length or station. Click Next.  See Figure 16-23. 
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Figure 16-23: Superelevation Section Definitions Dialog 

 Part Eight: 
Notice that the results are displayed in the wizard. If there were other locations on the 
project that had different speeds that would require a different table, you can add multiple 
Sections for these areas. This dialog will allow you to round the stations to the nearest 1’ or 
10’. Click Finish.  See Figure 16-24. 

 
Figure 16-24: Superelevation Controls Dialog 
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 Part Nine: 
The Fix Superelevation Overlap dialog will appear if there are issues with overlap. Notice 
that the Curve 1 superelevation starts before beginning of alignment. Click Next.  See 
Figure 16-25. 

 
Figure 16-25: Fix Superelevation Overlap Dialog 

The next curve shows that there is overlapping based on the standard transitions when 
applied. Edits can be made to this dialog (like shortening the transition or shifting the 
transition to avoid overlap) but it may be easier to edit the wire diagram based on standards 
from the Highway Design Guide (Figure 16-26). Select Close. 

 
Figure 16-26: Fix Superelevation Overlap Dialog - Adjustments 
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Step Two: Adjust Superelevation 

 Overview 
We will adjust the superelevation so that there are no overlaps and so that the transitions are 
smooth. It is very similar to Template editing.  

 Adjust Display List 
The wire diagram is simple once you get the gist of it. The screen capture below shows the 
wire diagram with a lot of lines (Figure 16-27). Let’s clean it up to display only the left side 
travelway CE_L. 

 
Figure 16-27: Superelevation Diagram 

Right click the gridded background and select Superelevation Display List (Figure 16-28).  

 
Figure 16-28: Superelevation Display List 

Highlight Section1 MC-CE_L and select the Apply button. This will just display the left 
travelway line.  

 Analyze the Diagram 
Notice the thin white line at 0.00. This is the centerline point in your template. The red line 
(Edge Travelway Left) starts at -.02 (-2%) until it reaches the point where it will begin 
transition to superelevation (Figure 16-29).  
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Figure 16-29: Superelevation Diagram - Analysis 

Hover over the yellow point on the vertices on the red line (Figure 16-30). Yellow indicates 
that this point has one constraint. Red points indicate that there are two constraints to the 
point. The information box will give you all sorts of information about the point. Double 
click the point if you want to adjust it. If the Station is grayed out and you want to adjust the 
station, you will have to release the constraints of the point. 

 
Figure 16-30: Superelevation Diagram – Tool Tips 

  Move Point Graphically 
Let’s move the first point to 1+00 with a -2% slope. Right click the first vertex (point) on the 
red CE_L line and select Delete Horizontal Constraint. The point turns green which means 
unconstrained.  

 
Figure 16-31: Superelevation Diagram – Move Point 

Right click the point again and select Move Point (Figure 16-31). The Dynamic Settings 
dialog opens (Figure 16-32).  
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Adjust the Station: Step to the nearest foot by entering 0+01.00. Adjust the Cross Slope: 
Step to 1.000% (Figure 16-32).  

 
Figure 16-32:  Superelevation Dynamic Settings – Adjust Step Values 

Now move the point until the Station readout says 1+00.00 while staying at the -2.000% 
Cross Slope (Figure 16-33). This may require that you zoom way in near station 1+00.00 in 
order to hit it. Once there left click to place the point. 

 
Figure 16-33: Superelevation Dynamic Settings – Move Cursor to Corrected Station and Cross Slope 

Now undo last edit. This is accomplished by typing Ctr+Z on your keyboard or by selecting 
the Undo last edit tool on the view control area of the dialog (Figure 16-34). 

 
Figure 16-34: Undo Button 

 Move by Entering Station and Slope 
Right click the point again and select Move Point. This time, enter 1+00,-2% in the 
x+xx,x%= field. Great flexibility if you have figured out your superelevation according to 
standards. 

Undo this edit also. 

 Move by Editing Point 
Right click the point again and select Edit Point. Enter 1+00 in the Station field and -2% in 
the Cross Slope field. Click Apply and then Close.  See Figure 16-35. 
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Figure 16-35: Superelevation Point Properties 

 Delete Points 
Rather than let the low side of the shoulder return to normal cross slope from the first curve, 
we’ll hold the full super as it transitions into the next superelevated curve. 

 Part One: 
Right click in the gridded window and select Delete Points. This will require two opposite 
corner clicks similar to a fence command. Place the box so it encompasses the 3 yellow 
points along the red line that are still at the -2% cross slope as in the capture below (Figure 
16-36). 

 
Figure 16-36: Delete Multiple Points 

This will delete the points and create the transition from the low side full super to transition 
directly to the low side full super of the next curve (Figure 16-37). 
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Figure 16-37: Delete Points Results 

Step Three: Adjust High Side Superelevation 

 Adjust the Display List 
Display both right side section1 lines (use Control key to help select from list) 

 Move Start Station to 1+00 with -2% Cross Slope 

  Delete Points to transition from Full Super (Curve 1) to Full Super 
(Curve 2). 
Review sections and plan view to verify latest edits.   

 

Step Four: Process All 
Select the Process All button. Select the Display Mode of Normal radio button to change 
back to section view. Check out the progress in the section view, notice the purple boxes on 
the points being superelevated (point controls being used).  Save your design at this point. 

Step Five: Add Rollover Lock 
It is necessary to add a shoulder rollover lock for the Superelevation to display correctly. 
Select Superelevation > Apply Shoulder Rollover Lock… from the Roadway Designer 
menu. Apply an 8.00% rollover lock to the High side for ES_L and ES_R for Daylight 
Sections (ESH for Box Sections and EF for Guardrail Sections). Click Apply and close to 
dismiss the dialog (Figure 16-38).  
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Figure 16-38: Apply Shoulder Rollever Lock Dialog 

 Hint: Once you click Apply to the first point, ES_R will appear as the shoulder 
point, but the Control Line Name remains ES_L. You should click the Shoulder 
Point down arrow and select ES_R from the list to correctly populate the Control 
Line Name field. 

Step Six: Check out Results 
Select Process All. View the results using the Cross Sectional View of the Roadway 
Designer (Figure 16-39). Navigate through the Sections in areas of Superelevations. Review 
in Superelevation mode too. Navigate through the Sections in areas of Superelevations. 
One handy view will display the slopes of shoulders and travelways. High side shoulder will 
change so as not to be greater than an 8% grade change (between lane and shoulder).  

 
Figure 16-39: Shoulder Rollover Lock – Cross Section View 

Step Seven: Save Roadway Designer 
Select File > Save from the Roadway Designer menu. 
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 CREATE/VIEW A PRELIMINARY SURFACE 
Step One: Create a MainLine Surface 
Select Corridor > Create Surface from the Roadway Designer menu. Enter MainLine as 
the Name of the surface (Figure 16-40). The remainder of the dialog is good by default. 
Click Apply and then Close. 

 
Figure 16-40: Create Surface Dialog 

Step Two: Close the Roadway Designer 
Close the Roadway Designer dialog (File > Close). If prompted to save, select Yes. 

Step Three: View Surface Features 

 Apply Plan Display Filter 
Apply the PLAN DISPLAY Filter by selecting the pull down that currently has Unnamed 
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as the selection. Next to the pull down, make sure that the filter button is active (pressed). 
See Figure 16-41. 

 
Figure 16-41: Feature Filter List – Select PLAN DISPLAY 

 If the Filter toolbox is missing, right click on the menu bar and select Locks. 

 View Features  
Select Surface > View Surface > Features from the InRoads main menu (could also use 
Surface > Update 3-D/Plan Surface Display..). Select MainLine as the Surface. Click 
Apply and then Close.  See Figure 16-42. 

 
Figure 16-42: View Features Dialog 
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  PPAARRAAMMEETTRRIICC  CCOONNSSTTRRAAIINNTTSS  
((OOPPTTIIOONNAALL))  
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TEMPLATE POINT CONTROLS 
Overview 
The standard templates, sub assemblies and components have been developed so that 
adjustments for depths, lane or shoulder widths and side slopes can be adjusted easily from 
station to station. This prevents the need to place a new Template Drop at every point in 
which the shoulder widens or a truck lane is added. It also narrows down the number of 
predefined template scenarios that need to be established in the template library. A single 
box shoulder scenario can cover all possible widths or depths of pavement, base pavement 
or gravel. 

Logic Behind the Labels 
The standard Labels are grouped by abbreviations such as TW (Travelway), ATW 
(Auxiliary Lane Travelway), SH (Shoulder), GR (Guardrail), Drive (driveways), SW 
(Sidewalk), Berm, Ditch, 3:1 (Slopes) etc…  

Within the Label there may be other abbreviations such as WC (Wearing Course), BC 
(Binder Course), AG (Aggregate), SUB (Subgrade), DAY (Daylight Slope), Bmp (Drive 
Bump), etc… 

The suffix of the Label may indicate a LT (Left) or RT (Right), Slope, Dist, Width, or Depth 
depending on the Label.  

Mirrored Labels 
Sub Assemblies were originally developed for one side of the road with the idea that they 
can be placed on the left (reflected) or on the right side of the road. This caused problems 
with connectivity between templates so instead, we created a LT and a RT scenario for all 
Sub Assemblies. This should eliminate most mirrored labels. 

Some Typical Labels 
The following Labels in any given template can be overridden by the Parametric Constraint 
values.  

 Travelway Labels 
• TWWidthRT – Width of the right Travelway. 

• TWSlopeRT – Slope of the right Travelway. 

• TWWidthLT – Width of the left Travelway. 

• TWSlopeLT – Slope of the left Travelway. 

• TWwcDepth – Depth of the wearing course for the Travelway. 

• TWbcDepth – Depth of the binder course in the Travelway. 
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• SGDepth – Subgrade depth at CL (for TW)- LT and RT only when TW w/separate 
values 

 Shoulder Labels 
• SHWidth – Width of the Shoulder. 

• SHSlope – Slope of the Shoulder. 

• SHwcDepth – Depth of wearing course in the Shoulder. 

• SHbcDepth – Depth of the binder course in the Shoulder. 

• SHbcSlope – Slope of the binder course in the Shoulder which could be the same as the 
Travelway but different from the wearing course on the shoulder 

• SHCurbWidth – Width of the Box Section with Curb. Depending on the curb type, the 
box may extend 1 foot beyond gutter line. 

 Auxiliary Lane Labels 
• ATWWidth – Auxiliary Travelway Width 

• ATWSlope – Auxiliary Travelway Slope 

• ATWwcDepth – Auxiliary Travelway wearing course depth 

 Median Labels 
• MTWSlope(LTorRT) – Median Pavement Slope to curb 

• MTWWidth(LTorRT) – Median Pavement Width to curb 

 Other Labels 
• To be continued…  
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ADJUSTING TRAVELWAY SLOPE /WIDTH/DEPTH 
Step One: Open Parametric Constraints 
Select Tools > Parametric Constraints… from the Roadway Designer menu (Figure 
16-43). 

 
Figure 16-43 Parametric Constraints dialog 

Step Two: Locate Label 
When the dialog opens, you can start typing the first letter of the Label you’re after or you 
can click the pull down and scroll and select the constraint Label. The Constraint Label pull 
down list all of the Labels available based on the Template Drops you added into your 
project. Locate TWSlopeLT from the list (type “T” to get to the bottom of the list).  

Step Three: Adjusts Start and Stop Station 
The dialog is very self explanatory. If the adjustment to the Constraint Label adjustment is 
for the whole project, the start and stop stations will cover the whole alignment and the start 
and stop Values will be the same. In this example documentation, it will be for the whole 
project. 

Step Four: Adjust Slope of Travelway 
Enter a Start Value of 3% and a Stop Value of 3% (the decimal slope value works also). You 
would think of this value being a negative, but with sloped lines, a line that runs right to left 
and slopes down is a positive slope.  

 Please refer to Page 15-4 for more information on positive and negative values 
when editing Templates. 

Once you enter the slopes, select the Add button to add the adjustment to your project. If 
you can see past the Parametric Constraints dialog and can see the cross section view, you 
will visually see the change in slope. Repeat for the right Travelway.  
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Step Five: Adjust Width of Travelway 
Select the Label called TWWidthLT from the list of Constraints. Adjust the width to -11’. 
Click Add.  Repeat for the right Travelway (w/o supplying a negative value). To add a truck 
or turning lane with the same cross slope, adjust the widths being sure to add the transition 
areas (Figure 16-44). 

Step Six: Adjust Depths of Pavement and Gravel in 
Travelway 

Pick the Constraint Label TWwcDepth. Adjust the depth from 3” to 4”. It can be entered as 
4” or decimal feet. Adjust the TWbcDepth from 3” to 2”. Adjust the depth of Aggregate 
Subbase Course Gravel SGDepth from 1.5’ (18”) to 2’ (24”). In these cases, the value for 
the left and the right pavement or subgrade will be the same so one label covers both sides. 
The subgrade depth is a value used for the shoulder components also. This is why it isn’t 
specific to the Travelway.  

 
Figure 16-44: Parametric Constraints dialog with examples of adjustments. 

 If adjustments are made to the Travelway layers of pavement, chances are that you 
will have to make similar changes to the shoulders. 
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ADJUST SHOULDER WIDTH/SLOPE/DEPTH 
Overview 
If the wearing course and binder are at the same depth as the Travelway and adjustments 
have been made, make the same adjustments to the Shoulder Constraint Labels to prevent 
tapering layers of pavement from Travelway to shoulder. Adjust width of binder if 
necessary.  

Step One: Adjust Depths of Pavement 
In the previous example, you would need to set the SHWCDepth to 4” and the 
SHBCDepth to 2”.  

Step Two: Adjust Shoulder Width 
If the shoulders vary or if they are consistent but are different than the defaulted 8’ width, 
make that change. In this example, make the change to 4’ shoulders. The shoulder width on 
a bituminous curb box section will need to stay a foot wider than any daylight section of 
shoulder on the project. 

Step Three: Adjust Width of Binder Pavement 
In some cases the binder doesn’t run the full width of the shoulder. It may require that the 
base course of pavement is adjusted when a shoulder width is adjusted drastically. 
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  GGEENNEERRAATTIINNGG  PPRREELLIIMMIINNAARRYY  DDEESSIIGGNN  
SSUURRFFAACCEESS  
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DISPLAYING YOUR DESIGN SURFACE 
Overview 
The Roadway Designer contains all of your design information for the project. In order for 
other team members in various workgroups to see your design, these design features must be 
written to graphics in a MicroStation file. Typically their default MicroStation files 
automatically look for the design by a standard name (i.e. Highway.dgn or Bridge.dgn). 
Though you can have multiple options for your final design, it is important that your latest 
design or the most likely candidate is called one of the standard file names. To help keep 
drawings standard, using the correct name and seed file used in its generation, the Make 
Sheetz utility in MicroStation will help accomplish this. 

Step One: Create a new Drawing 

 Part One: Make Sheetz 
Select File > Make Sheetz… from the MicroStation main menu. 

 Part Two: Select No Prefix 
Select the option for No Prefix (Figure 16-45). Click OK. 

 
Figure 16-45: Select No Prefix in the Make Sheetz dialog 

 Part Three: Select the File Name 
Select Highway (or Bridge for Bridge users) (Figure 16-46). Click OK. 

 
Figure 16-46: Select your drawing name 
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 Part Four: Add Suffix (optional) 
The next dialog gives the user the option of adding a suffix to the file name.  

If this is simply your preliminary design that you would like to view, consider adding the 
word working (i.e. Highway_working or Bridge_working) as the suffix.  

This can also be used for multiple design scenarios on a project, but the latest design or the 
most likely candidate should not have a suffix (Figure 16-47).  

 Other scenarios must be communicated to the other team members so that they can 
manually attach them. Working drawings aren’t automatically attached, therefore 
you can “play” in this drawing.  

Click OK. The new drawing is opened and ready. Select Cancel to stop making new 
drawings.  

 
Figure 16-47: Do not add a suffix for standard drawing names 

Step Two: Open the Roadway Designer 
Open InRoads and select Modeler > Roadway Designer… from the InRoads menu.  

Step Three: Select Corridor and Active Surface 
Select the Corridor (i.e., MainLine or Design) and Active Surface (i.e., Ground) you have 
been working with and click Process All. 

Step Four: Create Surface(s) 
 After entering your project files you may want to verify your Global Scale Factors 

are set to the desired scale before displaying your design drawing. Select Tools > 
Global Scale Factors from the InRoads menu. Plan display should be 300, 300, 300 
for 1” = 25’ drawings (600, 600, 600 for 1”=50’ drawings).  You can also navigate to 
File > Project Options and review the Factors tab, possibly loading a desired 
preference if need be to change these numbers (quick and avoids typing). 

Select Corridor > Create Surface… from the Roadway Designer’s main menu. Supply a 
name to the Surface (i.e. MainLine or Design). Select your corridor from the Create 
Surface(s) from: portion of the dialog. If you desire, place a check in the Create Alternate 
Surface check box to create these alternate surfaces: 

• WearCourse – Bottom of Wearing Course of pavement 

• BaseCourse – Bottom of Base Course (Binder or other) 

• Subgrade – Bottom of Subgrade 
 All other settings are predefined for you (Figure 16-48). Click Apply. 
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Minimize or close the Roadway Designer window. 

 
Figure 16-48: Create Surface dialog with default settings 

Step Five: Set a Filter 
Select a Filter called PLAN DISPLAY from the list of available filters in the InRoads 
dialog menu. Turn the Feature Filter Lock to the ON position by clicking the filter lock 
button (Figure 16-49). 

 
Figure 16-49: Set the active filter to PLAN DISPLAY 
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Step Six: Display Features 
Select Surface > View Surface > Features… from the InRoads main menu. Select your 
surface from the Surface pull down in the View Features dialog (Figure 16-50). Click 
Apply.   

 
Figure 16-50: View Features dialog with the design surface selected 

 You can also use the Surface > View Surface > Triangles or Contours to view these 
aspects of your design. Most likely you would want to create a new MicroStation 
drawing before doing so unless you are in a working drawing. You can also view the 
triangles of Alternate Surfaces by selecting a different surface. 

Changes to the Design 
The display of the design inside of the Highway.dgn or Bridge.dgn is only a snapshot of the 
design in its current state inside of InRoads. Any changes made inside of the Roadway 
Designer will not automatically update the Highway or Bridge drawings, you must select 
Process All in the Roadway Designer and recreate surface. 

You can update the display in the Highway or Bridge drawings by selecting Surface > 
Update 3D/Plan Surface Display from the InRoads menu. Select your surface and then 
select all the features you want to update (can also right click over names to get more 
options) and then plan display updates automatically. 
Another way to do it is to first, delete all the graphics in the .dgn, then view the new 
Features for the re-created surface. 

Fast Track Projects 
In the event that complete modeling vs. scheduling/ learning curve is tight for the project, 
consider using this surface to generate the design deliverables and cross sections. Finalize 
the project using MicroStation tools. If the MainLine corridor from gutter line to gutter line 
(cross slopes and lane widths) is still valid, the 3D surfaces are still viable for GPS grading.  
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Editing the Design 
All edits to the design should be done inside of the Roadway Designer to keep the integrity 
of the design model. Any edits done to the Highway.dgn or Bridge.dgn using MicroStation’s 
tools will be over written if the surface is recreated and re-displayed.  

Adding Additional Features 
Any additional proposed features can be placed in the Highway.dgn or Bridge.dgn and 
merged into the Design Surface for projection onto Cross Sections. The most common 
features have been established and others can be with your input. 



mdot MicroStation 

01/01/12 

Roadway Design 
Development 

16-42 

 

  PPLLOOTTTTIINNGG  PPRROOPPOOSSEEDD  UUTTIILLIITTYY  PPOOLLEESS  
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PLOTTING UTILITY POLES 
Overview 
InRoads has key-in capabilities within MicroStation to place information relative to the 
alignment. Here we are going to use the “SO=” key-in which stands for Station and Offset 
to place proposed utility poles in our plan view. 

The suggested method of utility pole placement will be to place the proposed poles in a 
separate drawing from your design. This will isolate them in the event you want to redisplay 
the design surface features and also lends itself to utility companies or our own Utility 
Coordinators developing and submitting proposed utility designs and revisions.  

Step One: Open MicroStation and inRoads 
Double click your MicroStation V8i icon and select and select your project from the project 
pull down list. Open any file. Select Applications > InRoads Group > Activate InRoads 
from the Main Menus. 

Step Two: Create Utilities drawing 

 Part One: Create File 
Select File > Make Sheetz from the MicroStation Main Menu. Create Utilities.dgn drawing 
using the no prefix option. 

 Refer to 1-57 for help making drawing files 

 Part Two: Reference 
Select File > Reference from the MicroStation Main Menu. Within the Reference dialog 
select Tools > Attach and pick the Alignments.dgn and attach it using the Coincident 
World Attachment Method (Figure 16-51). 
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Figure 16-51: Reference Attachment Settings 

 Repeat this for the design file (i.e., Highway.dgn or Bridge.dgn) and Topo.dgn file in the 
topo folder. 

 Refer to 2-67 for more on Reference File attachments. 

 Part Three: Prepare File 
From the Main Menu, select Settings > Locks > ACS Plane Snap.  Key-in az=0 in the Key-
in dialog and press Enter. (Figure 16-52) Click in the CAD View.   .   

 
Figure 16-52: az=0 

Step Three: Load InRoads Project Information 
 If you are confident that the *.rwk file for the project is up to date with the latest 

InRoads files to be loaded you could load this file and move on to Step Four. If not 
continue on to Part One. 

 Part One: Load Geometry 
Select File > Open from the InRoads Main Menu. Switch the Files of Type: to Geometry 
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Projects (*.alg) within the Open dialog (Figure 16-53). Highlight the geometry project and 
click Open. 

 
Figure 16-53: Open Geometry Projects 

 Part Two: Load Surfaces 
Switch the Files of type: to Surfaces (*.dtm), select the Design surface (*.dtm) and click 
Open (Figure 16-54). 

 
Figure 16-54: Open Design Surface 

Repeat the process above by browsing to the Survey/msta folder, select the Ground.dtm 
and click Open. 

Step Four: Set Active Horizontal Alignment 
Navigate to the Geometry Tab of the InRoads dialog and make the alignment relative to the 
placement of the utility poles the active alignment by right clicking on it and selecting Set 
Active (Figure 16-55). 
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Figure 16-55: Set Active 

Step Five: Open Key-in Dialog in MicroStation 
Select Utilities > Key-in from the MicroStation Main Menu to launch the Key-in dialog 
(Figure 16-56). 

 
Figure 16-56: Key-in 

Dock this dialog so that it is out of the way from the view window. 

Step Six: Place Proposed Utility Poles 
Typically you would be working from a report provide by the Utility Coordinator. In the 
following example we will place a couple of poles randomly to the left and then to the right.  

From the Main Menu, select Settings > Drawing Scale.  From the list of available scales, 
select 1”=25’. (Figure 16-57). 

 
Figure 16-57: Select Scale 

From the Tasks Menus, select your Workgroup > Plan > Utilities > Pole Left.  This will 
set your text to the correct height, width, color, level, style and weight (Figure 16-58). 
Remember to use the appropriate cell for placing the poles left or right of the centerline.  
This will save work when displaying the poles in section. 
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Figure 16-58: Pole Left 

With the proposed pole on your cursor click into the Key-in dialog and type the station and 
offset value like this so=910.25,-42.5 (Figure 16-59), click enter on your keyboard.  

 You do not have to place the + symbol within the station value. InRoads recognize 
the station value as a whole number, 910.25 equals 9+10.25. Negative offset values 
will place cells left of the alignment and positive values will place cells right of the 
alignment looking up station. Place Pole Left using a negative value for the offset 
and Pole Right with a positive value for the offset. 

 
Figure 16-59: Key-in Value 

Gesture your mouse to the view window and use the Nearest snap mode on the alignment to 
complete the rotation of the cell with an accept click (left button) making it roughly 90 
degrees to the alignment. 

Step Seven: Import Surface Advance to DTM 

 Overview 
Once all of the proposed poles have been placed in the Utilities.dgn file graphically you will 
want to bring this data into a surface within InRoads for reporting and easy placement in the 
Cross Sections. Before doing this you will want to turn off all Reference File attachments so 
that you only see the display of the proposed poles. 

 Part One: Create Surface 
Select File > New from the InRoads Main Menu (Figure 16-60). With the Surface tab 
selected change the following to: 

• Type: Design 

• Name: Utilities 
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• Description: Proposed Utilities 

 
Figure 16-60: New Surface 

Click Apply and then Close the dialog. 

 Part Two: Import Data to InRoads 
Select File > Import > Surface Advanced… from the InRoads Main Menu (Figure 16-61). 

Within the Import Surface Advanced dialog set the: 

• Surface: Utilities (this is the new surface that was created earlier.) 

• Load From: leave set to All 

• Intercept Surface: Design (This is the finish grade surface created by the Roadway 
Designer.) 

• Rule Set: Name: Utilities (If the rule set name does not exist then you will need to 
update the MDOT_US_V8i.XIN file for the project pin you are working with.) 
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Figure 16-61: Import Surface Advanced 

Click Apply and then Close the dialog. 

Step Eight: Save Surface 
At this point you will want to save the surface that was created for future use with your 
Cross Sections. Select File > Save As… > Surface from the InRoads Main Menu and save 
the surface as Utilities.dtm. 
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PLACING PROPOSED UTILITY POLES ON CROSS 
SECTIONS 

Overview: 
Before displaying and annotating the new poles remember to set your Global Scale Factors 
to the appropriate scale or load the desired File > Project Options preference, which also 
specifies the necessary factors. 

Option A: Display Poles in New Cross Sections 
If you are creating new Cross Section drawings then you will need to make sure the Utilities 
surface is loaded in InRoads so that it can be selected in the General section of the Create 
Cross Sections dialog. Follow the documentation for Creating Cross Sections at this point. 

Option B: Display Poles in Existing Cross Sections 

 Step One: Adding the Proposed Poles 
Select Evaluation > Cross Section > Cross Sections.. and click the Update Cross Section 
folder from the InRoads Main Menu. 

Within the Update Cross Section dialog (Figure 16-62) set your Cross Section Set: if there 
is more than one in the existing Xsect.dgn file and toggle the Mode: to Display On. 

 
Figure 16-62: Update Cross Section – General 

Select the Projected Features leaf in the explorer tree to the left. In the Surface: list, pick the 
Utilities surface and right click in the Feature: area on a feature and Select All (Figure 
16-63). 
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Figure 16-63: Update Cross Section - Projected Features 

Click Apply and then Close the dialog. 

 Step Two: Annotate Proposed Poles 
Select Evaluation > Cross Section > Cross Sections.. and click the Annotate Cross 
Section folder from the InRoads Main Menu. 

Select the Preferences… button at the bottom of the dialog and load the UTILITIES 
preference (Figure 16-64).  

 
Figure 16-64: Annotate Preferences 

Close the dialog. 

Within the Annotate Cross Section dialog set to your Cross Section Set: if there is more 
than one in the existing Xsect.dgn file and in the General area of the explorer tree select the 
Utilities surface to the right (Figure 16-65). 
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Figure 16-65: Annotate Cross Section – General 

Pick the Features folder in the explorer tree to the left and highlight Annotate under it. Right 
click on a feature to the right and Select All (Figure 16-66). 

 
Figure 16-66: Annotate Cross Section – Features 

Click Apply and then Close the dialog. View the results within your Cross Sections to see 
the new poles and annotation.
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OVERVIEW 
This section will be developed in the future. 
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INTERSECTION DESIGN 
Prerequisites 

 Final Horizontal and Vertical Alignments Designed for 
Maineline(s) and Side Road(s)  
 Depending on if the intersection being designed is a signalized section or a non-

signalized section determines how the vertical alignment should be designed and what 
edges will need to be intercepted. This workflow is a design example for a signalized 
intersection so we will be designing to the travelway edge instead of the shoulder edge 
of MainLine. 

 Superelevation Applied 

 MainLine Surface and SideRoad Surface Created 

Overview 
The intent is to create intersections that transition smoothly together using the Roadway 
Designer. This method is an outline and is not intended to cover every unique situation out 
there.  

The generation of this workflow was from viewing a video supplied by Bentley for 
designing intersections using the Roadway Designer. To view the video follow the link 
provided. \\Oit-
teaqasdtiis.mdot.w2k.state.me.us\PCPIN1\msworksp\Documentation\MDOT\Training\video
\InRoadsXMEditionIntersectionDesign.wmv 

Step One: Create a Working Drawing 
Select File > Make Sheetz from the MicroStation main menu. Create a No Prefix drawing 
called either Highway_working or Bridge_working based on your workgroup. 

 Refer to page 1-57 for more information on using the Make Sheetz program. 
Select which reference files you want to display as well as the levels in each reference 
file. You may want to shut off the Highway or Bridge drawing if one has been created. 
The features for the MainLine and SideRoad will be written to this drawing through 
InRoads. This is intended to be a working drawing and the final display and editing of 
the features will be in the dtm file and displayed in the Highway.dgn or Bridge.dgn file. 
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Step Two: Create and Display MainLine and SideRoad 
Surface Features 

 Overview 
This step assumes you have created a Main Line and SideRoad corridor in the Roadway 
Designer, passed a template along each, assigned superelevation and applied shoulder 
rollover locks. For this example the two corridors have been supplied for you. 

 Part One: Creating Surfaces 
Select Modeler > Roadway Designer from the InRoads main menu. Select Corridor > 
Create Surface from the Roadway Designer. Turn on New Surface for Each Corridor, 
highlight your MainLine and SideRoad corridors in the Create Surface(s) from, turn on Add 
Transverse Features and pick the Style: D_Transverse_Features if it is not already 
provided and leave off Create Alternate Surfaces (Figure 17-1). 

 
Figure 17-1: Create Surface Dialog 
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Click Apply and after it is done processing Close the Results and Create Surface dialogs 
and minimize the Roadway Designer. 

 Part Two: Displaying Features 
Set the Filter to Plan Display and turn on the filter lock from the locks toolbar. Select 
Surface > View Surface > Features… from the InRoads main menu. Select the MainLine 
surface in the pull down and click Apply. Select the SideRoad surface in the pull down and 
click Apply. Fit the view to see your graphics (Figure 17-2). 

 
Figure 17-2: Display Features 

Close the View Features dialog. 

Step Three: Using the Multicenter Curve tool and Review 

 Overview 
To determine what radii are needed, use AutoTrack. Once turning movements are 
determined the designer will decide what radii are needed when using the Multicenter Curve 
tool. 

 For more information about Multicenter Curve tool refer to the InRoads Help button 
within the dialog. 

 Part One: Creating Multicenter Curve for Quad1 Travelway Edge 
Select Geometry > Utilities > Multicenter Curve from the InRoads main menu. Use of 
this tool will allow for generating a horizontal and vertical alignment from the MainLine and 
SideRoad surfaces (Figure 17-3). 
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Figure 17-3: Multicenter Curve Dialog 

In this example we will use Curve Type: Three Center for one side of the intersection 
(Figure 17-4). 

On the Main tab set your desired Radii in the three radius boxes as shown below, for the 
Widths you will want to set the travelway width for the MainLine in Width 1 and your 
SideRoad travelway width in Width 2.  

 Refer to the Example illustration at the bottom of the dialog for a better understanding 
of the width relationship to centerline. 

 
Figure 17-4: Multicenter Curve Dialog – Radii and Widths - Quad1 Travelway Edge 
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In the Define By area leave the radio button set to Offsets at Shifted PC/PT and set the 
Offset 1 and 2 as shown below (Figure 17-5). 

 
Figure 17-5: Multicenter Curve Dialog – Define By - Quad1 Travelway Edge  

Select the Advanced tab and assign an Alignment Name: Quad1_Edge_TW and pick the 
Style: D_Roadway_Edge_TW (Figure 17-6). 

 
Figure 17-6: Multicenter Curve Dialog – Advanced Tab - Quad1 Travelway Edge 

Turn on Create Vertical Alignment and for the First Selected Alignment set the surface to 
your MainLine surface. Set the Second Selected Alignment to the SideRoad surface as 
shown below (Figure 17-7). 
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Figure 17-7: Multicenter Curve Dialog – Advanced Tab – Vertical Alignments - Quad1 Travelway Edge 

Click Apply. You will be prompted to locate the first alignment. Select graphically with a 
left mouse button the MainLine alignment. 

Next you will be prompted to identify the second alignment, select the SideRoad alignment 
with a left mouse button. 

Then you will be asked to identify the quadrant for return, send a left mouse button click to 
the desired quadrant.  See Figure 17-8. 

 
Figure 17-8: Multicenter Curve – Quadrant and Alignment Selection - Quad1 Travelway Edge 
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If you like the alignment then left mouse button in the view to accept the alignment. You 
can choose to save the results if you want or just close the dialog. To view the alignment; 
right click on the alignment in the InRoads explorer tree and select View (Figure 17-9).   

 
Figure 17-9: Multicenter Curve – Quadrant and Alignment  Acceptance - Quad1 Travelway Edge 

The new alignment ties into the edges of travelway for each roadway surface.  

 Part Two: Creating Multicenter Alignment for Quad1 Shoulder 
Follow the same routine as the Quad1 edge of travelway and develop the radii for the 
shoulder in the same quadrant using the following information in the Main tab: 

 
Figure 17-10: Multicenter Curve Dialog – Radii and Widths - Quad1 Shoulder 

In the Advanced tab set the options to the following (Figure 17-10): 



mdot MicroStation 

01/01/12 

Driveway & Intersection 
Design 

17-12 

 

 
Figure 17-11: Multicenter Curve Dialog – Advanced Tab – Vertical Alignments - Quad1 Shoulder 

Click Apply; identify your MainLine and SideRoad alignments and select the quadrant area 
as you did with the travelway edge. 

 Part Three: Creating Multicenter Curve for Quad4 Travelway Edge 
In this example we will use Curve Type: One Center for the other side of the intersection. 

On the Main tab set your desired Radius in the radius box as shown below, for the Widths 
you will want to set the travelway width for the MainLine in Width 1 and your SideRoad 
travelway width in Width 2.  See Figure 17-12. 

 
Figure 17-12: Multicenter Curve Dialog – Radii and Widths - Quad4 Travelway Edge 

Select the Advanced tab and assign an Alignment Name: Quad4_Edge_TW and pick the 
Style: D_Roadway_Edge_TW (Figure 17-13). 
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Figure 17-13: Multicenter Curve Dialog – Advanced Tab – Quad4 Travelway Edge  

Turn on Create Vertical Alignment and for the First Selected Alignment set the surface to 
your MainLine surface. Set the Second Selected Alignment to the SideRoad surface as 
shown below (Figure 17-14). 

 
Figure 17-14: Multicenter Curve Dialog – Advanced Tab –Vertical Alignments - Quad4 Travelway Edge  

Click Apply. You will be prompted to locate the first alignment. Select graphically with a 
left mouse button the MainLine alignment. 

Next you will be prompted to identify the second alignment, select the SideRoad alignment 
with a left mouse button. 

Then you will be asked to identify the quadrant for return, send a left mouse button click to 
the desired quadrant.  See Figure 17-15. 
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Figure 17-15: Multicenter Curve – Quadrant and Alignment Selection – Quad4 Travelway Edge 

If you like the alignment then left mouse button in the view to accept the alignment. You 
can choose to save the results if you want or just close the dialog. To view the alignment; 
right click on the alignment in the InRoads explorer tree and select View. See Figure 17-16. 

 
Figure 17-16: Multicenter Curve – Quadrant and Alignment Acceptance – Quad4 Travelway Edge 

The new alignment ties into the edges of travelway for each roadway surface.  

 Part Four: Creating Multicenter Curve for Quad4 Shoulder Edge 
Follow the same routine as the Quad4 edge of travelway and develop the radius for 
the shoulder in the same quadrant using the following information in the Main tab 
(Figure 17-17): 
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Figure 17-17: Multicenter Curve Dialog – Radii and Widths - Quad4 Shoulder 

In the Advanced tab set the options to the following (Figure 17-18): 

 
Figure 17-18: Multicenter Curve Dialog – Advanced Tab - Quad4 Shoulder 

Click Apply; identify your MainLine and SideRoad alignments and select the quadrant area 
as you did with the travelway edge. 

Step Four: Review Vertical Alignments 
Select Evaluation > Profile > Create Profile from the InRoads main menu. In the Source 
area set the alignment to one of the Quad alignments generated using the Multicenter tool 
(Figure 17-19). 
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Figure 17-19: Create Profile Dialog 

In the General area set a style name for the MainLine and SideRoad surfaces listed in the 
Surface: section by highlighting the surface and selecting Properties. Set the Cross Sections 
and Profiles Symbology to D_Roadway_Centerline for each surface clicking Apply for 
each of them and Close the dialog (Figure 17-20). 

 
Figure 17-20: Surface Properties – Advanced Tab 

Make sure all surfaces are selected with an X next to them in the Surfaces: area of the dialog 
(Figure 17-21). 
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Figure 17-21: Create Profile Dialog – Surface Selection 

Click Apply and send a left mouse button to the view window to see the profile. Select 
Geometry > View Geometry > Active Vertical to see how the Multicenter Curve tool built 
the vertical alignment (Figure 17-22). 

 
Figure 17-22: Profile of Side Road and Main Line 

If you want to adjust the vertical alignment then refer to the geometry tools to edit or 
recreate the vertical alignment. 

Repeat the following to view the other 3 vertical alignments created through the use of the 
Multicenter Curve tool. You will only need to change the Source alignment; all other 
settings will still be preset for you. 
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Step Five: Point Control for Edge of Travelways and 
Shoulders 

 Overview 
Now that we have alignments for each edge of travelway and shoulder of the SideRoad the 
widths of travelway and shoulders can be controlled with point controls within the Roadway 
Designer. 

 Part One: Travelway Edge Control 
Select Modeler > Roadway Designer from the InRoads main menu. Pick your SideRoad 
Corridor: and set the Active Surface: to Ground.  Also, enable the Lock to keep your active 
surface set to GROUND for this session of InRoads (Figure 17-23).   

 
Figure 17-23: Active Corridor and Surface 

Select Corridor > Point Controls from the Roadway Designer main menu. Set Point: to 
CE_L, change the Mode to Both, set the Control Type: to Alignment, select the Horizontal 
and Vertical Alignment that was developed for the left side of the SideRoad travelway (if 
you can’t remember the name hold down the Ctrl key and use the selection button to the 
right of the Horizontal Alignment drop down box to graphically select it in the MicroStation 
view window.) and place a check mark in the Use as Secondary Alignment (Figure 17-24). 
Note, entering text in the Control Description field is optional.  

 
Figure 17-24: Point Controls Dialog – Travelway Edge Control 

For the Station Limits the Start: station should be the first point of the Quad1_Edge_TW 
alignment intersecting the travelway edge of the SideRoad and the Stop: should be 
approximately the last point along the Quad1_Edge_TW alignment that can be seen 
perpendicular to the SideRoad alignment (Figure 17-25).  

 If you want an exact Stop station then use MicroStation to draw a line with a tangent 
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snap to the Quad1_Edge_TW alignment and perpendicular snap to the SideRoad 
alignment. 

 
Figure 17-25: Point Controls Dialog – Travelway Edge Example Diagram 

To set the Station Limits hold down the Ctrl key and use the selection button to the right of 
the start and stop station to pick the limits graphically (Figure 17-26). 

 
Figure 17-26: Point Controls Dialog – Travelway Edge Station Limits Example 

Deduct .10’ from the stop station to help eliminate any spiking (Figure 17-27). 

 
Figure 17-27: Point Controls Dialog – Travelway Edge Station Limits Example – Adjusted for Spiking 

Click the Add button to populate the Horizontal and Vertical Controls area of the dialog 
(Figure 17-28).  

 
Figure 17-28: Point Controls Dialog – Populated Example with Conflict 
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You may have noticed the current point control turned orange. This tells you that there is a 
conflict in station range of a point. This can be corrected by adjusting the priority of one of 
the points OR change the station range of the point control. In this case change the stop 
station of the Vertical mode point control for CE_L to end at the start station of the point 
control of CE_L being controlled by Alignment type.  Once clicking Change, the orange 
text will turn to black text (Figure 17-29). 

 
Figure 17-29: Point Controls Dialog – Populated Example with Conflict Corrected 

Repeat this process for the right travelway edge (CE_R) taking it as far as the alignment 
will allow, click Add and adjust any conflicting stationing as necessary (Figure 17-30). 

 
Figure 17-30: Point Controls Dialog – Example Continued 

Close the dialog. 

After setting the right side you should see the secondary alignments displayed within the 
Roadway Designer. By using secondary alignments to control the travelway edge this allows 
the shoulders and end conditions to come off perpendicular to the secondary alignment for 
better triangulation (Figure 17-31). 

 
Figure 17-31: Plan View Graphic Results 
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 Part Two: Shoulder Edge Control 
Select Corridor > Point Controls from the Roadway Designer main menu. Set Point: to 
ES_L, change the Mode to Both, set the Control Type: to Alignment, select the Horizontal 
and Vertical Alignment that was developed for the left side of the SideRoad at the shoulder 
edge (if you can’t remember the name hold down the Ctrl key and use the selection button 
to the right of the Horizontal Alignment drop down box to graphically select it in the 
MicroStation view window.) and place a check mark in the Use as Secondary Alignment 
(Figure 17-32). 

 
Figure 17-32: Point Controls Dialog- Shoulder Edge Control 

For the Station Limits the Start: station should be the first point of the Quad1_Edge_SH 
alignment intersecting the shoulder of the SideRoad and the Stop: should be approximately 
the last point along the Quad1_Edge_SH alignment that can be seen perpendicular to the 
SideRoad alignment (Figure 17-33).  

 If you want an exact Stop station then use MicroStation to draw a line with a tangent 
snap to the Quad1_Edge_SH alignment and perpendicular snap to the SideRoad 
alignment. 

 
Figure 17-33: Point Controls Dialog – Shoulder Edge Example Diagram 
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To set the Station Limits hold down the Ctrl key and use the selection button to the right of 
the start and stop station to pick the limits graphically (Figure 17-34). 

 
Figure 17-34: Point Controls Dialog – Shoulder Edge Station Limits Example 

Deduct .10’ from the stop station to help eliminate any spiking (Figure 17-35). 

 
Figure 17-35: Point Controls Dialog – Shoulder Edge Station Limits Example – Adjusted for Spiking 

Click the Add button to populate the Horizontal and Vertical Controls area of the dialog.  

Repeat this process for the right shoulder edge (ES_R) taking it as far as the alignment will 
allow, click Add and Close the dialog. 

After setting the right side you should see the additional secondary alignments displayed 
within the Roadway Designer (Figure 17-36). 

 
Figure 17-36: Plan View Graphic Results 

Step Six: Adjust Template drops for SideRoad 

 Part One: Template Drops and Edits 
At this point additional template drops will be needed at key stations along the SideRoad 
corridor and will need to intercept the edge of travelway of the MainLine. This is done by 
adding additional template drops and doing additional point controls.  

Select Corridor > Template Drops from the Roadway Designer main menu. In the Current 
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Template Drops: highlight the only template drop, set the station to the first alignment to be 
encountered along the corridor (i.e., 31+73.38), set the interval to 2 feet and click Copy 
(Figure 17-37). 

 
Figure 17-37: Template Drops Dialog – Set Interval and Copy – First Alignment Encountered 

Next, set the Station: to the closest station intercepting the edge of travelway of the 
MainLine looking up station (in this case it is the last station given for the point control for 
the CE_L which is 32+60.93). Set the Interval: to 2 feet and click the Copy button (Figure 
17-38). 

 
Figure 17-38: Template Drops Dialog – Set Interval and Copy – Edge of Travelway Intercept 
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Highlight the new template drop and select Edit (Figure 17-39). 

 
Figure 17-39: Template Drops Dialog – Edit Template Drop 

Delete left end conditions, curbing, and shoulder from the template drop (leaving just the 
lane).  See Figure 17-40. 

 
Figure 17-40: Edit Template Drop – Delete Left End Conditions, Curbing and Shoulder 

Click OK. 
Next, highlight the last template drop, set the Station: to the intersecting point of the 
SideRoad alignment and the edge of travelway of the MainLine (hold the ctrl key and pick 
the selection tool to graphically select the intersection point to populate the station) and then 
back it off an inch plus/minus. Set the Interval: to 2 and click the Copy button (Figure 
17-41). 
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Figure 17-41: Template Drops Dialog – Set Interval and Copy – Edge of Sideroad Intercept 

Highlight the new template drop and select Edit (Figure 17-42). 

 
Figure 17-42: Template Drops Dialog – Edit Template Drop 

Delete the left travelway edge and sub points from the template drop by right clicking on 
each point and selecting Delete Point. When more than one point display in a separate 
dialog select All and click OK (Figure 17-43). 
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Figure 17-43: Edit Template Drop – Delete Travel Edge and Sub Points 

Select OK when finished editing and Close the Template Drops dialog. 

 Part Three: Point Controls for Edited Template Drops 
Select Corridor > Point Controls from the Roadway Designer main menu. Set Point: to 
CE_L, change the Mode to Both, set the Control Type: to Corridor Point, select the 
MainLine as the Corridor: and set the Reference Point: to the edge of travelway point name 
from the MainLine (CE_L).  See Figure 17-44. 

 
Figure 17-44: Point Controls Dialog- Edited Template Drops 

For the Station Limits the Start: station should be the same as the first edited station drop 
and the Stop: station should be the last station drop. In the Horizontal Offsets set the Start: 
and Stop: to 0.1000 (Figure 17-45). 
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Figure 17-45: Point Controls Dialog- Station Limits – Horizontal Offsets 

Click the Add button (Figure 17-46). 

 
Figure 17-46: Point Controls Dialog – Adding Point Controls for Edited Templates 

Do the same process for the MC point with the same Mode:, Control Type: Corridor and 
Reference Point:. Set the Station Limits start station to match the last template drop in the 
series of drops for the SideRoad, stop station at the farthest point of intersection for the 
travelway edge and edge of travelway on the MainLine and supply a 0.100 Horizontal 
Offsets for both the start and stop (Figure 17-47). 
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Figure 17-47: Point Controls Dialog – Adding MC Point 

Click Add to populate the Horizontal and Vertical Controls and Close the dialog. 

In the Roadway Designer click the Process All and view the plan view of the Roadway 
Designer to see how the interfacing looks (Figure 17-48). 

 
Figure 17-48: Plan View Graphic Results  
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As you can see there is a line following the mainline corridor. 

Step Six: Target Alias 
Select Tools > Target Aliasing from the Roadway Designer main menu. Add the MainLine 
corridor and the existing ground surface to the Aliases: area of the dialog. Move the corridor 
to the top if necessary (Figure 17-49). 

 
Figure 17-49: Target Aliasing Dialog 

Click OK to close the dialog. 

Step Seven: Create Combined Surface 
Select Corridor > Create Surface from the Roadway Designer main menu. Set the Name: 
to Design. 

In The Create Surface(s) from: area of the dialog, highlight both the MainLine and 
SideRoad surfaces. 

 
Figure 17-50: Create Surface Dialog – Selecting Surfaces 

Click on the Clipping Options button to review the settings (Figure 17-50). 

 
Figure 17-51: Create Surface Dialog – Clipping Options  
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This should be set to Clip All for the SideRoad clipping corridor. To change it left click the 
desired row of the Clipping Options column. Click OK to close the dialog box. 

You may or may not want to Create Alternate Surfaces at this time. In this exercise we 
will not be creating the alternate surfaces so uncheck this option. The overall look of the 
Create Surface dialog should look like this (Figure 17-52). 

 
Figure 17-52: Create Surface Dialog 

Click Apply and allow for the processing to finish before closing the dialog. Close the 
Roadway Designer and Save your *.ird. 

Step Eight: View Features 
If you have features already displayed in your drawing select Edit > Select All from the 
MicroStation main menu and use the delete tool to remove all feature graphics. 

Select Surface > View Surface > Features from the InRoads main menu. Set the Surface: 
to Design and click on the Filter button. Set the filter to PLAN DISPLAY and click OK 
(Figure 17-53). 
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Figure 17-53: View Features Dialog – Change Filter to PLAN DISPLAY - Verify Feature Lock is On 

Verify that the Feature Filter Lock is ON in the Locks toolbar and click Apply to display 
the features of the combined surface (Figure 17-54). Close the dialog. 

 
Figure 17-54: Feature Display  

As you can see there will still need to be some clean up of the features coming into the edges 
of the MainLine. Also, the Cut and Fill might need to use end condition exceptions to 
continuously follow the toe of slope along the corridors.  Surface editing tools within 
InRoads and alignments that were created to control the edge of travelways for the SideRoad 
by importing them to the Design surface will help improve the surface. 
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Step Nine: View Triangles 
To view the triangles select Surface > View Surface > Triangles from the InRoads main 
menu. Set your surface to Design, select the Preferences button and load the Proposed 
preference. Click Apply to view the triangles (Figure 17-55). 

 
Figure 17-55: Triangle Display 

The display of the triangles shows how the SideRoad interfaces to the edge of travelway of 
the MainLine and also how they turn on the secondary alignments of the travelway edge to 
create a more accurate model. 

Step Ten: Rendering Triangles (Optional) 
To render the triangles select MicroStation Settings > View Attributes (or Control+B).  
Change the Display Style to Smooth for View 1 (Figure 17-56).  

 
Figure 17-56: View Attributes - Smooth 

This will render the view. 

 You will want to turn the level off for the Exterior. Turn off the level named 
(Exterior Boundary) in the level display of MicroStation. 

Use the Rotate View tool, set Method: to Dynamic and place a tentative snap near the 
intersection and accept (left button) to rotate the triangles around viewing the interfacing 
into the MainLine (Figure 17-57). 
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Figure 17-57: Rotate View - Dynamic 

 
Figure 0-58: Rendered View 

Select the Rotate View tool again and change Method: to Top to set the view back to 
normal. Open the View Attributes icon and set the Display Style: to Wireframe to remove 
the rendering (Figure 17-59). 

 
Figure 17-59: View Attributes - Wireframe 

Step Eleven: Delete Triangle Display 
Select Surface > Update 3-D/Plan Surface Display from the InRoads main menu. Ensure 
the Surface is Design, then uncheck the Triangles option to remove the triangle graphics 
that were displayed earlier (Figure 17-60).   

 
Figure 17-60: Update 3-D/Plan Surface Display 
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 SURFACE EDITING 
Overview 
Final surface editing is required to mesh the areas that could not be completely modeled due 
to skew conditions etc. Final editing should only be done after all driveway and intersections 
have been designed, any boring for drainage situations have been received and drainage 
conditions designed and template depths design have been adjusted for final computation. 
Basically you want to make sure you are done using the Roadway Designer. 

Display Alignment Edges 
In the Geometry tab of the InRoads explorer tree right click on each of the horizontal 
alignments created earlier and select View (Figure 17-61). 

  
Figure 17-61: View Horizontal Alignment 

They will be displayed in your MicroStation view window. 

Partial Delete Features 
Select Surface > Edit Surface > Partial Delete from the InRoads main menu. You will be 
prompted to ‘Identify Feature’ at the bottom left of the MicroStation window (Figure 
17-62). 

 
Figure 17-62: Identify Feature Prompt 

 Part One: Locate Feature 
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Left click on the CE_L feature of the SideRoad. You will be prompted to Accept/Reject the 
feature (Figure 17-63). 

 
Figure 17-63: Accept/Reject Prompt 

Left click to accept the SideRoad-CE_L feature for editing. 

 Part Two: Identify Starting Point 
Identify the starting point of the feature to be deleted. This feature starts along the MainLine 
corridor, drag your mouse to the end of the feature and left click to accept the starting point 
(Figure 17-64). 

 
Figure 17-64: Locate Start of Partial Delete 

 Part Three: Identify Ending Point 
Identify the ending point of the feature to be deleted. This will be the starting circle of the 
alignment that was created for the control of the CE_L feature. Use a center snap to get the 
exact station and accept this point (Figure 17-65). 

 
Figure 17-65: Locate End of Partial Delete 
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Repeat this process for the Curb, Shoulder and Travelway edges remaining for the SideRoad 
and Curb and Shoulder edge for MainLine. 

What you should see in the end is all the features trimmed to the ends of the alignments that 
were created (Figure 17-66). 

 
Figure 17-66: Partial Delete Complete 

We will address the back of sidewalk later.  

Import Geometry to Surface 

 Overview 
By applying the correct styles for the travelway edges and shoulders when creating the 
multicenter alignments the import process can be done all at once. 

 Part One: Import to Surface 
Select File > Import > Surface from the InRoads main menu. Select the From Geometry 
tab within the Import Surface dialog (Figure 17-67). 

 
Figure 17-67: Import Surface – From Geometry 
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Set the Target Surface to your Design surface. In the Points/Alignments area of the dialog 
select the radio button for Alignments. Place your cursor in the Name: field and select the 
Filter… button to the right of the dialog (Figure 17-68). 

 
Figure 17-68: Import Surface – Filter 

A second dialog will appear called the Geometry Selection Filter, select the entire Quad* 
alignments that were created for this intersection and Add them to the Selected: side of the 
dialog (Figure 17-69). 

 
Figure 17-69: Geometry Selection Filter 

Press OK when done and this will populate the Selected: area of the Import Surface 
dialog. In the Features: area of the dialog you will leave the Name: set to From Geometry, 
Type: set to Breakline and the Duplicate Names: set to Rename (Figure 17-70). 
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Figure 17-70: Populated Import Surface Dialog 

In the Elevation area of the dialog change the Source: to Vertical Alignment (Figure 
17-71). 

 
Figure 17-71: Import Surface – Elevation 

Select Apply and Close the dialog. This places the new features into the Design surface. 

 Part Two: Display New features 
With the graphic group lock on delete the alignments displayed in the MicroStation view 
window. Select Surface > View Surface > Features… from the InRoads main menu. Set 
your Surface: to Design and select all the features in the Feature: list (Figure 17-72). 
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Figure 17-72: View Design Features 

Click Apply to update the features in the view window. You should now see new features 
tying in the SideRoad and MainLine (Figure 17-73). 

 
Figure 17-73: Design Feature Display 

This took care of the edge of travelway and edge of shoulder. 

 Part Three: Copy Features for Curb Features 
Select Surface > Edit Surface > Copy Single Feature… from the InRoads main menu. 
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OVERVIEW 
The default preference for this dialog has been setup to establish the station range limits for 
25 scale plans. There are other preferences for establishing plan and profile pages, plan only, 
profile only and 50 scale setups. Remember if you chose to do 50 scale then previous 
prerequisites will need to be redisplay with the Global Scale Factors set to 600 absolute 
scale (or use File > Project Options and select the correct preference). 
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CREATE PLAN OVER PROFILE PAGES 
Step One: Open MicroStation 
To begin, double click your MicroStation V8i icon and select your project from the project 
pull down. Open any file. 

Step Two: Create or Open a Profile Drawing 
Select File > Make Sheetz from the MicroStation Main Menu. Create a Profile.dgn 
drawing (if one doesn’t already exist) using the no prefix option. 

 Refer to 1-57 for help making drawing files. 

Step Three: Create Plan Page Layout without Graphics 
Not all alignments begin with an even station. For this reason we need to establish how we 
are going to control the sheet drawing station limits before generating plan over profile 
drawings. By default we are ready to control station limits for 25 scale drawings. If you 
intend to do 50 scale plans you will need to click the Preference button open the 50 Scale 
preference sets. 

 Disable your station lock before you begin the next step. 

 Part One: Main 
From the InRoads Main Menu select Drafting > Plan and Profile Generator… (Figure 
18-1). In the Main tab select your alignment in the Horizontal Alignment: area and 
manage the start and stop limits of your project in the Station Limits area of the dialog box. 
Enable the Plan Only option. Disable the Generate Sheets option. 

 
Figure 18-1: Plan and Profile Generator-Main 
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 Part Two: Plan Controls 
Place focus on the Plan Controls tab (Figure 18-2). Select the Model Files… button to the 
right and pick your workgroups source drawing file i.e. (HDPlan.dgn, BDPlan.dgn or etc.). 

 
Figure 18-2: Plan and Profile Generator-Plan Controls 

Click Apply.  This will result in creating Plan Views.  

Step Four: Create Plan over Profile Pages 
The top of the dialog has multiple tabs with certain settings preset for you. We will need to 
place some information in a few of these tabs. 

 Before you begin reactivate your Station Lock button on the Locks toolbar. 

Located at the bottom of the dialog box select the Preferences… button (Figure 18-3) and 
load Plan & Profile 25 scale by either double clicking or highlighting and selecting Load. 

 
Figure 18-3: Preferences 
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Press Close to return to the Plan and Profile Generator dialog.  Enable the Use Plan Views 
option on the Main tab of the Plan and Profile Generator dialog 

 Part One: Plan Controls 
Place focus on the Plan Controls tab (Figure 18-4). The path should already be written into 
the Model Files… area for the source drawing file (i.e., HDPlan.dgn, BDPlan.dgn or etc.). 

 If the path shown is pointing to something other than your source drawing file you 
must reset your preferences back to default and redo the instructions give in Step 
Three: Create Plan Page Layout without Graphics. 

 
Figure 18-4: Plan and Profile Generator-Plan Controls 

 Your source drawing file should have the standard files attached to it. At any time 
you can attach files to the source drawing and have them display within your plan 
pages. 

 Refer to 2-72 for more information on Reference Attachments. 

 Part Two: Profile Controls 
Place focus on the Profile Controls tab (Figure 18-5). Select your Vertical Alignment: 
from the pull down and pick the existing and proposed surfaces for display. 

 Remember to also highlight the Surface names (using the Ctrl key) along with placing 
the X next to the surface names (i.e., Ground and Design). If this isn’t done you will 
get undesirable results in the way your grid will display with your profiles. 
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Figure 18-5: Plan and Profile Generator-Profile Controls 

 Part Three: Sheet Layout 
Place focus on the Sheet Layout tab (Figure 18-6). Press the ... button right of the Host 
File: location and select the same file as you did for your plan controls (i.e., HDPlan.dgn, 
BDPlan.dgn or etc.). 

 
Figure 18-6: Plan and Profile Generator-Sheet Layout 

 Part Four: Sheeting Drawings 
 Remember to toggle the Station Locks On from the Locks toolbar prior to sheeting 

your files. If you have changed the start station of your alignment to be something 
other than an even 100 foot station and this lock is off, your stationing along the 
profile will increment at even 100 foot intervals based on the start station. 

Click Apply at the bottom of the Plan and Profile Generator dialog. You will be prompted 
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at the bottom right of the MicroStation screen to Identify Location, send a left mouse 
button to the view 1 window to begin the sheet creation process. 

When the sheet creation process finalizes the Plan and Profile Generator dialog will 
reappear. Click Close and save your VDF file for future use. 

 If you do not have a proposed design surface when generating your P & P, you must 
go back after and display you active vertical alignment to get the vertical to display. 

 Part Five: View the Results 
Select File > Open from MicroStation’s main menu and view the sheets (i.e., ??plan1.dgn).  

If you are satisfied with the sheet layout, then consider running the Sheet Renumbering 
Utility to place the 3 digit prefixed in front of the file names. Without the 3 digit prefix, the 
Border Information macro can’t be run to fill in the border information on each sheet.  

 For detailed instructions on using the Sheet Renumbering Utility, please refer to 1-62. 
 For detailed instructions on using the Border Information macro, please refer to 1-69. 
If you are not satisfied with the sheet layout, re-open the Plan and Profile Generator, 
select the Sheet Index tab and open the saved VDF file. Adjust the Plan View and Profile 
View stations or overlaps on the Main tab. 

 If you need to adjust any of the plan pages for layout, refer to Bentley InRoads help. 

Part Five: Adjusting Plan Area 

 Overview 
The viewable area of the plan can easily be adjusted with MicroStation tools and the 
Reference File dialog. There is an element that surrounds the plan view area within the 
border drawings.  

 The element is color 160 (which plots white) and is a Construction element, therefore it 
will never plot. 

 Part One: Export the DGN to 2d 
From the Main Menu, select File > Export > 2d.  Use the current name of the DGN, but add 
a suffix of “_2d”.  The resulting DGN will be flat and ready for use.  Open the new 2d file. 

 Part Two: Open Reference Dialog 
Select File > Reference (DOT) > Dialog from the MicroStation main menu. This opens the 
Reference dialog. 
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The dialog lists multiple reference files. Select all of the reference files you want to clip, 
except xxx_Profile.dgn which contains the profile and its extents. 

 Part Three: Set Element as Clip Boundary 
Select HDPLAN.DGN with a left click. Now select Tools > Clip Boundary from the 
Reference file menu. Set the Method to Element and place a check in the Use Reference 
Dialog List box.  

 
MicroStation prompts you to Identify Clipping Element. Click on the light yellow shape 
surrounding the plan area. 

 

 Part Four: Modify with MicroStation Tools 
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Now that the Clip Boundary element has been established, the element can be modified by 
moving a vertex with the Modify Element tool or by adding or deleting a vertex with the 
appropriate tool.  

 Rotate or Move References (Optional) 
To move or rotate the area within the view extents, highlight HDPLAN.DGN in the 
Reference dialog and use the Tools > Move or Tools > Rotate to reposition the area. This 
may require that you adjust the Clip Boundary afterwards. 

Step Six: Adjust the Clip Boundaries 
Adjust the Clip Boundaries of each plan sheet that was created.  

Step Seven: Annotating Profiles 
Reopen the Profile.dgn file that was created earlier. Fit the view. 

 Part One: Label Proposed Elevations 
From the InRoads Main Menu select Evaluation > Profile > Annotate Profile… (Figure 
18-7). By default we are preset to label the elevations of the proposed vertical design. If you 
want to label the existing ground elevations also then select the Preferences… button and 
activate the Proposed and Existing Elevation option and close the dialog. 

Verify your vertical Profile Set if you have multiples in the Profile.dgn file, set your 
Vertical Alignment: to the vertical design, Surface: to the existing ground surface and 
select All under the station ranges listed in the Profiles: area. 

 
Figure 18-7: Annotate Profile 

Click Apply and Close to exit this dialog. 

 Part Two: Label Vertical Annotation 
Normally, the Vertical alignment will already be automatically annotated based on the 
Geometry > View Geometry > Options command.  If it is not annotated, select 
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Geometry > View Geometry > Vertical Annotation… (Figure 18-8). Verify your vertical 
Profile Set if you have multiples in the Profile.dgn file. You will see a rectangular outline 
around the profile set to be annotated. 

 
Figure 18-8: View Vertical Annotation 

Click Apply and Close to exit this dialog. There will still be a need to do some clean up 
through MicroStation tools to fit some of the data into the sheet drawings display area. 
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CREATING PLAN PAGES ONLY 
Step One: Open MicroStation 
To begin, double click your MicroStation V8i icon and select your project from the project 
pull down. Open any file. 

Step Two: Create Plans Only 
 Before you begin deactivate your Station Lock button on the Locks toolbar. 

From the InRoads Main Menu select Drafting > Plan and Profile Generator… Select the 
Preferences… button at the bottom and load Plan Only 25 scale. This will setup some of 
the settings automatically. 

 If you decide to use the 50 scale option you will need to adjust your Global Scale 
Factor and redisplay your annotation for the alignment and design drawings. 

 Part One: Plan Controls 
Place focus on the Plan Controls tab (Figure 18-9). Select the Model Files… button to the 
right and pick your workgroups source drawing file (i.e., HDPlan.dgn, BDPlan.dgn or etc.). 

 
Figure 18-9: Plan and Profile Generator-Plan Controls 

 Your source drawing file should have the standard files attached to it. At any time 
you can attach files to the source drawing and have them display within your plan 
pages. 

 Refer to 2-72 for more information on Reference Attachments. 

 Part Two: Sheet Layout 
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Place focus on the Sheet Layout tab (Figure 18-10). Press the ... button right of the Host 
File: location and select the same file as you did for your plan controls (i.e., HDPlan.dgn, 
BDPlan.dgn or etc.). 

  
Figure 18-10: Plan and Profile Generator-Sheet Layout 

 Part Three: Sheeting Drawings 
Click Apply at the bottom of the Plan and Profile Generator dialog to begin the sheet 
creation process. When the sheet creation process finalizes you will be left in the last sheet 
created. 

 Part Four: View the Results 
Select File > Open from MicroStation’s main menu and view the sheets (i.e., ??plan1.dgn).  

If you are satisfied with the sheet layout, then consider running the Sheet Renumbering 
Utility to place the 3 digit prefixed in front of the file names. Without the 3 digit prefix, the 
Border Information macro can’t be run to fill in the border information on each sheet.  

 For detailed instructions on using the Sheet Renumbering Utility, please refer to 1-62. 
 For detailed instructions on using the Border Information macro, please refer to 1-69. 
If you are not satisfied with the sheet layout, re-open the Plan and Profile Generator, 
select the Sheet Index tab and open the saved VDF file. Adjust the Plan View and Profile 
View stations or overlaps on the Main tab. 

 If you need to adjust any of the plan pages for layout you will need to reopen the Plan 
and Profile Generator dialog and adjust per Bentley InRoads help. 
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CREATING PROFILE PAGES ONLY 
Step One: Open MicroStation 
To begin, double click your MicroStation V8i icon and select your project from the project 
pull down. Open your Profile.dgn file. 

 If you do not have a Profile.dgn file then open another file and use the Make Sheetz 
program from the Main Menu to create the drawing file. 

Step Two: Create Profiles Only 
 Before you begin deactivate your Station Lock button on the Locks toolbar. 

From the InRoads Main Menu select Drafting > Plan and Profile Generator…. Select the 
Preferences… button at the bottom of the dialog and load Profile Only 25 scale. This will 
setup some of the settings automatically. 

 If you decide to use the 50 scale option you will need to adjust your Global Scale 
Factor before you create your drawings and then select Profile Only 50 scale. 

 Part One: Main 
In the Main tab select your alignment in the Horizontal Alignment: area and manage the 
start and stop limits of your project in the Station Limits area of the dialog box (Figure 
18-11). 

 
Figure 18-11: Main tab 
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 Part Two: Profile Controls 
Place focus on the Profile Controls tab (Figure 18-12). Select your Vertical Alignment: 
from the pull down and pick the existing and proposed surfaces for display. 

 Remember to also highlight the Surface names (using the Ctrl key) along with placing 
the X next to the surface names (i.e. Ground and Design). If this isn’t done you will 
get undesirable results in the way your grid will display with your profiles. 

 
Figure 18-12: Plan and Profile Generator-Profile Controls 

Click Apply and identify a location within your MicroStation Profile.dgn file. Fit the view 
to see the profile graphics. Next do an undo from either the Standard Toolbar or select Edit 
> Undo from the MicroStation Main Menu. 

 The undo is necessary to control the even 100 foot stationing when the project starts 
with an odd stationing. 

 Part Three: Main 
 Before you begin activate your Station Lock button on the Locks toolbar. 

Reselect the Main tab within the Plan and Profile Generator dialog (Figure 18-13). Set the 
Profile Views to Use Profile Views and turn on the Generate Sheets in the Sheets option. 

 

 

 

 

 

 



mdot MicroStation 

01/01/12 

Plan/Profile Sheet 
Development 

18-16 

 

 

 
Figure 18-13: Main tab Profile Controls 

 Part Four: Sheet Layout 
Place focus on the Sheet Layout tab (Figure 18-14). Press the ... button right of the Host 
File: location and select Profile.dgn from the active directory. 

 
Figure 18-14: Plan and Profile Generator-Sheet Layout 

Click Apply at the bottom of the Plan and Profile Generator dialog. Click Close and save 
your VDF file for future use. 
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 Part Five: View the Results 
Select File > Open from MicroStation’s main menu and view the sheets (i.e. Profile1.dgn).  

If you are satisfied with the sheet layout, then consider running the Sheet Renumbering 
Utility to place the 3 digit prefixed in front of the file names. Without the 3 digit prefix, the 
Border Information macro can’t be run to fill in the border information on each sheet.  

 For detailed instructions on using the Sheet Renumbering Utility, please refer to 1-62. 
 For detailed instructions on using the Border Information macro, please refer to 1-69. 
If you are not satisfied with the sheet layout, re-open the Plan and Profile Generator, 
select the Sheet Index tab and open the saved VDF file. Adjust the Profile View stations or 
overlaps on the Main tab. 

 If you need to adjust any of the profile pages for layout refer to Bentley InRoads help 
for sheet adjustments. 

Step Three: Annotating Profiles 
Reopen the Profile.dgn file that was created earlier. Fit view. 

 Part One: Label Proposed Elevations 
From the InRoads Main Menu select Evaluation > Profile > Annotate Profile… (Figure 
18-15). By default we are preset to label the elevations of the proposed vertical design. If 
you want to label the existing ground elevations also then select the Preferences… button 
and activate the Proposed and Existing Elevation option and close the dialog. 

Verify your vertical Profile Set if you have multiples in the Profile.dgn file, set your 
Vertical Alignment: to the vertical design, Surface: to the existing ground surface and 
select All under the station ranges listed in the Profiles: area. 

 
Figure 18-15: Annotate Profile 

Click Apply and Close to exit this dialog. 
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 Part Two: Label Vertical Annotation 
Normally, the Vertical alignment will already be automatically annotated based on the 
Geometry > View Geometry > Options command.  If it is not annotated, select Geometry 
> View Geometry > Vertical Annotation. (Figure 18-16). Verify your vertical Profile Set 
if you have multiples in the Profile.dgn file. You will see a rectangular outline around the 
profile set to be annotated. 

Verify your vertical Profile Set if you have multiples in the Profile.dgn file. You will see a 
rectangular outline around the profile set to be annotated. 

 
Figure 18-16: View Vertical Annotation 

Click Apply and Close to exit this dialog. There will still be a need to do some clean up 
through MicroStation tools to fit some of the data into the sheet drawings display area.
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OVERVIEW 
Prerequisites: 
• Ground.dtm file loaded in InRoads from Survey MSTA folder. 

• A horizontal and vertical alignment developed in InRoads. 

• A template design passed through your alignment. 

Global Scale Factor 
By default when you enter InRoads the Global Scale Factors are preset for plan scales at 25 
feet to the inch (i.e., 300 absolute scale) in the mdot_US_V8i.xin file. You can verify what 
your scales are set to by selecting from the InRoads Main Menu File > Project Options and 
select the Factors tab. You can also check Global Scale Factors if you add the separate 
dialog through Tools > Applications Add-ins… and select Global Scale Factors Add-In. 
This will give you the option to pick Tools > Global Scale Factors… and launch an 
independent dialog. 

The Scale Factors adjust sizing of your Text, Cell and Line Style placement within your 
Cross Section drawing set. MaineDOT has two standard scale sizes for Cross Section 
drawings those scales are 5 feet to the inch (60 absolute scale) and 10 feet to the inch (120 
absolute scale). 

Locks Toolbar 

 Feature Filter Lock 
Filter locks will aid in displaying what is necessary for the Cross Section presentation. From 
the InRoads Main Menu select Tools > Customize… and launch the Locks tool bar from 
the Toolbar tab (if it is not already docked within your InRoads platform). Turn the Feature 
Filter Lock on (button next to the pull down will be depressed when on) and select CROSS 
SECTION ANNOTATION from the pull down (Figure 20-1) when you are ready to 
display annotation within your Cross Section drawing set. 

 
Figure 20-1: Feature Filter lock with various predefined filters 
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 Station Lock 
The Station lock, which is the next to last lock located in the Locks toolbar plays an 
important role in cutting your cross sections at the even interval specified. The lock should 
be enabled during Cross Section creation. 

Event Stations 
Horizontal event stations can be created by the designer for additional sections at critical 
stations. These sections will be perpendicular to the alignment and will display with either 
method of developing cross section drawings. 

Select from the InRoads main menu Geometry > Horizontal Curve Set > Events… 
(Figure 20-2). 

 
Figure 20-2: Horizontal Events 

Set the Define By: to Single Station, the Add As to Northing and Easting, toggle on both 
Add Vertical Event Points and Compute Elevation from Active Vertical Alignment 
(Figure 20-3). 
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Figure 20-3: Horizontal Events – Settings 

Using the target selector in the Locate By area of the dialog start selecting areas graphically 
along the alignment each time selecting Apply to populate the bottom portion of the dialog 
(Figure 20-4). 

 
Figure 20-4: Horizontal Events - Events 

If there are event stations that are no longer valid to the project than highlight one or more 
and select the Delete button and click Yes when prompted. Also existing event stations can 
be edited by highlighting one and selecting Edit… to change relative information of that 
point (Figure 20-5). Remember to click Apply as data is changed. 
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Figure 20-5: Edit Horizontal Event 

When done Close the dialogs. 
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CREATE PRELIMINARY CROSS SECTION 
DRAWINGS 

Overview 
This set uses a constant interval between cross sections and is used for preliminary analysis. 
These could be stored in your current working dgn file or in the Xsect.dgn as explained 
below. Most projects will require special skewed stations which require using the Custom 
folder in the Create Cross Section dialog as explained further into this document. 

Step One: Open Microstation and InRoads  
To begin, double click your MicroStation V8i icon. By default the user is set to 
InRoads_network_V8i, if you are working in a local pin setup then you will want to 
change the user to InRoads_local_V8i. Select your project from the project pull down and 
open your workgroups ??plan.dgn (i.e., HDPlan.dgn or BDPlan.dgn.). Select Applications 
> InRoads Group > Activate InRoads from the Main Menus. Pick your projects *.rwk or 
load the necessary InRoads files for you project.  

Step Two: Create Cross Section Drawing File 
Select File > Make Sheetz from the MicroStation Main Menu. Select the no prefix option 
and press OK, select Xsect and press OK, press OK again in the next dialog and the 
program will create your Xsect.dgn file in the active directory and opens it for you. Click 
Cancel to exit the program. 

 Refer to page 1-57 for help making drawing files. 

Step Three: Create Cross Sections 
Select Evaluation > Cross Section > Cross Sections.. and click the Create Cross Section 
folder from the InRoads Main Menu (Figure 20-6).  
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Figure 20-6: Create Cross Section 

The default setting for cross section creation is setup for horizontal borders at 5 feet to the 
inch scale. There are other setups ready for you under the Preferences… button of the 
dialog (Figure 20-7). 

 
Figure 20-7: Preferences 

Select the preference by highlighting it and picking Load to the right of the dialog and 
Close. 
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Step Four: Global Scale Factor 
Depending on what you choose to display the cross sections at, you will need to set the 
Tools > Global Scale Factor before beginning (Figure 20-8) or go to File > Project 
Options and load the correct preference set (The example below would have used the XS 5 
scale preference.  If you choose to do 5 feet to the inch then set the scales as shown below or 
set the Text: and Line Style: scale to 120 for 10 feet to the inch. The Cell scale will stay set 
to 1 for either scale. 

 
Figure 20-8: Scale Factors 

Click Apply and Close the Scale Factors dialog. 

Step Five: Create Cross Section 
There are a lot of settings predefined for you in the Create Cross Section dialog. There are 
some items that need to be set before displaying them. To the left of the dialog is an explorer 
tree of settings. We will discuss the bare minimum to cut sections at 50 foot intervals. 

 For more information on this dialog refer to InRoads help. 

 Part One: General 
In the General area items have been preset for 50 foot intervals. You could choose to 
change the Interval: to 25 feet here. The only other thing is to select what Surfaces: you 
will want to display. 
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Figure 20-9: Create Cross Section General 

The figure above shows that we have Ground and Design selected for display in sections 
with an X indicating them being selected. If under the Name portion the symbology is set to 
Default then you will need to change this by selecting Properties… (Figure 20-10). 

 
Figure 20-10: Surface Properties 
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In the Advanced tab select the Ground surface and set the Cross Sections and Profiles 
Symbology to S_Roadway_Centerline and click Apply. Select your Design surface and set 
the Cross Sections and Profiles Symbology to D_Roadway_Centerline and click Apply. 
Close the dialog. 

 Part Two: Add Existing Right of Way 
In order to display the Existing Right of Way in your cross sections, you will have had to 
create an EROW surface. Include this surface to display it on your cross sections. 

 Part Three: Source 
The Source selection will be set to Alignment. By default this field will be populated by the 
active alignment. If this is not the alignment that sections are to be cut to then use the pull 
down to select your alignment (Figure 20-11). 

 
Figure 20-11: Create Cross Section Source 

This is the location where you could select Single Station to cut a particular section 
perpendicular to your centerline within a border. 

 Part Four: Include 
In the Include leaf there isn’t anything that needs to be set at this time. This is where we 
control how random point features get placed into the cross section drawings. 
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Figure 20-12: Create Cross Section Include 

 Part Five: Controls - Limits 
The Controls section by default is setup to cut sections along the whole alignment. In the 
Limits area you could limit the range of sections to display by toggling on Station and 
specifying a start and stop station (Figure 20-13). 

 
Figure 20-13: Create Cross Section Controls - Limits 

 Part Six: Controls – Critical Sections 
The Critical Sections leaf is setup by default to include Horizontal Event Points and 
Superelevation Event Stations you could choose to also include other critical sections here 
(Figure 20-14). 

 For more information on this dialog refer to InRoads help. 
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Figure 20-14: Create Cross Section Controls - Critical Sections 

 Part Seven: Controls – Plan Display 
The Plan Display leaf has been predefined to place the cross section drawings at a z 
elevation of zero. The Symbology portion could be toggled on to see the relationship of 
each section relative to the plan layout (Figure 20-15). 

 
Figure 20-15: Create Cross Section Controls - Plan Display 
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 The rest of the folders in the explorer tree have been predefined and there will be no 
need for the general user to have to make changes. Further in this document there 
will be a setup procedure of the Custom folder for cross section displays. 

Step Six: Click Apply 
Click Apply and you will prompted to Identify Location. Send a left mouse button (data 
click) anywhere in the view window of MicroStation. 

Step Seven: Clean Up (hold) 
All cell placements left of centerline will need to be mirrored to represent proper offset 
placement within the cross sections. You will wait to do this after you have annotated the 
existing features in the next step. 



mdot MicroStation 

01/01/12 

InRoads Cross Section 
Development 

20-15 

 

  CCRROOSSSS  SSEECCTTIIOONN  AANNNNOOTTAATTIIOONN  



mdot MicroStation 

01/01/12 

InRoads Cross Section 
Development 

20-16 

 

CROSS SECTION ANNOTATION 
Step One: Existing Annotation 

 Refer to the Global Scale Factor and Project Options in the overview to ensure 
correct annotation scale. 

Select Evaluation > Cross Section > Cross Sections… and click the Annotate Cross 
Section folder from the InRoads Main Menu. 

Select the Preferences button and load the EXISTING preference by double clicking it or 
highlighting it and selecting Load (Figure 20-16). 

 
Figure 20-16: Preferences - Annotate Cross Section 

Close the dialog. 

Set the filter lock to CROSS SECTION ANNOTATION (Figure 20-17). 

 
Figure 20-17: Filter Lock Cross Sections 

 Part One: General 
If there are multiple sets of cross sections in the file then verify what Cross Section Set: that 
is intended to be annotated by using the pull down or selecting the cross section set 
graphically with the target selector (Figure 20-18).  

Select your Ground surface with an X. 
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Figure 20-18: Annotate Cross Section - General 

 Part Two: Features 
Select the Features folder in the explorer tree and highlight the Annotate leaf (Figure 
20-19). Right click on any Feature in the Feature: list area and pick Select All. 

 
Figure 20-19: Annotate Cross Section – Features 

Click Apply. 

 There will be a need to do some clean up of the annotation, removal of commas, 
changing all the Rt. to Lt. on the left side of the cross section set and any other 
incidental cleanup for plan presentation. 
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Step Two: Proposed Annotation 
Select the Preferences button and load the DESIGN preference by double clicking it or 
highlighting it and selecting Load (Figure 20-20). 

 
Figure 20-20: Preferences – Design 

 Part One: General 
Select your Design surface with an X. 

 
Figure 20-21: Annotate Cross Section - General Design 

 Part Two: Points 
The Points folder has been turned on for the design preference. This folder establishes 
standards for labeling the centerline station elevation. The general user does not need to 
change things here.  

 Part Three: Segments 
The Segments folder has been turned on with the design preference. This folder establishes 
standards for labeling cross slope percents and side slope ratios. The general user does not 
need to change things here.  

 Part Four: Features 
Select the Features folder in the explorer tree and highlight Annotate. Right click in the 
Feature: area and Select All.  Click Apply.  
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 There will be a need to do some clean up of the design annotation for plan 
presentation. 

Step Three: Existing ROW Annotation 
Select the Preferences button and load the EROW preference by double clicking it or 
highlighting it and selecting Load (Figure 20-22). 

 
Figure 20-22: Preferences - EROW 

 Part One: General 
Select the EROW surface with an X. 

 

 Part Two: Features 
Expand the Features folder and select Annotate. Right click on the features in the Feature 
portion of the dialog and Select All (Figure 20-23). 
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Figure 20-23: Select all of the Features for EROW 

Click Apply. 

Step Four: Edit Left Side of Cross Sections 
All cell placements left of centerline will need to be mirrored to represent proper offset 
placement within the cross sections and all annotation for existing features will need to be 
cleaned up to remove the negative value and change the RT. to LT. 

Select Macros > Edit Left Side X Sections from the MicroStation Main Menu. This will 
launch a VBA that will mirror all existing cells placed on the left side of each cross section 
sheet and will fix the annotation for the left side as well. 

 If you have run this program before annotating you will have to run it again to fix the 
text and one more time to readjust the cells. 
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OVERVIEW 
Custom sections will probably be the way a designer will want to manage the cross section 
set of drawings in the long run. This method allows for multiple ways of controlling what 
sections are necessary for display throughout the project. Custom Sections does look at 
Controls > Critical Sections… in development of the cross section drawings but does not 
look at the General information for standard intervals and offsets but does look at what 
Surfaces: are to be displayed. 

 Refer to Step Five: Part One for General settings. 

 If you already saved Custom Cross Sections while designing your driveways, select 
the Import button and import your custom sections. 
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STATION RANGE 
Step One: Type 
If necessary, re-open the Create Cross Sections tool (Evaluation > Cross Section > Cross 
Sections… and click the Create Cross Section folder). Make sure you select the Custom 
folder.  There are a few settings that need to be set before clicking the Add button. Set the 
Type: to Station Range. 

Step Two: Details 
In the Details area of the dialog you can set the Start and Stop Station: if the project limits 
are different than the length of alignment developed. 

The Interval: area will need to be set to desired section cuts (Figure 20-24). In this example 
we will set it to 50 foot intervals. 

 
Figure 20-24: Create Cross Section - Custom – General 

Depending on what preference was selected will determine the Left and Right Offset: 
(Figure 20-25). Refer to Create Cross Section > General leaf of this dialog to see what the 
offsets are and use those values here. Remember to use a negative value for the Left Offset. 
The Skew Angle: will be set at 0 degrees to maintain perpendicular section cuts along the 
alignment. 

 
Figure 20-25: Create Cross Section - Custom – Station Range and Offsets 
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Step Three: Features 
In the Features area toggle on both Crossing and Projected and set the Ahead Band and 
Back Band to half the value of the Interval: value used. In this case we used 50 foot 
intervals so we will set these values to 25 (Figure 20-26). 

Click the Add button to populate the Station/Type area. 

 
Figure 20-26: Create Cross Section - Custom – Features 

 At any time adjustments can be made to the preset values by highlighting the entry in 
the Station/Type area, make the necessary changes and clicking the Update button. 
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PERPENDICULAR 
Overview 
Horizontal Event stations could be used to cut special sections perpendicular to the 
alignment but it takes on the general offsets of the Station Range and does not allow 
management of the left and right offset values. The Perpendicular option in the Custom area 
does allow for manipulation of the left and right offsets. 

Step One: Type 
Set the Type: to Perpendicular. 

Step Two: Details 

 Part One: Station 
In the Details area you can type the station you want or use the picker to graphically select 
the station within the view window. 

 Part Two: Left and Right Offset 
Depending on what preference was selected will determine the Left and Right Offset: 
(Figure 20-27). Refer to Create Cross Section > General leaf of this dialog to see what the 
offsets are and use those values here. Remember to use a negative value for the Left Offset. 
Also, enable the Crossing and Projected Features and use the bandwidth if necessary. 

 Part Three: Add 
Click the Add button to populate the Station/Type area. 

 
Figure 20-27: Create Cross Section - Custom - Perpendicular 

 The offsets shown in Figure 20-27 are for a full section matching the standard left 
and right offsets of the Station Range. If there is a need to have more of a section to 
the right of centerline the values could be adjusted to reflect the need. For example if 
the Right Offset: needed to be 100 feet then the Left Offset: would need to be set to 
-40 feet giving a total distance of 140 feet. 
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SKEWED STATIONS 
Step One: Type 
Set the Type: to Skewed. 

Step Two: Details 

 Part One: Station 
In the Details area you can type the station you want or use the picker to graphically select 
the station within the view window. If there is a feature crossing the alignment then use the 
MicroStation intersection snap to get the exact station. 

 Part Two: Left and Right Offset 
Depending on what preference was selected will determine the Left and Right Offset:. 
Refer to Create Cross Section > General leaf of this dialog to see what the offsets are and 
use those values here. Remember to use a negative value for the Left Offset.  Also, enable 
the Crossing and Projected Features and use the bandwidth if necessary. 

 Part Three: Skew Angle 
 All skewed stations by default will be skewed back right. If you want a skewed back 

left section you must place a negative sign in front of the angle measured and 
InRoads will translate the appropriate angle. 

From the Tasks Menus, select your Workgroup > Plan > Symbols & Linestyles > Junk 
Lines tool.  

 
Place a line along the crossing feature (Figure 20-28) you would want sectioned at a skew 
(i.e., crossing pipe). 
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Figure 20-28: Junk Line along Crossing Feature 

On Alignment Tangent (Option 1) 
Using the Place SmartLine tool in conjunction with the perpendicular snap place a 
perpendicular line (Figure 20-29) near the other junk line placed earlier for the crossing 
feature. 

 
Figure 20-29: Perpendicular Junk Line 

From the Tasks Menus, select Drawing > Measure Angle and follow the prompts in the 
lower left corner of MicroStation to measure the angle. 

On Alignment Tangent (Option 2): 
Using the Place SmartLine tool place a perpendicular line starting from the intersection of 
the structure and centerline out to a random point. 

 Hint: with AccuDraw having focus use the “I” for intersection, “O” to set 
AccuDraw's origin, “RQ” to rotate AccuDraw’s compass, “N” for a nearest point on 
alignment and “Enter” to lock the compass. Place the line. 

Measure the angle and highlight the resulting angle (Figure 20-30) to Copy and Paste it into 
the Skew Angle: area of the Custom Details area. 

 
Figure 20-30: Measure Angle between Lines 
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On a Radius: 
Using the Junk Lines tool, place a line from the intersection of the alignment and crossing 
feature to the center of the arc. 

 Hint: with AccuDraw having focus use the “I” for intersection and the “C” for center 
and tentative snap to the arc and accept. 

 For more on using AccuDraw refer to page 2-45. 
Highlight the resulting angle (Figure 20-30) to Copy and Paste it into the Skew Angle: area 
of the Custom Details area. 

Click the Add button to populate the Station/Type area. 

 
Figure 20-31: Create Cross Section – Custom – Skewed 



mdot MicroStation 

01/01/12 

InRoads Cross Section 
Development 

20-29 

 

LINE STRING STATIONS 
Overview: 
A line string is an element that has a start and end point and also has one or more vertices 
within it. You could use a straight line with this option and InRoads will consider it a 
skewed section and place it in the dialog. One use for Line string sections would be for the 
centerline driveway alignments. 

Step One: Type 
Set the Type: to Linestring. 

Step Two: Station/Type 
Using the MicroStation Element Selection tool, pick the line strings (Figure 20-32) drawn 
perpendicular from centerline out to the apron and through the driveway. 

 
Figure 20-32: Driveway Centerline Line Strings 

Having a selection set picked within MicroStation will allow the Graphics button in the 
Custom folder of the Create Cross Section dialog box to be used. Select the Graphics 
button (Figure 20-33) to populate the Station/Type area of the dialog. 

If the Graphics button is still grayed out, select Linestring one more time (basically the 
Element Selection tool needs used first). 
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Figure 20-33: Create Cross Section – Custom – Line String 

If you highlight one of the line strings within the Station/Type area of the dialog (Figure 
20-34) you will be able to see the details relative to centerline to the right. 

 
Figure 20-34: Line String Details 

If the overall measurement of the Left and Right Offset values exceed that of the Station 
Range offset value total then you should shorten the overall length of the line string (i.e., 
140 foot maximum length for 5 foot horizontal sheets). 

 If you need to remove a station in the list simply highlight the station and press the 
Delete key on your keyboard. 

When done setting up your Custom Sections click on the Save button.  Name the *.xsc for 
future retrieval by using the Import button on the Custom tool in a future session of 
InRoads. 

Step Three: Annotation 
 Refer back to Annotation portion of this chapter to apply annotation and running the 

Macro application to fix the left sides of your cross section set. 
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CREATING SINGLE CROSS SECTION FILES 
Overview: 
By default InRoads places all cross sections within the same file. For efficiency purposes to 
utilize resources within your team we have created a method to build individual files of each 
cross section drawing page. These are a copy of the originals and are not linked to the 
master file. 

Creating Single Cross Section Files 
Select Macros > Create Single Sheet Cross Section from the MicroStation Main Menu. 
This will launch a tool that will prompt you for a Starting Page Number (Figure 20-35). 

 
Figure 20-35: Starting Page Number 

Determine what number you would like to start with and press OK. 

The program will loop through all sections placed in the master file based on the priority 
they were placed in the file and create fence file drawings with a prefix number, a root name 
of XSECT, the first identifiable section on each sheet and an incremental suffix for total 
number of cross section sheets. For example the file name would look like this: 
020_XSECT_5+00_001.dgn. 

You can now process the border information onto each of the drawings through our normal 
process once these drawings are created. This will turn off the appropriate levels based on 
what workgroup you belong to, it will fit the view and a Save Settings will be done as it 
loops through the files. 

 For more on Border Information please refer to page 1-69. 
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DISPLAY VOLUMES ON SECTIONS 
Overview 
The End Area Volumes are based on the closed components of the Templates. If these 
Components are manipulated in the Cross Sections, their end area volume will adjust 
accordingly. The Components have been named appropriately so that like items will be 
quantified together and eventually quantified with the InRoads Quantity Manager.  
Some volumes may need manual adjustments to better represent the item estimated. For 
example, pavement or base pavement layers may consist of multiple items that need to be 
broken out separately. 

For more accurate volumes, it may be necessary to add additional cross sections at certain 
stations in order to capture the best representation of the surface and sub-surface conditions 
(i.e., Guardrail widening areas). 

Step One: Basic End Area Volumes 
Select Evaluation > Cross Section > Cross Sections… and click the End-Area Volumes 
folder to get the following menu (Figure 20-36). 

  
Figure 20-36: End Area Volume menu. 

Step Two: Setup the Dialog’s General Tab 
Verify that the active Cross Section Set is set to the Cross Sections you want to create 
volumes from and your Ground and Design surfaces are selected. Place a check mark in the 
Create XML Report check box. If the project has a lot of curves in it, place a dot in the 
Correct for Curvature radio button (Figure 20-37).  
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Figure 20-37: End-Area Volumes General tab dialog. 

Step Three: Click Apply 
Verify that the Global Scale Factors are set correctly for Cross Section display (Tools > 
Global Scale Factors = 60, 1 and 60). The remainder of the settings have been set for you. 
This is assuming that you want text placed on cross sections of Cut and Fill Quantities. Click 
Apply and then Close. 

View End Area Volume Report 
Select which End Area Volume style sheet you want (i.e., EndAreaVolumePageTotals.xsl). 
One option would be to right click on the report and select Export to Microsoft Excel and 
include only the columns you want to display for your estimate.  The preferred option is to 
select File > Save As, then save the report directly to an Excel or Word file because the 
formatting will also be part of the new document. 

Other Volumes 
Switch the Style Sheet to Volumes.xsl (or RoadwayDesignerComponentQuantities 
Summary Report.xsl) to view the volumes of all the other closed components. They are 
listed by their Styles. If areas are required for the item you want to estimate, create the Excel 
(or Word) document and manipulate the report to the desired output. 



mdot MicroStation 

01/01/12 

InRoads Cross Section 
Development 

20-35 

 

Other Adjustments 
There are many other adjustments that can be made and quantities calculated. Please refer to 
InRoads Help for a dialog that you want help with. 

• Unsuitable Materials (by Feature or Station) – This could be used to 
determine Muck Excavation, Loam Salvage, Pavement Salvage and Waste 
Storage Areas.  

• Classifications – This can be used to identify other surfaces such as Rock or 
Structural Rock Excavation. 

• Compaction/Expansion – This can be used to add the factors for Cut (1.15) 
and Fill (0.85) but normally this is calculated within the Summary of 
Excavation and Borrow. 

• Volume Exceptions – Allows you to deduct a station range from the End 
Area Volumes to be calculated manually. 

• Added Quantities – Allows you to add additional cut or fill using a station 
range. 

• Forced Balance – Allows you to reset the cut or fill values to zero at a 
specific station. 

• As Built – Requires that you have an As Built surface to include. 

• Annotation – This is where you set up what you want annotated as well as 
adding color to the cut and fill shapes. 

Volumes for Driveways 
In order to get better volumes for driveways, consider creating a cross section set that has a 
section at the start and stop for every drive. This way the averaging may give more accurate 
results.
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OVERVIEW 
Design Prerequisites: 
• Existing Survey – Ground.dtm 

• Horizontal and Vertical Alignment 

Station Lock 
The station lock on the Locks toolbar is very important when establishing even stationing on 
reports. For example if the lock is not on and you report every 25 feet and have an odd start 
station then it will increment 25 feet from that station giving you odd stationing throughout 
the report.  
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CREATE ELEVATION DIFFERENCE REPORT 
Step One: Open InRoads Suite V8i 
To begin, double click your MicroStation V8i icon. By default the user is set to 
InRoads_network_V8i, if you are working in a local pin setup then you will want to 
change the user to InRoads_local_V8i. Select Applications > InRoads Group > Activate 
InRoads from the Main Menus. Select your project from the project pull down and open 
your workgroups ??plan.dgn (i.e., HDPlan.dgn or BDPlan.dgn.). 

Step Two: Load Your Project 
Load your project by opening the saved RWK file or open the surfaces and geometry 
project that have been saved. 

 Refer to page 13-25 for more information on managing your RWK. 

Step Three: Settings for Elevation Difference Report 
From the InRoads Main Menu select Tools > XML Reports > Station Base... 

 Part One: General Settings 
Select General on the left side of the dialog box (Figure 21-1). 

  
Figure 21-1: Station Base Report General 

There are a couple of different settings in this area, for basic reporting of elevation 
difference you will need to establish what alignment you want to report from. On the right 
side of the dialog select the radio button for Horizontal Alignment: in the From area and 
select your alignment from the pull down arrow or use the cross hair to graphically select the 
alignment in MicroStation. 

The Limits area on the right will allow you to control the station range for the report. This 
report is for the full station range of the vertical alignment so we will leave this unselected. 

 Part Two: Include Settings 
Select Include on the left side of the dialog box (Figure 21-2). 
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Figure 21-2: Station Base Report Include 

On the top there are some options to include in the report. If you want to include PC, PT, 
PVC and PVT points in the report select the On-Alignment options of Horizontal/Vertical 
Points. If you want to include event points that you have indicated along your alignment in 
the report then select the Event options of Horizontal/Vertical Points. 

Select the Interval: option and place a value in the box next to it. This is the station interval 
that will be on the report. 

 Part Three: Horizontal Alignments 
Select Horizontal Alignments on the left side of the dialog box (Figure 21-3). 

 
Figure 21-3: Station Base Horizontal Alignments 

There are a couple of ways to select your alignment. Place focus in the Include: area on the 
right side of the dialog, select the Filter… button, select your alignment in the Geometry 
Selection Filter dialog at the left, press the Add-> button to select it to the right and press 
OK or use the cross hairs and graphically select your alignment in MicroStation. 

 Part Four: Features 
Select Features on the left side of the dialog box (Figure 21-4). 
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Figure 21-4: Station Base Features 

In the Surface: area to the right, select your Ground surface but do not select any features.  

 If you wanted reporting relative to a feature here is where you would select this. 

Step Four: Creating Report 
Click Apply to create the report. The Bentley Civil Report Browser will display for you a 
default report of StationOffset.xsl.  Select the ProfileExistingProposedElevation.xsl to see 
your elevations and cut/fill depths along centerline. 

Select File > Save As.. from the Bentley Civil Report Browser menu and save your reports 
(Excel or Word) to your project location on the network. 
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OVERVIEW 
This is a custom report for MaineDOT, therefore you might need to run the MicroStation/ 
InRoads Update Utility V8i to make it available as it wasn’t delivered with the original 
InRoads install. 

 Refer to page 3-10 for information on using the Update Utility. Place a check in 
the last option to Installs/Updates InRoads Style Sheets. 

Design Prerequisites: 
• Existing Survey – Ground.dtm 

• Horizontal and Vertical Alignment 

 The report is designed to display the description of the features based on the Survey 
Notes established in the field. This will only be available if the Survey was fully 
edited within InRoads. 



mdot MicroStation 
01/01/12 

InRoads XML Reports 

21-9 

 

CREATE STATION AND OFFSET REPORT 
Step One: Open InRoads Suite V8i 
To begin, double click your MicroSttaion  V8i icon. By default the user is set to 
InRoads_network_V8i, if you are working in a local pin setup then you will want to 
change the user to InRoads_local_V8i. Select Applications > InRoads Group > Activate 
InRoads from the Main Menus. Select your project from the project pull down and open 
your workgroups ??plan.dgn (i.e., HDPlan.dgn or BDPlan.dgn.). 

Step Two: Load Your Project 
Load your project by opening the saved RWK file or open the surfaces and geometry 
project that have been saved. 

 Refer to page 13-25 for more information on managing your RWK. 

Step Three: Settings for Clearance Report 
From the InRoads Main Menu select Tools > XML Reports > Clearance... 

 This step uses the Clearance tool at first, but the final report is in essence a Station 
and Offset arrangement.  The customized MaineDOT style sheet (.xsl) is needed in 
the step below as the default report can’t be used since the description column won’t 
be available.  

 Part One: General Settings 
Select General on the left side of the dialog box (Figure 21-5). 

 
Figure 21-5: Clearance Report General 

On the right side of the dialog select the radio button for Horizontal Alignment: in the 
From area and select your alignment from the pull down arrow or use the cross hair to 
graphically select the alignment in MicroStation. 

 Part Two: Features 
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Select Features on the left side of the dialog box (Figure 21-6). 

 
Figure 21-6: Clearance Report Features 

In the Surface: area to the right, select your Ground surface. Now select the feature in the 
surface you wish to report on (i.e., S_Utilities_Pole_JointDNC). 

 In the future, there will be Filters developed of all the common features that are 
typically reported on. 

Step Four: Creating Report 
Click Apply to create the report. The Bentley Civil Report Browser will display the default 
Clearance Report for you. On the left side, in the Clearance folder, select MaineDOT 
StationOffset.xsl.  
Select File > Save As… from the Bentley Civil Report Browser menu and save your report 
to your project location on the network. 



mdot MicroStation 
01/01/12 

InRoads XML Reports 

21-11 

 

  VVOOLLUUMMEE  RREEPPOORRTTSS  



mdot MicroStation 
01/01/12 

InRoads XML Reports 

21-12 

 

TRIANGLE VOLUMES 
Overview 
This is a perfect method for computing ledge volumes from a surveyed ledge surface to the 
subgrade surface of the design or stock piles and pit calculations.  

Step One: Activate Report 
Select Evaluation > Volumes > Triangle Volume… from the InRoads main menu. 

Step Two: Setup Dialog 
Set the Mode to the desired method. Entire surface will compare the two surfaces where they 
have common coverage (Figure 21-7). If the edges of the two surfaces do not touch, a 
vertical line will represent the connection and volumes are produced within this boundary. 
Other methods are self explanatory. 

 
Figure 21-7: Set Mode to desired method 

Set the Original Surface to Ledge or the top most surface you are comparing. Set the Design 
Surface to Subgrade and the bottom most surface. Click Add. Consider adding the Design 
surface as a Design Surface as well in the event that ditching encounters ledge as well. Add 
these quantities together (Figure 21-8). Click Apply and then Close. 

 
Figure 21-8: Ledge and Subgrade surfaces as well as Ledge and Design 

This calculation may take a while. You may get a warning that you do not have a Style Sheet 
assigned to the Triangle Volume reporting. Click OK and browse to the Evaluation > 
TriangleVolumes.xls report. Right click and set it as the Default Triangle Volume report if 
desired. View results. 
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END AREA VOLUMES 
Step One: Activate Report 
Select Evaluation > Cross Section > Cross Sections… and click the End-Area Volumes 
folder from the InRoads Main Menu.  

Step Two: Setup Dialog 
Adjust the Surfaces you are calculating and place a check box in the Create XML Report 
check box (Figure 21-9). Click Apply and then Close. 

  
Figure 21-9: End Area Volumes dialog. 

 Refer to page 20-32 for more information about End Area Volume Reports.
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CONSTRUCT STATION AND OFFSET 
The F12 key runs a customized macro that is going to make it possible for us to construct 
points at a specific distance along an existing alignment. From these points, we’ll be able to 
draw a line perpendicular to the alignment at a specific distance. 

Starting Point 
Run the Pointalong macro by hitting your F12 key. You will be prompted to “Identify Point 
to Construct Distance From.” (Figure 22-1)  

 
Figure 22-1: Start Point Along Status Prompts 

The Macro is expecting a data point on your “alignment.” Note that you can construct 
distances along many different kinds of elements: arcs, lines, line strings and complex 
chains and shapes are all legitimate elements to construct a distance along. This will let you 
construct distances along baselines, ROW lines, property lines, etc. 

You are quite possibly going to be entering this start point based on an intersection of 
another line with your alignment. For instance, you may want to construct a Plus and Offset 
starting at the intersection of a tick mark with a baseline.  

Entering the Distance and Direction 
Once you’ve entered a data point telling the macro the start point, it will prompt you to 
“Enter Distance Along Element.” (Figure 22-2)  

 
Figure 22-2: Input Distance 

If you were trying to construct Station 1+35.240 from a tick mark at Station 1+20.000, the 
distance to construct would be 15.240. Enter in your desired value and press the OK button. 

Choosing the Direction 
This next step is very important. The macro isn’t smart enough to know whether or not you 
want to construct a point to the left or to the right of the point that you just chose. Look 
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down in your Status Bar to see that the macro is now prompting you to “Identify Direction 
for Construction.” (Figure 22-3)  

 
Figure 22-3: Status Bar Message 

What it is asking for is a data point either to the left or to the right, or, in the case of a 
vertical line, above or below the first point you entered. Put your cursor on the baseline near 
the first point, but clearly to one side or the other (Figure 22-4) and enter in a data point (left 
button). There is no need to snap to enter this point.  

 
Figure 22-4: Identify Direction for Construction 

When you enter a data point, MicroStation will start drawing a line at the specified offset 
and direction from the first point you entered (Figure 22-5).  

 
Figure 22-5: Point Constructed 

It will also put the AccuDraw compass on the line, rotated to make it easy for you to 
construct a line perpendicular to your baseline. 

Choosing the Offset Distance 
Now that we are drawing a line, we can choose to go either to the right or to the left of the 
baseline. Just put your cursor graphically near where you want the line to go. Keep your 
cursor near the axes of AccuDraw and it will ensure that you are drawing perpendicular to 
the baseline. 

Enter your Offset into the Distance field of your AccuDraw window (Figure 22-6).  
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Figure 22-6: Constructing a Distance off the Baseline 

Notice that the angle is 90°. Enter a Data Point to complete the command. Reset to stop 
drawing lines and press F12 to start again! 

Troubleshooting 
There is a Warning Dialog (Figure 22-7) that you will get from time to time when you 
construct distances using this macro.  

 
Figure 22-7: Pointalong Warning Dialog 

It lets you know that the point you are trying to construct cannot be constructed because 
your Element is too short. This could happen for a couple of reasons. 

1) You may have just chosen the wrong direction to construct from. Your baseline may run 
16 kilometers to the right and only 16 centimeters to the left of your offset point. You can’t 
construct a point 10 meters to the left of that first point. 

2) You may have picked the wrong element to construct the distance along. Choose the 
point again and make sure that you Accept only the element you want to construct along.  

3) You may have used the Drop Element tool to drop Complex Status of the baseline. This 
would have broken up the lines and arcs that are joined together in a “complex chain” of a 
baseline, leaving only individual lines and arcs. The resulting elements are much shorter 
than a typical baseline.  

You can put dropped baselines back together using the Create Complex Chain tool. Set your 
method in the Tool Settings Window to Automatic. 

 Refer to 2-12 for using the Complex Chain Tool  
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4) You may be confusing Metric and English units. Make sure you’re not trying to go 75 
feet along a 40-meter line. MicroStation reads that “75” distance as 75 meters if you’re 
working in a metric drawing.  
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CREATING ROW PLAN SHEETS 
Step One: Open RWPLAN-clips.dgn 
Select your project from the list of projects in the Project pull down at the bottom of the 
File Open.  

Select RWPLAN-clips.dgn from the list of files on the left and press OK. If the 
RWPLAN-clips.dgn does not exist the file will have to be created. Open the RWPlan.dgn. 

Select: File > Make Sheetz click on no prefix (Figure 22-8) and click OK. 

 
Figure 22-8: File Prefix Dialog  

Choose RWPlan-Clips (Figure 22-9) and click OK in the Create File Of Type… Dialog. 

 
Figure 22-9: Create File Of Type Dialog 

Click OK in the Make File Dialog (Figure 22-10). 

 
Figure 22-10: Make File Dialog 

Click Cancel in the File Prefix Dialog to exit the Make Sheetz program. 
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In the RWPlan-clips.dgn look in the Reference Dialog (Figure 22-11) to confirm the 
attached Reference Files. 

Select: Files > Reference (DOT) > Dialog  

 
Figure 22-11: Reference File Dialog 

 This dialog already shows that you have topo, text, bridge, highway, etc. files 
attached. If these files are not attached or other files are needed, refer to page 2-72 
for Reference Attach Methods.  

Step Two: Cut Sheets 

 Introduction 
At this stage we are going to be placing rectangles along the alignment that will correspond 
to our sheets. We will be using the Tasks Menus to accomplish this.  If the desired Task 
Menu is not available on the left side of your MicroStation file, select the correct workgroup 
from the Maine DOT WorkGroups drop-down (i.e., Maine DOT WorkGroups > Right of 
Way). 

 Part One: Set Category Scale 
From the Main Menu, select Settings > Drawing Scale.  Select the intended plot scale for 
the plan sheets (i.e. 1 in. = 25 ft. or 1 in. = 50 ft. (1:250 or 1:500 for metric projects)). 

 You should be the same scale that other programs are using for the project. When 
Survey Editors create the topo and text for the projects, this governs the scale.  

 Part Two: Place Clip Boundaries 
From the Tasks Menus, select your Workgroup > Right of Way > Borders > Clip 
Boundary. This selects our sheet boundary cell and activates a cell placement command 
that will make it easy to place a bunch of these rectangles along the alignment.  

Notice the box on the end of your cursor. When you send a Datapoint to MicroStation, the 
box will be placed at that location. (You might want to set your snap mode to Nearest and 
snap to the centerline of road.) The box you just placed will immediately begin to rotate by 
the origin point (the point you just entered.) Move your mouse around and notice how it 
spins. When it is aligned with the roadway, enter another Datapoint (again, you might want 
to Nearest snap to the centerline) and it will immediately prompt you to place the next 
boundary.  
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Don’t worry if they’re not in exactly the right place -- you can go back and clean up any 
mess later by using the move and rotate tools. It is important, however, that you place these 
boundaries in the order that you want your sheets to be numbered. We have a routine that 
automatically creates plot drawing files for us, and it will number them in the same order 
that you place these clip boundaries. 

Step Three: Make new Plan Files 
From the Tasks Menus, select your Workgroup > Right of Way > Tools > Plan File 
Maker. This macro is doing a number of things. First off, it is creating saved views in 
RWPlan-clip.dgn that are aligned with the clip boundaries we just placed. It asks you what 
number you want to use for the starting number of the ROW plan sheets. If you know where 
the sheets will fall in your plan set, enter this number here. The default will be “1”. If you 
don’t know yet where they will fall, use the default and we will utilize the Sheet 
Renumbering routine to organize the files outside of MicroStation. 

When you have finished, the program will drop you back into rwplan-clips.dgn. Open up the 
files you’ve just created and see how they look! 

 Refer to page 1-62 about the Sheet Renumbering Utility. 
 Refer to page 1-67 about PCF editing. 
 Refer to page 1-69 about the Border information macro. 
 Refer to page 1-72 about disabling the Borderinfo Substitution. 

 Troubleshooting 
This macro has very specific expectations, and anything different about your input has the 
potential of giving you bad output.  

It can only sheet up files in the order that the clip boundaries were placed in the file. If you 
need to add sheets at the beginning of the project, it might be easier to delete all your clip 
boundary cells that you placed and start again from scratch. 
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CREATING ROW INFORMATION PLAN 
Overview 
As a new requirement Right-of-Way Mappers will be required to generate a 
001_RWCoordinates.dgn file which contains control information for a project. This will 
require communication with the Project Designer/Technician to receive the necessary file 
to read into the dgn. 

Step One: Creating 001_RWCoordinates.dgn 
From the main menu select File > Make Sheetz. Leave the dialog toggled to Sheet Number 
and select OK (Figure 22-12). 

 
Figure 22-12: File Prefix Dialog 

Choose RWCoordinates (Figure 22-13) and click OK. 

 
Figure 22-13: Create File of Type… Dialog 

Click OK in the Make File Dialog (Figure 22-14). 

 
Figure 22-14: Make File Dialog 
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Now that the file is created select Cancel to end the process of creating files. 

Step Two: Placing Coordinate Information 
From the Tasks Menus, select your Workgroup > Right of Way > Tools > Create ROW 
Coordinate Info. (Figure 22-15). 

 
Figure 22-15: Right-of-Way Tasks 

The information will be developed on the sheet drawing automatically if the file is found. 
The program also looks for any overrun of information and will create, if necessary, a 
second drawing to finish the process. 

 This program was created to look for a RWInformation.txt file created in the 
MX/Reports folder of the specific work group. (i.e. Bridge or Highway) If the 
program cannot locate the file you will receive a message stating you need to talk to 
the Project Designer. They are required to run a program within MX called 
MaineDOT Right of Way Sheet to generate this file. 

 Refer to page 1-62 about the Sheet Renumbering Utility. 
 Refer to page 1-67 about PCF editing. 
 Refer to page 1-69 about the Border information macro. 
 Refer to page 1-72 about disabling the Borderinfo Substitution. 
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CONSTRUCT A METES AND BOUNDS 
DESCRIPTION 

You will use this routine to construct county layouts and surveys. When you need to 
construct a Metes and Bounds, below are the primary things you need to bear in mind. 

Tools 
You're going to be using SmartLine and AccuDraw. Make sure that you are in Bearing 
mode by hitting your F9 function key. 

Setup 
First off, make sure you're in a Top View.  
Choose Rotate View icon from the tools at the top of your View 1 - Top Window (Figure 
22-16).  

 
Figure 22-16: Rotate View Dialog 

Look at your Tool Settings Dialog and make sure you have Top selected as your rotation 
Method (Figure 22-17).  

 
Figure 22-17: View Rotation Top Dialog 

Enter a Data Point to begin your line, then type your bearing and distance into the 
AccuDraw Dialog. Make sure you are in Distance/Angle mode. Hit your Spacebar if you 
aren't (Figure 22-18). 

 
Figure 22-18: Toggle AccuDraw Mode Dialog 
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Placing Lines 
As you go, your AccuDraw Compass is going to rotate to align with line that is being 
placed.  

 You have to make sure that it is always rotated back to horizontal between every 
segment: type V with active AccuDraw to rotate the Compass to the view (Figure 
22-19). 

 
Figure 22-19: Rotate AccuDraw to the View 

For More Information 
 Check page 22-17 for more information on working with Baselines. 

Offset Using Copy Parallel 
Once your line is constructed, you're going to want to offset the line by some distance. Use 
the Move Parallel tool from the Manipulate Tasks (Figure 22-20). 

 
Figure 22-20: Move/Copy Parallel Dialog 

In your Tool Settings Window, make sure that Distance and Make Copy are turned on. 
Type the offset distance into the Distance field and identify the element you want to copy 
by Data Pointing on it. Move your mouse and watch the line pop back and forth to either 
side of your original line. Once it is displaying on the proper side, Data Point again to 
accept the final location. Reset to complete. 

Fitting the Layout 
Once the layout has been constructed, you're going to need to rotate and move it into place 
over the survey information. There are only a couple steps to this process. 
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First, use the Element Selection tool to pick all the elements in your layout (Figure 22-21).  

 
Figure 22-21: Pick the Elements in your Layout 

Snap (but do not Accept) to your layout at the point you want to pick it up from.  

Second, choose Edit > Cut (Ctrl+X) from your Main Menu. 

Now, choose Edit > Paste (Ctrl+V) from your Main Menu. You should see your layout 
hovering over your drawing, hanging off your cursor from the point you gave it in step one 
(Figure 22-22). 

 
Figure 22-22: Paste your Layout Down 

Look at your Tool Settings Window, be sure that your Scales are all set to 1 (otherwise, 
your layout will be made bigger or smaller.) Change the Angle field and move your layout 
around until you get a good fit. Data Point to place the layout in your drawing. 

Fine Tuning 
If you want to make changes to individual components of your layout after you've got it into 
place, use the Modify Element command from the Manipulate Tasks (Figure 22-23). 

 
Figure 22-23: The Modify Element Command 
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With this command you can flatten or sharpen angles and shorten or lengthen lines. It 
basically will allow you to move any vertex to any other point. AccuDraw sometimes 
interferes with these kinds of “eyeball” commands -- press your F7 key until you see your 
AccuDraw Window disappear. When you’re done, press F7 and it will come back again. 

It’s going to be tough to use Modify to make your second line be parallel to a Modified line. 
Use Delete to get rid of your second line entirely, and then use Copy Parallel to create 
another parallel copy of your Modified line. 
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BASELINE OVERVIEW 
As with most things in MicroStation, there is more than one possible approach to 
constructing a baseline. What we are presenting here is the method that is going to minimize 
the amount of hand calculating required. 

Baseline Geometry: 
First we're going to construct the baseline using SmartLine and AccuDraw. We're only going 
to need a few pieces of information to complete a Baseline. For starters, we're going to need 
a Bearing and Distance of a tangent. After that, all we need is the Radius and Delta Angle 
for each curve and a distance for further tangents.  

Checking and Cleaning Up Geometry: 
After we have constructed a Baseline, we're going to drop it into its components to make 
sure we've drawn it correctly. If we've made any mistakes, we'll correct them with the 
Modify and Rotate tools. Then we'll group the Baseline back together as a Complex Chain.  

Stationing and Annotating: 
Next we'll place PC and PT lines. We'll label them from the Tasks Menus.  

 Check page 2-20 for an overview of the Tasks Menus. 
From those we'll find a beginning station and we'll put station marks along the length of the 
baseline. Then we'll edit the text of our Station Marks and place Curve Data. 
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BASELINE TOOLS 
There are a number of tools that we’re going to be using to construct our Baseline. Some of 
them have some very specific capabilities that we should review and clarify before you get 
started working with them. 

SmartLine 
We’re going to be relying on SmartLine to create our baselines. SmartLine is capable of 
creating a series of lines and arcs (Figure 22-24). We are going to be constructing lines 
based on Distance and Bearing and constructing arcs based on Radius and Delta. With a 
little help from AccuDraw, it’s going to be simple to build “on the fly” lines that are tangent 
to arcs as well as arcs that are tangent to other arcs. 

 
Figure 22-24: SmartLine Segment Type Options 

As we work we are going to be toggling SmartLine’s Segment Type back and forth from 
Lines to Arcs. We are not going to be making any changes to SmartLine’s Vertex Type. 
We are going to make sure it’s set to Sharp and leave it at that.  

 Something that isn’t going to be obvious at first about drawing with SmartLine is that you 
should try to do all of your construction without hitting your Reset key (right mouse button.) 
With Join Elements selected in your SmartLine Tool Settings Window, constructing your 
entire baseline without hitting Reset means that the resulting series of lines and arcs is going 
to be joined together as one element (a Complex Chain). Another benefit of constructing the 
SmartLine as one element is that AccuDraw is going to be more helpful. It’s going to do this 
by keeping constant tabs on our latest distance and direction of construction.  

A Word About AccuDraw 
AccuDraw is a critical part of this process. There are a couple of things to keep in mind 
when you’re using AccuDraw.  

First off, when you type angles into AccuDraw’s Angle field, you can enter either the 
Bearing (N 23° W) or Angle (113°).  The format of the Bearing is as follows: 
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N23°45’33.44”E.  You can use the semicolon to separate the digress-minutes-seconds fields, 
e.g., N23:45:33.44E.  

 Make sure that when you type a distance or an angle into AccuDraw that you do not 
use the Enter key to “submit” your values to AccuDraw. Enter has a very specific 
function to AccuDraw. It is the SmartLock function. What this does is to lock the 
Angle of whatever you’re constructing to be either horizontal or vertical (relative to 
the AccuDraw Compass.) We will be using the Enter key for SmartLock, but not 
for entering numbers in the window. 

Also, keep your eye on your AccuDraw Window when you’re entering in distances and 
angles to keep from typing angles into the distance field and vice versa. It takes a good long 
time to type an angle in bearing format right down to the nearest tenth of a second. It’s a 
shame to have to type it all over again because you entered it into the distance field instead 
of the angle field. The easiest way to get into the distance field from the angle field is by 
using your Tab key (just to the left of the letter Q). 

AccuDraw Shortcuts 
AccuDraw Shortcuts are single (or occasionally double) key strokes that you type while 
AccuDraw is active. A common example of a shortcut is the Spacebar. When AccuDraw is 
active and you hit the Spacebar, AccuDraw shifts back and forth between Distance/Angle 
and XYZ mode.  

Another shortcut that we’re going to get a lot of mileage out of is the tilde key (~). This is 
the key that’s just to the left of the number 1 at the top of your keyboard. This shortcut is 
called Bump Tool Setting, and we’re going to use it when we swap back and forth between 
drawing arcs and lines as we’re using the SmartLine tool. It’s worth noting that you don’t 
have to hold down the Shift key to get this shortcut to work -- even though the “~” character 
is usually typed by holding down the Shift key. 

Conclusions 
These tools are going to be able to do just exactly what we need them to do to help us 
minimize the amount of hand calculations required to lay out a Baseline. However: they’re 
finicky. You’re going to have to keep a constant eye out on your AccuDraw window and 
your Tool Settings Window to make sure that your options are set correctly as you go. 
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BASELINE GEOMETRY 
Step One: Bearing and Distance 
From the Tasks Menus, select your Workgroup > Right of Way > Baseline > Baseline 
(Figure 22-25).  

 
Figure 22-25: ROW Tasks 

This will put you in the correct level, color, style and weight for drawing Baselines, as well 
as activating the Place SmartLine command.  

It’s a good idea to start every baseline with a Bearing and Distance if at all possible. Start by 
entering a Data Point to begin your line. Take a look at your AccuDraw Window and make 
sure that you are in Bearing mode (look for an N or an S in the angle field.) Then enter your 
Bearing and Distance into your AccuDraw Window.  

Note that you can still draw the line either to the left or the right of the origin point, as 
illustrated in Figure 22-26 and Figure 22-27. Make sure that your line on the screen visually 
agrees with the baseline you intend to draw by moving your cursor either to the left, right, 
up, or down to get the direction correct.  



mdot MicroStation 
01/01/12 

ROW Sheets 

22-21 

 

 
Figure 22-26: Drawing to the Right at a Fixed Angle 

 
Figure 22-27: Drawing to the Left at the Same Angle 

 Don’t enter a Data Point until you’re satisfied that you’re drawing in the right 
direction. 

Step Two: Troubleshoot and Prepare to Draw a Curve 
You have now successfully entered the first segment of your Baseline. Do not hit your Reset 
button (right mouse button.) MicroStation should now be in the middle of drawing a 
SmartLine (Figure 22-28) Your Status Bar (bottom of your screen) should be prompting 
you to “Enter next vertex or Reset to complete.” 

 
Figure 22-28: First Line Complete 

Even if you have screwed up this first portion, do not hit your Reset button -- go to your 
Main Menu and select Edit > Undo Last Data Point. This is important to keep in mind now 
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and for the rest of this creation process: if you make a mistake, UNDO. Do not Reset. You 
can also Undo by typing Ctrl+Z.  

If you do (accidentally) hit your Reset at this stage, it’s not the end of the world. All you 
have to do is start drawing again. Snap to the end point of the baseline you just constructed 
and Accept. This will put your AccuDraw Compass at the correct point but it will probably 
not be rotated. 

Tentative Point. Instead, type “RQ.” This will activate AccuDraw’s Rotate Quick Shortcut 
and spin the Compass to the proper rotation. 

 Use the Tilde key (~) to toggle SmartLine from Segment Type Lines to Segment 
Type Arcs (Figure 22-29).  

 
Figure 22-29: Swap to SmartLine Arcs 

Step Three: Draw a Curve 
Move your mouse around a bit to notice a couple of specific features here. First off, you’re 
going to see a dotted circle moving around the screen. Notice that your cursor is at the center 
of this circle.  

Notice also that the AccuDraw Compass is at the edge of this circle at the point where the 
circle intersects the line you just drew. Move your mouse around until the dotted circle looks 
like it’s perpendicular to the line you just drew. Notice that as you get close to this point, 
AccuDraw is going to tend to “snap” you in along one of its axes. This is going to help us 
lock in our curve to be tangent to our baseline.  

Moving your mouse around, line up the dotted circle so that it is curving in the right 
direction. Also make sure it is at least visually perpendicular to the baseline, then hit Enter. 
This is AccuDraw’s SmartLock, and it will nail down the location of the center of the 
curve. Now you’re ready to enter in the Radius of the curve.  

 Make sure that you are typing in AccuDraw’s Distance field (if there is a cursor 
blinking in the Angle field, hit your Tab key to put it in the Distance field.), then type 
the radius of the curve.  

What you are entering at this point is the center point of the curve. As you know, the center 
of the curve can be a long way away from the baseline. What this means to us in 
MicroStation is that the point you are about to enter may be way out of your Window. This is 
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not a problem. Enter in a Data Point to accept the point you’ve just constrained, and let’s see 
where we are. 

What you’re going to see is probably going to be something like the picture in Figure 22-30. 
As you move your mouse around you’ll notice you’re constructing an arc. You’ll notice a 
couple of dotted lines that are radial to the arc, one of them at the tangent point to the 
baseline, one of them near your cursor.  

 
Figure 22-30: Sweep an Arc 

What you need to do here is make sure that you are drawing this curve in the right direction. 
You may have to use the Zoom Out command to get the center of your arc in your view. 
Type F3 and Data Point in your window. 

Zoom Out. You may need to click a few times to Zoom Out a number of times. Reset (just 
once) and MicroStation will drop you out of your Zoom command and back into the Place 
SmartLine command and it will show you a more complete picture of the curve you are 
constructing. 

Once you can see the AccuDraw Compass at the center of the arc, move your mouse 
around a bit. Notice that the arc sweeps around with the mouse. To change the direction of 
the arc, sweep your cursor around the Compass point until you see the arc begin to look a 
little bit more like you want it to. Now you’re ready to enter in the Delta of the curve.  

Make sure you are typing in AccuDraw’s Angle field. Again, if you are in the Distance 
field, just type Tab to get to the Angle field. Now type the Delta value for the curve into the 
field. Enter a Data Point when you are done. 

Step Four: Troubleshoot and Prepare for Another Curve or 
Tangent 

You have now successfully placed a Curve on to your Baseline.  

 If you made a mistake in this portion of construction, remember NOT TO HIT 
YOUR RESET (Right mouse button.) All you need to do is Undo (Ctrl+Z) to 
gracefully step back in the command and pick up your construction from the last 
correct point. You can Undo more than once, if need be, but take it slow and be sure 
not to Undo too far.  

If you did (Accidentally) hit your Reset key, you can start up again like you did in Step 2 
with one notable exception. You’re going to snap to the end of your baseline and Accept 
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to start placing your SmartLine again. Then you need to get the AccuDraw Compass 
rotated correctly again. Instead of snapping to the center of the last tangent, you’re going to 
want to snap to the center of the last curve that you placed (use the Center Snap by typing C 
into AccuDraw). Note that this center point is usually far away from the baseline. Once 
you’ve snapped, type RQ to rotate AccuDraw’s compass. 

At this stage of the game you’re totally set up to repeat Step 3 and construct another curve. 
Your AccuDraw Compass should be all set up and your Angle Mode should be correct and 
ready for curve placement. Go back to the beginning of Step 3 if you’re going to lay in 
another curve. 

If, however you are going to construct a tangent from this point, you need to toggle 
SmartLine back to its Segment Type Lines mode by typing a Tilde (~) into AccuDraw. 
Check that the change has been made in the Tool Settings Window. 

It is not going to be necessary to enter in the Bearing for this next tangent. If we have 
constructed our curve correctly we can just let AccuDraw get the Bearing right for us. 

Move your mouse around until SmartLine looks like it’s going to draw a tangent in the right 
direction (Figure 22-31). Hit the Enter key to activate AccuDraw’s SmartLock.  

 
Figure 22-31: Construct Tangent Direction 

Make sure you are in the Distance field by hitting your Tab key and type in the length of 
the Tangent  

Note that this tangent distance is just the distance between the PT and the next PC or end of 
project. Enter a Data Point to accept this point. 

Step Five: Troubleshoot and Prepare for Another Curve or 
Tangent 

Again, make sure not to hit your Reset until you’re done with your whole baseline. If you do 
hit your Reset, check out Step 2 for a method of getting back on track.  

From this point, you now have all the construction tools you need to create any sort of 
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baseline. The next step will be to double-check the geometry you have laid out and make 
any necessary corrections. Then we’ll go on to Stationing and Annotating 
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BASELINE CHECKING/CHANGING 
Once you have your baseline constructed you’re going to want to make sure you haven’t 
made any mistakes. If you have, you're going to need to fix it up. 

Drop Complex 
It’s going to seem strange since we went to all that trouble to make sure our alignment was a 
single element, but the first thing we’re going to do when we check our baseline is to drop it 
up into separate elements. We’re going to do this to make it easier to check the length of 
individual elements. 

Pick the Drop Element tool from the Main Tool Tasks. Check your Tool Settings 
Window and make sure that Complex is checked off (Figure 22-32). This ensures that 
Complex Chains will be dropped into their individual components.  

 
Figure 22-32: Drop Elements Complex 

Check your Status Bar (at the bottom of your screen) for prompting about what to do next. It 
should tell you to “Identify element.”  

Data Point on the baseline. It will highlight, and your Status Bar will prompt you to 
“Accept/Reject (select next input)”. Data Point to Accept and your baseline will be broken 
up into a series of lines and arcs. If there was an angle point on your baseline, you may have 
constructed a baseline that has two intersecting tangents. When you drop complex status of 
this baseline, this “elbow” is going to be preserved as a Line String. To drop that Line 
String, use Drop Complex again, making sure to have Line Strings/Shapes toggled on in 
your Tool Settings Window.  

Measure Lengths 
From the Measure Tasks, pick the Measure Length tool. This is a great tool for measuring 
the components of a baseline. It will tell us the length of tangents and curves, as well as the 
bearing of tangents.  
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Figure 22-33: Measure Distance 

Your Status Bar will be prompting you to “Identify Element.”  It is not going to be 
necessary to snap to the element to pick it here, just Data Point on the element you want to 
measure. MicroStation will display some information for you regarding this element. Look 
to the lower middle of your Status Bar or the Measure Length Dialog for the length of lines 
and arcs, as well as the bearing of lines (Figure 22-33). 

Measure Radius of Curves 
Once you have established the bearing of lines and the length of lines and arcs, you should 
double-check the radii of the curves of the baseline. From the Measure Tasks, choose 
Measure Radius. The Status Bar will prompt you to "Identify Element."  

 
Figure 22-34: Measure Radius 

Data Point on an arc and it will highlight. You will see the Radius being displayed in the 
lower middle of the Status Bar or the Measure Radius Dialog (Figure 22-34).  
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Fix the Problems 
So you've found out that something isn't quite right with the baseline you've just constructed. 
There are a number of tools that we can use to fix it up.  

Modify 
The Modify tool is going to let us change the distance and bearing of lines, as well as the 
sweep angle (delta) and radii of curves. From the Modify Tasks on the Tasks Menus, 
choose the Modify tool (Figure 22-35).  

 
Figure 22-35: Modify Element 

Rotate 
Say you've made a change to the bearing of a tangent line. That is going to affect the curve 
that you previously constructed from that tangent. You need to use the Rotate tool to 
reorient that curve to align with your modified tangent. 

From the Manipulate toolbox on the Main Tool Tasks, choose the Rotate tool (Figure 
22-36). From the Tool Settings Window make sure to set the Method to 3 Points. 

 
Figure 22-36: Rotate Element 
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It is also possible that you made a mistake on your initial bearing and need to reorient the 
rest of your baseline. You might have too many segments to want to fix them one at a time. 
You can use Element Selection to pick all of the elements that need to be reoriented (Figure 
22-37). That makes it possible to rotate the entire baseline at once. 

 
Figure 22-37: Element Selection 

Punt 
If it looks like it's going to be too complicated to modify and manipulate your baseline into 
shape, you can always wipe it out and start again. Practice is good. 

Put It Back Together Again 
Now that we've checked and rechecked and fixed all of the problems in our baseline, we're 
going to want to reassemble it into a Complex Chain. From the Groups tasks, choose 
Create Complex Chain. In the Tool Settings Window, make sure to set the Method to 
Automatic instead of Manual (Figure 22-38). Your Status Bar is going to be prompting 
you to "Identify Element". Pick the first element in the baseline with a Data Point. The 
element will highlight. Data Point away to Accept.  

 
Figure 22-38: Create Complex Chain 

Now MicroStation will look for another element to attach onto the end of this first element. 
Whatever element it can find at the end of that first element (within a certain distance: the 
"Max Gap") will be highlighted, and MicroStation will prompt you to "Accept Chain 
Element." Data Point to Accept each portion of the baseline as MicroStation finds it. If 
MicroStation cannot find an element, it will finish up the Complex Chain.  

If for some reason MicroStation doesn't find elements that should be part of the baseline, the 
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first thing you need to do is Undo the Complex Chain that you just created. If you don't do 
this, you're going to end up with lots of elements on top of each other by the time you're 
through recreating your baseline.  

MicroStation may not have found elements to put on the end of the chain because they were 
too far away from the end of the element preceding them. This could be as simple as a 
missed snap or as complicated as a 3D issue. You should be able to resolve it by using the 
Move command (make sure to use Element Selection if you want to move the entire 
alignment together) and carefully put the problem elements into place at the end of the 
baseline. If this doesn't work, try flattening the file (File > Export > 2D). Then go back and 
recreate the Complex Chain from the first element again. You have to use the File > Open 
command to open the 2D file that was just exported. 
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BASELINE STATIONING 
There are going to be a couple of steps involved in Stationing. First we're going to label the 
PCs and the PTs. Then we'll use those points along with the "Pointalong" macro to find a 
beginning station. From there, we'll use the Tasks Menus to place our stations. 

Construct the PCs and PTs 
From the Tasks Menus, select your Workgroup > Right of Way > Baseline > Baseline to 
set the element attributes. The way to find the PCs and PTs is to snap to the ends of your 
curves. Place your cursor near the intersection of a tangent with a curve but ON the tangent 
and hit your middle button. You should see the tangent highlight and a crosshairs will 
appear at the end of the tangent (Figure 22-39). Accept this point with a Data Point to start 
the PC line.  

 
Figure 22-39: Snap to the End of a Curve 

Choose Center as your Snap Mode and Tentative snap to the curve. Make sure AccuDraw 
is in Distance/Angle mode (the AccuDraw Compass will be a circle if it is). Type "150" (50 
for metric) as your distance (making sure your cursor is in the AccuDraw Distance field.) 
This will lock your line to be pointed at the center of the curve (perpendicular to the 
Baseline) and 150 feet (50m metric) long. Accept by entering a Data Point.  
Repeat this process for all PCs and PTs along the Baseline. 

Double Check Your Baseline Chain 
Step Zero at this phase is to make sure that your Baseline is all one element (Complex 
Chain). From the Primary Tools, pick the Element Information tool. MicroStation will 
prompt you to “Identify element to add to set.” Pick on your Baseline with a Data Point. A 
dialog box will appear that will tell you (at the top) what kind of an element your Baseline 
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is. The top of the dialog should say “Complex Chain”. If it does, close the dialog and 
continue. If it doesn't, make it into a Complex Chain.  

Generate a Station Marker 
Once the PC’s and PT’s lines are drawn, you're going to use the Station of a PC or PT to 
locate an even 100’ Station on the Baseline. Press the F12 key to run the Pointalong macro. 

 
Figure 22-40: Point Along Distance 

Data Point to Accept and MicroStation will prompt you to enter in a distance (Figure 
22-40). Take the station of your PC or PT and calculate the distance to a nearby 100’ station. 
Enter this distance and push OK. MicroStation will prompt you to “Identify Direction for 
Construction.” Enter a Data Point on the Baseline in the direction of the Station you want to 
place. Finish drawing the line at this point. This will serve as a Station Marker Construction 
Line for placing your Stationing in the next step.  

Place Generic Stations 
Now that we have a marker on an even Station, we can use the Stationing tools in the Tasks 
Menus to begin to annotate. From the Tasks Menus, select your Workgroup > Right of 
Way > Baseline > Stationing English.  
MicroStation is going to prompt you to “Place Cell Along > Identify Element.” We want to 
pick the Baseline, but we want to be certain to pick it at the point where our Station Marker 
Construction Line intersects the Baseline. We’re going to do this by using the Intersection 
snap again. Make sure to snap to the Construction line first, then the Baseline. Data Point to 
Accept and it will show generic station markers at even intervals along your Baseline. At 
this point you will need to Data Point one more time to Accept this configuration.  

Fill in the Station Information 
What you have just placed is a series of tick marks along your Baseline. These tick marks 
are labeled by stations marked 0+00. The next thing we have to do is change these stations 
to the proper values. These Underlined letters are a special kind of MicroStation text called 
Enter-Data Fields. 
We are going to make changes to these Fields by using tools from the Text toolbox from the 
Tasks > Drawing > Text tasks (Figure 22-41). 



mdot MicroStation 
01/01/12 

ROW Sheets 

22-33 

 

  
Figure 22-41: Fill in Single Enter Data Field 

We’re going to start by changing the value of the first Station on our Baseline. From the 
Tasks > Drawing > Text tasks, choose the Fill In Single Enter-Data Field tool. 
MicroStation will prompt you to "Identify Element". Pick on the underlined characters of 
your first Station with a single Data Point. MicroStation will open the Text Editor. Type 
your Station into the Text Editor and hit Enter (Figure 22-42).  

  
Figure 22-42: Pick an Enter Data Field 

MicroStation will put the text you typed into the Text Editor into the Enter-Data Field 
(Figure 22-43). 
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Figure 22-43: Data Point to Change the Field 

Once we have the first Station correct, it's going to be easy to fill in the rest of our Stations. 
We're going to use a tool that will copy our Data from that one field into each Station. For 
each Station we fill, MicroStation is going to add 100 to the value of the previous Station.  

 
Figure 22-44: Copy/Increment Enter Data Fields 

From the Text tasks, pick the Copy/Increment Enter-Data Fields tool (Figure 22-44). On 
your Tool Settings Window, set your Tag Increment to 100. MicroStation will prompt you 
to "Select enter data field to copy." Data Point on the field you just entered.  

The Station value should appear in your Status bar. Now Data Point on the next Station. 
MicroStation will change the value of that Station to the next appropriate value.  

Keep picking stations (in order) until you get station 2+500. MicroStation is not smart 
enough to put that hundred marker on the left side of the plus sign. Go back to the Fill In 
Single Enter-Data Field tool and change the station to 25+00. Then use the 
Copy/Increment Enter-Data Fields tool to continue stationing. 
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PTS AND CURVE DATA 
There are only a couple of tricks to labeling the PCs, PTs and Curve Data. 

Text Placement Options 
The first step here is to label the PCs and PTs. MicroStation has a couple of text placement 
features that are going to make this an easy process. When you place text, you have a 
number of options about how that text is going to get stuck into the drawing. By default, 
your text placement method is By Origin. This method hangs the text off the end of your 
cursor and stamps it into the drawing wherever you click.  

The methods that we're going to be using to label the PCs and PTs are Above Element and 
Below Element (Figure 22-45). When you use these methods, you type in the text you'd like 
to place, and then Data Point on an element. MicroStation will then place in the text you've 
typed either Above or Below that element. 

 
Figure 22-45: Text Placement Methods 

We will also be setting the Justification value to either a Right Top or a Left Top 
Justification. If the PC/PT line is on the Right of the Baseline, we'll be using the Right Top 
Justification. If the PC/PT line is on the Left of the Baseline, we'll be using the Left Top 
Justification. To set the Justification, expand by click the arrow in the lower right corner of 
the Place Text Dialog.  

Label the PCs and PTs 
From the Tasks Menus, select your Workgroup > Right of Way > Baseline > PCPT Text. 
This will set your active text height, width, and font and will launch the Place Text 
command. Based on the desire to keep the PC and PT labels to the INSIDE of the curve, 
make a decision about whether your current PC or PT should be Above or Below the PC/PT 
line. Select Above or Below Element from the Method section of the Place Text Tool 
Settings Window. Select a Justification from the same Tool Settings Window (Figure 
22-46).  
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Figure 22-46: Labeling a PC 

Type your text into the Text Editor and place it on your PC/PT line by snapping (Keypoint) 
to the end of the line. Data Point to Accept and MicroStation will highlight the line (Figure 
22-46). Data Point again and it will place the text. 

Place PC/PT Circles 
Next we need to place circles (of radius 2.5' at the PC and PT point on the Baseline. From 
the Tasks Menus, select your Workgroup > Right of Way > Baseline >  PCPTCircle ('). 
This will stick the appropriately sized circle on the end of your cursor. Stamp it into place by 
snapping to the ends of the PC/PT lines. 

Place and Edit Curve Data 
Once you have labeled the PC and PT lines with text and circles, it's time to place Curve 
Data on the Baseline. Our Curve Data is stored in a cell in our ROW cell library. We're 
going to place the cell onto our drawing as many times as necessary to label all of our 
curves. For each one, we're going to want to try to rotate the cell such that it's aligned with 
the radius of the curve at the center of the curve's length. 

From the Tasks Menus, select your Workgroup > Right of Way > Baseline > Curve Data 
(Figure 22-47). This will pick our Curve Data cell from our cell library and stick it on the 
end of your cursor. 
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Figure 22-47: Choose Baseline>Curve Data 

When the Cell Tools Dialog appears click on the Place Cell and Rotate Icon (Figure 
22-48). By adjusting the number of degrees in the Angle field of the Place Cell and Rotate 
Dialog can be placed between the PC and PT of the curve with a Data Point. 

 
Figure 22-48: Placing Curve Data 

Once your Curve Data is in the right place on your drawing, you are going to have to edit it 
to the correct values. Since you can't edit text that is in a cell, we're going to have to start by 
Dropping the cell into its Components.  
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Figure 22-49: Drop Element Tool Settings 

From the Main Tool Tasks, pick Drop Element. Look at your Tool Settings Window and 
make sure that Complex is turned on (Figure 22-49). MicroStation will prompt you to 
"Identify Element." Pick on the Curve Data Cell. It will highlight, and you will Accept with 
a Data Point to complete the Drop. 

 
Figure 22-50: Edit Text Button 

Once the Curve Data has been dropped, use your Edit Text tool to change the values to 
reflect your current curve (Figure 22-50). 
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ROW FUNCTION KEYS 
 

F1  

F2 Window in 

F3 Zoom Out 

F4 Update View 

F5 Element Selection 

F6 Fence 

F7 AccuDraw On/Off 

F8 Set Angle Mode to Azimuth East 

F9 Set Angle Mode to Bearing 

F10 Distance Macro measures along element and gives you options 
on how you can label distances. 

F11 Perpendicular Snap 

F12 Construct Point at Distance and Offset 

Alt+F1 Works similar to a refresh/ clear 

Alt+ F2  

Alt+ F3 /actan2 changes your active angle with 2 hit points for placing 
text. 

Alt+ F4 Reserved for Closing Windows/Files 

Alt+ F5 Copy Parallel & Change Attributes (Color, Style, Level, Etc.) 

Alt+ F6  

Alt+ F7  

Alt+ F8  

Alt+ F9  

Alt+ F10  

Alt+ F11  

Alt+ F12 Copy Parallel 

Shift+F1  

Shift+ F2  

Shift+ F3  

Shift+ F4  



mdot MicroStation 
01/01/12 

ROW Sheets 

22-41 

 

Shift+ F5  

Shift+ F6  

Shift+ F7  

Shift+ F8  

Shift+ F9  

Shift+ F10  

Shift+ F11  

Shift+ F12  

Ctrl+F1  

Ctrl+ F2  

Ctrl+ F3  

Ctrl+ F4  

Ctrl+ F5  

Ctrl+ F6  

Ctrl+ F7  

Ctrl+ F8  

Ctrl+ F9  

Ctrl+ F10  

Ctrl+ F11  

Ctrl+ F12 Move Parallel 
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LAUNCH INROADS 
 All instructions are based upon the project folder being created using the InRoads 

Survey Project setup icon. 

 Refer to page 4-3 for information about the InRoads Survey Project setup 
program. 

Step One: Launch InRoads 
Start InRoads Suite V8i using the desktop icon (Figure 22-51). 

 
Figure 22-51: InRoads Suite Desktop icon 

Step Two: Adjust User 
In the Workspace portion of the File Open dialog (Figure 22-52), adjust the User pull down 
to InRoads_local_V8i. 

Step Three: Pick your Project 
 Select your project from the Project pull down.  

 This should adjust your directory path to your project’s SURVEY/MSTA directory.  

 Never browse for your project in the directory portion of the dialog. If your directory 
doesn’t point you to your project, contact CADD Support personnel. 

Step Four: Select a File to Open 
The Interface pull down should always read mdot. Select the Survey.dgn from the list of 
files to open (or another file if this one doesn’t exist). Click OK. 
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Figure 22-52: Workspace area of the File Open dialog 

Step Five: Upgrade the File (if necessary) 
 If the Information message appears (Figure 22-53), alerting the user that the chosen 

*.dgn is not in the correct units of resolution, then the file must be corrected before 
being used in the InRoads software. 

 
Figure 22-53: Information dialog stating that the file was created for the MX platform 

Click OK.  
After the file opens, select Macros > Update UOR and Units from MicroStation’s main 
menu (Figure 22-54). 
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Figure 22-54: Run the Update UOR and Units from the MicroStation menu 

 The Update MaineDOT Foot File dialog will open displaying information about the 
program (Figure 22-55). Select Proceed. 

 
Figure 22-55: Update MaineDOT Foot File program dialog 

Once the program is done processing, a message will appear (Figure 22-56). Click OK. 

 
Figure 22-56: Successful Completion message 
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CREATE A GEOMETRY MODEL 
Overview 
InRoads handles a boundary as an alignment, therefore, a Geometry Project must be created 
to store the bearings and distances needed to verify boundary information. This process will 
allow for checking of closure tolerances. 

Step One: Create a Geometry Project 
Using the tabs located at the lower left of the InRoads panel, select Geometry (Figure 
22-57). 

 
Figure 22-57: Select the Geometry tab 

Right-click on the Geometry Projects name and Select New… (Figure 22-58). 

 
Figure 22-58: Right Click and select New 

The New panel will allow the user to create and name the geometry project (Figure 22-59). 
Verify that the Type is set to Geometry Project. The Name for this example will be Parcel 
1. The Description is Barker Brook Easements. Click Apply. 
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Figure 22-59: Create the Geometry Project called Parcel 1 

Step Two: Create a Horizontal Alignment 
In the Type field, select the pull down and change the Type to Horizontal Alignment 
(Figure 22-60). Enter Parcel 1 alignment in the Name field. Set the Style to 
E_Property_Easement_Line. The Curve Definition is Arc. Click Apply. Click Close. 

 
Figure 22-60: Create a Horizontal Alignment 

Step Three: Set the Active Alignment 
Expand the Explorer view of the project located at the left side of the InRoads panel. With 
the alignment name selected, right-click with the mouse and Set Active (Figure 22-61). 
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Figure 22-61: Right Click Alignment and Set Active 

Step Four: Create a Traverse 
Select Geometry > Traverse from InRoads main menu (Figure 22-62). 

 
Figure 22-62: Select Traverse from the InRoads main menu 

In the Traverse dialog (Figure 22-63), set the Method to Direction. Set the Insert Point 
Mode to After Alignment.  
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Figure 22-63: Adjust the Traverse dialog 

Step Five: Identify Starting Point 
Using the Occupied Point selection button (target symbol), click on the starting position of 
the boundary.  This will populate the Northing and Easting fields with the starting 
coordinates. 

Step Six: Set Point Name and Style 
Set the Foresight Point Name to 1000. Set the Description to Start. Set the Style to 
E_Property_Easement_line (Figure 22-64). 

 
Figure 22-64: Enter Point Name, Description and Style 

Step Seven: Enter Deed Description 
With the Occupied point and foresight point information set, follow the boundary 
description and enter in the necessary bearing and distance information (Figure 22-65). 

In the Course portion of the dialog, set the Direction to the first bearing (i.e., N 16 15 W). 
Set the Horizontal Distance (i.e., 80.1). Click Apply. 
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Figure 22-65: Enter the deed description's bearing and distance 

A Results panel (Figure 22-66) will appear automatically if the InRoads Report lock is on.  
This can be minimized during this operation and viewed at a later time. 

 
Figure 22-66: The Results dialog displaying the current traverse 

The Traverse panel has been updated so that the Occupied Point information now reflects 
point number 1000 and the foresight point name is automatically incremented to point 1001 
(Figure 22-67).  The description can be modified to reflect the new description for the next 
point of the boundary (i.e., Angle Point). Enter the next set of course direction and distance, 
then click Apply. 
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Figure 22-67: Traverse dialog auto incremented and ready for next description 

 The direction field can be easily changed by double-clicking on the numbers.  This 
does not change the course direction though, but if there were a number of values to 
be entered in the same quadrant, this is a quick way to type those in. 

 The Tab key will move from the direction field to the distance field and highlight the 
number so the user can type in the new distance. 

Following the boundary description documentation, continue in this manner until all sides 
have been entered.  At any given time the user may expand the minimized Report window to 
view the data that has been entered. 

With the last bearing and distance values added, the user can close the Traverse Panel. 

 Do not click the Close Traverse button, if this process was done to check the boundary 
for closure.  By using the Close Traverse button, the boundary traverse will 
automatically close with whatever the necessary bearing and distance needs to be, 
eliminating any error. 

Step Eight: Annotate the Boundary 
To graphically view the bearings and distances on the boundary just created, select 
Geometry > View Geometry > Horizontal Annotation from the InRoads main menu 
(Figure 22-68). 
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Figure 22-68: View Horizontal Annotation to graphically view annotation 

Use the data point button (target icon) to pick the alignment from the screen display.  The 
alignment will be added to the Selected: area of the dialog (Figure 22-69). 

 
Figure 22-69: The list of alignments selected to be annotated 

CADD Support created a preference to view this annotation with the correct display 
properties. Select Preferences from the lower portion of the dialog (Figure 22-70). 

 
Figure 22-70: Select a custom preference 

 Select the preference for Property (Figure 22-71). Click Load. Select Close to dismiss the 
dialog. 

 
Figure 22-71: Select and Load the Property preference 

The View Horizontal Annotation dialog is now adjusted to match the Property preference 
(Figure 22-72). Click Apply. Select Close. 
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Figure 22-72: View Horizontal Annotation adjusted by the Property Preference 

The annotation is displayed with the bearing and distance (Figure 22-73). 

 
Figure 22-73: Bearings and Distances annotation are displayed 
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CLOSURE CHECKING 
Step One: Open Traverse Edit 
To check the closure error, select Geometry > Utilities > Traverse Edit from the InRoads 
main menu (Figure 22-74). 

 
Figure 22-74: Open the Traverse Edit dialog 

Step Two: Select Geometry Project 
Select your Geometry Project from the pull down if it’s not already set as your Active 
geometry project (Figure 22-75). The Traverse Edit dialog offers the user a chance to check 
the closure results. 
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Figure 22-75: Traverse Edit dialog 

Step Three: Make Adjustments (if necessary) 
Adjustments may be made by selecting the boundary course in the Traverse portion of the 
dialog. To adjust the Direction or Distance, highlight the boundary course and select Edit at 
the bottom portion of the dialog. 

 Part One: Modify Existing Boundary Lines (if necessary) 
Modifications are made in the Edit Element dialog (Figure 22-76). Once changes are made 
the user must click Apply, and then Cancel. 
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Figure 22-76: Edit Element dialog allows adjustment to existing boundary lines 

 Part Two: Add Elements (if necessary) 
If the user needs to add another element to the boundary, highlight an adjacent element and 
select either Add Before or Add After from the lower portion of the Traverse Edit dialog 
(Figure 22-75). This opens the Add Element After or Before dialog (Figure 22-77). Add the 
new element and select Apply and then Cancel. 

 
Figure 22-77: Add Element Before or After dialog 

 Part Three: Apply Changes to the Boundary 
For the boundary to retain the changes made, select the Apply button on the Traverse Edit 
dialog (Figure 22-75). 

Step Four: View Report 
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A report of the boundary can be generated by clicking the Report button in the Traverse 
Edit dialog. The report opens in the Bentley Civil Report Browser dialog (Figure 22-78). 
This is an example of a report that is generated.  Different reports can be selected on the left 
pane of the Bentley Civil Report Browser. 

 
Figure 22-78: The Bentley Civil Report Browser dialog displays a report of the boundary 
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CREATE PROPERTY BOUNDARY REPORTS 
Overview 
InRoads has the ability to generate XML reports containing a variety of different formats of 
boundary descriptions. The boundary must be completed as an active Alignment and saved.  

Step One: Open the XML Reports dialog 
Select Tools > XML Reports > Legal Description… from the InRoads main menu (Figure 
22-79).   

 
Figure 22-79: Opening the Legal Descriptions dialog 

Step Two: Select the Alignment 

 Graphically select the boundary (alignment)   
Using the Data point button (target icon) select the Alignment that represents the parcel 
boundary graphically from the view window (Figure 22-80). 

 
Figure 22-80: Example of Legal Description Reports panel 

 If the alignment won’t select from the screen, be sure to verify that it is an open/active 
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geometry project in InRoads.  If the report is being generated at a later time, the user 
will have to open the Geometry Project first (Figure 22-81). 

 
Figure 22-81: Opening a Geometry Project 

 Re-Opening an Alignment (if necessary) 
If you need to re-open your Geometry Project, right-click on the Geometry Projects folder in 
the InRoads explorer, and click Open.  At the Open dialog (Figure 22-82), select the 
alignment name (i.e., Parcel 1.alg), click Open and then Cancel. 

 
Figure 22-82: Open Geometry Project dialog 

Step Three: Select Apply 
With the boundary alignment highlighted in the Selected portion of the dialog (Figure 
22-83), click Apply. 
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Figure 22-83: Select your alignment and click Apply 

Step Four: Choose XML Format Type 
The XML report displays automatically. Different report formats can be displayed by 
selecting from the choices listed in the left hand explorer view (Figure 22-84). 

 
Figure 22-84: XML Report is displayed with current style sheet 

  

Step Five: Save As… 
Once the type of report has been selected, the user can choose to save it by clicking File > 
Save As… (Figure 22-85). Browse to the correct folder location to save the document.  This 
should be the Reports folder located within the project’s directory folder (i.e., 
\SURVEY\MSTA\REPORTS).  
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You can save the file directly as an .html file, but notice the drop-down allows for saving to 
a Microsoft Word (*.doc) or even Microsoft Excel (*.xls) file.  Pick the desired Save as 
type, enter a name for your report, and then click Save.  Select the Close button to dismiss 
the dialog. 

 
Figure 22-85: Save As dialog waiting for file name and type
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DETAILING TO SCALE 
Introduction 
We’d like to make it as easy as possible to draw our structural details. The biggest problem 
we face in doing this is the issue of controlling text and dimension size relative to plot scale. 
To make sure we’re always drawing 1:1 (full size), we’ve adopted a workflow that relies on 
MicroStation’s built-in use of reference files, as well as a heavily customized Tasks Menus. 

File Segregation 
Let’s look at an abutment as an example of how we’re going to segregate files. Say we have 
three sheets for abutment one: a footing sheet, an abutment sheet and a wing sheet. In our 
bridge\msta\ folder for this project, we will have one .dgn file that corresponds to each of 
these sheets. They might be named “016_abutment1.dgn” “017_pier_1.dgn” and 
“018_framing.dgn.” These files would be empty except for a border that contains the title 
block, signature block, etc. All of the detailing work that we’ve done for this abutment will 
be other files, which might be called “z_abut_1.dgn”, “z_pier_1.dgn” and “z_framing.dgn.” 
These files contain the lines, text and dimensions that make up our details.  

Creating A Detailed Drawing 
The first step in detailing our abutment is to create the drawing file that is going to contain 
our lines, text and dimensions. 

 Refer to page 1-57 for Creating Drawing Files. 
Now we are ready to do our detailing work. We will discuss this in detail elsewhere, but for 
now, note that we will be using the Tasks to control our level, color, style and weight. From 
the Tasks Menus, select your Workgroup > Substructures > Abutment and draw up your 
abutment plan.  

Now it’s time to decide what scale we’re going to want to plot this plan. Until we have 
placed text or dimensions on this plan, we can plot it out at any scale. It is the size of text 
and dimensions that lock us down to a fixed plot scale. 

If your Drawing Scale dialog is not open, navigate to Settings > Drawing Scale (Figure 
23-1). 

 



mdot MicroStation 
01/01/12 

Structural Sheets 

23-4 

 

Figure 23-1: Accessing the Drawing Scale dialog 

From the Main Menu, select Settings > Drawing Scale.  Select the desired scale from the 
drop down (Figure 23-2). 

 
Figure 23-2: Select Scale 

Let’s select a scale of ¼ in. = 1 ft. 

 Check page 2-25 for more information on the Drawing Scale. 
Once you have selected your scale, it is time to annotate your detail. From the Tasks Menus, 
select your Workgroup > Bridge > Prop. Text and Dims > Dimension Ft./In. (1/4 
accuracy) (Figure 23-3), this will setup your dimension sizes and your text size. Finish up 
your detailing work. 

 
Figure 23-3: The Prop. Text and Dims Group 

Once you have finished your annotation, we are going to set up a Saved View that contains 
our detail. From the Tasks Menus, select your Workgroup > Bridge > Tools > Saved View 
Maker.  
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This will run a macro to quickly create a saved view for you. It will prompt you to enter the 
lower left and upper right hand corners of a box that contains all of the lines and text that 
make up your detail (Figure 23-4).  

 
Figure 23-4: Define the Extents of your Saved View 

Once you enter in both of these points, the macro will then resize your open window to the 
aspect ratio of your detail and open up a Saved View dialog to ask you for a name and a 
description of your view (Figure 23-5).  

 
Figure 23-5: Naming a Saved View 

 In the description field, make sure to include a reference to the scale of the detail, as 
you will need that information later. 
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This completes the work that needs to be done in this file. Now we are going to create a 
Sheet File and attach our detail to it. 

Creating a Numbered Border File 
 Refer to page 1-57 for creating your Border File  

Fill in the information in the border by selecting Macros > Border Information from your 
main menu. 

 If you find the information on your border to be incorrect then it will be necessary to 
edit your “Project Configuration File”. This can be accomplished by going to the 
main menu and selecting Workspace > Edit Project Data (PCF). 

 Refer to page 1-67 for more information about PCF Editing. 
Now it’s time to attach our detail to this drawing. Select File > Reference (DOT) > Attach. 
This will bring up the Preview Reference dialog (Figure 23-6).  

Select your drawing file and push OK. 

 Using this selection instead of the out-of-the-box File > Reference allows us to go 
directly to the project directory that we are working in and keeps us from having to 
browse to the directory. 

 
Figure 23-6: The Preview Reference Dialog 

This will bring up the Attach Reference File dialog (Figure 23-7).  
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Figure 23-7: The Attach Reference File Dialog 

We will need to make a number of selections here. First off, pick your saved view from the 
Orientation portion of the dialog. When picking a Saved View you will notice that the 
Logical Name and the Description will fill in automatically. Finally, set your Scale 
(Master:Ref) to be equivalent to the Drawing Scale that you used when annotating your 
detail. (In this case, our 3/16 in.=1 ft. scale translates to a 1:64 Master:Ref scale.) Push OK. 

 Refer to page 31-2 for the table of U.S. Customary detailing scales. 
This will dump you back into your file with a box hovering on the end of your cursor 
(Figure 23-8). 
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Figure 23-8: Reference Placement by Saved View 

Datapoint somewhere on your border to place your detail in an acceptable location. 

Adding Further Details, Different Scales 
To continue with the previous example, you might go back into your z_arch.dgn and create 
an abutment elevation. Since the abutment plan and elevation may be at the same scale, you 
should have no trouble working on both of those details in the same file for the life of the 
project. You would set up a saved view for the elevation and attach that saved view to your 
017_abutment1.dgn. Then any changes that needed to be made to those two sections would 
be made by opening up z_arch.dgn drawing file. 

However, the abutment section is often at a different scale than the plan and elevation. To 
create a abutment section using a different scale, create a new design file 
(“z_arch_sect.dgn”) and choose something like “1/2 in.=1 ft.” for the scale. Then draw and 
annotate as we just explained, creating a saved view and attaching that file to 
017_arch_plan.dgn. 

You MUST select the proper Drawing Scale before using the Tasks to place additional text, 
dimensions, custom line styles, or cells. This means that each drawing can only have one 
scale and you must separate each scale into different drawings.   

To check your current Drawing Scale, select your Workgroup > Bridge > Tools > Plot 
Scale? from the Tasks Menus. (Figure 23-9)  

 
Figure 23-9: Drawing Scale Information 
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TOOLS IN THE TASKS MENUS 
The Tools section of the Bridge tasks (Figure 23-10) has a couple useful automation 
routines.  

 
Figure 23-10: Bridge > Tools 

The File Making Macros 
File creation has been removed from the Structural Tasks. Cut sheets will be created from 
the Workgroup > Plan > Create Plan Sheets tasks and all other file creation will be 
handled through the makesheetz.bas macro (File > Make Sheetz). 

 Check page 1-57 for a description of the Make Sheetz macro. 

 There is a file creating process within the Tools group that allows for developing 8.5 
x 11 detail sheets for the purpose of developing Coast Guard permit plans. This 
works very similar to creating plan sheets. You would use the option Place 8.5x11 
Clip Boundary around your specific details and then process them to sheet drawings 
by using the option Create 8.5x11 Plan Sheets. 

Plot Scale 
The Plot Scale? task reminds you of your current Drawing Scale (Figure 23-11).  
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Figure 23-11: Drawing Scale Information 

Make Saved Views 
The Saved View Maker is a way of automatically creating a Saved View of a specific size 
and aspect ratio.  

Saved Views are a little bit like bookmarks in a MicroStation .dgn file. They help you get 
back to a specific location in your file by storing the coordinates in a utility called Saved 
Views.  

The default way of accessing Saved Views is by opening the dialog from the Menus under 
Utilities > Saved Views (Figure 23-12).  

 
Figure 23-12: Saved View Dialog 

Structural Detail Tasks 
Selecting Bridge Tasks will allow you to place structural detail cells that have been built 
into a cell library for you. They are categorized by bridge components. 

 If there are any details that you develop while detailing that would be pertinent to be 
created as cells please contact your support staff to develop and make them 
accessible to all others. 
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DIMENSIONS TASKS 

 
Figure 23-13: Dimensions 

Dimensions With Arrows 
There are currently four options for placing Dimensions with Arrows. 

• Dimension Decimal Feet lays out dimensions to hundredths of inch accuracy. 

• Dimension Ft/In (1/16 accuracy) lays out dimensions to a 1/16” accuracy. 

• Dimension Ft/In (1/4 accuracy) lays out dimensions to a 1/4” accuracy. 

• Dimension Ft/In (1/8 accuracy) lays out dimensions to a 1/8” accuracy. 
Selection of any of these options will setup your active level, color, style and weight, as well 
as setting an appropriate dimension text height for your active Drawing Scale. It will also 
launch the appropriate tool for dimensioning (in this case, the Dimension Size Arrow tool 
(Figure 23-14).)  
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Figure 23-14: Dimension Size Arrows Command 

Angle (Text Above) & Angle (Text Horiz.) 
These Components set us up for dimensioning the angle between two lines. The Text Above 
option places the text in-line with the dimension arc. The Text Horizontal option cuts the 
dimension arc and always draws in text horizontal (Figure 23-15). 

 
Figure 23-15: Angular Dimension Examples 

 This command can be used to dimension obtuse as well as acute angles, depending 
on the order in which you identify the lines. In the pictorial, I identified the 
horizontal line first, and then the slanted line and I got the angle that was less than 
180°. This is because MicroStation always dimensions angles in a counter-clockwise 
direction, if I had identified the slanted line first, I would have gotten the angle that 
was greater than 180°. 
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Dimension Arc Length 
This tool allows for dimensioning an arcs length with a radial dimension (Figure 23-16). 

 
Figure 23-16: Dimension Arc Length 
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STRUCTURAL DETAILING TASKS 
The Structural Detailing component of the Tasks (Figure 23-17) is set up to help us 
control level, style, color, and weight of elements that we place on our drawings as we draw 
details.  Select Maine DOT WorkGroups > Construction from the Main Menu to access 
the Structural Detailing tasks.  From the Tasks Menus, select ConstructionGroup > 
BridgeAS > Structural Detailing. 

 
Figure 23-17: Structural Detailing Tasks 

Nuts and Bolts 
Selecting any component from the Structural Detailing portion of the Tasks does a number 
of things. 

Most of the components set you active color, level, style and weight. You can watch these 
attributes change on your Attributes tool box (Figure 23-18).  

 
Figure 23-18: The Primary Tool Box 
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The only exception to this is the Hidden component, which only changes your style to 
dotted and weight to thin. (This allows you to draw a Hidden line of any of the other types: 
Abutment, Framing, etc.) 

Some Typical Uses 

 New Elements: 
Probably the most common workflow will be simple. Decide what kind of detail you’re 
working on. See which Tasks best corresponds to the work you’re going to be doing, and 
pick that item from the Tasks Menus. This will set up the proper Symbology and level for 
you.  

 Symbology is MicroStation’s collective term for color, style and weight.  

Now choose your drawing commands (place circle, place SmartLine, etc.,) and start 
drawing. 

 Changing Existing Elements: 
You’ll also use the Structural Detailing Group for cleaning up elements that may have 
been drawn wrong. Maybe you constructed lines parallel to a centerline, and now you need 
to change them to an Abutment style.  

From the Tasks Menus, select ConstructionGroup > BridgeAS > Structural Detailing > 
Abutments to set the appropriate level, color, style and weight.  

Then, choose the Change Attributes tool either from the Main Tool Tasks or from the 
Menus (Qualities > Change > All). This will prompt you to Identify Element. Pick the 
element that you want to change. (Make sure to Accept the change by entering a Datapoint.) 

Adding New Detailing Types 
If there is a detail type that you think needs to be added, please bring it to the attention of 
your support group. 
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CHANGING DETAIL SCALE 
So you’ve finished drawing up your detail. You’ve got it all dimensioned. You’ve got it all 
annotated. Now you’ve changed your mind about what scale you need to use, and all your 
text, dimensions, and line styles look wrong.  

No Quick Solution 
There’s no one-step program to fixing this problem. It’s going to take some work. But here 
are the things you need to do: 

Scale 
First off, let’s make sure you pick your new scale. From the Drawing Scale dialog, pick 
your new scale (Figure 23-19). 

 
Figure 23-19: Pick a Drawing Scale 

 Check page 2-25 for more information on the Drawing Scale. 

Text 
Now let’s get the text out of the way. You’ve already got a lot of text on the drawing; you 
just need to change it. We’re still going to start by going to the Tasks Menus and choosing 
your Workgroup > Plan > Prop. Text and Dims > Text Note (Figure 23-20). 
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Figure 23-20: Proposed Text and Dimension Tasks 

This will open up the Text Editor (Figure 23-21). 

 
Figure 23-21: The Text Editor 

It opens up because that Task launched the Place Text command. We’re not going to use the 
Place Text command, however. Go to your Main Menu and choose Text > Update Text. 
(This is the same as the Change Text Attributes command (Figure 23-22) from the Text 
tool box.). 
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Figure 23-22: Change Text Attributes 

This tool is used to change the Text Attributes of an existing text item. The status bar will 
prompt you to “Identify Element.” Go around your detailing, picking on all the text that 
needs to be changed. Or, if you prefer, place a fence that encompasses all of the text items 
that you want to change and check off the Use Fence option in your Tool Settings Window. 
This will let you change a whole bunch of text items at once.  

Once that’s done, you’re going to notice that some of the text doesn’t fit into spaces where it 
used to fit, or text will overlap other text or parts of the detail. This is going to require some 
cleanup. I recommend the Main Menu Zip > Move to move text items back into place. 
Make sure to use AccuDraw to keep them in proper horizontal and vertical alignment. 

Dimensions 
We’re going to use a similar procedure for all the dimensions that need to be changed. First, 
go to the Tasks Menus and choose the dimension Task that corresponds to the dimension 
that you need to change.  

Once you have selected a Task, MicroStation is going to launch a Place Dimension 
command. We’re going to ignore that command and go on to select Update Dimension 
either from the Dimension Tasks (Figure 23-23) or from the Main Menu Dimension > 
Update.  
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Figure 23-23: The Dimension Tasks 

This command works very similar to the Change Text Attributes command. It will prompt 
you to identify a dimension to change. Go around your detail, picking on every dimension 
that needs to be updated to your current settings. Note that there is no way to change a fence 
full of dimensions at once. However, you can use the Element Selection tool to pick a whole 
bunch of dimensions, and then issue the Update Dimension command to change the whole 
lot of them. 

Linestyles 
The last thing that needs to be changed may not be obvious at first. Your Arrow and Bullet 
linestyles should always be the same size relative to your text. So if your text size changes, 
you should make sure to change your line styles as well.  

Do this by going to the Tasks Menus, select your Workgroup > Plan > Symbols & 
Linestyles > Bullet (Figure 23-24). 
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Figure 23-24: Structural Line Styles 

This will set your active settings appropriately. It will also issue the Place SmartLine 
command. Again, we’re going to ignore the command launched by the Tasks Menus and go 
on to select Change Element Attributes.  

This can be selected from the Main Tool Tasks or from the Main Menu Qualities > 
Change > All. Now identify each line that needs to be changed. 

Speeding up the Process 
It is possible to use the Select By Attributes command from the Edit menu (Figure 23-25) to 
speed up the process of selecting elements that need to be changed.  

 
Figure 23-25:Select By Attributes 
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This utility allows you to select elements by Level, Symbology, and Type (Line, Arc, etc.)  

 Refer to page 2-35 for a thorough discussion of Selecting by Attributes. 
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TEXT TASKS 
One of the primary functions of the Tasks Menus is to help us control text size on details of 
various scale. We have programmed a number of text settings into the Tasks Menus. They 
are accessed through the Prop. Text and Dims Group. 

A Word on Scale 
Before you place text on a detail, make sure that you have determined what scale you want 
that detail plotted at. Make sure you have used the Main Menu, select Settings > Drawing 
Scale.   
 Check page 2-25 for more information on the Drawing Scale. 

Text Components 
There are basically four different types of text we’ll be placing on our drawing. All of our 
annotation will be done with the Text Note option. This sets up our standard normal text 
size and activates the text placement command. The other text size options are the Title 
Text options: Title Text and Title Text (Underlined) and the Sub-Title Text.  

 It is no longer necessary to underline text by drawing a line underneath it. 
MicroStation will automatically underline text for you. If you are going to place a 
detail label, make sure to use the Underlined option.  

There may be cases where you want larger text that is not underlined, and that is where the 
Title Text Task comes in, also you may find an instance where you want a text size that falls 
between our standard normal size and the title text size. This is when the Sub-Title Text 
option would be handy. 

Behind the Scenes: The Long Way Around 
What are these Tasks really doing for you? They are setting up text attributes like font, 
height and width. To see the changes that are made when you select the text Tasks, open up 
the Text Dialog by choosing Element > Textstyles from the Main Menu (Figure 23-26). 
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Figure 23-26: The Text Styles Dialog 

Placing Text Annotation 
Much of the text that we’re going to be placing on our drawings is going to be in the form of 
annotation: a label with an arrow or bullet that extends to a detail. We have decided to 
approach this matter as simply as possible. First, place your text around your detail. Then, 
from the Tasks Menus, select one of the Text Note linestyles (like Text Note Arrow). 

 Selecting the Note/Linestyle component does two things. First off, it sets your active 
color, style, weight and level -- just like the Structural Detailing Task. Second, it 
runs the Place SmartLine command. 

MicroStation is now ready to help you draw a leader line from your text to your detail. Use 
AccuDraw and your snaps to control the geometry of the leader line (Figure 23-27).  

 
Figure 23-27: Sample Leader Line 
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Some Difficulties 
First off, you can’t snap to text in a very useful way for placing notes. The only points you 
can snap to on text are the origin, the center, and the midpoint. These probably aren’t going 
to help you locate the perfect spot to start placing your leader lines. This means eyeballing is 
the answer. 

Changing Your Mind About Scale 
If you change your mind about the scale that a detail is going to be, it’s going to screw up 
your text. There’s no way around it.
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  MMHHPPCC  DDOOCCUUMMEENNTTAATTIIOONN  
Quick Punch List 

• Create a MHPCPlan.dgn using Make Sheetz 
• Copy or Place New Clip Boundaries 
• Create Cut Sheets 
• Run Border Macro 
• Place Legend 
• Edit Sheet Info. (Title Only) 
• Send to Color Plotter 
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VIEWING A PROJECT USING MHPC COLOR 
SCHEME 

Step One: Start MicroStation V8i 
Double-click your MicroStation V8i icon. Click the Project pull-down and pick on your 
PIN. Select EnvPlan.dgn from your list of files and click OK. 

 Picking your project from the pull down should bounce you to your project’s 
Environ\MSTA folder. If it doesn’t, contact CADD Support. 

Step Two: Creating a MHPC File 
Go to File > Make Sheetz. When the dialog opens, select “No Prefix” and pick “Environ” 
as your workgroup (Figure 24-1). Click OK. 

 
Figure 24-1: File Prefix and Workgroup Selected 

From the list of available drawings pick MHPCPlan and click OK (Figure 24-2). This 
creates the new file and opens it. 

 
Figure 24-2: Select MHPCPlan 
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Step Three: Adjust Background to White 
Select Workspace > Preferences from the Main Menu. In the next dialog, select View 
Windows from the left side of the dialog. On the right, place a check in the Black 
Background->White box. Click OK (Figure 24-3). 

 
Figure 24-3: Preference set to White Background 

Check your colors for accuracy. Sometimes you will find that standardization is not 
followed and you will need to adjust the colors of levels in a reference file or two. Do this in 
this file. 

 Please refer to 24-9 for more information on Changing colors Manually. 

 If your color scheme doesn’t appear to be correct, make sure that your view 
attributes (Settings > View Attributes) has Level Symbology enabled. It should set 
correctly by default. Contact CADD Support for more assistance. 

 In attempts to stabilize this process, we created a pen table that will not use 
Symbology. Instead, the pen table will adjust colors at plot time only. If the colors do 
not appear to be accurate using Symbology, instead, turn off Symbology and hit the 
Print Icon. Browse to the correct plotter and attach the “MHPC-no symbology” pen 
table. Use your preview in the print dialog to see if the colors are better represented. 
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CREATING MHPC PLAN SHEETS 
Step One: Temporarily Attach HDPLAN or BDPlan.dgn 

(Optional) 
As a time saver you can use another programs Clip Boundaries instead of placing your own 
manually. Depending on the type of project Bridge or Highway, use File > Reference DOT 
> Attach and browse to the appropriate groups \MSTA directory and select bdplan.dgn or 
hdplan.dgn. No logical is needed, set the nesting to Copy Attachments and depth to “0” 
(or use No Nesting) and click OK. 

 If there aren’t any clip boundaries in the bdplan.dgn or the hdplan.dgn, you will have 
to place your own boundaries manually.  

Step Two: Copy Clip Boundaries 
Now we need to merge the clip boundaries into the active file. This will produce clip 
boundaries for the MHPC plans that cover the same area as the plans sheets for the project. 
This procedure is assuming that you want a MHPC plan for every plan sheet. If you only 
need a MHPC plan for specific areas on your project, place clip boundaries manually in your 
active file as you would when creating the normal plan drawings. 

 Refer to page 12-5 for the procedure on placing clip boundaries manually. 
In the Reference File dialog, highlight the reference file (**plan.dgn) then select Tools > 
Merge Into Master from the Menu Bar. Now you will be prompted to select a view by 
clicking a data point anywhere on your top view. An informational dialog will open telling 
you that you are about to merge one reference file into the current design file. This is what 
you want to do. Select OK to start the procedure. Refresh your window to update the view 
in order see your clip boundaries in the active file. 

Step Three: Create the Cut Sheets 

 Part One: Activate Macro 
From the Tasks Menus, select your Workgroup > Plan > Create Plan Sheets > Create 
Cut Sheets.  

 Part Two: Supply Starting Number 
It asks you what number you want to use for the starting number of the MHPC plan sheets 
(Figure 24-4). Use the default “1”. This will appear in your border as your sheet number.  
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Figure 24-4: Start Numbering At? 

 Part Three: Sit Back and Watch 
When the program is finished, it will drop you back into MHPCPlan.dgn. Open up the files 
you’ve just created and see how they look! 

Step Four: Troubleshooting 
If you open a MHPC plan sheet drawing and the graphics within the sheet are not correct, it 
could mean that one the drawings that is referenced in is not at the same Global Origin as 
the other drawings. If the graphics aren’t aligned with your border, try and re-cut the sheets 
again. It won’t be necessary to place new boundaries. Normally this will fix the problem. 
See CADD Support for assistance if needed. 
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EDITING MHPC PLAN SHEETS 
Step One: Run the Border Information macro 
The Border contains variables that can be replaced by a macro. It is not necessary to edit 
anything on this drawing that contains a $ or @ (i.e., $TOWNORCITY$). Select Macros > 
Border Information to run the macro. Process all of your sheets.  

 Please refer to PCF Editing on page 1-67 if the variables do not get filled in with 
the proper information. 

Step Two: Place MHPC Legend 
Select Settings > Drawing Scale from the Main Menu. Set the scale to 1 in. = 25 ft. or 1 in. 
= 50 ft..  From the Tasks Menus, select your Workgroup > Plan > Create Plan Sheets. 
(Figure 24-5).  

 
Figure 24-5: Create Plan Sheets 

Select MHPC Legend from the Create Plan Sheets menu (Figure 24-6). 

 
Figure 24-6: Pick MHPC Legend 

Place the cell down where you want it with a left mouse click. 
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Step Three: Edit the Plan Type in the Title Box 
The only text that needs to be edited on the border is the word “PLANS”. Select Text > Edit 
Text from the menu and click on the word PLANS. When it highlights, click again to 
accept. When the Text Editor window opens, type MHPC in front of the words PLAN and 
hit Apply. Right Click to stop editing the text. 

Step Four: Repeat as Necessary 
Repeat Step One and Step Two on all of your ###_MHPCPlan#.dgn drawings. 
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ADJUSTING COLORS MANUALLY IN REFERENCE 
FILES 

Sometimes you will find that standardization is not followed and you will need to adjust the 
colors of levels in a reference file or two.  

 In attempts to stabilize this process, we created a pen table that will not use 
Symbology. Instead, the pen table will adjust colors at plot time only. If the colors do 
not appear to be accurate using Symbology, instead, turn off Symbology and hit the 
Print Icon. Browse to the correct plotter and attach the “MHPC-no symbology” pen 
table. Use your preview in the print dialog to see if the colors are better represented. 

If you need to adjust the symbology (colors) of a reference files, do this in the 
MHPCPlan.dgn file and the change will reflect on all of your plan sheets. Open your Level 
Manager by selecting Settings > Level Manager from the Main Menu (Ctrl+L). Make sure 
that the Symbology pull down is set to Overrides. 
Use Quality > Analyze Element and click on the element in question to find out what 
reference file the element resides in and the level it is on. 

In the example below (Figure 24-7), the topo.dgn has two levels, UTILS AERIAL and 
WTLND_RARE VEG, that are the wrong color. They should be color “14”. Expand the 
directory tree on the left and select topo.dgn. Select a single or multiple levels on the right 
and click on either of the color boxes. A color chart will open (Figure 24-8) allowing you to 
pick the color to change it to. Click on the color to see the number associated to it. Click 
OK.  

 
Figure 24-7: Example of selecting two levels within the topo reference file 
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Figure 24-8: Example of selecting a new color for a level(s) within a reference file 

Select File > Save Settings to save the adjustment. 
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PRINTING MHPC PLANS SHEETS 
Step One: Open Print Organizer Dialog 
Select File > Print Organizer from the Main Menu.  

Step Two: Add Design Files 
Select File > Add Files to Set from the Print Organizer menus. Click the Add button. Select 
all of your numbered MHPCplan drawings. Click Done. 

Step Three: Select a Printer Style 
Click the magnifying glass (Browse) Print Styles field on the Create Print Definitions 
dialog. Choose US_HPCOLORRoom303.  

Step Four: Select a Display (Pentable) 

 Pentable that uses Level Symbology 
Click the Manually Specified Options button on the Create Print Definitions dialog. This 
will bring up the Print Definition Creation Options dialog. Click the Main tab on the Print 
Definition Creation Options dialog.  Click the magnifying glass (Browse) next to the Pen 
table field. Choose Color_MHPCplans and click Open. This pen table utilizes Level 
Symbology. 

 Pentable without Level Symbology 
 Click the Manually Specified Options button on the Create Print Definitions dialog. This 
will bring up the Print Definition Creation Options dialog. Click the Main tab on the Print 
Definition Creation Options dialog.  Click the magnifying glass (Browse) next to the Pen 
table field. Choose MHPC-no symbology and click Open. This pen table does not utilize 
Level Symbology. Test this using method below. 

 In attempts to stabilize this process, we created a pen table that will not use 
Symbology. Instead, the pen table will adjust colors at plot time only. If the colors do 
not appear to be accurate using Symbology, instead, turn off Symbology and hit the 
Print Icon. Browse to the correct plotter and attach the “MHPC-no symbology” pen 
table. Use your preview in the print dialog to see if the colors are better represented. 

Step Five: Send the Plots 
Click the printer icon or select File > Print from the Print Organizer dialog menu to send 
all sheets to the plotter. 

If you don’t want to send them all, highlight only the files you want to plot. At this point you 
can send just the ones you have selected. Click OK. 
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  WWEETTLLAANNDD  PPLLAANNSS  
Quick Punch List 

• Copy or Place New Clip Boundaries 
• Use Others or Create Cut Sheets 
• Run Border Macro 
• Send to Color Plotter 

Need to Find Wetland Drawings? 
The wetlands should be automatically attached if they were surveyed with the original 
topo.dgn or if the Topoadd and Textadd files have been cleaned up and merged properly. If 
not, they were picked up with other means (GPS) and they may be residing in a Topoadd_# 
and Textadd_# files sitting in the Survey/MSTA folder. Browse to the Survey/MSTA and 
open the Topoadds to see which one contains the wetland information. There may be an 
OrigWetlands file in the folder. In either case, these files need to be cleaned-up and either 
merged into the topo.dgn or copied into the topo folder. 

 Users should refer to Chapter 6 Survey Clean-up and treat an OrigTopoAdd_# and 
OrigTextAdd_#  file as “Additional Topo Clean-up” (6-27). 

 Users should refer to Chapter 6 Survey Clean-up and treat an OrigWetlands as 
“Initial Wetlands Clean-up” (6-40). 

For a quick plot use File > Reference (DOT) Attach and attach the files directly from the 
Survey\MSTA folder to your EnvPlan.dgn or Wetlands-clips.dgn using Coincident World 
method. These files will not stay attached for future plotting as the Survey folder is not 
recognized as a valid path to reference files. Consider cleaning up these files to avoid this 
from happening.  

 In the near future, there will be a separate drawing for wetlands. Cleaning up the 
wetlands.dgn will be the responsibility of the Environmental staff. Details of the 
cleanup will be in Topo Cleanup section of this manual. The wetlands.dgn will be 
attached to EnvPlan.dgn and Wetlands-clips.dgn by default, however there are many 
old projects that will require the users to attach it manually. The wetlands.dgn will 
exist in the Survey\MSTA folder within your PIN and will be copied into your topo 
folder and cleaned up. Additional wetlands will be handled very similar to the 
Topoadds. 

 Please refer to 6-40 for information on Wetlands cleanup. 
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PLOTTING WETLAND PLANS FOR BIOLOGIST’S 
(USING OTHERS PLAN SHEETS) 

Introduction 
When plotting wetlands for checking purposes, it may be easier to use the plan sheets cut by 
another workgroup as opposed to creating your own. You can open someone else’s plan 
sheets (i.e., 011_hdplan1.dgn or 005_bdplan1.dgn) to check and see if the information you 
need is displayed on them. If topo cleanup is done properly, wetland lines and flags should 
be displayed. If not, you can ask the Program (Urban and Arterial, Bridge or Regional) to go 
through the process of cleaning up the additional topo and text files or consider cleaning 
them up yourself. 

Step One: Start MicroStation V8i 
Double-click your MicroStation V8i icon. Click the Project pull-down and click on your 
PIN. 

Step Two: Open Any Drawing 
Select any file in your list of files in your workgroups \MSTA folder (i.e., EnvPlan.dgn). 
Click OK to open it. 

Step Three: Printing - Create a New Print Set 

 Part One: Open Print Organizer Dialog 
Select File > Print Organizer from the Main Menu. 

 Part Two: Add Design Files 
Select File > Add Files to Set from the Print Organizer menus. Depending on the type of 
project and who has cut the plan sheets, browse to the workgroup’s MSTA folder (i.e., 
highway\MSTA or bridge\MSTA). Select all of the plan sheet drawings (i.e., 
011_hdplan1.dgn or 005_bdplan1.dgn). Click the Add button. Click Done. 

 Part Three: Select a Printer Style 
Click the magnifying glass (Browse) Print Styles field on the Create Print Definitions 
dialog. Choose US_OCE9800FULL or US_OCE9400FULL. Click OK. 

 Part Four: Select a Display (Pentable) 
Click the Manually Specified Options button on the Create Print Definitions dialog. This 
will bring up the Print Definition Creation Options dialog. Click the Main tab on the Print 
Definition Creation Options dialog.  Click the magnifying glass (Browse) next to the Pen 
table field. Choose graysurvey_wetlands and click Open. 
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 Part Five: Save your Print Set 
Select File > Save As… and give you Print Set a logical name so you can print it again if the 
need arises (i.e., Wetland_ck_OCE9800.pset). 

 Part Six: Send the Plots 
Click the printer icon or select File > Print from the Print Organizer dialog menu to send 
all sheets to the plotter. 

If you don’t want to send them all, highlight only the files you want to plot. At this point you 
can send just the ones you have selected. Click OK. 
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CREATING WETLAND PLAN SHEETS FOR 
BIOLOGIST’S 

Introduction 
If you are required to create plan sheets for checking Wetlands and are unable to get what 
you need through another workgroups existing plan sheets, you can place your own clip 
boundaries or copy another workgroups clips into the Wetlands-clips.dgn without effecting 
other work to be done in the file (i.e. Army Corps. 8 ½ x 11 sheets).  

Step One: Create a Wetlands-clips Drawing 
It is now necessary to create a Wetlands.dgn within the ENVIRON\MSTA folder to create 
cut sheets for the Wetlands. Use the File > Make Sheetz macro to create a Wetlands-
clips.dgn file. Select “No Prefix” and select “Wetlands-clips” from the list of available 
drawings. Hit Cancel to stop making sheets. 

Step Two: Temporarily Attach HDPLAN or BDPLAN.dgn 
(Optional) 

As a time saver you can use another programs Clip Boundaries instead of placing your own 
manually. Depending on the type of project Bridge or Highway, use File > Reference 
(DOT) > Attach and browse to the appropriate groups \MSTA directory and select 
bdplan.dgn or hdplan.dgn. No logical is needed, set the nesting to Copy Attachments and 
depth to “0” (or use No Nesting) and click OK. 

 If there aren’t any clip boundaries in the bdplan.dgn or the hdplan.dgn, you will have 
to place your own boundaries manually. 

 Refer to page 12-5 for the procedure on placing clip boundaries manually. 

Step Three: Copy Clip Boundaries 
Now we need to merge the clip boundaries into the active file. This will produce clip 
boundaries for the Wetland plans that cover the same area as the plans sheets for the project. 
This procedure is assuming that you want a Wetland plan for every plan sheet. If you only 
need a Wetland plan for specific areas on your project, place clip boundaries manually in 
your active file as you would when creating the normal plan drawings. 

 Refer to page 12-5 for the procedure on placing clip boundaries manually. 
In the Reference File dialog, highlight the reference file (??plan.dgn) then select Tools > 
Merge Into Master from the Menu Bar. Now you will be prompted to select a view by 
clicking a data point anywhere on your top view. An informational dialog will open telling 
you that you are about to merge one reference file into the current design file. This is what 
you want to do. Select OK to start the procedure. Refresh your window to update the view 
in order see your clip boundaries in the active file. 

Step Four: Create the Cut Sheets 
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 Part One: Activate Macro 
From the Tasks Menus, select your Workgroup > Plan > Create Plan Sheets > Create 
Cut Sheets.  

 Part Two: Supply Starting Number 
It asks you what number you want to use for the starting number of the Wetland plan sheets. 
Use the default “1” (Figure 24-9). This will appear in your border as your sheet number.  

 
Figure 24-9: Start Numbering At? 

 Part Three: Sit back and watch 
When the program has finished, it will drop you back into Wetlands.dgn. Open up the files 
you’ve just created and see how they look! 

 Live Nesting 
What is Live Nesting? This is a new method in MicroStation V8 of attaching a file with 
references to another file like our border sheets. By using Live Nesting you no longer need 
to use the old methods of Batch > Attach and Batch > Settings to manipulate the way you 
want your cut sheets to appear for plotting purposes. Now if you want to turn off certain 
levels, adjust displays of reference files or attach/detach additional reference files, you can 
simply do this in your source drawing (i.e., Wetlands-clips, HDPlan, BDPlan, Envplan, etc.) 
and all of your border files will be displayed in the same manner.  

Step Five: Troubleshooting 
If you open a Wetland plan sheet drawing and the graphics within the sheet are not correct, 
it could mean that one the drawings that is referenced in is not at the same Global Origin as 
the other drawings. If the graphics aren’t aligned with your border, try and re-cut the sheets 
again. It won’t be necessary to place new boundaries. Normally this will fix the problem. 
See CADD Support for assistance if needed. 

Step Six: Printing - Create a New Set 

 Part One: Open Print Organizer Dialog 
Select File > Print Organizer from the Main Menu. 

 Part Two: Add Design Files 
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Select File > Add Files to Set from the Print Organizer menus. Select all of the plan sheet 
drawings you just created (i.e., 001_Wetlands1.dgn). Click the Add button. Click Done. 

 Part Three: Select a Printer Style 
Click the magnifying glass (Browse) Print Styles field on the Create Print Definitions 
dialog. Choose US_XEROX6279BFULL or US_XEROX6204FULL. Click OK. 

 Part Four: Select a Display (Pentable) 
Click the Manually Specified Options button on the Create Print Definitions dialog. This 
will bring up the Print Definition Creation Options dialog. Click the Main tab on the Print 
Definition Creation Options dialog.  Click the magnifying glass (Browse) next to the Pen 
table field. Choose graysurvey_wetlands and click Open. 

 Part Five: Save your Print Set 
Select File > Save As… and give you Print Set a logical name so you can print it again if the 
need arises (i.e., Wetland_ck_XEROX6279B.pset). 

 Part Six: Send the Plots 
Click the printer icon or select File > Print from the Print Organizer dialog menu to send 
all sheets to the plotter. 

If you don’t want to send them all, highlight only the files you want to plot. At this point you 
can send just the ones you have selected. Click OK. 
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  AARRMMYY  CCOORRPP..  DDOOCCUUMMEENNTTAATTIIOONN  
Quick Punch List 

• Cross Hatch Areas 
• Measure Areas/Place Text 
• Place 8 ½ x 11 Clip Boundaries 
• Create Cut Sheets 
• Run Border Macro 
• Send to Color Plotter 
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CROSS HATCHING WETLANDS 
Introduction 
This section is intended to provide assistance with some of the tasks related to the 
production of plans for submittal to the Army Corp. of Engineering. There are many ways to 
do the same thing in MicroStation, however to create standardization and efficiency, we 
encourage you to follow the steps outlined below. 

Step One: Start MicroStation V8i 
Double-click your MicroStation V8i icon. Click the Project pull-down and pick on your 
PIN. Select EnvPlan.dgn from your list of files and click OK. Click your Fit View icon. 

Step Two: Locate the Wetlands 
Check and see if the information you need is displayed on your EnvPlan.dgn. If topo 
cleanup is done properly, wetland lines and flags should be displayed. If not, you can ask the 
Program (Urban and Arterial, Bridge or Regional) to go through the process of cleaning up 
the additional topo and text files or consider cleaning them up yourself. 

 In the near future, there will be a separate drawing for wetlands. Cleaning up the 
wetlands.dgn will be the responsibility of the Environmental staff. Details of the 
cleanup will be in Topo Cleanup section of this manual. The wetlands.dgn will be 
attached to EnvPlan.dgn by default, however there are many old projects that will 
require the users to attach it manually. Use File >Reference (DOT) > Attach and 
attach them to your EnvPlan.dgn using Coincident World method. 

Step Three: Lock “Z” to Zero 
From the Main Menu, select Settings > Locks > ACS Plane Snap.  Key-in az=0 in the Key-
in dialog and press Enter. Click in the CAD View. 

 This will prevent MicroStation from jumping to elements at different depths in the 
file. 

Step Four: Set the Drawing Scale 
Select Settings > Drawing Scale from the Main Menu.  From the list of available scales, 
select the scale that you intend on plotting your sheets. Normally a good scale that is still 
legible on 8 ½ x 11 plan sheets is 1” = 50 ft. for U.S. Customary.  

Step Five: Cross Hatching Wetlands 

 Part One: Select Hatching 
From the Tasks Menus, select your Workgroup > Plan > Patterning > 45^Hatching for 
“Wetland Impacts” or use Patterning > 45/135XHatching for “Wetlands of Special 
Significant Impacts”. (These types coincide with the legend on the 8 ½ x 11 plan sheets.) 

 Part Two: Set Hatching Method 
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The setting in the Hatch Area or Cross Hatch Area dialog should be correct based on the 
Scale set in the Drawing Scale dialog. Adjust the Method to Points (Figure 24-10). 

 Using Points method instead of Flood will place a bounding element around the area 
you are hatching which will allow you to label the areas all at once. 

 
Figure 24-10: Hatch Area/Cross Hatch Area Dialog Settings 

 Part Three: Create Hatch Area 
Using AccuDraw and the available snap methods, hit the intersection and the vertices of the 
elements that bound your area. Right click when you’ve hit them all to finish the command. 

 If you have missed a point and need to add a vertex or want to modify and existing 
vertex, use the tools in the Modify Tool Box to accomplish this. Because we used 
Associative Patterning, the pattern will adjust itself to the new shape.    
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ADDING FILLED SHAPES 
Step One: Set the Shade Type 
Select Patterning > Shade 20% (or another degree of shade). By Default, the settings for 
this tool should be correct. 

Step Two: Create the Shape 
Using AccuDraw and the available snap methods, hit the intersection and the vertices of the 
elements that bound your area. Return to beginning point or hit Close Element to end 
command. 

 If you have missed a point and need to add a vertex or want to modify and existing 
vertex, use the tools in the Modify Tool Box to accomplish this.    

Step Three: Reset the Fill Type 
If you are finished using the Shape command, you need to tell MicroStation to stop using 
Opaque fill otherwise future areas or hatching that you do will be filled solid. To do this, 
select Qualities > Change > Fill from the Main Menu. 

 
Figure 24-11: Change Fill Type to None 

  In the dialog (Figure 24-11), change Fill Type to None. 
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MEASURING AREAS AND PLACING TEXT 
Step One: Lock “Z” to Zero 
From the Main Menu, select Settings > Locks > ACS Plane Snap.  Key-in az=0 in the Key-
in dialog and press Enter.  Click in the CAD View.   

 This will prevent MicroStation from jumping to elements at different depths in the 
file. 

Step Two: Set the Drawing Scale 
Select Settings > Drawing Scale from the Main Menu. From the list of available scales, 
select the scale that you intend on plotting your sheets. Normally a good scale that is still 
legible on 8 ½ x 11 plan sheets is 1” = 50 ft. for U.S. Customary. 

Step Three: Set the Text Attributes 
From the Tasks Menus, select your Workgroup > Plan > Prop. Text and Dims>Text 
Note. This will set your text to the correct height, width, color, level, style and weight. 

Step Four: Open Measure Area Tools 
Select Measure > Area Tools from the Main Menu. A new set of tools should open. 

In the rightmost tool in the Tool Box (Figure 24-12), set some Parameter Settings. 

 
Figure 24-12: Area Parameter Settings 

 Part One: Set the Default Text Font 
While in the Text tab, set the Font to 123 dotitalics (Figure 24-13). This is the only setting 
necessary on the tab. 
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Figure 24-13: Adjust Text Font to 123 dotitalics 

 Part Two: Set the Default Prefix 
Click on the Prefix tab (Figure 24-14). Add a prefix that you would like to use (i.e., 
Wetlands = ). You’re limited to ten characters. 

 
Figure 24-14: Add a prefix 

 Part Three: Set the Default Suffix 
Click on the Suffix tab (Figure 24-15). Add a suffix that you would like to use. (i.e., s.f.). 
You’re limited to ten characters. 
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Figure 24-15: Add Suffixes 

Step Five: Select by Attributes 
You can select all of your hatched areas, measure and label them all at once with one click 
to the screen. 

Select Edit > Select By Attributes from the Main Menu. Select Tools > Set Select By from 
Element in the Select by Element dialog box. Click on one of the hatched areas. Click again 
to Accept. Now hit Execute. This should highlight all of the hatched areas. 

 If you want to measure and label shaded area, you will have to select one of those 
areas and hit execute to select them all. 

Step Six: Select Measure Area Tool 
From the Area Tools toolbox (Figure 24-16), select Measure Area. 

 
Figure 24-16: Measure Area Tool 

Configure area tool for the method, prefix and suffix. Select Element from the Method pull 
down and place a check in the Prefix and Suffix boxes and select the corresponding pull 
down and pick one of your preset options. Click in your view to Accept the command.  

This should label all of your areas. The orientation of the text will be horizontal to your 
current view window which means you will have to rotate and possibly move text. Use the 
Rotate Element tool and set method to either 2 points or 3 points. Follow the prompts. 

 If you cannot see the text for your areas, check that you have done all the steps in this 
section. 
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Step Seven: Select None 
Select Edit > Select None to unselect your hatching. Close the Select by Attributes dialog 
and click Cancel to tell MicroStation to stop filtering by the hatched attributes. 

Step Eight: Edit the Text (Optional) 
You can use the Edit Text tool to add additional verbiage to your area text. While the text is 
in your Text Editor window, you can click on another type of text placement such as Place 
Note (Figure 24-17). This will allow you to point with an arrow to small areas that cannot be 
labeled clearly.  

 You may have to select a dimension placement from your Tasks Menus first in order 
for the arrowhead to be filled in.  

 
Figure 24-17: Place Note tool 

Consider changing the default setting of the tool and selecting Box as a Text Frame (Figure 
24-18). This will make your text stand out and if masking is required, it will make it easy to 
place a fence around your text. 

 
Figure 24-18: Using a Box text Frame 

Place the text and delete the old text. 

Step Nine: Masking References (Optional) 
 If the text you placed is obscured by reference files, place a fence around your text and 
select File > Reference (DOT) > Clip > Mask > All if you want to mask all elements in 
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all references or File > Reference (DOT) > Clip > Mask > Single and click on the specific 
reference file you want to mask. Click on the view to Accept. 
Or, you can also open your reference file dialog and highlight the specific reference file(s) 
you want to mask and select Tool > Clip Mask. 
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CREATING 8 ½ X 11 CUT SHEETS 
Step One: Set Category Scale 
Select Settings > Drawing Scale from the Main Menu. Select the scale you want to use for 
your cut sheets. 1 in. = 50 ft is a good scale to use. This scale will still allow the stationing 
and existing text to be legible. This should be the same scale you used to place your text for 
the areas. 

Step Two: Place 8 ½ x 11 Clip Boundaries 
From the Tasks Menus, select your Workgroup > Plan > Create Plan Sheets > Place Clip 
Boundary 8.5x11. You will have a rectangle on your cursor waiting for placement. You are 
holding the portrait page by the bottom edge of an 8 ½ x 11 piece of paper. With your first 
click, place the boundary along the centerline and move your cursor up-station to rotate the 
page. Click again to define the amount of rotation. Continue placing boundaries for the 
length of your project. 

 You can stop at any time (by right clicking) and move and/or rotate your boundaries. 
Restart the placement if necessary. 

 You must keep the boundaries in order! This will determine the creation order of the 
cut sheets. 
 Refer to page 12-3 for the procedure on placing clip boundaries manually. 

Step Three: Create the Cut Sheets 

 Part One: Activate Macro 
From the Tasks Menus, select your Workgroup > Plan > Create Plan Sheets > Create 
8.5x11 Cut Sheets.  

 Part Two: Supply Starting Number 
The macro asks you what number you want to use for the starting number of the cut plan 
sheets. Use the default “1” (Figure 24-19). This will appear in your border as your sheet 
number (consider using “2” if you plan on including a Title Sheet, “3” if you plan on having 
a Layout sheet). 

 
Figure 24-19: Start Numbering At? 
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 Part Three: Sit back and watch 
When the program has finished, it will drop you back into EnvPlan.dgn. Open up the files 
you’ve just created and see how they look! 

Step Four: Troubleshooting 
If you open a plan sheet drawing and the graphics within the sheet are not correct, it could 
mean that one the drawings that is referenced in is not at the same Global Origin as the other 
drawings. If the graphics aren’t aligned with your border, try and re-cut the sheets again. It 
won’t be necessary to place new boundaries. Normally this will fix the problem. See CADD 
Support for assistance if needed. 

Step Five: Run the Border Information macro 
The Border contains variables that can be replaced by a macro. It is not necessary to edit 
anything on this drawing that contains a $ or @ (i.e., $TOWNORCITY$). Select Macros > 
Border Information to run the macro. Process all of your sheets.  

 Please refer to PCF Editing on page 1-67 if the variables do not get filled in with 
the proper information. 
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CREATE A TITLE SHEET 
Step One: Create a Title Sheet 
Using File > Make Sheetz, create a title sheet. 

 Refer to page 7-1 for more information on creating a title sheet. 
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CREATE A LAYOUT DRAWING 
Step One: Open EnvPlan 
Open the drawing that contains your Cut Sheets (i.e. EnvPlan.dgn). 

Step Two: Create Saved View 
Create a Saved View called Layout. 

 Refer to page 7-5 for more information on creating a saved view. 

Step Three: Create 002_Layout Drawing 
Using File > Make Sheetz, create a numbered drawing called Layout. 

 Refer to page 1-57 for more information on creating drawings. 

Step Four: Attach Saved View  
Select File > Reference (DOT ) > Attach and attach the drawing that contains your saved 
view. Set the scale based on the number of clips boundaries in combination with the scale in 
which you placed them. In this example, 10 (clip boundaries) x 600 (scale of the clips) = 
6000 (scale of the reference attachment). Set the Nesting to Copy Attachment 1. 

 Refer to page 2-72 for more information on attaching, scaling and rotating your 
saved view.  

Step Five: Adjust Level Display (if necessary) 
Users may want to limit the levels that are displayed and drawings displayed to better 
represent the layout drawing. 
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PRINTING 8 ½ X 11 CUT SHEETS 
Step One: Open Print Organizer Dialog 
Select File > Print Organizer from the Main Menu. 

Step Two: Add Design Files 
Select File > Add Files to Set from the Print Organizer menus. Select all of the plan sheet 
drawings you just created (i.e., 001_EnvPlan1.dgn). Click the Add button. Click Done. 

Step Three: Select a Printer Style 
Click the magnifying glass (Browse) Print Styles field on the Create Print Definitions 
dialog. Choose the appropriate Printer Style. Click OK. 

Step Four: Select a Display (Pentable) 
Click the Manually Specified Options button on the Create Print Definitions dialog. This 
will bring up the Print Definition Creation Options dialog. Click the Main tab on the Print 
Definition Creation Options dialog.  Click the magnifying glass (Browse) next to the Pen 
table field. Choose the appropriate Pentable and click Open. 

Step Five: Save your Print Set 
Select File > Save As… and give you Print Set a logical name so you can print it again if the 
need arises (i.e. EnvPlan_ArmyCorp_printer.pset). 

Step Six: Save your Batch Print job 
Select File > Save As… and give you Batch Print a logical name so you can print it again if 
the need arises (i.e. EnvPlan_ArmyCorp_printer.job). 

Step Seven: Send the Plots 
Click the printer icon or select File > Print from the Print Organizer dialog menu to send 
all sheets to the plotter. 

If you don’t want to send them all, highlight only the files you want to plot. At this point you 
can send just the ones you have selected. Click OK. 

 This Print Style will send your plots to the printer associated with the Print Style. 

 

. 

 

 





mdot MicroStation 

01/01/12 

Geotechnical Plan 
Development 

25-1 

 

CChhaapptteerr  2255  GGeeootteecchhnniiccaall  
PPllaann  DDeevveellooppmmeenntt  

To be documented in the future.
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CChhaapptteerr  2266  PPuubblliicc  
HHeeaarriinngg  PPllaannss  

To be documented in the future.
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  PPAACCKKAAGGIINNGG  AA  MMIICCRROOSSTTAATTIIOONN  
FFIILLEE((SS))  ––  ((VVEERRSSIIOONN  88  AANNDD  HHIIGGHHEERR))  

This document is intended for the general user as a guideline to creating a “snapshot” of a 
project as it has reached a critical stage that needs to be preserved or as a means to transfer 
design files to a consultant that does not have our resource (line styles) and cell libraries 
copied into their MicroStation configuration. In a sense, an archive is a zipped up copy of 
your original file or files and all reference attachments. It compacts the files into a single file 
about half the size of all files uncompressed. 

The MicroStation Packager can package a single or multiple design files, with or without all 
of their reference files. A good example is a plan sheet. If you package a plan drawing (i.e., 
011_HDPlan1.dgn), the Package Utility can include all files that need to be packaged to 
reproduce the drawing. You can also include Workspace items like cell libraries, line styles, 
fonts and more, however, if the files are going to be used in-house, we will always be using 
our configuration so these options do not need to be stored in the package. If the package is 
going to be shared with consultants, these options will display our files with our symbology. 
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PACKAGING SINGLE OR MULTIPLE FILES 
Step One: Open File to Package (Archive) 
Open MicroStation. Pick your project from the project pull down. Open a file.  

 If you are packaging a single file, open that file. If you are packaging multiple files, 
it doesn’t matter which file that you open. 

Step Two: Open Packaging Utility 
From the main menu, select Utilities > Packager… . This opens the Welcome dialog 
(Figure 27-1). Select Next. 

 
Figure 27-1: Create Package Welcome dialog 

Step Three: Enter Package Name 
Use a name that will identify the project from others. A good standard to follow is the PIN-
TownName (i.e. 8467-Topsham). Do not use decimals in the file name. It is not necessary to 
enter a description, but it could be helpful to identify at which milestone it was archived. 
Select Next. 

Step Four: Select Design Options 
Select which design options you want to use. Normally, Reference Files is the only box you 
want to check (Figure 27-2). Select Next. 

 
Figure 27-2: Design Options 
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 If you have images in your drawings, you will want to select Raster Reference Files 
also. If the package was going to be shared with consultants, you may want to 
include other options so it will be displayed correctly with our symbology.  

Step Five: Gather Design Data 
In this step (Figure 27-3), it gives you the option to select the Current Design File, Current 
Directory or Browse to select multiple files to Package. Remove the check mark in the 
Recursive box. This will prevent the Packager from digging down from the current directory 
into sub directories for design files. Make your selection, wait for it to finish processing, and 
then select Next. 

 
Figure 27-3: Create Package dialog – Recursive un-checked 

Current Design File – This option will package the current design file with its reference 
files. 

Current Directory – This option will package all MicroStation design files, AutoCAD 
.dwg and .dxf files. 

Browse – This option allows you to select single or multiple design files to package. Use the 
Ctrl key on your keyboard to pick multiple files. 

Refresh – This will refresh the list of files you have selected. If you uncheck a file that you 
do not want to be packaged, you must hit Refresh to remove it from the dialog window. 

Step Six: Select Workspace Options 
Normally we want to uncheck all of the Workspace Options (Figure 27-4). If the file(s) is to 
be shared with a consultant that doesn’t use our configuration, you may want to select all of 
these options. Make your selection and select Next. 
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Figure 27-4: Workspace Options 

Step Seven: Review Selections 
This is the last opportunity to change your selections (Figure 27-5). You can still hit the 
Back button to go back through the steps. A few extra files get generated automatically. Do 
not delete these files. If all looks good, select Next. 

 
Figure 27-5: Review Selections dialog 

Step Eight: Packaging Options 
This step gives you the opportunity to adjust the location of the package file (Figure 27-6). 
The defaults are usually good unless you want to change the path to another folder location. 
Select Next. 

 
Figure 27-6: Adjust Path Options 

 The Retain Design History box is to include the Design History of a file. It is 
basically a history of changes that have happened to the files. It is only as good as 
the information typed in by a user. (Full V8 files only).  

Step Nine: Finish 
Select Finish to begin the Packaging process. 
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  OOPPEENNIINNGG  AA  MMIICCRROOSSTTAATTIIOONN  VV88  
PPAACCKKAAGGEE  ((..PPZZIIPP))  FFIILLEE  

It is not necessary to have MicroStation open during the extraction process, however it 
won’t matter either way. These files can also be opened with any Zipping utility (i.e., 
WINZip).  
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EXTRACTING A PACKAGE FILE 
Step One: Locate Package File 
Browse to the location of the package file using Windows Explorer. The file has a .pzip file 
extension. 

Step Two: Open the Package File 
Double click the file to open it. The Properties tab (Figure 27-7) gives you a brief rundown 
of the file.  

 
Figure 27-7: properties Tab in the PZIP 

The Entries tab (Figure 27-8) displays the files that have been packaged. 

 
Figure 27-8: Entries Tab 
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Step Three: Set the Location for Extraction of Files 
Notice the Extract To Directory portion of the dialog (Figure 27-8). Adjust the path to suit 
your needs by typing the new path or by hitting the Browse button. 

 If you do not change the directory, you will not overwrite any existing files. It 
creates a folder structure of its own within the target folder. 

Step Four: Extracting the Package File 
Click the Extract button (Figure 27-8). When Prompted to “Launch MicroStation?”, click 
No. (Figure 27-9) 

 
Figure 27-9: Do Not Launce MicroStation – Click No 

  If you say yes, MicroStation will be opened, however, it will not use any of our 
configuration files, therefore will not have our symbology. 

Step Six: Finding the Extracted Files 
When the files are extracted, they are placed in the folder you specified in Step Three, 
however, it creates a series of subfolders within the target folder. (i.e., 
Y:\PIN\8467\00\Highway\MSTA\Workspace\projects\Topsham-8467\dgn). In this 
example, the characters in bold type represent the new folders created. 

Step Seven: Opening, Moving or Copying the Extracted 
Files 

Open the extracted files by select No Project from the Project pull down. You will have to 
browse to the files because they are buried in a subfolder. Because all the files live in the 
same folder, they will automatically display all of its reference files.  

Use Windows Explorer to Move or Copy the files to a desired location. One possibility of its 
use is to replace files that have been corrupted, changed unintentionally, etc. 
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  PPRROOJJEECCTT  WWRRAAPP  UUPP  
This portion of the MicroStation Manual is intended to provide the general workflow of a 
project once it has been completely designed and detailed in accordance to the MaineDOT 
standards. It makes reference to many topics already described in previous chapters of the 
manual. As opposed to duplicating this information, we briefly describe the steps involved 
and reference the pages where we describe the topic in great detail. The Sheet Re-numbering 
Utility, the Border Information macro, Print Organizer and the MicroStation Packager will 
be used in this chapter. 



mdot MicroStation 
01/01/12 

Finalizing a Project 

28-3 

 

RE-NUMBERING UTILITY 
Overview 
MaineDOT uses a 3 digit prefix followed by an underscore “_” on every .dgn file that is 
going to be placed in a printed plan package. After the underscore is a standard, sheet type 
identifier (i.e. 001_title.dgn). Sometimes this is immediately followed by numbering for 
sheets of similar types (i.e., 011_HDPlan15.dgn). 

 For a complete list of acceptable file names, please refer to the CADD Webpage at: 
http://www.maine.gov/mdot/caddsupportmsinroads/inroadsnaming.htm . 

With the MaineDOT configuration, we take the 3 digit prefix and use it as the page number 
that appears in the title block for each sheet. Therefore, each drawing with the 3 digit prefix 
has a border in it. We have a custom program called the Sheet Renumbering Utility to make 
it easier to renumber/rename your sheets to get them in the correct order. All MicroStation 
users should have this program installed at the same time MicroStation is installed. Contact 
CADD Support if this program is not installed. 

 Regional offices that produce projects that are partially a book job and partially a 
plan package should still use this numbering sequence, but only on the sheets that are 
going to be printed for the final contract drawings. All other areas that are covered 
by the book portion of the project should have the 3 digit prefix stripped from the file 
name. This can be accomplished easily by using the Sheet Renumbering Utility.  

 Do not create sub folders to separate the two portions of a Book/Plan Package. All 
final MicroStation drawing should remain in your workgroup’s /MSTA folder.  

Step One: Start Re-numbering Utility Program 
If the Ying-yang icon is not on your Desktop, you can launch the program by selecting Start 
> Programs > MDOT Utilities > MDOT MicroStation Sheet Renumbering Utility. 

 Close all MicroStation files and be sure that no one is accessing files in your 
workgroups MSTA directory. The program needs to rename the files and cannot if 
someone has one open. 

Step Two: Arrange Files 
Arrange the files that are going to be submitted in the correct ascending order that they will 
fall in the plan package. 

Step Three: Renumber Files 
Click on Renumber Plot Files and the program will place or replace the 3 digit prefix with 
the number in which it falls in the list. 

 Please refer to page 1-62 for more detailed instructions on the Sheet Renumbering 
Utility. 

http://www.maine.gov/mdot/caddsupportmsinroads/inroadsnaming.htm�
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Coordinate ROW Plans or Other Plans 
After the last page number of the plan package is known, let the Right of Way team member 
(or other workgroup) know what number to start numbering his or her plan set with. They 
will then run the Renumbering Utility on their plans. It may be necessary for them to 
Remove the prefixes from their plans (not the colored version) and open Windows Explorer 
and manually add the first number and underscore (i.e., 242_) to the first file name in the 
ROW plan set. In the example above, this will add 241 placeholders prior to the first file. 
Adding this manually would be very time consuming.  
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BORDER INFORMATION MACRO 
Overview and Benefits 
The Border Information macro is used to write the page number into the drawing’s title 
boxes. It also handles placement of many other variables. If this macro isn’t run, many of the 
variables will get filled in automatically at plot time, however, without running the macro, 
the border still retains variables (i.e., @SHEET@, $TOWNORCITY$, $PINNUMBER$, 
etc.) and would get archived that way. 

The benefits are many with this macro. All common title box information is entered only 
once and the macro will populate all the title boxes in all of the border drawings in a matter 
of minutes. If a variable needs to be changed, it can be updated just as fast.  

Step One: Launch MicroStation 
Launch MicroStation from the icon on your desktop or from the Start menu. Select your 
project from the Project pull down. 

Step Two: Select a Numbered File 
Select a file in the list with a 3 digit prefix and an underscore. Click OK. 

Step Three: Launch Border Information Macro 
From the Main Menu select Macros > Border Information. 

 If you get warning stating that you need to “Close MicroStation and choose a project 
(PIN) that is consistent with your file location” (Figure 28-1), it means that you 
entered MicroStation incorrectly. This is a safety measure to insure that the user is 
going to write the correct information into the title boxes. This is all based on the 
Project pull down matching the PIN you are working on. Close MicroStation if you 
get this error and go back to Step One and try again. If you still get an error, contact 
CADD Support personnel.  

 
Figure 28-1: Close MicroStation and pick correct PIN. 

Step Four: Single or All 
If you don’t get an error, you will be asked if you want to Change Current File or Change 
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Project Files. This will enable you to process just a single file or process all of the files in 
the directory that meets the 3 digit prefix requirement. Make your selection. 

Step Five: Review List 
There is an opportunity to review and remove any files from the list of drawing to be 
processed. 

Step Six: Process Drawings 
Click Cancel to process the list of drawings. This usually takes less than 5 minutes even on 
long jobs. 

 Refer to page 1-69 for more information on the Border Information Macro. 
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CLEANUP MSTA DIRECTORY 
All Projects (In-house, Regional and Consultant) 
We would like to preserve the drawings that are used in the plan set (Sheet Files) and those 
used to build the plan set (Reference Files). Drawings that were used temporarily, for 
example, the portion of a book job or unused alternatives, should be deleted if not needed. 
The best time to clean up a project directory is immediately after working on the project 
while you’re still familiar with it. According to the General Consultant Agreement (GCA), 
consultants are required to submit electronic files in addition to hard copies. Please treat 
these projects as if they were designed in-house. 

 Please refer to page 32-1 for more information on Consultant Coordination of 
CADD drawings. 

Delete Temporary files 
Throughout the life cycle of a project, additional cross sections are sometimes produced, the 
design may have been sent in two pieces, multiple alignment files are combined into one file 
and a project could be shortened removing a number of drawings. Any drawings, 
spreadsheets, or text files in the MSTA directory that are not needed and are not referenced 
should be deleted or moved into an “old” folder. Any MicroStation files with a .bak, .old, 
.xxx, etc., can be deleted as they are no longer needed. 

Delete Old Folders 
We create a folder named “old” as a temporary storage bin for copies of older versions of 
files until we know the newest version is OK. If you are certain that all files that are needed 
are in the MSTA directory and only junk exists in the old folder, delete the old folder. If you 
are uncertain of the necessity of the contents of the “old” folder, leave it alone or have 
someone more familiar look at it. If space on the server ever becomes an issue, we could 
delete all “old” folders in the whole PIN structure programmatically.  
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FINAL PRINTING 
Send Title Sheet for Signatures 
The title sheet is the only sheet in the plan package that needs hand written signatures. 
Circulate the hardcopy to the appropriate team members. There is a location on every plan 
page for an Engineer to stamp each sheet if necessary.  This will only occur if a certain 
portion of the plan set was approved by an Engineer other than the one approving the 
Highway or Bridge work. Otherwise, the Engineer Stamp on the Title Sheet governs the 
internal plans in the plan package.  

Once all team members have signed the Title Sheet, deliver it to the Chief Engineer’s Office 
for the final stamp and signature. 

Scan the Title Sheet and Others 
Any sheet that has an Engineer stamp and signature will need to be scanned to the project’s 
CONTRACTS folder (i.e. Y:\PIN\12671\00\CONTRACTS) by the Reproduction staff to be 
included in the final plan package as a PDF document and/or .tiff image.  

 If the PIN number doesn’t contain a CONTRACTS folder or if the permissions to the 
folder will not allow you to scan to the folder, contact CADD Support and the 
permissions will be adjusted. 
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CREATE A MULTI-PAGE PDF  
Overview 
We will use MicroStation’s Print Organizer to create a multi-page PDF file. This will 
provide a viewable plan set to anyone that has a computer and the free Adobe Reader 
software. This also provides a PDF file available for posting on the web for on-line bidding. 

 A .pdf file is only a “snapshot” of the file at its present state. Any changes made to 
the MicroStation file will not be represented in the .pdf without recreating it.  

Printing to a Multi-page PDF 

 Step One: Open Print Organizer 
Select File > Print Organizer from MicroStation’s Main Menu. If you have a saved Batch 
Print “.job” file or Print Set file (.pset) of your final plans, select that one using File > 
Open.  

 Step Two: Add Files 
Select File > Add Files to Set and add the files you want to print. The list of files should 
include all drawings with a 3 digit prefix. These are the drawings with a border to be 
included in the final plan set. Browse to the ROW/MSTA folder and select all 3 digit prefix 
drawings with the exception of a plan set used for presentation purposes. These are 
identified by a higher numbering sequence than the plan package set and are followed by the 
c_RWPlan root file name. If there are other workgroups submitting plans for the plan 
package, select these sheets also (provided that they have been numbered correctly). Select 
File > Save As… and save the Print Set file (.pset) as PIN- FinalPlans. The name of the 
PDF file will be the same as Print Set file name. 

 Step Three: Apply the Printer Style 
Select Tools > Apply Print Style from the Print Organizer dialog. Select the US_pdf-
fullsize printer from available Print Style Names (Figure 28-2).  
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Figure 28-2: Selecting a printer from the Printer Setup. 

 

 Step Four: Print to Multi-Page PDF 
Select File > Print… from the Print Organizer dialog (Figure 28-3). 

 
Figure 28-3: Select File > Print from the Print Organizer dialog. 

 Step Five: Add PDF File Name 
When the Print dialog opens, enable the All option (Figure 28-4). Click the magnifying glass 
button.   
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Figure 28-4: Browse to the Contracts folder of your PIN. 

Browse to your project’s CONTRACTS folder (Figure 28-5). Click OK. 

 
Figure 28-5: Browse For Folder dialog.   

Once the path has been set, it will be displayed in the Print dialog (Figure 28-6). Select OK 
to start the printing. 
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Figure 28-6: Print dialog with the path established. 

The multi-page PDF file will be created in the CONTRACTS folder. 
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ACTIVATE DESIGN HISTORY 
Overview 
After the PDF is created, we want to activate Design History on all of the files in your 
Workgroups MSTA directory. What this does is it establishes a point in the files that 
MicroStation can restore to. From this point on, anyone that makes a change in the file will 
need to commit their changes and document a description of the change or exit without 
committing the changes. This will ensure that any unintentional changes made to any of the 
files can restore back to the Contract deliverables. Any changes made to the legally binding 
electronic drawings will need to be more deliberate. 

Activating Design History in the drawing files will allow the use of the same set of drawing 
files for most of the life-cycle of a project from conception to bid letting. Way too often files 
get altered by the time ROW plans are shipped to the registry for recording. 

 Design History will enable users to roll-back any changes made to a file at any point 
during the design process. We are enabling Design History at the time of plan 
submittal to Contracts. In the future, we may enable Design History in every file as a 
PIN is created. 

 For more information on Design History, please refer to MicroStation Help.   

Avoiding Errors 
If your MicroStation Preferences are set to Save Settings on Exit, you will get an error when 
running the Batch Processor. It’s recommended that you disable this setting temporarily 
prior to running the Command File. Select Workspace > Preferences from the Main Menu 
and select Operation. Uncheck Save Settings on Exit. Click OK. 

Step One: Open Batch Process 
From the Main Menu, select Utilities > Batch Process… to open the Batch Process dialog 
(Figure 28-15). 

Step Two: Select Command File 
We created a standard command file for the purpose of activating Design History for all files 
in your workgroup’s directory after a Contract Submittal. This file also sets a description in 
the Design History that describes the milestone. Select the magnifying glass to browse to the 
C:\!msV8iconf\standards\data folder nod select Set Design History.txt Command File. 
Click OK. 
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Figure 28-7: Batch Process Dialog. 

Step Three: Add Files 
From the Batch Process dialog menu, select Edit > Add Files… and select all MicroStation 
design files (.dgn’s) in your workgroup’s MSTA folder.  

Step Four: Select All Files 
Select all files in the list. 

Step Five: Process Files 
Select File > Process… from the Batch Process dialog or click the Process Batch Process 
Job button (Figure 28-16). 
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Figure 28-8: Batch Process dialog displaying Process Batch icon. 

Step Six: Review Selection – Click Process 
A new dialog will appear displaying all the files (Figure 28-17). Click Process to start the 
command. Each file will open and run the command specified in the command file. When 
the process is complete, the Process button will change to a Done button. Close the Batch 
Process dialog. 

 
Figure 28-9: Files to process dialog. 

 It is not necessary to Save the Batch Process session. This is easily created again if 
the need arises. 
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MICROSTATION PACKAGER 
Overview 
The MicroStation Packager is a utility used as a means of creating a “snapshot” of a project 
as it reaches a critical stage that needs to be preserved. The Package is a zipped copy of your 
original files and all reference attachments. It will compact the files into a single “.pzip” file 
about half the size of all files uncompressed.  
 The .pzip file extension can be renamed to “.zip” and opened with any zipping 

software (WinZip or Windows XP’s Compressed Folder Utility) if the need arose. 

Step One: Start MicroStation V8i 
Launch MicroStation V8i from the icon on your desktop or from the Start menu. Select 
your project from the Project pull down. Select a file in the list with a 3 digit prefix and an 
underscore. Click OK. 

Step Two: Create New Package 
Select Utilities > Packager… from MicroStation’s main menu. This opens the Create 
Package dialog (Figure 28-18).  Click Next. Figure 28-18 
 Figure 28-10: MicroStation Packager's Welcome screen. 

Step Three: Enter Package Name 
Use a name that will identify the project from others. A good standard to follow is PIN-
SubmittalType (i.e., 12345-FinalPlans). Do not use decimals in the file name. It is not 
necessary to enter a description in the Description field, but it could be helpful to identify at 
which milestone it was archived (Figure 28-19). Click Next.  

 
Figure 28-11: Enter the Package Name and Description 

Step Four: Select Design Options 
Select which design options you want to use (Figure 28-20). Normally, Reference Files is 
the only box you want to check. Click Next. 
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Figure 28-12: Select Reference Files as the only Design Option 

Step Five: Select Project Files 
The Add Designs button allows the user to Browse and select the files you want to package. 
Select all of the 3 digit prefix files in your workgroup’s MSTA directory used for the final 
plan set (Figure 28-21). Select Open. 

 
Figure 28-13: Browse and select all 3 digit prefix drawings only 

 Browse to the ROW/MSTA folder and select all 3 digit prefix drawings with the exception 
of a plan set used for presentation purposes. These are identified by a higher numbering 
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sequence than the plan package set and are followed by the c_RWPlan root file name. If 
there are other workgroups submitting plans for the plan package, select these sheets also 
(provided that they have been numbered correctly). 

Uncheck the Recursive option so that all files will fall within a single folder instead of 
reproducing the original folder structure. 

Step Six: Unselect Workspace Options 
Uncheck all of the Workspace Options.  
 If the files are to be shared with a consultant that doesn’t use our configuration, you 

may want to select all of these options. Make your selection and click Next. 

Step Seven: Review Selections 
This is the last opportunity to change your selection. You can still select the Back button to 
go back through the steps. A few extra files get generated automatically. Do not delete these 
files. If all looks good, click Next. 

Step Eight: Package Options 
This step gives you the opportunity to adjust the location of the package file. The defaults 
are usually good unless you want to change the path to another folder location. Place a check 
in the Retain Design History box if not already checked. Click Next. 

Step Nine: Finish 
Click Finish to begin the Packaging process. 
 
 For more detailed instructions on MicroStation Packager, please refer to page 27-

1. 

Step Ten: Extract Archive to Contracts Folder 
Once the Package has been created it needs be extracted to your PIN’s \Contracts folder. 
This will provide Contracts with the drawings that are needed to be archived into Digital 
InterPlot for future document retrieval via the intranet Webpage. Using Windows Explorer, 
locate the MicroStation Package (.pzip) file that should be in your workgroups MSTA folder 
(i.e., 12345-FinalPlans.pzip). Double-click the file and you will see a dialog describing the 
package. Adjust the “Extract To Directory” path by clicking the Browse button. Set the path 
to your PIN’s \Contract folder. Click Extract and you will be prompted to “Launch 
MicroStation?”  Select NO. 

Step Eleven: Notify Contracts 
Once the files are extracted to the Contracts folder, notify someone in that section so they 
can apply proper permissions to the folder to prevent accidental editing of the final contract 
plans. 
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AMENDMENTS OVERVIEW 
Overview 
Occasionally revisions need to be made to the plans after the contract has been advertised. 
Sometimes the problem can be remedied by an Amendment to the contract book, other times 
the change(s) needs to be made on the plans. This portion of the manual will instruct users 
on how to deal with these changes or Addendums which are now being called Amendments. 

Edits 
It is necessary to “cross out” graphics and notes for all items that have changed. New 
features will be entered using the Tasks Menus as normal workflow dictates. A revision 
triangle should be added with a revision cloud if necessary so that all changes are apparent 
to those who have the original set of plans. If the compounded changes result in obliteration 
of the sheet, the word VOID should be written across the page and a full replacement sheet 
provided. 

Incrementing Sheets 
All sheets that have been changed will have a new sheet designation. This is done by adding 
a letter suffix to the original sheet number in the bottom right hand corner of the sheet and 
the actual filename. If the original sheet number was 3, then the revised sheet number will 
be 3A. Likewise, if the original filename was 003_Typical02.dgn, then the new filename 
will be 003A_Typical02.dgn.  

Place Copies with Originals 
When the Amendments are complete, only the files adjusted will be copied into the 
CONTRACTS folder with the rest of the Contract Plans for the project.  
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USE FILES IN WORKGROUP’S MSTA FOLDER 
Overview 
Users should always use the “Legally Binding” original set of drawings that were printed for 
the bidding process. Working on the files requires that the original set were unaltered since 
the final printing. The potential of someone editing or adjusting a file since the final printing 
is high. By applying Design History to all files in the workgroup’s MSTA directory, this 
gives users a record of changes to any given file (if any were made) and the opportunity to 
undo those changes resorting back to the original set at time of Final Plans. If a file has been 
altered since it was printed, the user will receive a warning saying that someone else has not 
committed changes to the file, would you like to take over the changes. The user may review 
the Design History to view a description of changes made if someone made a change 
deliberately. The user can determine what changes have been made and visually see and 
undo the changes. Likewise, when a user consciously makes a change considered to be an 
Amendment, they are prompted to enter a short description of the change. 

If the user doesn’t want to rely on these files because too many changes may have been 
made, the .pzip can be re-extracted into the workgroup’s MSTA directory to recover the 
original files. This places all original files needed to re-generate the final plans into a sub 
folder. A restore can also be done from backup tapes if necessary. 

 For more information on Design History, please refer to MicroStation’s internal 
HELP. 

Saving the Files – Commit Design Changes 
When a user exits a file that has been edited, the Commit Changes dialog opens waiting for a 
description of the change (Figure 29-1). It’s a must to enter a brief description. If the user 
plans on making many changes and wants to enter the description later, he or she can select 
Cancel and still save the changes to the file. Remember to return to the file and make a note 
of the overall changes. 

 
Figure 29-1: Add a brief description to the Commit Changes dialog 
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 If users have their Preference set so that they Save Settings on Exit, they will receive 
this message regardless if a change has been made to the file. Consider removing this 
preference by selecting Workspace > Preferences from the MicroStation Main 
Menu and adjusting the Operation category by un-checking the Save Settings on Exit 
option. 

Adding Elements with the Tasks Menus 
Make all the changes that are needed as you normally would during the design phase within 
the proposed design files (i.e., Highway, Bridge, Alignment, etc.). 

Some additional cells (Revision Triangles), line styles (Cross Outs and Revision Clouds) 
and text (Revision Text) have been added to help the changes stand out from original data. 
These items, when printed in color, will be printed green. 

 When editing the sheet files (files beginning with a 3 digit prefix) remember that 
some sheets do not contain any editable graphics besides the border elements. These 
will be the “plan view” Sheets, Geometric Sheets (Curb Layout Sheets) and 
Structural Detail sheets. The “plan area” visible in Plan Sheets actually reside in 
other files. These changes will need to be made in the proposed design file(s) (i.e., 
Bridge.dgn, Highway.dgn, Multimode.dgn, Alignments.dgn, etc.). Structural details 
usually reside in a “z_” file.  

Add Revision Triangles 

 Overview 
If changes span a number of plan sheets, each and every sheet affected by the change needs 
to have a revision triangle, date, description and initials. If the change on a “plan view” sheet 
can be handled with a note or additional graphics, then it would be OK to work on the 
individual plan sheet drawings.  

 Revision Triangles 
Each collective change that is made needs to be marked with a triangle that is numbered. If a 
new cross pipe is added to a project, the numbered triangle that represents the change in plan 
view is the same number that will be used on the Cross Section, Estimate Sheet and 
Drainage Sheet for that specific change. Each of the respected sheets needs the triangle 
label. If Riprap is also added to the pipe ends, this item will also use the same numbering as 
the plan view drawing. If a ditch, driveway, catch basin is relocated a new number is 
assigned to the triangle. Select the Maine DOT WorkGroup of ConstructionGroup, then 
the correct sub task (i.e. PlanAS) > Symbols & Linestyles > As-Built Triangle (Large) 
and left-click to place.  To place a triangle in the Signature Block, select As-Built Triangle 
(Title Block). Select Qualities > Drop > Complex (Cell, Chain, etc.) from the Main Menu 
and left-click on the triangle, and left-click again anywhere in the view to Accept the 
command. Use the Edit Text tool or select Text > Edit Text from the Main Menu to edit the 
text within the revision triangle. 
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Revision Clouds 
A revision “cloud” can also be used to better display the area that has changed if it isn’t 
completely apparent with just a revision triangle. Place revision clouds by using the Tasks 
Menus. Select the Maine DOT WorkGroup of ConstructionGroup, then the correct sub 
task (i.e., PlanAS) > Symbols & Linestyles > Revision Cloud and left-click to place a 
shape encompassing the area of change. 

Signature Blocks 
Every file in the list with a 3 digit prefix has a border with a signature block. U.S. 
Customary borders have been expanded to accommodate more revisions whether they are 
Amendments or As-builts. There are lines in the signature block dedicated to revisions and a 
single box for Field Changes (Figure 29-2). The Field Changes section is reserved for the 
governing signatures of the revisions. This is where the Project Manager, Asst. Project 
Manager or Resident would sign the plans as final approval of the As-built plans.  

 
Figure 29-2: US Customary signature block with revision triangles 

Metric plan sets may require an expansion to the signature block to cover the revisions 
(Error! Reference source not found.). Use a variety of MicroStation tools to accomplish 
this. 

Additional Sheets 
When a new sheet needs to be added into the plan package, whether it’s a full replacement 
or a sheet unintentionally left out, it should fall after the sheet that it normally would and 
labeled using the letter “A” as an increment to the sheet number (i.e. 11A). The file name 
will also use the letter “A” as an increment (011A_HDPlan01.dgn). 
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Rename and Copy Files to Contracts Folder 

Part One: Rename Sheets That Contain Changes 
Once all the changes to the plan set have been made, and all sheets have been labeled with 
revision triangles and page numbering updated, open Windows Explorer and manually add 
the letter suffix to the filenames of any sheet that has a revision (i.e., 011A_HDPlan01.dgn, 
101A_XSMC10_dr_001.dgn, etc.). Do not change the file extension or rename a file 
without a border, only a 3 digit prefix drawing.  

 Do not rename any other files besides the sheet type drawings. These are the drawings 
that begin with a 3 digit prefix followed by an underscore. Do not rename “z_” files or 
the state plane correct files (i.e. highway.dgn, bridge.dgn, alignments.dgn, etc) as their 
standard file names are important to maintain. 

 Copy Files into Contracts Folder 
Notify the Contract Section that the Amendments have been made. They may need to adjust 
permissions to allow you to place the new files into the CONTRACTS folder of the PIN. 
Select all new sheet files that have changed. They all will have a letter “A” as the suffix on 
the sheet number. Select all the additional drawings that have had changes made to them. 
These additional may be files such as Bridge.dgn, Highway.dgn, Rwplan.dgn, 
Alignments.dgn, etc. Viewing the modified date on the files may help you tell the 
difference.  

Once all the files that have had revisions have been selected, select Edit > Copy from the 
menu. Browse to the CONTRACTS folder within your PIN (i.e., 
CONTRACTS\Workspace\Projects\12671_FinalPlans\dgn). Select Edit > Paste from the 
menu. You will be prompted to overwrite some files. Select Yes. 

Printing a Multi-page PDF 
All Amendments needs to be mailed out to all original bidders and added to the web page 
for on-line bidding. Using MicroStation’s Print Organizer, select all of the revised sheets 
and print them to a new multi page PDF file. Browse to the CONTRACTS folder and 
supply a standard name that includes the PIN-Amendments01.pdf (i.e., 12345-
Amendments01.pdf) to describe the new document. Notify the Reproduction staff that the 
Amendments are available for printing. 

 Refer to page 28-10 for instructions on creating a multi-page PDF. 

Print Amendments 
The Amendment plans can be printed a variety of ways, but are most efficiently printed 
from the PDF document to the OCETDS800 by the Reproduction staff or anyone with 
Adobe writer software. Rotation of the Vertical Cross Sections may be necessary. 

 Refer to page 28-13 for instructions on rotation when printing the multi-page 
PDF.
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OVERVIEW 
Overview 
A Change Order is issued when changes are needed on the plan set during the Construction 
phase of your project. This Change Order may require re-engineering a structure, retaining 
wall or other detail. Because this project has already been awarded, the revisions made to the 
plan set now will be considered As-Built plan work. The work performed on the files will 
be done in the Const/MSTA folder as a standard.  

The electronic As-Built drawings will be printed using the MicroStation drawings directly 
into the Digital InterPlot Archive and will be printed in color. When printed, all As-Built 
elements will be red, any Amendments will be printed green, existing topography will be 
gray, and the design and Right of Way elements will be black.  

Some final “paper As-Builts” may not get transferred into electronic As-Builts, but if they 
are done using the same concepts and written with RED ink or dark RED pencil, they can be 
scanned in color and placed into the Digital InterPlot Archive. The end product of either a 
scanned paper or an electronic As-Built will be nearly identical when view through a web 
browser. 

 Until electronic signatures are accepted by MaineDOT’s Legal Division and the 
State’s Archivist, plan sheets that require an Engineer’s stamp and signature will 
need to be hand editing (using red pen or dark red pencil) and re-scanned to preserve 
the legal binding document. When the multi-page PDF is created from the electronic 
CADD files, the sheets that have been re-scanned can replace the sheets without 
signatures. 
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RETRIEVE THE LATEST PLAN SET 
Overview 
To work on the plans for a Change Order, we want to start off with the latest plan set. If 
previous steps are followed properly, the CONTRACTS folder should contain the latest plan 
set with the latest revisions (Amendments). These files will be copied into the Const/MSTA 
folder. 

Copy Contracts Folder Contents to Const/MSTA Folder 
Using Windows Explorer, browse to your projects CONTRACTS folder and browse 
internally to the MicroStation files (i.e., 
CONTRACTS\Workspace\Projects\PIN_FinalPlans\dgn). Select all of the files in this 
folder. Select Edit > Copy. Browse to your PIN’s Const/MSTA folder. Select Edit > Paste.  

End Result 
Use the documentation that follows to make the edits for the Change Order. The end result 
will be all contract plans will exist in the CONTRACTS folder and all of the Change 
Orders/As-Built plans will exist in the CONST/MSTA folder for ease of Archiving through 
Digital InterPlot. 
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CHANGE ORDER/AS BUILT GENERAL 
WORKFLOW 

Overview 
The files adjusted will be considered the start of As-Builts for the project. Each change will 
be labeled with a revision triangle, encompassed with a revision cloud if necessary for 
clarity and the border initialized with a short description of the change, revision number and 
date. 

The As-Built tools are under the Maine DOT WorkGroup drop-down Task Menu of 
ConstructionGroup.  The correct sub task needs to be selected next (SectionAS, ProfileAS, 
PlanAS or BridgesAS), this will help users get the elements on the desired level.  

Launch MicroStation V8i 
Launch the MicroStation V8i icon on your desktop or from the Start menu. In the 
Workspace portion of the dialog, use the pull-down next to the User and select Const. This 
will point you to the Const/MSTA folder of the PIN you pick from the Project pull-down. 
Pick your PIN from the Project pull down. Verify that you are now pointing to the path to 
your PIN’s Const/MSTA folder. 

Construction WorkGroup 
We have a Construction WorkGroup that will be used when conducting Change Order/As-
Built mark-ups. This will automatically load based on the User selection being set to Const. 
The As-Built work done on the paper copy of the plan set will be reproduced using the Tasks 
Menus and a combination of MicroStation tools. 
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MAKING CORRECTIONS 
Overview 
This section of the manual was interpreted from a Construction Manual dated 2002. We will 
use these guidelines for doing As-Builts on paper or electronically using our CADD 
package. 

An extra set of full size plans will be furnished to the Resident for use as As-Built plans. The 
Resident may request an additional set of plans from the MaineDOT’s reproduction room 
for As-Builts if needed. Preparation of As-Built plans done on paper shall be done using 
RED pen or DARK RED pencil only. The As-Built plans shall be an exact representation of 
the completed work. All revised plan sheets and sheets with no change must be included in 
the complete As-Built plan set. The Estimate Sheet needs to be corrected to show the Final 
Quantities including additional items of work. 

Saving the Files – Commit Design Changes 
When a user exits a file that has been edited, the Commit Changes dialog opens waiting for a 
description of the change (Figure 30-1). It’s a must to enter a brief description. If the user 
plans on making many changes and wants to enter the description later, he or she can select 
Cancel and still save the changes to the file. Remember to return to the file and make a note 
of the overall changes. 

 
Figure 30-1: Add a brief description to the Commit Changes dialog 

 For more information on Design History, please refer to MicroStation’s internal 
HELP. 

 If a user has their Preference set so that they Save Settings on Exit, they will receive 
this message regardless if a change has been made to the file. Consider removing this 
preference by selecting Workspace > Preferences from the MicroStation main 
menu and adjusting the Operation category by un-checking the Save Settings on Exit 
option. 

 



mdot MicroStation 
01/01/12 

As Built Drawings 

30-7 

 

Title Sheet/Others 

 Updating Sheets with Signatures 
Some sheets in the plan set may have required signatures and stamps by an Engineer. These 
sheets will require hand written adjustments in either red pen or dark red pencil. 

The title sheet shall bear the following label in some convenient blank space: AS-BUILT 
PLANS. The initial box will also include who the work performed by (Contractor, if more 
than one contract has been let to complete the work, list all prime contractors), the person 
who prepared the As-Builts (listed in the Revisions box) and the approving signature by the 
Project Manager in the FIELD CHANGES section. 

 Scan the Sheets 
These sheets will need to be re-scanned by the Reproduction staff directly to individual 
PDFs and placed into the CONST\MSTA folder. They will need to be included in the As-
Built multi-page PDF document. 

 This process will be required until electronic signatures are accepted by the Legal 
department and the State’s Archivist. 

Editing the Proposed Design 

 Overview 
Lines, dimensions and notations shown in the original plans which have been eliminated or 
corrected shall be "X ed" (crossed out) and encompassed with a revision cloud. The 
ConstructionGroup Tasks Menu contains the same tools and settings that a detailer or 
designer used throughout the life cycle of a design with the addition of some Line Styles and 
Symbols to help standardize the look of As-Built drawings. Select the correct sub task 
(SectionAS, ProfileAS, PlanAS or BridgesAS), then expand Symbols and Linestyles from 
the left side of the Task Menu and select one of the tools. 

 Adding “As Built” Elements 
In the past, dashed lines were used to indicate any as-built lines, dimensions, or tie points 
which do not conform to the original plans. Now, all As-Built lines will look identical to the 
previous work done with the exception of its Color (red) and the Level (As-Builts). These 
things may not be evident when looking and working on the As-Builts, but they will be 
when they are plotted in color to the web archive. Level Symbology can be used to better 
display the corrected colors when working on the files. 

When correcting a cross pipe for example, a 2' x 65' 8" pipe culvert was constructed at 
Station 103+50, whereas the plans called for a 2’ x 63’-3” pipe culvert at Station 101+50. 
The culvert line and the notations describing the work at Station 101+50 shall be "X ed" 
(crossed out). In striking out figures and notations, care should be used to avoid obliterating 
the original figures. From the Tasks Menus discussed above, select Symbols and Linestyles 
> Cross Out Linestyle to place a series of  “X”s over an existing element whether lines or 
text. The new As-Built culvert and corrected description notation should be shown at Station 
103+50 by using the ConstructionGroup Tasks Menu for electronic As-Builts or red ink 
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(or dark red pencil) for paper As-Builts. A revision triangle will be added and possibly a 
revision cloud to better display the area that has changed. 

 Revision Clouds 
A revision “cloud” can be used to better display the area that has changed if it isn’t 
completely apparent with a revision triangle.  From the ConstructionGroup select the 
correct sub task (i.e., PlanAS) > Symbols & Linestyles > Revision Cloud and left-click to 
place a shape around a change to help make it apparent to anyone reviewing the plans. 

 Revision Triangles 
Select the Maine DOT WorkGroup of ConstructionGroup, then the correct sub task (i.e., 
PlanAS) > Symbols & Linestyles > As-Built Triangle (Large) and place a revision 
triangle in a visible location near the change or the cloud if one is necessary. Use Qualities 
> Drop > Complex from the main menu to drop the triangular cell and use the Edit Text tool 
or Text > Edit Text from the main menu to edit the text in the cell to the desired number 
sequence. Each collective change that is made needs to be marked with a triangle that is 
numbered. If a pipe is added to a project, the numbered triangle that represents the change in 
plan view is the same number that will be used on the Cross Section, Estimate Sheet and 
Drainage Sheet. Each of the respected sheets needs the triangle label. If Riprap is also added 
to the pipe ends, this item will also use the same numbering as the plan view drawing. If a 
ditch, driveway or catch basin is relocated, a new number is assigned to the triangle. 

 Mandatory Inclusion List 

Grading:  
1. All changes in alignment.  

2. All equations in stationing used during construction.  

3. ?All permanent references for control points. Also, all control points required to 
establish centerline shall be perpetuated. Brass caps and pipe are available for this.  

4. All changes in grade lines and elevations.  

5. Locations and elevations of all benchmarks used during construction or permanently 
established in taking final cross sections. Permanent benchmark should be identified 
by the word "Permanent'. Benchmarks shall be established at box culverts, bridges 
and other locations where they may be considered permanent.  

6. Location and number stamped on brass disc of all Government Survey benchmarks. 
The elevation based on the project level datum, if available.  

7. ?Location of all Right-of-Way markers installed.  

8. Location of all land corner witnesses, existing, or installed by the Project Manager. 

9. Location of all farm entrances constructed showing lengths, diameters and type of 
culverts laid or re-laid. 

10. Location of limits of construction of all borrow pits, channel changes, dikes, 
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intercepting ditches, etc., outside the Right-of-Way not covered by extended 
roadway cross sections. The stationing and location of the base line with respect to 
the project centerline shall also be shown.  

Culverts:  
1. All changes in location.  

2. All changes in lengths or dimensions.  

3. The type of pipe installed (CMP, RCP, etc.). 

Bridges and Special Culverts:  
1. All changes in stationing. 

2. All changes in design.  

3. All revised dimensions.  

4. Deck and bridge seat elevation of bridges.  

5. Maximum and minimum length of piling in each footing.  

6. The description, location and elevation of all permanent benchmarks.  

Surfacing:  
1. Beginning and ending stationing of each type and width of surfacing constructed. 

2. Location of all option pits used in connection with the construction of the project. If 
any plan pits are not used, designate by the words "Not Used".  

Initial Borders 
Every file in the list with a 3 digit prefix has a border with an initial box. For U.S. 
Customary projects, the initial box has been expanded to accommodate more revisions 
whether there are Amendments or As-builts. Currently we have lines in the initial box 
dedicated to revisions and a single box for Field Changes (Figure 30-2). The Field Changes 
section is reserved for the governing signatures of the revisions. This is where the Project 
Manager, Asst. Project Manager or Resident would sign the plans as final approval of the 
As-built plans. Select the Maine DOT WorkGroup of ConstructionGroup, then the correct 
sub task (i.e., PlanAS) > Symbols & Linestyles > As-Built Triangle (Title Block) to 
place a triangle in the Signature Block of the plan sheet. Use Qualities > Drop > Complex 
from the main menu to drop the triangular cell and the Edit Text tool or Text > Edit Text 
from the main menu to edit the text in the cell to the desired number sequence. Enter your 
initials and a brief description of the change. 



mdot MicroStation 
01/01/12 

As Built Drawings 

30-10 

 

 
Figure 30-2: US Customary signature block 

Renaming the Drawing Files 
All sheets that have been changed will have a new sheet designation. This is done by adding 
a letter suffix to the original sheet number in the bottom right hand corner of the sheet and 
the actual filename. If the original sheet number was 3, then the revised sheet number will 
be 3A. Likewise, if the original filename was 003_Typical02.dgn, then the new filename 
will be 003A_Typical02.dgn. 

 Do not rename any other files besides the sheet type drawings. These are the drawings 
that begin with a 3 digit prefix followed by an underscore. Do not rename “z_” files or 
the state plane correct files (i.e. highway.dgn, bridge.dgn, alignments.dgn, etc) as their 
standard file names are important to maintain. 

Batch Printing to a Multi-page PDF 
Using MicroStation’s Print Organizer, select all of the sheets (3 digit prefix drawings) and 
print them to a new multi page PDF file using the pdf_ColorFull plot driver and the As-
Built pen table. Supply a standard name that includes the PIN-As-Builts (i.e., 12345-As-
Builts.pdf) to describe the new document. 

 Refer to page 28-10 for detailed instructions on creating a multi-page PDF. Use 
the settings described above to create the color PDF. 

 Any sheets requiring an Engineer’s stamp and signature will need to replace non-
signed sheets in the PDF document (i.e., 001_Title, others that require stamp). 

Stamped and signed sheets will need to be replaced and vertical cross sections rotated by the 
Reproduction staff or someone with the Adobe writer software. 

 Refer to page 28-13 for instructions replacing sheets, rotating vertical cross 
sections, and printing the multi-page PDF. 
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Printing As-Builts 

 Hand written As-Builts 
These As-Builts can be scanned and re-produced by the Reproduction staff. These can 
eventually be added into the E-Plans Archive through Digital InterPlot and reproduced at a 
later date. 

 Printing (No Signatures) 
The As-Builts can be printed directly from MicroStation to a variety of color plotters, 
however the pages will lack the signatures and stamps. The CANONCOLOR plotter located 
in the Reproduction room is an available plotter from within MicroStation. 

 Official Electronic As-Builts (with Signatures) 
Once the PDF has been adjusted by replacing sheets with stamps and signatures and rotating 
vertical pages, it is ready for reproduction. 

The As-Builts can be most efficiently reproduced from the PDF document to the 
CANONCOLOR by the Reproduction staff. The CANONCOLOR plotter produces a high 
quality print in less time than any other color plotters we currently have available. Printing 
the color PDF will require that the CANONCOLOR has been added as one of your available 
printers. If it isn’t, open Windows Explorer and browse to the \\Dot0dta1psprint\ folder (or 
click the underlined link in the electronic document). Double click the CANONColor-
Rm126 printer in the list. 

Create a MicroStation Package 
Use the MicroStation Packager to create a new package of the As-Built drawings using the 
standard file name PIN-As-Builts (i.e., 12345-As-Builts.pzip). 

 Refer to page 28-18 for detailed instructions on creating a package. 

Final Review 
The final review will be performed. After the final review is completed, the specified sheets 
or complete copies, as requested by the District, will be copied in half-size sets. The copies 
will be returned to the District within three (3) to four (4) weeks after submittal to the 
Project Manager (Is this still done? What District?). Consider sending a Portable plan sets 
from Digital InterPlot. 

Distribution of Plans 
The As Builts will be submitted to the Project Manager with the final records for filing with 
notification of the number of complete copies or specified sheets desired.  

Cities, counties, etc. that have money involved or a special interest in the project will be 
asked by the Project Manager if they need/want a complete copy of the As Builts or only 
specified sheets. Electronic copies will be available as Portable Plan sets from Digital 
InterPlot once the As-Built archive is complete. 
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Submit a copy of the As Builts to the Transportation Planning Division for their use. (Is this 
still done?) Upon completion of their work, the Transportation Planning Division will 
periodically return the full-size As Builts to the District, via truck. 

Lighting and Signals - On all roadway lighting and signal projects, a set of "as-builts" will 
be prepared, pertinent to the wiring alignment, showing the exact location of conduit or 
cable runs, pull boxes, and any other information which would be beneficial in case of 
maintenance problems or construction activities in the area. When "as-builts" are submitted 
to the agency at the time the agency is notified by letter of the acceptance of the installation 
and to assume the maintenance. 
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DRAWING SCALES 
Overview 
The following scales are available through MicroStation’s Drawing Scale dialog. The scales 
described will inform you on what the absolute scale will be when referencing saved views 
to paper space borders. 

1/32”=1’___________________________________________________________1:384 

1/16”=1’___________________________________________________________1:192 

3/32”=1’___________________________________________________________1:128 

1/8”=1’_____________________________________________________________1:96 

3/16”=1’____________________________________________________________1:64 

1/4”=1’_____________________________________________________________1:48 

3/8”=1’_____________________________________________________________1:32 

1/2”=1’_____________________________________________________________1:24 

3/4”=1’_____________________________________________________________1:16 

1” =1’______________________________________________________________1:12 

1½”=1’______________________________________________________________1:8 

2” =1’_______________________________________________________________1:6 

3” =1’_______________________________________________________________1:4 

6” =1’______________________________________________________________1:2 

1” =1’_____________________________________________________________1:1 

1”= 4’_______________________________________________________________48 

1”= 5’_______________________________________________________________60 

1”= 10’_____________________________________________________________120 

1”= 20’_____________________________________________________________240 

1”= 25’_____________________________________________________________300 

1”= 30’_____________________________________________________________360 

1”= 40’_____________________________________________________________480 

1”= 50’_____________________________________________________________600 

1”= 60’_____________________________________________________________720 

1”= 100’___________________________________________________________1200 

1”= 200’___________________________________________________________2400 

1”= 400’___________________________________________________________4800 
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1”= 500’___________________________________________________________6000 

1”= 1000’_________________________________________________________12000 
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TYPICAL U.S. CUSTOMARY DRAWING SCALES 
 

Description US. Cust. 
Title Sheet 12"=1ft. (Full Size 1=1) 

Typicals 1" = 4' or 1/4" =1' (48) 

Estimate 12"=1ft. (Full Size 1=1) 

Drainage 12"=1ft. (Full Size 1=1) 

Notes 12"=1ft. (Full Size 1=1) 

Plans 1"=25' (300) or 1"=50' (600) 

Geometrics 1"=25' (300) or 1"=50' (600) 

Profiles 1"=25' (300) or 1"=50' (600) 

Cross Sections 1"=5' (60) or 1”=10’ (120) 
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ACCESSING CUSTOM SYMBOLS 
We have added a number of characters to our fonts. They can be accessed from the text 
editor by typing a “backslash” and then the number corresponding to the character. 

Note that in these tables, the number corresponding to a symbol is the number above the 
symbol. So to type the Centerline symbol, type “\201” 

The Degrees Symbol 
The degrees symbol can be accessed by typing Shift + 6 (the ^ symbol). 
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FONT 32: DOT_ENG 

 
Figure 31-1: Character Map of Font 32, DOT_ENG 
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FONT 123 DOTITALICS 

 
Figure 31-2: Character Map of Font 123, dotitalics 
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FONT 229 (VERDANA) 

 
Figure 31-3: Character Map of Font 229, Verdana 
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FONT TABLE 
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STRUCTURAL LINE STYLES 
Samples 

 
Figure 31-5: Structural Line Styles 

Using Custom Line Styles 
Line Styles are activated from the Tasks Menus.  Select BridgeGroup > Bridge > Special 
Linestyles group (Figure 31-6).  
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Figure 31-6: Structural Linestyle Options 

Line styles are scale-dependent. Make sure you select the appropriate scale from the 
Drawing Scale dialog before you make a line style selection. 

Tweaking Line style Size 
Sometimes your lines are going to show up either bigger or smaller than you’d like them to 
be. The Break and Cut line styles are most likely going to be the culprits here -- you may 
want to squeeze a break line into a small area.  

Go through the routine outlined above as a starting point. If the Break line is too big for 
example, select Element > Line Style > Custom from the Main Menu. 
This will open up the Line Styles dialog (Figure 31-7). 
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Figure 31-7: Line Styles Dialog 

Note that there is an on/off switch labeled Scale Factor: followed by a text field. This is the 
scale, as determined by the Tasks Menus and Drawing Scale dialog, to place your line 
style.  

 If you want your line style, to be smaller, edit the number in the Scale Factor text 
field. If it is currently 48, changing it to 24 will make it smaller (half as big) and 
changing it to 96 will make it bigger (twice as big.) 
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  LLEEVVEELLSS  
There are too many levels to display here. Please refer to our CADD Support webpage 
http://www.maine.gov/mdot/caddsupport/msinroads/inroadslevelstructure.htm for a 
complete listing.

http://www.maine.gov/mdot/caddsupport/msinroads/inroadslevelstructure.htm�
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DETERMINE THE CONSULTANTS DUTIES 
(PROJECT BY PROJECT BASIS) 

What is their responsibility? 

Consultant Doing Survey 
Aerial Photogrammetric Mapping - Consultants will coordinate through the mapping 
department manager.  They submit their information back to the manager and no 
information is necessary from the Consultant Coordinator. 

Traditional Surveying - Consultants will coordinate through the Area Survey supervisors 
to get specifications. They submit their information back to the Area Survey supervisors and 
no coordination is necessary. 

Consultant Doing ROW 
Existing ROW - Consultants will coordinate through the Real Estate Manager in the 
Programs. They will require CADD drawings of existing topography and text. 

Proposed ROW - Consultants will coordinate through the Real Estate Manager in the 
Programs. If they are doing the proposed ROW, chances are they are doing existing also. 
They will require CADD drawings of existing topography, text, existing ROW (if 
necessary), alignment, design (highway.dgn or bridge.dgn) and cross sections. 

Consultant Doing Design 
Bridge Projects - Consultants will coordinate through the Consultant Coordinators in the 
Program. They will require CADD drawings (both 2D and 3D) of existing topography, text, 
contours, points, triangles and existing ROW. The agreement may or may not require the 
consultants to “clean-up” topo and text drawings. For all new projects, consultants will 
follow the current General Contract Agreement. 

Highway Projects - Consultants will coordinate through the Consultant Coordinators in the 
Program. They will require CADD drawings (both 2D and 3D) of existing topography, text, 
contours, points, triangles and existing ROW. The agreement may or may not require the 
consultants to “clean-up” topo and text drawings. For all new projects, consultants will 
follow the current General Contract Agreement. 

Multimodal Projects – Similar to the Highway and Bridge projects. 

Traffic Projects - Similar to the Highway and Bridge projects.  

What do they need from us? 

Link to Web page 
All of our CADD customization is available online for consultants to download. This 
includes seed files, line style resource files, cell libraries and font resources. The web 
address is as follows: www.maine.gov/mdot/caddsupport/ . We highly encourage them to 

http://www.maine.gov/mdot/caddsupport/�
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use our customization. For more information, have them call MaineDOT’s CADD support 
personnel. 

Seed Files 
We have quite a few seed files in our configuration. Instruct consultants to use our standard 
seed file called “usMDOT_SEED.dgn” for all U.S. Customary projects (MDOT_SEED for 
metric projects). These can be found on the CADD download page at the following address: 
www.maine.gov/mdot/caddsupport/msinroads/inroadsdownloads.htm .  

 Our Standard file Structure/File Names 
Consultants should follow our standard naming convention which is laid out on our 
webpage. The address is www.maine.gov/mdot/caddsupport/msinroads/inroadsnaming.htm .  

http://www.maine.gov/mdot/caddsupport/msinroads/inroadsdownloads.htm�
http://www.maine.gov/mdot/caddsupport/msinroads/inroadsnaming.htm�
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SENDING SURVEY FILES TO A CONSULTANT 
MAINEDOT Survey Data 
Most of the consultants will require our survey data with the exception of Survey 
Consultants. When a Survey Editor is done editing the survey data and creating 
MicroStation design files, they zip all the pertinent files into a single Zip file and place them 
in a consultant folder under the survey folder on the y:drive (i.e. 
y:\pin\8467\00\Survey\consultant\). The zip file will be named PINTOWN.zip (Figure 
32-1). See breakdown below for explanation of the files included in the zip. 

 
Figure 32-1: Example of zipped Survey Files ready to be sent to a consultant 

 Breakdown of files sent to a consultant 
InRoads Files:  
Ground.dtm – Complete ground surface with all updates. 

Ground.fwd – Combined InRoads Fieldbook containing all original and updated data. 

MicroStation files: 
Topo.dgn is the features collected from Survey (cleaned-up). This file, if cleaned-up, is 
located in the topo folder of the PIN number.  

Text.dgn is the text associated with Survey data (cleaned-up). This file, if cleaned-up, is 
located in the topo folder of the PIN number. 
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Points.dgn is the field Survey point numbers. This file resides in the Survey\MSTA folder. 

Wetlands.dgn is the name of the cleaned up version of the wetlands drawing. It is located in 
the topo folder. If the file has not been cleaned up, the file will reside in the Survey/MSTA 
folder and is called OrigWetlands.dgn.  
Contours.dgn is the 3D contours drawing. This would also include Aerial Mapping 
Contours. The file resides in the Survey\MSTA folder. 

3DtopoMMDDYY.dgn is the 3D MicroStation design file (.dgn) of the Survey. This file 
resides in the Survey\MSTA folder. Select the file with the most recent date in the file name. 
It will include any additional topography if any was taken. 

3DMappingMMDDYY.dgn is the 3D MicroStation design file of the Aerial Mapping (only 
on Photogrammetric Mapping projects). This file resides in the Survey\MSTA folder. Select 
the file with the most recent date in the file name. It will include any additional topography 
if any was taken. 

Origtext.dgn is the 3D MicroStation design file of the text associated with ground survey 
data and Aerial Mapping. This file resides in the Survey\MSTA folder. 

 If any additional topography was taken prior to distribution to a consultant, there 
may be Origtextadd_#.dgn. Include these files also. 

Triangles.dgn is the 3D triangulation file for the project. This would also include Aerial 
Mapping Triangles. This file resides in the Survey\MSTA folder. 

 When a design consultant requests survey information for a project, the 
3DtopoMMDDYY with the most recent date is the one file containing all the latest 3D 
topographical data. It will not be necessary to send any of the Origtopoadd_#.dgn files. 

Step One: Posting files to Outgoing FTP site 
Click your Start button and go to Programs > WS_FTP LE > WS_FTP LE or double 
click the icon (Figure 32-2) on your desktop. 

 
Figure 32-2: FTP Icon 

When the program opens you should see a Session Properties dialog. Press OK (Figure 
32-3) to log into the FTP site. 
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Figure 32-3: Session Properties 

Step Two: Browse and Push Files to FTP 
On the right side (Remote Site), you should see the folder list, (incoming, outgoing, etc.) 
and on the left (Local System), see a list of available drives. These are the drives you 
currently have mapped to your computer. 

We have a folder for all outgoing files and a folder for all incoming files. Open the 
appropriate folder for the action you are taking. 

In the Local System window, browse to the y:drive and folder where the file exists that 
requires transferring (i.e. y:\pin\8467\00\survey\consultant\). When the contents of the folder 
are displayed in the left section of the dialog area, highlight the desired file and click on the 
directional arrow (Figure 32-4) between the two view areas. 

 
Figure 32-4: WS_FTP LE ftp.maine.gov 
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Step Three: Send Email with Link to File 

 Introduction 
We can send a hyperlink in an email document that points directly to the file you posted, 
starting the download on their end automatically.  

Or, we can also notify clients when a file is posted and provide them with the HOST 
(ftp.maine.gov ) with the user (anonymous) and the password (anonymous). Then, by using 
a normal Internet browser or some type of FTP software, they can connect to our site and 
find the file and download it manually. 

 Part One: Type address to FTP in email 
Type the complete address path and file name, within the body of an email message area and 
the recipient can click the link and start downloading to a specified location on their 
computer. 

Here is an example: ftp.maine.gov/outgoing/8467topsham.zip. 

 Always test the link by sending this to a coworker or to yourself. It doesn’t always 
work in the draft email that you are preparing. 

 Use forward slashes between folders and never use spaces in the file names. Use 
lowercase for the ftp address and outgoing folder. Match the case of the file name 
you created.  

 Part Two: Add Subject Line and Send 
Add the filename in the Subject line of your email. Provide a brief description of files 
attached. Click Send. 

ftp://ftp.maine.gov/�
ftp://ftp.state.me.us/outgoing/8467topsham.zip�
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SENDING OTHER FILES TO A CONSULTANT 
Step One: Create Consultant “Out” Folder 
Open Windows Explorer and browse to your Workgroup’s folder (i.e. 
Y:\pin\8467\00\HIGHWAY). Right Click and select New > Folder. Name this folder 
Consultant. Open this folder and Right Click and select New > Folder. Name this folder 
OUT. Open this folder. An example is shown in Figure 32-5. 

 
Figure 32-5: An example of a consultant folder structure 

Step Two: Create a Zip file 
Creating a Zip file is as easy as Right clicking and selecting New>Compressed (zipped) 
Folder in the folder where you want the zip file to exist (i.e. 
Y:\pin\8467\00\HIGHWAY\consultant\OUT). This will create a Compressed (zipped) file 
called “New Compressed (zipped) Folder.zip. Select the file and pick File > Rename. 
Supply a new name by typing the name and hitting enter. Be sure to add the “.zip” extension 
to the file name. 

 Use good judgment when naming files. Rather than dumping random files without 
unique names to the FTP site, always use naming that will make it easy to identify 
your files from someone else’s (i.e. 8467topsham.zip or 8467rwplan.zip). 

Select one or more files in Windows Explorer and drag and drop them onto the Zip file, or 
double click the zip file to open it, then drag and drop files from Windows Explorer into the 
Zip folder. 

Step Three: Post to Outgoing FTP site 
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General Rules of Thumb! 
1) Send a zip (compressed) file when sending more than one file, or files large in size.  

2) Use good judgment when naming zip files. Do not dump random files (i.e., topo.dgn, 
Rwplan.dgn, text.dgn, highway.dgn, etc.) to the FTP site, always try and use unique naming 
that will make it easy to identify your zip file’s from someone else’s. (i.e., 8467topsham.zip) 

3) Do not create a folder. 

4) Clean up you own mess! BIS does house cleaning only when the server is too full to 
function. By then it’s a crisis. Delete incoming files after you have downloaded them.  

 Open FTP Site 
Follow steps previously documented in the Sending Survey Files to a Consultant section. 
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RECEIVING PROJECT FILES FROM A CONSULTANT 
File Format 
Older projects that were started before the current GCA are grand fathered and we will 
accept .dwg or .dxf files. MicroStation can open/attach these files in their native format. If 
the consultant uses AutoCAD, request that they send MODEL SPACE drawings in our State 
Plane Coordinate System. 

Newer contracts that are governed by the current GCA require that consultants send .dgn 
(MicroStation) files. 

Drawings to Receive 
The Department separates drawings by discipline and use referencing to combine all 
drawings necessary to produce a plan set. As previously stated in this document, consultant 
duties vary from project to project. Consultants doing ROW work should send back only the 
existing and/or proposed ROW files. If a consultant is doing proposed design for a project, 
they should be sending back an alignments.dgn and a highway.dgn or bridge.dgn. As the 
project nears completion, they should send all files relative to the project. They may or may 
not use our naming convention. We encourage them to follow our standard naming 
convention which is laid out on our website: 

 www.maine.gov/mdot/caddsupport/msinroads/inroadsnaming.htm  If they do not, it may be 
necessary that they include a text document that describes their filenames. It’s up to you to 
rename these files if necessary and place them where they belong in the project directory. 

What don’t we want back? 
Because we usually supply the consultant with Survey data, we do not want it back unless 
they have made significant changes to the topo and text files due to field review or 
inspection. If the consultant is required to clean up the topography, we would want the 
cleaned up version back from them and placed on our network. If they have added 
topography, have them send only the things that they have added. These items can be 
merged into our topo.dgn. Someone in-house may have cleaned up our copy of the topo.dgn 
so we may not want to replace it. 

Step One: Create a Consultant Directory 
Now we need to create a folder in the projects PIN structure for the consultants “.zip” file. 
This will be a record of what was received from them and the date of submittal. 

Open Windows Explorer and browse to your Workgroup’s folder (i.e. 
Y:\pin\8467\00\HIGHWAY). Right Click and select New > Folder. Name this folder 
Consultant. Open this folder and Right Click and select New > Folder. Name this folder 
IN. Open this folder.  An example is shown in Figure 32-6. 

http://www.maine.gov/mdot/caddsupport/msinroads/inroadsnaming.htm�
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Figure 32-6: Consultant/IN folder in your Workgroup’s folder 

Step Two: Download Files From Incoming FTP Site 

Part One: Open FTP software 
Click your Start button and go to Programs > WS_FTP LE > WS_FTP LE or double 
click the icon (Figure 32-7) on your desktop. 

 
Figure 32-7: FTP Icon 

When the program opens you should see a Session Properties dialog. Press OK (Figure 
32-8) to log into the FTP site. 
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Figure 32-8: Session Properties 

 Part Two: Browse and Pull Files From FTP Site 
In the Local System window, browse to the y:drive and to the folder you just created (i.e. 
y:\pin\8467\00\Highway\consultant\IN).  

On the right side (Remote Site), you should see the folder list, (incoming, outgoing, etc.). 
Open the incoming folder. 

Locate the file that the consultant posted for you in the incoming folder and click on the 
directional arrow (Figure 32-9) between the two view areas. You should start to see the 
progress of the download. If you feel confident that the file was copied to the 
Consultant\IN folder, delete the file from the incoming folder. Close the FTP session. 
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Figure 32-9: Incoming folder using WS_FTP LE ftp.maine.gov   

Step Three: Extract Files from the Zip folder 

Part One: Browse to your PIN’s Consultant\IN Folder 
Navigate to the Consultant\IN folder that you created in your project’s PIN number. Locate 
the file that you just copied from the FTP site. Double click this file to display its contents 
(Figure 32-10). 

 
Figure 32-10: Contents of the zipped folder 

Part Two: Extract Files to Consultant directory 
From the Explorer menu, select File > Extract All… . The Extraction Wizard will open. 
Click Next. The next dialog window allows you to either browse to where you want to 

ftp://ftp.maine.gov/�
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place the extracted files or simply remove a portion of the path in the “Files will be 
extracted to this directory” window. Trim off the end of the path until you reach the 
Consultant folder (i.e. y:\pin\8467\00\highway\consultant). Click the Next button (Figure 
32-11).  

 
Figure 32-11: Remove part of the path to the desired directory in the Extraction Wizard 

 We want to extract to the consultant directory temporarily. 

Step Four: Rename Consultant files in Consultant\In Folder 

Standard Naming Convention 
We have standard names for files. We ask that consultants follow our naming convention, 
but chances are some won’t. A complete list of acceptable file names is listed on our web 
site. Here is the address:  

www.maine.gov/mdot/caddsupport/msinroads/inroadsnaming.htm  It is up to the Consultant 
Coordinator to rename the files if necessary. Common file names are listed below. 

Alignments.dgn - This is the proposed alignment file. It contains all Main Line and Side 
Road alignments including Curve Data and Bearings.  

Highway.dgn - This is the proposed design file for a Highway project. 

Bridge.dgn - This is the proposed design file for a Bridge project. 

Rwplan.dgn - This is the file that will contain both existing and proposed ROW.  

Renaming the Files 
To rename a file, select the file and pick File > Rename from Windows Explorer’s Main 

http://www.maine.gov/mdot/caddsupport/msinroads/inroadsnaming.htm�
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Menu. Type the new file name and be sure to include the file extension. Hit enter to 
complete this process. 

Step Five: Move Files to Bridge\MSTA, Highway\MSTA or 
ROW\MSTA 

MicroStation requires that files be in a certain place for them to be viewable to everyone as a 
reference file. Now you will have to move them into the correct location. Highlight the 
design files in the consultant folder. From the Main Menu, select Edit > Cut. On the left 
side of the window, click on the MSTA folder next to the consultant folder to display its 
contents on the right. Select Edit > Paste to place the files into the MSTA folder. 

 You may get a warning stating that there are files in the folder with the same names, 
“Do you want to overwrite them?”. Consider moving the files into an “old” folder 
unless you are sure that they are complete replacements. 

 If you receive a Right of Way file, you may not have permissions to move it to the 
correct folder. Have your ROW technician move this file into the ROW\MSTA 
folder. 

 It is important that all MicroStation files relative to the project exist in a MSTA folder. 
This is where MicroStation will look for files to reference. 

Step Six: Compare with our Files (Optional) 
This is an optional step that might save a lot of headaches for someone in the future. If the 
drawing doesn’t follow our standards, it will be apparent immediately when a person views 
it with our standard drawing files. 

Open MicroStation 
Click the MicroStation icon on your desktop. Select your project number from the project 
pull down. 

Select a File to Open 
Open a file that should be referencing the topography files and the proposed design files (i.e. 
hdplan.dgn or bdplan.dgn). Fit view. The files should line up correctly. 

If all looks good… 
If the files line up good, skip to the next step. If it doesn’t, contact MaineDOT’s CADD 
support for additional troubleshooting. 

Step Seven: Send Message to Team Members 
After the files have been named correctly and placed in the correct directory, it would be a 
good idea to send a message to team members notifying them that the files are ready to be 
used. 
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RECEIVING UPDATES FROM A CONSULTANT 
Communication 
Communication is the key for receiving updates from a consultant. The update process is 
when a file can be unintentionally overwritten.  

Is this a Complete Replacement? 
Ask the consultant if the file is a replacement of a previous submittal, or if it’s an addition to 
an existing file or simply a file to be added to the project files. It is better to receive a 
complete replacement unless it took a lot of manual editing on our end to get their file to 
meet our standards. In this case, we can reference and merge only the changes into the 
previous submittal.   

Readme file 
A readme.txt file is a good way for a consultant to describe what their intentions are. 
Encourage your consultant to include this in zip files that they submit. 

Step One: Create an OLD folder 
In order to keep a running record of what was submitted by a consultant, create an OLD 
folder under the workgroups MSTA folder (i.e. \Highway\MSTA\OLD). 

Step Two: Move Older file(s) into the OLD folder 
If a file is going to be completely replaced by a new one, move the older file into the old 
folder. In Windows Explorer, find the file to be replaced. Select it and pick Edit > Cut from 
the Main Menu. Click on the OLD folder on the left side of the Explorer window displaying 
the contents on the right. Select Edit > Paste from the Main Menu to paste it into the “old” 
folder. 

  If you have placed files in the “old” folder already, and they have the same name of 
the files you are pasting, Windows may ask you if you to overwrite them. Select 
“OK” (Yes) to overwrite them. Keep only the latest “old” file. 

Step Three: Copy File From FTP to Consultant folder 
Use the same procedures as previously outlined for copying files from the incoming FTP 
site. This was outlined in the “Receiving Project Files from a Consultant” portion of this 
manual.  If the consultant used the same file name as a previous zip, create an old folder 
under the Consultant\IN folder and move the older zip into the “old” folder. If the zip file 
name is different from any previous, leave all zip files in the consultant\IN folder. 

Step Four: Extract files, Rename Accordingly and move to 
MSTA Folder 

Use the Extracting procedures as outlined previously in this document (“Receiving Project 
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Files from a Consultant”). Rename the file if necessary to follow our standard file naming. 

Step Five: Compare with our Files (Optional) 
This is an optional step that might save a lot of headaches for someone in the future. If the 
drawing doesn’t follow our standards, it will be apparent immediately when a person views 
it with our standard drawing files. 

 Open MicroStation 
Click the MicroStation icon on your desktop. Select your project number from the project 
pull down. 

 Select a File to Open 
Open a file (i.e. hdplan.dgn or bdplan.dgn) that should be referencing the topography files 
and the proposed design files (alignments, highway, bridge and rwplan). Fit view. The files 
should line up correctly. 

 If all looks good… 
If the files line up good, skip to the next step. If it doesn’t, contact MaineDOT’s CADD 
support for additional troubleshooting. 

Step Six: Send Message to Team Members 
Many team members may be using the files received from the consultant. It is a good idea 
that you send a message to them stating a revision has been made. This will keep the project 
flowing smoothly. 
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PROCESS OF SAVING A SINGLE FILE AS A DWG 
Introduction 
Occasionally a consultant may require an AutoCAD file. Find out what version of AutoCAD 
they are using. MicroStation can create the drawing using our file standards. It uses the 
active file’s Global Origin, Level Structure, Units and Color table. It is recommended that 
you use the Batch Converter utility to convert multiple files or files that you haven’t got 
permissions to.   

Step One: Open file to be Converted 
Open MicroStation, pick your project from the project pull down and open the file you wish 
to convert. 

Step Two: Select File Save As… 
Choose File > Save As… from the Main Menu. A dialog will open (Figure 32-12) giving 
you the opportunity to change the file type and directory path. From the “Select Format to 
Save” pull down, select AutoCAD (R) DWG Files (*.dwg). Browse to your Workgroup’s 
Consultant\OUT directory (i.e., Y:\pin\8467\00\Highway\Consultant\OUT).  

 If you are trying to convert reference files that you do not have permissions to (i.e. 
RWPlan.dgn), you may not be able to convert these files. MicroStation will attempt to 
write them to their original directory. In this case, browse to somewhere on your hard 
drive and all the files will be written there. Consider using the Batch Converter to 
define an Output directory that you have privileges to. 

 
Figure 32-12: Save As dialog (*.dwg File Format) pointing to the Workgroups Consultant/OUT directory 

 Put the file(s) in the consultant\OUT directory. This is where you will zip up the 
file(s) prior to placing them onto the FTP site. 
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Step Three: Adjust Options 
Select the Options button in the Save As… dialog. In the General tab (Figure 32-13), pick 
the version of AutoCAD the consultant is using by clicking on the current value in the row. 
Units should be set to Feet or Meters. In the DWG Seed File area, click the current value to 
browse to MaineDOT’s standard seed file folder (i.e. c:\!msv2004conf\standards\seed\DWG 
seed\). Depending on the project type, choose either the usMDOT_SEED.dwg or the 
MDOT_SEED.dwg (metric projects). Place a check mark in the Drop Unsupported 
LineStyles box. This will display our line styles even though the consultant may not have 
them configured or mapped appropriately.  

 
Figure 32-13: General tab with appropriate selections 

Scroll down to the Fonts portion of the dialog (Figure 32-14). Expand the selection. Place a 
check mark in the box to Convert MicroStation fonts to AutoCAD fonts. Adjust the SHX 
Output Directory to point to the c:\temp folder.  
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Figure 32-14: Adjust the Fonts portion of the dialog 

There are many more adjustments possible on the General tab (Figure 32-14), however it’s 
not recommended that you make other changes unless you are advised to do so from the 
consultant or CADD Support personnel. 

The Remap tab is fine by default. Click on the References tab and adjust your options to 
those seen in Figure 32-15. 
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Figure 32-15: Save As Reference Tab options 

Select the Filter tab and adjust your options to those seen in Figure 32-16. 

 
Figure 32-16: Save As Filter Tab options 



mdot MicroStation 

01/01/12 

Consultant CADD 
Coordination 

32-24 

 

Click OK and then OK again. The file(s) will be created in the same folder as the .dgn. 

Step Four: Zip and FTP the File 
MicroStation will also create resource file that AutoCAD can use to display the same Fonts 
and Line Styles in their drawing. Open Windows Explorer and browse to your C:\temp 
folder and copy all of the .shx files to your Workgroup’s Consultant\OUT folder. 

Browse to your Workgroup’s consultant\OUT folder and Right Click and select New > 
Compressed (zipped) Folder. Rename it appropriately copy your .dwg and .shx files into it. 
Post it to the FTP site. Now that you have a record of what you sent in the Zip file, delete the 
single .dwg file and .shx files. 
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BATCH PROCESSING MULTIPLE FILES TO DWG 
Introduction 
If you need to create many DWG files it is quicker to setup a Batch job to do this. 
Sometimes you may need to convert and send the survey files as .dwg. You can add files 
from different directories for conversion also. 

Step One: Open a File 
Open MicroStation, pick your project from the project pull down and open any file, 
preferable one that you do not need to convert. 

Step Two: Start Batch Utility 
From the Main Menu, select Utilities > Batch Converter… The Batch Convert dialog will 
open. Select DWG from the Default Output Format pull down (Figure 32-17). 

 
Figure 32-17: Changing the Default Output Format to DWG  

Step Two: Adjust Options 
Adjust the DWG output preferences by selecting Edit > DWG Save Options. These options 
should be set the same as you would for a single file conversion. See figures Figure 32-13, 
Figure 32-14 and Figure 32-15. 

Step Three: Adjust Destination 
In the Default Destination field, click the magnifying glass and browse to your Workgroup’s 
consultant\OUT folder. 

 If you change your mind about the destination you must highlight all of the files and 
select Apply to Selection. 

Step Four: Add Files to Convert 
Select Edit > Add Files from the Batch Convert dialog. A new dialog will open. Browse to 
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the directory that contains the files you want to convert. Select them and click the ADD 
button (Figure 32-18). Browse to other directories and add more files if necessary.  

Select a whole directory of files by selecting a folder in the right panel of the dialog and 
placing a check mark in the Include Subdirectories box (Figure 32-18). Click the Add 
button. Click the Done button when you’re finished adding files or directories. 

 
Figure 32-18: Select Files and Directories to Convert dialog 

Step Five: Process Files 
Select File > Process… from the Batch Convert menu. The Files to Convert dialog will 
open (Figure 32-19). Click the Convert button and it will show you the progress as it 
process the files. 

 
Figure 32-19: Files prepared to convert 

 Occasionally you will receive a warning message when a file doesn’t get converted. 
Make note of which files fail during the conversion process. This message is very 
common. It may be because you are in a file that is referencing a file you are 
converting. Click OK. 
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When the files have all been processed, the dialog (Figure 32-20) will display which files 
that were converted and which ones may have failed. Click Done. 

 
Figure 32-20: Dialog displaying the results 

Re-process the file(s) that have failed. This time, select only the file or files that failed and 
place a check mark in the Process Selection Only box (Figure 32-21). Select File > 
Process… to start the conversion on the individual file(s). Second time usually works fine. 

 
Figure 32-21: Selecting files and using the Process Selection Only box 

When you have finished processing all of the files, close the dialog. It is not necessary to 
save the Batch Convert session.  

Step Six: Zip and FTP the File 
MicroStation will create resource files that AutoCAD can use to display the same Fonts and 
Line Styles in their drawing. Open Windows Explorer and browse to your C:\temp folder 
and copy all of the .shx files to your Workgroup’s Consultant\OUT folder. 

In your Workgroup’s consultant\OUT folder and Right Click and select New > Compressed 
(zipped) Folder. Rename it appropriately copy your .dwg and .shx files into it. Post it to the 
FTP site. Now that you have a record of what you sent in the Zip file, delete the single .dwg 
file and .shx files.
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GENERAL INFORMATION 
What is an FTP (File Transfer Protocol) site? It’s a secure drive on a computer, protected by 
a firewall, where files are temporarily stored completely accessible by any outside Internet 
connection. This allows consultants to do business with us while exchanging large amounts 
of data directly from computer to computer. Our FTP Internet address is ftp.maine.gov . This 
can be accessed through Internet Explorer if the recipient doesn’t have FTP software. At that 
point, dragging and dropping files works best instead of Edit>Copy and Edit Paste. Consider 
sending a link in an email to files that are place on our FTP site. 

Files over 10 Mb cannot be transferred via email. The State’s email system stops the transfer 
of large files due to their size and the systems restraints. It is recommended that files over 10 
Mb be transferred to outside sources by using this process. 

General Rules of Thumb! 
• Send a zip (compressed) file when sending more than one file, or files large in size.  

• Use good judgment when naming files. Rather than dumping random files without 
explicit names to the FTP site, always use naming that will make it easy to identify 
your files from someone else’s. (i.e. 8467topsham.zip) 

• Do not create folders on the FTP site. Folders can be created within the outgoing 
folder, but are impossible to remove, due to protections that are set by BIS. Only they 
have privileges to remove them, regardless of who created them. 

• Clean up your own mess! OIT does house cleaning only when the server is too full to 
function. Delete incoming files after you have downloaded them. Tell the 
consultant/recipient that they have permissions to delete the files you posted after 
they download them. 

ftp://ftp.maine.gov/�
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USING FTP 
Step One: Open FTP Software 
Click your Start button and go to Programs>WS_FTP LE>WS_FTP LE or double click 
the icon (Figure 33-1) on your desktop. 

 
Figure 33-1: FTP Icon 

When the program opens you should see a Session Properties dialog. Press OK (Figure 
33-2) to log into the FTP site. 

 
Figure 33-2: Session Properties 

Step Two: Browse and Push Files to FTP 
On the right side (Remote Site), you should see the folder list, (incoming, outgoing, etc.) and 
on the left (Local System), see a list of available drives. These are the drives you currently 
have mapped to your computer. 

We have a folder for all outgoing files and a folder for all incoming files. Open the 
appropriate folder for the action you are taking. 

Scroll and browse to the drive and folder where the file exists that requires transferring (i.e. 
y:\pin\8467\00\highway\consultant\topsham-design.zip). When the contents of the folder are 
displayed in the left section of the dialog area, highlight the desired file and click on the 
directional arrow (Figure 33-3) between the two view areas. 
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Figure 33-3: WS_FTP LE ftp.maine.gov 

Use the same techniques to copy files from the incoming folder on the FTP site to a drive 
letter on the network or to your local hard drive. 
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SENDING LINKS IN EMAIL MESSAGES (OPTIONAL) 
We can send a hyperlink in an email document that points directly to the file you posted, 
starting the download on their end automatically.  

Or, we can also notify clients when a file is posted and provide them with the HOST 
(ftp.maine.gov ) with the user (anonymous) and the password (anonymous). Then, by using a 
normal Internet browser or some type of FTP software, they can connect to our site and find 
the file and download it manually. 

Step One: Type address to FTP in email 
Type the complete address path and file name, within the body of an email message area and 
the recipient can click the link and select Save to start downloading to a specified location on 
their computer. 

Here is an example: ftp.maine.gov/outgoing/8467topsham.zip. 

 Use forward slashes between folders and never use spaces in the file names. Use 
lowercase for the ftp address and outgoing folder. Match the case of the file name you 
created.  

Step Two: Test the Link 
Even though the link shows up in the body of the email message, clicking it will not 
accurately verify that the link works. Send the email to yourself and test the link the email. If 
it works, send the email to the recipient. 

Step Three: Add Subject Line and Send 
Add the filename in the Subject line of your email. Provide a brief description of files 
attached. Click Send. 

ftp://ftp.maine.gov/�
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  UUSSIINNGG  AAUUTTOOTTRRAACCKK  ––  TTUURRNNIINNGG  
RRAADDIIUUSS  SSOOFFTTWWAARREE  

AutoTrack is an add-on program for MicroStation, which is used for evaluating a design for 
turning movements of trucks, and any other large vehicles.  We have purchased a 2 user 
network license, which means that only two users can be running AutoTrack at the same time 
on our network.  Depending on the usefulness and demand for the product, we may increase 
the number of licenses in the future.  AutoTrack must be separately installed on the PC of 
each user that is going to run it. 
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AUTOTRACK INSTALLATION 
Introduction 
The AutoTrack licensing system points to the oit-teaqasdtiis.mdot.w2k.state.me.us 
server.  The installation steps below set up a client PC that will look to that server for its 
license.  To avoid problems with our own customized MicroStation interface, we prefer not 
to let the AutoTrack install procedure “configure” the CAD system for us.  Therefore, please 
follow these instructions carefully. 

Step One: Browse to Folder 
Using Windows Explorer, browse to the Y:\msworksp\AutoTrack folder. 

Step Two: Launch Setup 
Double-click on atr###.exe to launch the installation process (i.e., atr700a.exe). These 
numbers will change as new versions become available. Click RUN to bypass the security 
warning. If a previous version is found, you will be asked if you want to install manually, 
uninstall previous versions without migrating your custom settings or uninstall and migrate 
your custom settings. If you’ve consciously made adjustments, then migrate your settings, 
otherwise, it may be a good time to start with a fresh install. 

You will be asked if you want to install a Full copy.  Choose Yes. 

Click Next to begin the install program and click Yes to agree to the license terms. At the 
Customer Information page, enter State Of Maine as the User Name and enter Department Of 
transportation as the Company Name. Click Next. 

When you get to the Setup Type screen, choose Custom. 

Uncheck the SavoyCAD (Stand alone version) box and hit Next. 

Click Next through to the last of a set of 5-6 pages, where you should see the version of 
MicroStation that we are using checked as an item in the list, with the path to the 
USTATION.EXE file listed to the right. Click Next.   

Click Next to confirm the installation path. 

Click Next again to confirm the selected components, and Next once more to install support 
for earlier versions of vehicle libraries. 

Step Three: Adjust IP Address 
You should now be at the Network License Setup page. Place a checkmark to signify that this 
is a network version.  In the first IP Address line, enter the address of our oit-
teaqasdtiis.mdot.w2k.state.me.us server, which is 10  10  19  11.  Click Next. 

Step Four: Update Advise 
Uncheck the top box to prevent users from being able to run updates. All updates will be 
downloaded, tested and approved for use by the CADD Support Staff. Click Next. 
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 Do not attempt to upgrade/download a newer version of the software. Our server 
license is relative to the version we are using at any given time. We will notify you in 
the event of an upgrade that affects us. 

Step Five: CADD Configuration 
You should now be at the Configuration of CADD Systems page.  Uncheck both of 
the options on this page and click Next and click Next again to confirm the default program 
folder. 

Step Six: Finishing up 
On the next page, you can skip the Readme file and click OK to the next dialog mentioning 
the USB license install screen. 

You will need to reboot the PC after the procedure completes. 
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USING AUTOTRACK (BASICS) 
Introduction 

We have purchased a 2 user network license. Only two users can be running 
AutoTrack at the same time. We’ve added menu items to load and unload AutoTrack 
during a MicroStation session. Use AutoTrack then unload it to release the license. 
Closing the file unloads it also.     

Open MicroStation 
Always open MicroStation from your desktop icon or from the Start menu. Select your 
project from the Project pull down. Open any file in your list of drawings. 

Create a New Drawing  
Use File > Make Sheetz to create a new drawing with no prefix called Turning Radius. 

 Refer to 1-57 for more information on the Make Sheetz process. 

 Using a new drawing to design your turning movements keeps this information 
separate from the files that another unit references by default. 

Load AutoTrack 
Start AutoTrack by selecting Utilities > AutoTrack > Load AutoTrack.   
The Welcome dialog (Figure 33-4) should open as well as a new tool bar for AutoTrack 
(Figure 33-5) and an additional menu item called Applications.  
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Figure 33-4: AutoTrack Welcome dialog  

 
Figure 33-5: AutoTrack Toolbar for MicroStation 

Set Default Vehicle (Optional) 
It isn’t necessary to select a default vehicle (Figure 33-4). You will be prompted for a vehicle 
when you hit any of the Drive options. If you do set a default, you will have an opportunity 
to change it after selecting a drive option. 

Set Drawing Settings 
You should always verify your Drawing Settings (Figure 33-4) during each session to set 
your units for AutoTrack, especially since we are producing both metric and U.S. Customary 
projects. 

Start AutoTrack Tutor 
Click on the AutoTrack Tutor icon (Figure 33-4) for guidance in using AutoTrack for the 
first time. It will provide a help screen that is relative to the dialog you are on. 

For More Assistance, Read the Manual 
The manual and tutor will be your best friend through the first few uses. Contact CADD 
Support for assistance. 
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VIEW AN AUTOTRACK DEMO (OPTIONAL) 
Step One: Start Demo 
Click Window’s Start button and browse to the \Programs\AutoTrack#\AutoTrack 
Tutorial Demonstration program. 

Step Two: View at Your Leisure 
The demo is a good rundown of AutoTrack’s functionality and multiple settings. It’s a good 
idea to watch this 40 minute demonstration. 
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USING AUTOTRACK’S MANUAL AND HELP 
AutoTrack On-Line Manual 
An On-line Manual (in PDF format) can be launched independently from MicroStation by 
selecting Start > Programs > AutoTrack # > AutoTrack Manual In PDF Format… 
It also can be launched from within MicroStation by selecting Applications > AutoTrack > 
Help > AutoTrack Help… from the Main Menu.  

 The Table of Contents is linked to the rest of the document. The PDF document is 
fully searchable also. 

 Do not attempt to use the PDF installation instructions. Our installation instructions 
are specific to our workflow and licensing. 

AutoTrack’s Webpage Knowledge Base 
Use AutoTrack’s websites ( http://www.savoy.co.uk ) to provide assistance also. Once you 
are at this site, you can select SUPPORT, then KNOWLEDGE BASE or KNOWN 
PROBLEMS and even ask for email support.

http://www.savoy.co.uk/�
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UUSSIINNGG  MMAAIINNEEDDOOTT  EEPPLLAANNSS  AARRCCHHIIVVEE  
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ABOUT THE EPLANS ARCHIVE 
Overview 
The E-Plans Archive is MaineDOT’s Electronic Plans Archive. It is a web-based, large 
format document management system similar to TEDOCS. They are viewable, measurable 
and ready to be plotted to scale through a web browser (i.e., Internet Explorer).  The software 
powering the web archive is called Digital InterPlot, which is a product of Bentley Systems, 
Inc (the owners of MicroStation, InRoads and MX). Digital InterPlot (D.I.) is available to all 
MaineDOT employees who have access to the Intranet. Users can search for projects based 
on over a dozen filtering options and print them if necessary. The E-Plans Archive is 
currently organized in categories such as Vault Plans and Property Plans (R/W). There may 
be additional categories in the future. D.I. may also facilitate in producing an electronic set of 
plans for the on-line bidding process available to Contractors on the Internet. You can access 
D.I. by clicking the following hyperlink  http://dot0dta1asiis03/plansweb/dpr.asp. You can 
also access from the MaineDOT intranet Home Page by selecting E-Plans Archive. 

Vault Plans 
The Vault Plans archive originated from the scanning of the bridge and highway project 
plans (both Contract and As-Builts) hanging in the physical vault. Vault Plans were 
organized in hanging file racks. Their rack number is listed as their Source File Location (i.e. 
AA01) in the E-Plans Archive. The Source File Location will vary depending on the source 
of the plan set. All future “Contracts” that have been advertised will have a Source File 
Location of Contract Plans. Any Amendments to these “Contract” drawings will have a 
Source File Location of Amendments. As-Built drawings for any given project will have a 
Source File Location of As-Built Plans.  
The Vault Plans archive will include other documents for retrieval. There are Maintenance 
Facilities, Rail Road Maps and Airport Plans. 

Property Plans 
This Archive will be where Right-of-Way property maps (old hanging files), miscellaneous 
Survey documents, POR documents and tax maps will be stored and made available through 
the E-Plans Archive. Recently included will be ROW PLAN REVISIONS. If the archive is 
searched properly, these revised plans will be included with the original plans. When 
searching for a ROW File Name, always use wild cards before and after the ROW File Name 
(i.e., *160150*). These revisions will immediately follow the originally archived sheet. They 
can be identified by their Source File Location as well as the REV# incremented onto the 
ROW File Number. 

http://dot0dta1asiis03/plansweb/dpr.asp�
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GETTING STARTED 
Accessing the Web Page 
The link to our Electronic Plans system on Digital InterPlot is: 
http://dot0dta1asiis03/plansweb/DPR.asp . We recommend that you save this link as a 
Favorite in your web browser.  

A link to the page can also be found on the MaineDOT Intranet page (MDOTWEB) Figure 
34-1. 

 
Figure 34-1: E-Plans archive via MDOTWEB page 

http://dot0dta1asiis03/plansweb/DPR.asp�
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One Time Installation 
On the "home page" of our Electronic Plans system, you will see a list of available archives. 
You can either Browse or Search these archives. These instructions are intended get you 
started as well as how to refine your searches to access the plans you need.  

On your first time in to Digital InterPlot, your PC will need to install the Bentley Web 
Viewing Control after you click on a thumbnail image. You may get a Security Warning 
asking if you want to install this control.  If so, click Yes. 
Check Yes, I accept the agreement  
Click OK  

   The above is a one-time procedure. Afterward, you go directly to the plan sheet that 
you select.  
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BROWSING AN ARCHIVE 
Simple Browsing and Viewing 
The archive that we are using for this example is called VaultPlans. This archive contains 
plan sets that were scanned from our Vault as well as Contract plans and As-Builts. You can 
use either the Folder icon or the Browse tab (or binoculars) to get to a page that lists the plot 
sets within the archive (Figure 34-2). In that list, the items in the Plot Set Name column are 
linked to the corresponding plot sets.   

 
Figure 34-2: Browsing an Archive 

Click on a Plot Set Name to select a plot set.  You are then presented with a list of thumbnail 
images of the sheets in the set.  Click on an image to view the full sheet.    

 Note the index data for the plot set is listed at the top of a Table of Contents frame 
on the left of your screen (Figure 34-3).   

 
Figure 34-3: Table of Contents Frame 

Viewing a Selected Sheet 
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Notice that there is a link titled "Hide Table of Contents Frame" near the top left of the main 
frame (Figure 34-3).  This will provide more room on your screen to browse the sheet you 
have selected.  There are several controls available in a right-click menu to Pan, Zoom, 
Window an Area, Fit View, Rotate, Plot, Measure, etc (Figure 34-4).   

 
Figure 34-4: Right Click menu items 

Icons are also available at the lower left of the view screen (Figure 34-5) to do some of these 
functions.  These icons will be familiar to MicroStation users. 

 
Figure 34-5: View controls 

Advanced Searching - Two Stage Search 
If you don't know the specific Project Number or PIN that you are looking for, it will be 
more efficient to do your search in two stages.  In the first stage, you will search for title 
sheets of all the projects that meet your criteria in a specific town. When you have found the 
title sheet for the project you are interested in, note the Scan Project ID.  The second stage 
will be to search on that number as a Plotset ID.  This results in all the sheets archived from 
the selected project. 

Example: 
Sheet Type:  *Title* 

Town(s):       *Topsham* 

Among the results is project I-95-5(47)74.  The plans for this project have Scan Project ID of 
1185.  A second search, on Plotset ID 1185, yields 22 sheets from that project.  If we had 
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done a single search for plan sheets in Topsham, we would have had 266 sheets to wade 
through in order to find what we need. 

The advantage of this Two Stage search procedure is that you don't have to browse through a 
huge number of sheets to find your project! 

 Due to the design of the index database, there is a field, shown as Scan Project ID, 
associated with individual sheets, and another field, shown as Plotset ID, associated 
with plot sets.  While these are technically different fields, their meaning to us is the 
same, and they can be used as a key to retrieving the sheets from a particular project, 
as in the above example. 

State Aid Plans 
We have scanned some State Aid plans into the VaultPlans archive, which do not have title 
sheets.  Therefore, you can't find them via the Two Stage Search described above.  However, 
we have Region, Division, and SA designations in the Source File Location field.  Use the 
following example to search for all of the State Aid plans in a particular town 

Example: 
Source File Location:  *SA* 

Town(s):       *Winthrop* 

You can then use the Sort By pull down in the Results page to help in focusing in on the 
plans you need. 

Right of Way File Numbers 
Right of Way plans are located in the Property Plans archive. Most of the plans have a 
ROW File Number. The file number in Digital InterPlot will consist of a six digit number. 
The ROW File Number contains a hyphen. You will need to substitute a zero “0” in place of 
the hyphen. Add a preceding zero to the number to the left of the hyphen if the number is a 
single digit. Add one or more proceeding zeros to the number to the right of the hyphen so 
that the number is a total of 3 digits. 

 In all examples below, the file numbers should be preceded and followed by and 
asterisk (*) in order to produce all possible results. Right of Way files that are 
REVISED will be added to the same Scan Plotset ID, however their ROW file number 
will be incremented by _REV#. If searching by the ROW file number, add the asterisks 
in order to locate these revised plan sheets. 

Example 
ROW File Number: 2-58 

Digital InterPlot #: *020058* 

 

In some cases there will be a letter included at the end of a ROW File number. Tack this 
letter to the end of the file number (no space). 



mdot MicroStation 

01/01/12 

EPLANS Archive (General 
Users) 

 

34-9 
 

Example 
ROW File Number: 2-129 A 

Digital InterPlot #: *020129A* 

 

In some cases there will be the letter “S” at the beginning of a ROW File number. Tack this 
letter to the front of the file number and add a space. Do not use a hyphen. 

Example 
ROW File Number: S-2-179 

Digital InterPlot #: *S 020179* 

 In order to retrieve only the revised plans for any given ROW file number, do a two 
stage search by entering *Rev* in the Source File Location field as well as the ROW 
file number with asterisks. 

Limit Your Criteria Fields 
Fill in only the fields that are important in defining your search, using wildcards 
appropriately (see below).  Filling in too many fields may limit your search in ways that you 
do not intend. 

Wildcards 
Originally, the % sign was used as the wildcard character in the search criteria, and searches 
were case sensitive. We have modified the programming to allow the asterisk (*) as a 
wildcard, and to make the search insensitive to the case of the entered search criteria. 

It's generally a good idea to use a wildcard on either side of the text in a criteria field.  For 
example, *Brewer* in the Town(s) field would return plan sheets in any plot set where 
"Brewer" is included in the field, including entries like "Bangor, Brewer".  Specifying a town 
name without the wildcards will cause the search to miss records where the specified town is 
one of several in a list. 

Practice 
As you experiment with searching the archive, you will get a better feel for what works and 
what doesn't.  Maybe you'll even come up with some suggestions we can use in this Hints 
and Tips list! 
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MEASURING A E-PLAN IMAGE 
Overview 
Digital InterPlot assumes a 300 dpi image when it calculates scales.  Our Black and White 
images are 300 dpi.  However, our color images are 200 dpi.  Therefore, when setting scales 
for plotting or for measuring (color images only), there is a "fudge factor" involved.  We, and 
some of the other customers, are urging Bentley to modify their software to automatically 
adjust the calculation, depending on the image resolution, without the need for a fudge 
factor.  Until that is done, there is a ratio of 300/200 (or 150%) that needs to be applied to the 
scale setups for color images.   

If you see shades of gray in the image, especially in the background, it is most likely a color 
image. The black & white images have no gray in them and have a crisp white background. 

 Newly scanned color images that have been scanned in-house will not require a 
“fudge factor”. They have been scanned at the same resolution as previously scanned 
color images, but maintain their paper size dimensions. 

Configure Ruler 
Before measuring either distances or areas, you need to complete the settings under 
Configure Ruler in the Measure menu. You first enter this menu system by a Right-Click 
on the image and then choose Configure Ruler (Figure 34-6). 

 
Figure 34-6: Entering the Ruler Configuration 
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Example 25 ft per 1 Inch 
The image below (Figure 34-7) illustrates the setup for a scale of 25 feet per inch.  Note that 
we have indicated that we will measure in Model Units, and that 1.00 inches on the paper 
equals 25.00 feet in the model (or on the ground in our case). For a color image, the settings 
would be 1.00 inches on the paper equals 37.5 feet in the model, due to the "fudge factor" 
discussed above. 

 
Figure 34-7: Setup for 25 feet per Inch 

 We recommend that you do a test measurement on a known distance, such as a station 
interval, to confirm that your ruler setup is correct before you do a series of 
measurements. 

Other Setups 
You need to know the scale of the drawing you are measuring, in order to set the Ruler 
correctly.  It is possible to set up for any scale ratio.  You must remember to add the 150% 
"fudge factor" when measuring on our color images.  Here are some typical setups for plan 
view drawings (Figure 34-8). 

 
Figure 34-8: Typical drawing scale setups 
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Measuring Distance 
Choose Measure - Distance from the Right-Click menu.  Click on the first point and then 
click on the second.  You should see the measured distance in the lower-right border of the 
drawing window (Figure 34-9).  You can continue measuring a cumulative distance, from 
point to point to point.  One tap on the ESC (Reset) key will reset the measurement to zero.   

Two taps on the ESC key will back you out of the Measure Distance command. 

 
Figure 34-9: Distance is displayed in the lower right hand corner 

Measuring Area 
Choose Measure - Area from the Right-Click menu.  Click on the first point, then click on 
the second, and continue to define a polygon to be measured.  You should see the measured 
area in the lower-right border of the drawing window (Figure 34-10).   One tap on the ESC 
(Reset) key will reset the measurement to zero and clear the polygon.    

Two taps on the ESC key will back you out of the Measure Area command. 

 
Figure 34-10: Area measurement displayed in lower right hand corner 
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PLOTTING (PRINTING) A SELECTED SHEET 
Overview 
There are several variations available in methods for printing and plotting.  We'll discuss a 
method here that should be appropriate for most situations.   

Plot to Form 
From the right-click menu, select Plot to Form (Figure 34-11).  You can choose any printer 
or plotter that is set up in Windows on your PC. 

 
Figure 34-11: Right Click, select Plot to Form 

  Refer to the MicroStation manual for a list of available plotters and how to add 
them as a Windows Printer or place a Customer Support Ticket to request OIT to 
setup additional plotters. 

Once you choose a printer or plotter, you should click on the Properties button to select the 
appropriate sheet size (normally D+ or Arch D) and orientation (normally Landscape).   

 To plot only a portion of the sheet, select a different page size such as 8 ½ x 11. The 
shape on your cursor will be adjusted to this size. 

After you click OK on Properties, you need to set up the scaling of the plot. 

Black and White Images 
Digital InterPlot scales correctly with our black & white images, which were scanned at 300 
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dpi. If you are printing from a black & white image, select Plot at Original Scale or Scale 
Percentage of 100. To get a half size plot, use 50.0 in the Scale Percentage field.  

 Color Images (old vault plans) 
We have to set a scaling factor to get the proper sizes when printing our older vault plan 
color images.  To get a plot from a color image at full scale, use 150.0 in the Scale 
Percentage field. To get a half size plot, use 75.0 in the Scale Percentage field. 

Newer color scans (As-Builts) will be scanned at 200 dpi, but the size of the image will be 
identical to the black and white images. Select Plot at Original Scale or 100.0. To get a half 
size plot, use 50.0 in the Scale Percentage field. 

Place the shape 
Place the sheet frame on the image with a left-click of the mouse. The original may have 
been wider than the sheet frame. This procedure lets you decide which margins to crop off to 
make the plot fit well. 

Confirm by responding Yes to the Plot Selected Area question (Figure 34-12).  

 
Figure 34-12: Plot selected area? 

 You can answer No at this time if you have changed your mind. 
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USING A DOCUMENT POOL 
Overview 
A Document Pool is a collection of digital plots (DPR files).  The following is a summary of 
the use of the Document Pool for printing: 

Add Single files to the Document Pool 
From the "Plot Set Table of Contents" page or the "Archive Results" page, click the 
check box next to the thumbnail.  Check as many sheets as you want on this page (Figure 
34-13). 

 
Figure 34-13: Place a check in the box next to the image 

Click the "Add to Document Pool" icon (+) next to the check box (Figure 34-14) to add the 
document(s) to the document pool. 

 
Figure 34-14: Click the Plus sign (+) next to the check box of the image 

  You can repeat these first two steps to add sheets from other pages to the Document 
Pool. 
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Add Multiple files to the Document Pool 
Part One: Display all Documents on one Page 
If you have isolated the search to display only the pages you wish to print, you can add them 
all at once to the Document Pool.  
Only five images are displayed in the thumb nail view by default when the results of a search 
are displayed in Digital InterPlot. Towards the top left of the window (Figure 34-15) you 
will notice the Number of Records Found for the search (i.e. 65). The Records per page is 
only displaying 5 at a time. 

 
Figure 34-15: Number of Records Found and the Records per Page 

Part Two: Change the Records per Page 
Change the Records per page to the Numbers of Records Found. Type in 65 in the Records 
per page box and hit Enter. The page should now display all 65 images (Figure 34-16). 

 
Figure 34-16: Records per page matching the Number of Records 

Part Three: Select all Documents 
Select all the images at once by clicking the check mark in gray bar above all the images 
(Figure 34-17). This will place a check mark next to all the images on the page. 
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Figure 34-17: Select all the images at once 

Part Four: Add to the Document Pool 
Click the Plus Sign (Figure 34-18) next to the Check Mark to add all the images to the 
Document Pool. 

 
Figure 34-18: Click the Add button to add all images to the Document Pool 

 The last icon next to the Check Mark will Clear all of the documents (removes the 
check mark next to all the images).  

Removing Documents from the Pool 
From the Digital InterPlot page, click the "Document Pool" tab. Click the check box next to 
the thumbnail to select the document (Figure 34-19). 

Click the "Remove from Document Pool" icon (-) next to the document name.  
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Figure 34-19: Images in the Document Pool 

Printing Documents in the Document Pool 
If you are satisfied with the documents in the pool, select the Check Mark above all the 
images to select them all (Figure 34-20). 

 
Figure 34-20: Check All button 

 Pick Print Pool towards the top right of the page. This opens the Digital InterPlot Document 
Pool Printing window (Figure 34-21). By right clicking, you have an option of sorting, 
deleting or moving a document to get them in the correct order. 

 
Figure 34-21: Right Click to sort or move a document 

To print all the documents in the Print Pool, click Print. 

The print dialog box then comes up, where you can make settings, as you do for other 
methods of printing. 

 Refer to page 34-13 for picking a plotter and adjusting the settings. 
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SAVING AN IMAGE TO DISK 
Saving a JPG Copy of Image 
At the very bottom of the view page, there is a link to a JPEG image file of the selected plan 
sheet.  As with many web sites, you can right-click and do a Save As to get your own copy 
of the image to use however you need. These can be emailed to anyone requesting the 
images. 

 Refer to page 2-77 for instruction on attaching images to scale in MicroStation. 
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DISPLAY FIX 
Overview 
On some PC's, especially some of Maine DOT's laptops, you may see a display problem 
when viewing a sheet through Digital InterPlot, InterPlot Organizer, or the Portable Plan 
Set viewer. The image will appear as if it has been “shredded” (Figure 34-22) or doesn’t 
display at all. The fix for that problem is to set the following two variables in Windows at the 
System level: QV_SWCONTEXT=1 and QV_NOPBUFFER=1. 

 
Figure 34-22: Image on a PC that requires the Windows System Variable 

Add Windows System Variable 
Part One: Right Click My Computer 
Right click the My Computer icon and select Properties. 

Part Two: Select Advanced Tab 
Select the Advanced tab and click on Environmental Variables (Figure 34-23). 
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Figure 34-23: select the Environmental Variables button 

Part Three: Add new System Variables 
Select the New button in the System Variables section. Add the two new variables 
(QV_SWCONTEXT=1 and QV_NOPBUFFER=1) and their values as shown in Figure 
34-24.  

 
Figure 34-24: Add the variables and their values 

Once the variables have been added, you should be able to locate them in the list of System 
Variables (Figure 34-25). Click OK. 
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Figure 34-25: New variables added to the System Variables 
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DATA FIELD DICTIONARY 
Fields in Search Page 
Plot Set Name 
This field comes from the file name of the IPS file used to create the plot set. For our scanned 
Vault Plans, this filed is derived from the Project Number. In the Browse Page, this is the 
field with the attached link to go to the plan sheets in the set. 

Sheet Name 
This field comes from the file name assigned to the image when Smooth Solutions did the 
scanning. It is normally the sheet number, padded to at least 3 places. For example, sheet 2 of 
the plan set becomes 002. When there are sheets added in between, or the scanners found two 
or more of the same sheet number, Sheet Names like “002A” are created. 

Sheet Type 
This is the type of sheet, as interpreted by the scanners, from the following list: 

Title, Typical Sections, Standard Details, Estimate, Drainage, Plan, Profile, Plan_Profile, 
Xsections, Geometry, Highway_Other, RWPlan, Bridge_Abutment, Bridge_Pier, 
Bridge_Superstructure, Bridge_Details, Bridge_Other, Other. 

Project ID Number (PIN) 
This field is the PIN that we use on newer projects. Projects started before 1982 did not have 
PINs assigned. 

 Source File Location 
In the case of the original Vault Plans, this field was used for the “Rack ID” where the plans 
were stored. It can be useful in comparing with the earlier Vault Plans Index. 

Contract Plans, Amendments and As-Built Plans will be used for all Highway, Bridge, 
Traffic and Multimodal plans. 

In the case of the original Right of Way Plans stored in racks, this field was used to indicate 
where the scanned plan was stored. This field, along with the ROW File Number can be used 
in comparing with the old RW Plans Index. All new Right of Way Plans will have either 
ROW Plan or ROW Plans Revision as the Source File Location. 

Project Name 
This field was intended for the name and/or description on the title sheet of the plans. 
However, the process of transferring data from the old Vault Plans Index has resulted in the 
contents of this field usually being the same as the Scope/Description field (which is 
normally the same information). 

Project Number 
This is the Project Number as shown on the Title Sheet. This is likely to be a Federal-Aid 
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Project Number with various initials or abbreviations in it. The format of these numbers 
varies widely. The early projects had very cryptic numbers. 

ROW File Number 
This field contains a number assigned by our Right of Way staff to track the RW Plans. It 
will be blank in plot sets that are not RW Plans. 

Year 
Ideally, this is the year that the project was constructed. However, the old index was 
incomplete and lacked this information on many projects. In these cases, we have instructed 
Smooth Solutions to use the latest year they can find on the plans. If they have searched and 
cannot find a date, they are to enter “NONE” to indicate that the search was made and no 
date was found. 

Route Number(s) 
This field contains the route number, from a standard list, for most highway projects. 
Unfortunately, most of our bridge projects do not list a route number on the plans, relying 
only on the bridge number. There can be multiple route numbers listed on a project. 

Route Code 
This field contains an MDOT route code, which has been used by Planning and others, and 
relates directly to the route number. This field will provide more precise search results if you 
know the code for the route you are looking for. 
On projects which did not have a Route Number listed in the old index, we do not have a 
Route Code entered. 

 Refer to page 34-34 for a list of route codes. 

County 
This field can have more than one county in it, when projects cross county lines. 

Bridge Number 
This field can have more than one bridge number in it, when multiple bridges are involved in 
the project. 

Town(s) 
This field can have more than one town in it, when projects cross town lines. 

Scope / Description 
The contents of this field were taken from the old indexes. Many of these entries include four 
letter “scope codes.”  

 Refer to page 34-36 for a list of scope codes. 

Scan Plotset ID 
This field is essentially a “serial number” for the Plot Set (project) as it is processed into the 
Digital InterPlot system. Each plot set will have only one Scan Plotset ID. This field can be 
useful in doing a two-step search, where you get a list of title sheets meeting your search 
criteria, identify the project you want, then search for all sheets belonging to that plot set. 
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Sheet Fields 
Sheet 
This field is a number generated by Digital InterPlot. A “3” in this field means that this is the 
3rd sheet entered. When additional sheets are inserted, such as sheet 3A, or when sheets are 
missing from the set, this number does not match the sheet number on the plans. 

Sheet Name 
This field comes from the file name assigned to the image when Smooth Solutions did the 
scanning. It is normally the sheet number, padded to at least 3 places. For example, sheet 2 of 
the plan set becomes 002. When there are sheets added in between, or the scanners found two 
or more of the same sheet number, Sheet Names like “002A” are created. 

Scan Project ID 
This field is the “serial number” for the Plot Set, and is the same number as the Scan Plotset 
ID. 

 Due to the structure of the database, this sheet field has a different name than the 
corresponding field in the plot set. There is a “hidden” field which serves as the index 
on which the relationship between plot sets and sheets is technically established. 

Scan Image ID 
This field is a “serial number” for the image. Each image has a unique Scan Image ID, which 
can be used for system management purposes. This is required because the image file names 
are not unique. 

Other Fields 
Number of Sheets 
This is the number of sheets in a Plot Set in Digital InterPlot. It is very likely not the same as 
the number of sheets in the original plan set. For most projects, the cross section sheets were 
pulled out and microfilmed years ago. Other sheets may be missing, for whatever reason. 

Sheet __ of __ 
This is based on the sheet numbering generated by Digital InterPlot, and likely does not 
coincide with the original numbering of the plan set. 

DPR 
For a sheet, this is a link to an image file in the DPR format that Digital InterPlot uses. For a 
plot set, this field is a link to the IPS file that defines the makeup of the plot set. 

JPEG 
For a sheet, this is a link to an image file in the JPG format, which is a popular industry 
standard. You can Right-Click and Save As to get your own local copy of the image file, to 
be used with MicroStation, or almost any software that handles images. For a plot set, this 
field is a link to the IPS file that defines the makeup of the plot set. 
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INSTALLING PORTABLE PLAN SET UTILITY 
Overview 
If you receive requests from clients outside of MaineDOT for multiple images stored in the 
E-Plans archive, a Portable Plan Set (PPS) is the perfect solution to providing the images. 
PPS is a program delivered with Digital InterPlot that enables the packaging of images 
produced from a search of an archive. This program needs to be installed as a separate 
application on a user’s computer. 

Step One: Starting the Batch File 
We created a batch file that users can run to do the install for themselves. If viewing this as 
an electronic document, click this link (\\oit-
teaqasdtiis.mdot.w2k.state.me.us\pcpin1\msworksp\DigitalInterPlot\) to browse to the 
directory where the batch file is stored or type the address into a Windows Explorer address 
bar. Double click the InstallPPS.bat to start the program. 

Step Two: Click any Key to Continue 
A black command prompt dialog will open. Read the short description and click any key to 
continue. After a few commands run, you will be prompted to click any key again. 

Step Three: Add Info to Registry 
After clicking any key the second time, you will receive the message shown in Figure 34-26. 
Click Yes. 

 
Figure 34-26: Add information to Registry prompt. 

Step Four: Confirmation of Registry Addition 
Almost immediately you will receive another message stating the information was added 
successfully (Figure 34-27). Click OK. 

 
Figure 34-27: Confirmation of Registry information 
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Step Five: Click any Key to Finish 
The command prompt dialog will send a message stating that the installation was successful. 
Click any key to continue and exit the program. 

 Contact CADD Support personnel with assistance if necessary. 
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USING PORTABLE PLAN SET UTILITY 
Overview 
The Portable Plan Set utility looks and acts the same as the regular E-Plans archive. Do the 
searching with this utility instead of with the E-Plans archive. 

 Creating a Portable Plan Set is great for sending multiple images to an outside source. 
It will contain the indexing information as well as the image(s). If only a single image 
is needed, it may be just as easy to save the .jpg and email the image. No indexing 
information is available with a .jpg. 

 The file sent will not contain an image that can be saved out of the program, however 
if the recipient has Adobe Professional, they can print to a PDF and save to a tiff 
image. 

 Refer to page 34-19 for instruction on saving a .jpg image from the E-Plans 
archive. 

Step One: Launch PPS 
Launch the Portable Plan Set (PPS) utility from the Desktop icon or select Start > Programs 
> Create Portable Plan Set. The interface is very similar to the regular E-Plans archive 
(Figure 34-28). 

 
Figure 34-28: CreatePPS dialog 

Step Two: Locate Plan Set(s) 
Using the normal search routines, locate the desired plan set. Once a plan sheet is located, 
click the thumbnail image to enlarge it.  

 Refer to page 34-6 for information on searching an archive. 

Step Three: Create Folders (Optional) 
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 Overview 
We recommend that the user creates a folder to contain the images even if they are all for the 
same project location. This is optional, but when gathering multiple images from different 
projects or Right of Way Files, we highly recommend creating folders and sub folders to 
better organize the images. 

 Part One: Add Folder 
Select Tools > Add Folder from the CreatePPS menu or select the Add Folder icon (Figure 
34-29). 

 
Figure 34-29: Add Folder icon from the CreatePPS tool bar. 

Enter a folder name (i.e., PIN-Town or Town) and click OK.  

 Part Two: Add Sub Folders (if necessary) 
If adding multiple images from different projects, add a sub folder. Highlight the newly 
created folder and select Add Folder again. Enter the new folder name and click OK. The 
result will be similar to Figure 34-30. 
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Figure 34-30: Folder structure to organize the images. 

Step Four: Add Image to Folder 
Once an image is selected (enlarged from the thumbnail view), the ADD button is activated. 
Select which folder you want the image placed in and click ADD. 
Images and folders can be moved around simply be dragging and dropping to better organize 
the content. They can also be deleted, renamed or sorted by right clicking on the image or 
folder and picking from the sub menu. 

Step Five: Adding Additional Images 
With practice, you will find how fast you can click on a thumbnail drawing and add it to the 
PPS.  If you go too fast, you will “get ahead” of the software and add multiple copies of the 
same sheet.  On the other hand, you don’t have to wait for each sheet to fully “draw up” each 
time. You can also delete extra copies, if you added some inadvertently. 

Step Six: Create Plan Set 
Once all the images have been added and are organize the way you want, select Tools > 
Create Plan Set from the PPS main menu or click the icon with the picture of a folder with a 
hammer (Figure 34-31). 
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Figure 34-31: Create Plan Set tool on the tool bar. 

The Save In dialog will open giving the user the opportunity to browse to a location to save 
the file and supply a name for the PPS. The recommended location to place the files is the 
C:\temp folder. Double click the file to view the results. 

Step Seven: Send the PPS 

 Overview 
There are multiple ways to send the Portable Plan Set. Depending on the size of the PPS may 
help you determine the best method. If you aren’t showing the details of all files, right click 
and select Properties. The size is displayed. 

 Send via Email 
If the size of the PPS is less that 10MB it can be sent through our email system, however the 
recipients maximum file size may be smaller. 

  IMPORTANT NOTE: Most email systems will not allow an .exe file to be sent or 
received. Simply right click the file and select. Rename the files extension in the 
C:\temp folder from .exe to .txt. Windows will ask if you want to do this. Select Yes. 
Attach the file to the email message and instruct the user to save the file locally and 
rename it back to the .exe extension. 

 FTP Site 
The FTP site can handle almost any file size and files with an .exe extension. This is a good 
method for sending large files. 

 Refer to page 33-2 for instructions on sending a file using the FTP site. 

 Burn a CD 
Another option is to burn a CD and mail it. 

 Refer to Windows HELP for instructions on burning a CD. 
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ROUTE CODES 
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ROUTE CODES (CONTD.) 
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SCOPE CODES 

 
EPLANS Archive (Admin. Users) 
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INTERPLOT CLIENT SETUP 
Overview 
The InterPlot Client setup is for those who will be archiving plans into the E-Plans Archive 
(Digital InterPlot). The steps listed below are for a new installation (version 08.11.07.420). If 
you are doing an Upgrade of an existing installation, see the Upgrade Notes section of this 
document. 

Step One: Test E-Plans Viewing 
View a plan sheet through the Digital InterPlot Archive (E-Plans).   

 If there are problems, go to the Fix for Display Problem section on page 34-20. 

Step Two: Install InterPlot Client from Disk 
If viewing this as an electronic document, click this link (\\oit-
teaqasdtiis.mdot.w2k.state.me.us\pcpin1\msworksp\DigitalInterPlot\Software 
Install\pwpor081107420en \Install ) to browse to the install directory or type the address into 
a Windows Explorer address bar. Double click the Setup.exe program. 

Install everything with the exception of APLOT (AutoCAD), MicroStation J Support and 
Bentley View (scroll down). Restart Computer. 

  Step Three: Copy Icon to Desktop 
To create a shortcut to the desktop, browse to but do not click on Start > Programs > 
ProjectWise InterPlot Utilities > ProjectWise InterPlot Organizer. Right-click and select 
Send to > Desktop (create shortcut).  

Step Four: InterPlot Client Configure 
Select  Start > Programs > Bentley > ProjectWise InterPlot Utilities > ProjectWise 
InterPlot Organizer Configure.  Select the Integrate button. There, you will confirm that 
you are integrating with the installed copy of MicroStation. Click OK and Exit Configure. 

Step Five: Add the Plot Server Printer 
Establish a connection to InterPlot to XEROX 6204 on \\dot0dta1asplot1 . This printer 
provides access to the drivers needed by Digital InterPlot, even when “printing” only to the 
archive. To install this printer, click the link in the document link in this document and 
double click the IPXEROX6204 plotter in the list. If it doesn’t work, type the address in 
Windows Explorer and double click the IPXEROX6204 plotter in the list. 

 This is not the same as the plotter share on the regular print server, dot0dta1psprint. 

Alternatively, you can add a network printer and enter the wildcard *XEROX 6204* in the 
name field. Highlight the printer and click OK. 
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 Note that there must be a space between “XEROX” and “6204”.   

Step Six: Run Batch File 
Browse to the batch file located at the following location (\\oit-
teaqasdtiis.mdot.w2k.state.me.us\pcpin1\msworksp\DigitalInterPlot\ . Double click the 
IPClient.bat file to install the license and custom files. 

Step Seven: Setup InterPlot Organizer Printer 

 Part One: Create Folder 
Part of the setup will require an output directory. Create a folder called dprfiles at the root of 
the D:drive. 

 Part Two: Add Printer 
Select Start > Printers and Faxes. Click Add Printer [Next] and select Local Printer 
Attached to this Computer [Next]. Select Create a new port: and set the port to InterPlot 
Organizer Port [Next]. 

Enter a port name, (i.e. InterPlotPort) and then click OK. 

From the Job Storage Definition dialog box (Figure 34-32), select the output directory for the 
DPR files. (i.e. D:\dprfiles). Click Pattern Setup to change the file-naming pattern for the 
DPR files. Click OK. 

 
Figure 34-32: Job storage definition dialog. 

Click Next. 

Select Bentley from the Manufacturers list box, and the InterPlot Organizer Printer 
Driver from the Printers list box, and then click Next. 
Select Keep Existing Driver and then click Next. 



mdot MicroStation 

01/01/12 

EPLANS Archive (General 
Users) 

 

34-39 
 

Enter the printer name (i.e., InterPlot Organizer Printer Driver), and then click Next. Do not 
set it as the default printer. Click Next.  
Select Do not share this printer then click Next. 
Select No so as not to print a test page. Click Next and then click Finish.  

 Part Three: Test 
Open InterPlot Organizer. Pick Create a new plot set from files you select. Select the Add 
button and browse to an image file. Select OK. Select OK again. The image will populate in 
the InterPlot Organizer dialog. Right click the image and select Print Preview. If the image 
doesn’t display, then there is a problem with the setup. Contact CADD Support. Close the 
dialog w/o saving changes. 



mdot MicroStation 

01/01/12 

EPLANS Archive (General 
Users) 

 

34-40 
 

INDEXING AN IMAGE/DGN TO BE ARCHIVED 
Overview 
In order to perform complex searching easily in the E-Plans archive, standard information 
must be gathered from the original plan set. There are standard fields and standard responses 
to these fields. This portion of the manual is intended to provide instructions as to where to 
find the appropriate index sheets and specific instructions based on the type of plan you are 
indexing. There is an Example Index for each type of plan to be indexed. 

Location of Index and IPS files 
We have created folders to keep settings files, specific instructions, Indexing Examples, 
Standard Forms, and Master IPS files separated. This location is on the CADD server which 
is normally mapped as the Y: drive. Consider mapping the Y: drive to the following location 
\\oit-teaqasdtiis.mdot.w2k.state.me.us\pcpin1\ . The Digital InterPlot folder contains these 
folders Amendments, As-Builts, Contracts, Maintenance, Multimodal and Property Plans. 
Follow specific instructions within these folders based on the type of sheets to be archived.  

Paper Index Sheets 
The paper indexing documents can be printed and used to gather the information off the plan 
sheets. It’s easier to gather this ahead of time instead of when you are adjusting the values 
electronically. You can’t perform print preview and enter the values at the same time. Each 
end every sheet should have an index form with the exception of a range of the same sheet 
type (i.e., Cross Sections). Fill out the “constant”, project specific values and make 
photocopies. Adjust only the values that change per sheet. 

Electronic Index Sheets 
We made it easy to enter the information electronically in a Word document for those who 
are computer savvy. These standard documents can be edited easily electronically and the 
content copied and pasted into the Attributes inside of the IPS file.  

Archiving From a Scanned Image 
This procedure will utilize the Settings File that has the same name as the folder that it’s in. 
Pages scanned at MaineDOT will be either B/W at 300 dpi or color at 200 dpi. If the sheet is 
larger than a 24” x 36” page size, we may need to add additional Settings Files with other 
page sizes. Refer to the instructions within each folder titled PlanType.doc.??? 

Archiving MicroStation Drawings 
This procedure will utilize the Settings File that has a MS and the units of the file in the name 
(i.e., MS_ROW). The MicroStation files are added and printed through the InterPlot 
Organizer. Refer to the instructions within each folder titled MS_PlanType_units.doc. 

Archiving MicroStation Drawings with Images 
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This procedure will utilize the Settings File that has a MS, the units of the file and the word 
image in the name (i.e., MS_ROW-image.set). The MicroStation files are added and printed 
through the InterPlot Organizer. These MicroStation files have a raster image in the 
background and require a different settings file. Refer to the instructions within each folder 
titled MS_PlanType_units.doc. 
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GENERAL ARCHIVE INSTRUCTIONS 
Step One: Open the ???_Master.IPS file 
Open Windows Explorer and browse to the Y:\Digital InterPlot folder. Open the folder 
containing the type of drawing you plan to archive (i.e. Amendments, As-Builts, Contracts, 
Maintenance, Multimodal or Property Plans). Open the ???_Master.ips file in the folder (i.e. 
PORMAPS_MASTER.IPS, MaintF_MASTER.IPS, Contracts_MASTER.IPS, 
AsBuilt_MASTER.IPS, ROW_Master.IPS, etc.). 

Step Two: File > Save As... 
Select File > Save As... and supply a new file name based on the type of archiving you are 
doing. For PORMAPS, enter the PORMAPS_wholepin_decimal.IPS (i.e., 
PORMAPS_12671_00.IPS). For Maintenance Facilities, enter Town_TypeFacility.IPS (i.e., 
AUBURN PICNIC AREA.IPS or ALFRED MAINT LOT.IPS). For CONTRACTS, enter 
Contracts_wholepin_decimal.IPS. For ROW, enter ROW_FileNumber.IPS or 
ROW_FileNumber_REV#.IPS. Try to keep consistent with other types of file names in the 
list. 

Step Three: Browse to Images 
Select File > Create Plots. Select Add and browse to select images. Some scanned images 
may come from disk or have been scanned and place into the OCE Scan Pool folder on the E-
Plans server \\dot0dta1fseplan\OCEscanPool\ folder. Select and add the image(s). 

Step Four: Pick Settings File 
In the Plot creation options portion of the dialog, select the Browse button next to the 
Settings file name field. Browse to the Y:\Digital InterPlot folder. Open the folder 
containing the type of drawing you plan to archive (i.e., Amendments, As-Builts, Contracts, 
Maintenance, Multimodal or Property Plans). Select the appropriate settings file for the type 
of archiving you are doing (Archiving_POR.set, Maintenance.set, Contracts.set). Select 
Open. 

 If the wrong Settings File was chosen, select Edit > Select > All Plots. Then select 
Edit > Settings File > Apply and browse to choose the correct Settings File. 

Step Five: Review File Names 
Look at the sheet names. These files should be pre-named appropriately. For regular plans 
use 001, 002, 003, or Title Sheet, Typical01, etc. Right of Way Plans use the actual sheet 
number in the ROW File Number (i.e., sheet1, sheet2, etc). Are they in order? Select Edit > 
Select > All Plots. Select File > Print Preview. View the order of the plans. 
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Step Six: Rename Plot Name (if necessary) 
Rename the Plot Name in the InterPlot Organizer by selecting an image then selecting Edit > 
Rename. Once the images are renamed in ascending order with the naming convention or 
001, 002, 003, etc, re-sort the images by clicking on the Plot Name column.  

Step Seven: Edit Attributes (For Whole Plot Set) 
Select File > Attributes and supply the values from the hand written index page or from the 
page to be scanned.  

 The PSPROJID should be verified by checking the E-Plans Archive. Depending on the 
type of image being scanned, we have setup a number range for the plotset. 
Maintenance Facilities archives for example, start with a number greater than 25000. 
View the E-Plans archive to determine the last number that was used for the most 
recent archive. This number can be found in the rightmost column of the archive. Add 
the next available number. 

 You do not have to select all of the images. 

Step Eight: Individual Image Variables 
Each image has its own variables that need to be adjusted. Right click the first image in the 
list and select Properties. Select the Variables tab. Select the PROJID lines in the top 
portion of the dialog. Adjust the PROJID Value field to the same number that was 
determined from the previous step. Click Set. 

 As a time saver, select all of the images go to Edit > Properties. Click on the 
Variables tab and manually add in PROJID in the name field and add the variable to 
the image’s PROJID values all in one edit. 

Select a single image and select the Type line from the top portion of the dialog. Adjust the 
Value from “plan” to the type of sheet that the image represents (i.e. Title Sheet, Plan Sheet, 
Typical Section, Cross Section, etc.). Select Set. Close the Properties dialog. 

Step Nine: Save the IPS File 
Select File > Save from the InterPlot Organizer menu. 

Step Ten: Print to Archive 
Select all the images in the list. Select File > Print. Adjust the printer to the 
\\dot0dta1asplot1\InterPlot to XEROX 6204.  
In the Digital Archiving portion of the dialog, place a check in the Archiving box. In the 
Archiving Name pull down, select Vault Plans (or Property Plans). Place a check in the 
Archive without Printing box.  
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Step Eleven: Verify it’s in the Archive 
After allowing the print some time to process, verify that the archive made it into the Digital 
InterPlot archive (http://dot0dta1asiis03/plansweb/dpr.asp ). Do a search in the Vault Plans 
archive by selecting the binoculars icon and entering the Scan Plotset ID in the Scan Plotset 
ID box (i.e., 30000). Click Search.  

http://dot0dta1asiis03/plansweb/dpr.asp�
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REPLACING A SHEET IN AN ARCHIVE 
Overview 
You will need to login to a computer as MDOT.dpruser to perform certain activities. To 
replace a sheet in an archive, you will need to plot to a new “temporary” archive. This will 
build the images (DPR, PDF, Thumbnail, TIFF_G4, JPEG) that you need to replace the old 
images.  

Step One: Create Temporary Plot Set 
Open the ???_Master.IPS file. Save it as a temporary name (i.e., Temp_S 050203.IPS) in a 
temporary location. Use the normal sequence of adding images or MicroStation files to the 
temporary IPS file. Pick the settings file for the type of image. 

Step Two: Archive to Test Archive 
Archive the temporary plot set to a "test" archive, such as Test_Five. 

Step Three: View the Sheet 
View the sheet, as it sits in the temporary plot set within the E-Plans Archive, through the 
browser’s interface, to make sure it's OK. 

Step Four: Browse to Eplans Server 
In the \\DOT0DTA1FSEPLAN server, find the folder structure for the "target" plot set (the 
one where the replacement will be made) (i.e., \dprfile_store\PropertyPlans\none21982).  

 Locating the target folder may be the hardest part of replacing an image. It’s best to 
locate the old image you want to replace in the E-Plans Archive. Click the image 
thumbnail then jot down the PID# (i.e., PID=21982) located in the address bar of the 
Internet Explorer window. Now through Windows Explorer, search the Property 
Plans folder for a file with this number in it (i.e., *21982*). 

Step Five: Make sub-folders 
Make sub-folders named "OLD" under each of the "image" folders in the target plot set 
(DPR, PDF, Thumbnail, TIFF_G4, JPEG). 

Step Six: Move old Images (Requires Login as 
MDOT.dpruser) 

In each of the image folders in the target plot set, move the original file (for the sheet to be 
replaced) to the OLD subfolder. 

Step Seven: Copy New Images 
Copy the corresponding image files from the temporary plot set in the test archive to the 



mdot MicroStation 

01/01/12 

EPLANS Archive (General 
Users) 

 

34-46 
 

image folders in the target archive.  Rename these files, if necessary, so that their name is 
exactly the same as the original files (that were moved to the OLD folders). 

Step Eight: Test 
Test by viewing the replaced sheet through the web browser interface. 

Step Nine: Delete Temporary Plot Set 
Delete the temporary plot set from the test archive. 

 Due to the fact that the quality of the edited replacement image may not be as good as 
the original, it is wise to keep the originals in the OLD folders
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ADD A CONNECTION TO CADD DATA 
Open ArcCatalog 
Start ArcCatalog by using your desktop icon. 

Setup Connection to PIN 
From the main menu (Figure 35-1), select File > Connect to Folder…  

 
Figure 35-1: Selecting Connect to Folder from the File Menu. 

When the Connect to Folder dialog opens, browse to the Y: drive (oit-
teaqasdtiis.mdot.w2k.state.me.us\pcpin1). Locate your PIN (i.e. Y:\pin\11584). Select your 
PIN’s folder, click OK (Figure 35-2). Now you should see the connection alphabetically in 
your list of files and folders within ArcCatalog. 

 
Figure 35-2: Connect to Folder dialog box. 

 It is not recommended to make a connection to the root of the Y: drive or the Y:pin 
folder. ArcCatalog takes a long time to analyze all of the data it finds. It’s best to have 
it look to the PIN you are working with. 
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ADD CONNECTION TO GISDATA\CADD FOLDER 
G:DRIVE 

Setup Connection to GISDATA 
From the main menu (Figure 35-3), select File > Connect to Folder…  

 
Figure 35-3: Selecting Connect to Folder from the File Menu. 

When the Connect to Folder dialog opens, browse to the G: drive (dot0dta1fsaug01\gisdata). 
Expand the G: drive to locate the CADD folder. Select it and click OK (Figure 35-4).  

 
Figure 35-4: Connect to Folder dialog box. 

Now you should see the connection alphabetically in your list of files and folders within 
ArcCatalog (Figure 35-5). 
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Figure 35-5: Connected folders in ArcCatalog 
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COPY PREDEFINED GEODATABASE TEMPLATES 
Overview 
We have created three predefined Geodatabases for use with our CADD files. Two of the 
Geodatabases contain Feature Datasets with spatial extents for our common coordinate 
systems we use for CADD data. The difference is one uses Metric units and the other uses 
U.S. Customary units. The third Geodatabase is for the UTM zone for the state of Maine 
(NAD83_UTM_19N_Meters). Since most of the GIS world maps data using the UTM 
datum, we will project our data into this Geodatabase’s Feature Dataset. From there, the data 
can be re-projected into any coordinate system in any units. Likewise, we can take UTM data 
from the GIS world and project it back into the State Plane Coordinate system for all 
MaineDOT projects. 

Step One: Open ArcCatalog 
Start ArcCatalog by using your desktop icon. 

Step Two: Browse to G: drive 
In ArcCatalog’s Catalog Tree, browse to G:\CADD. 

Step Three: Copy MaineDOT’s UTM Geodatabase 
There should be 3 MDOT Geodatabases at this location. Right click the MDOT-
NAD83_UTM_19N_Meters Geodatabases and select Copy. Browse to your PIN’s GIS folder 
(i.e. Y:\pin\11584\00\GIS). Right click this folder and select Paste. 

 If you are unable to copy into this folder, it may be because you don’t have 
permissions to the folder. Contact CADD Support and you will be added to the 
permission group. 

Step Four: Copy MaineDOT’s State Plane Geodatabase  
Determine is your project is in US Customary or Metric units by referring to the Status.rtp or 
Status.doc file if necessary.  

 Refer to page 35-9 for more information on the Status report. 
The units will determine which of the remaining two Geodatabases you will copy into the 
GIS folder. All new projects will be US Customary but some of the older data is metric. 
Right click the MDOT-StatePlane_Feet Geodatabase and select Copy. Browse to your PIN’s 
GIS folder (i.e., Y:\pin\11584\00\GIS). Right click this folder and select Paste. 

 If you are unable to copy into this folder, it may be because you don’t have 
permissions to the folder. Contact CADD Support and you will be added to the 
permission group. 

Step Five: Remove Unused Datasets (optional) 
The two State Plane Geodatabases contain multiple Feature Datasets for all of the possible 
renditions of the State Plane coordinates for that unit of measure. To keep the size of the 
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Geodatabase down, right click the Feature Datasets that you will not be using and select 
Delete (Figure 35-6). Delete all but the Feature Dataset you will be using for your project. 

 
Figure 35-6: Delete unused Feature Datasets. 

Verification Process 
The Geodatabases can be used as a verification tool as you work with the CADD data. Each 
Geodatabase has a map of the state (metwp24) as a Feature Class. Use ArcMap to map the 
data and visually see that your data is in the correct town. If the data is re-projected, check it 
against the map in new Feature Dataset. 
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OVERVIEW OF SPATIAL REFERENCE AND CADD 
FILES 

What CADD Files should be used? 
There are only a handful of files in any PIN directory that will be useful for GIS. These are 
the files that represent the existing ground conditions or proposed conditions. We will never 
be bringing plan sheets (i.e. 001_RWPlan1.dgn), Cross Sections 
(069_XSMC10_dr_001.dgn) or Profile Drawings (038_PROFMC10_dr_001.dgn) into GIS. 
None of the files with a 3 digit prefix are spatially located. Instead, select files like 
alignments.dgn, bridge.dgn, highway.dgn, topo.dgn, text.dgn, RWPlan.dgn, etc. These files 
can be laid on the face of the earth. 

Coordinate System of MaineDOT CADD Data 
MaineDOT has used a variety of State Plane coordinate systems throughout the years. In 
order to use data from one coordinate system and reference it to another, it’s important to 
know both the source coordinate system and the destination coordinate system. Using 
Windows Explorer, browse to your PIN’s Survey/MSTA folder (Survey/MX folder for older 
projects). In one of these directories there will be a file called Status.doc or Status.rpt. Open 
the file (it will be read only). In the document you will find the working units (U.S. Survey 
Feet or METRIC) and you will find a Control Summary. The Control Summary section holds 
the coordinate description. Write down the units and the coordinates for this project for 
future reference (i.e. U.S. Survey Feet & NAD83(1996) 1804 ME2000 WEST Zone). 

Methods of Applying Spatial Reference to CADD Files 
The CADD files do not have the spatial reference in the file header. In the future they may, 
but until then, you can apply the Spatial Reference to a CADD Feature Datasets manually. 
There are a few methods of applying spatial reference to CADD data. The latest version of 
ArcGIS now provides an option to save the .prj file with the CADD dataset. This option 
works great for one or two files, however, if you plan on adding spatial reference to many 
files, it might be quicker to try Option Two. The Option Two method would be to copy the 
proposed projection file (.prj) into the same directory as the CADD file. Rename the 
projection file to the same name as the CADD file maintaining the .prj extension. Both of 
these options will require that you have privileges to the folder that contains the CADD 
dataset in order to save the .prj to the directory. Option Three is using the Conversion Tools 
which now provides the option of adding spatial reference as you’re creating the Staging 
Geodatabase. The three methods are described below.  
The recommended method would be to copy the CADD files and Geodatabases into the GIS 
folder of a PIN and use Option Two. This way other users will not have to repeat the process, 
they can take advantage of files already spatially referenced. They can also use the files in 
the Geodatabases that have been re-projected. CADD GIS permissions are required to do 
this. Contact CADD Support.  
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APPLY SPATIAL REFERENCE (OPTION ONE) 
Step One: Right Click the DGN (CAD Feature Dataset) 
In the list of files, scroll down beyond all the files that start with a 3 digit prefix, right-click 
the file RWPLAN.dgn and select Properties… (Figure 35-7). 

 
Figure 35-7: Accessing Properties of a CAD Feature Dataset. 

When the CAD Feature Dataset Properties panel appears (Figure 35-8), notice that the 
Spatial Reference indicates that there isn’t a default projection file associated to the CADD 
file.  
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Figure 35-8: CAD Feature Dataset Properties dialog. 

Click the Edit… button. This opens the Spatial Reference Properties dialog (Figure 35-9). 
Select the Import button. 

 Another option would be to pick the Select button and browse to a projection (.prj) 
file. We have placed the common projection files within the G:\CADD folder on the 
network.  
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Figure 35-9: The Spatial Reference Properties dialog. 

Step Two: Add Coordinate System info to the CAD Feature 
Dataset 

Browse the State Plane Geodatabase within your project’s GIS folder. Double click the 
Geodatabase and select the dataset internally that is named the same coordinate system as 
your project (Figure 35-10). Click the Add button.  

 Refer to page 35-9 for information on determining the coordinate system of your 
project. 
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Figure 35-10: Select the Dataset that matches your project's coordinate system. 

Then click OK at the Spatial Reference dialog. Next you have an option to save a .prj 
specifically for the file that assigns the coordinate system (Figure 35-11). It’s the same name 
of the original CADD Feature Dataset with the .prj extension. Select Save. 

 If you do not have permissions to copy the .prj file(s) into the project’s MSTA folder, 
consider copying the files into the GIS folder. 

 
Figure 35-11: Save coordinate system to your files. 

Click OK to close the CAD Feature Dataset Properties dialog. 

Step Three: Repeat as Necessary 
Adding spatial data need to be done for all CAD drawings that you intend on re-projecting to 
GIS. 
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APPLY SPATIAL REFERENCE (OPTION TWO) 
Step One: Add .PRJ files to File Directory 
Browse to the G:\CADD\Std-filename-projections folder (Figure 35-12). The G: drive is 
mapped as dot0dta1fsaug01\gisdata.  

 
Figure 35-12: The folder containing common file name projections. 

 Refer to page 35-9 for information on determining the coordinate system of your 
project. 

Step Two: Copy necessary files 
Double click on the folder whose name is the same as the coordinate system used for the 
project. Select the files that you will be re-projecting. Select Edit > Copy.  
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Step Three: Paste the files 
Browse to the Y:\pin\#####\## folder and to the workgroup’s MSTA folder that contains the 
dataset (i.e. Y:\pin\11584\00\Highway\MSTA). The Y: drive is mapped as oit-
teaqasdtiis.mdot.w2k.state.me.us\pcpin1. Select Edit > Paste.  

 
Figure 35-13: Project's folder on the Y: drive. 

 If you do not have permissions to copy the .prj file(s) into the project’s MSTA folder, 
consider copying the files into the GIS folder. Contact CADD Support for assistance. 
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APPLY SPATIAL REFERENCE (OPTION THREE) 
Overview 
This method is done on the fly while using the ArcToolbox>Conversion Tools>To 
Geodatabase>Import From CAD. It doesn’t require that you have permissions to the 
directory that contains the CADD data. Steps are described below. 

 Be aware that this method of applying spatial reference doesn’t maintain connectivity 
to the CADD data. It would need to be applied again for another instance. 
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IMPORT CAD DATA INTO GEODATABASE 
Overview 
ArcCatalog separates a CADD drawing into 5 different groupings; Annotation, MultiPatch, 
Points, Polygons and polylines. When Importing From CAD to Geodatabase, we will be 
selecting just the just the CAD Feature Dataset.  

 At this point, the annotation class doesn’t display the text, it displays points that 
represent the origin of the text. The actual text has to be handled differently in order 
to get the sizing, font and rotations to come in correctly. This will be dealt with later. 

Step One: Copy Geodatabase to PIN’s Subfolder (if not 
already done) 

 Refer to page 35-6 for complete instructions on copying the Geodatabases into the 
GIS folder. 

 You will need to have permissions to this folder. Contact CADD Support personnel.  

Step Two: Import From CAD to Geodatabase 
Select the ArcToolbox > Conversion Tools > To Geodatabase > Import From CAD tool 
(Figure 35-14).  

 
Figure 35-14: Select the ArcToolbox>Conversion Tools>To Geodatabase>Import From CAD tool. 
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Step Three: Browse to CADD Feature Dataset 
Select Browse button next to the Input Files field (Figure 35-15).  

 
Figure 35-15: Import from CAD dialog. 

Locate the CAD Feature Dataset by browsing to your PIN’s workgroup/MSTA folder that 
contains the data needed in GIS (Figure 35-16). 

 
Figure 35-16: Browse to the CAD Feature Dataset needed in GIS. 
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Step Four: Output Staging Geodatabase 
Accept the Output Staging Geodatabase as is. You can copy and paste the CAD Feature 
Dataset from the Staging Geodatabase to the UTM Geodatabase once the process is complete 
to keep all the data within one Geodatabase. 

Step Five: Add Spatial Reference 
Depending on whether or not you added spatial reference to the CAD files in a previous step, 
this field may or may not be correct. This spatial reference will be the State Plane Coordinate 
System of your project, not the intended coordinate system you are projecting to.  

 
Figure 35-17: Select the Browse button next to the Spatial Reference field. 

Select the Browse button next to the Spatial Reference field. Click the Select button, browse 
to the G:\CADD folder and select the State Plan coordinate projection file that is unit and 
zone specific (Figure 35-18). Select Add. Click Apply at the Spatial Reference Properties 
dialog. 

 
Figure 35-18: Select the coordinate system of the CADD data. 

Step Six: Uncheck Explode Complex Objects 
It is recommended that you uncheck this feature. This pertains to cells within the .dgn. If a 
cell is made up of many elements, it will leave it intact and place it at its insertion point in the 
file as opposed to breaking it apart into multiple elements. 
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Step Seven: Adjust Environments 
Select the Environments button. In the General Settings, set the Output Coordinate System to 
As Specified Below. Select the Browse button next to the Spatial Reference field. Click the 
Select button, browse to the G:\CADD folder and select the 
NAD_1983_UTM_Zone_19N.prj file. Select Add. Click Apply at the Spatial Reference 
Properties dialog. Click OK in the Environment Settings dialog. 

Step Eight: Process the File 
Click OK at the Import From CAD dialog. At this point, ArcCatalog will show you the 
progress and report on the status of each imported Feature Class. If you receive red text in the 
progress box, it indicates that there have been errors processing the data. If the error indicates 
that there are some elements that do not fit spatially, there may be actual elements that 
inadvertently got placed outside of the zone (either in NH or in the ocean). Opening the 
MicroStation file and doing a fit view may show the elements that are outside of the drawing 
area. If this is found, the elements should be deleted. 

Once the process is complete, you should see a message like the one below (Figure 35-19). 

 
Figure 35-19: Completed dialog once the data has been processed. 

Step Nine: Verify by Mapping the Data (Optional) 
Now you can verify that your project has been projected into the UTM (metric) coordinate 
system. Start ArcMap and create a new map. Select the Add Data icon and browse to your 
Geodatabase in your PIN folder. Double-click the Geodatabase and select your Feature 
Dataset. Click the Add button. 

The Geodatabase has a map of the state as one of its default Feature Classes so when the map 
is displayed, you should see your data (points only while zoomed out). If you zoom in on the 
data, more details will become visible. Verify that it falls in the correct town or city by 
selecting the “i” for the information tool and click in the shaded polygon that encompasses 
the project. The information box should display what town your project is in. 
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 Depending on the order you added the data, you may have to move the Map to the 
bottom of the list in ArcMap. 

Troubleshooting 
There seems to be some trouble with the latest version of ArcGIS with the MicroStation 
CAD feature datasets. If everything seems to process but no data is present, consider opening 
the MicroStation file and saving it as an AutoCAD file (.dwg) and trying it again. The 
interoperability with AutoCAD currently provides better results. If you’ve added a projection 
file to the directory and name the file the same, ArcCatalog will pick up on the projection of 
the file. 
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CREATING A FEATURE CLASS FOR ANNOTATION 
Overview 
When creating annotation for CADD data, you need to treat the annotation and dimensions 
separately from the line work. ArcToolbox has a conversion tool that handles the text very 
well. The steps that follow will instruct how use this tool.  

For best results, follow the process outlined below. First add the annotation into the 
Geodatabase setup with the original coordinates and units of the project. Then right click and 
Export to the UTM Geodatabase or other proposed coordinate system. This gives better 
control over the text size. 

Step One: Open ArcToolbox 
Select the ArcToolbox icon or by selecting Window > ArcToolbox from the main menu. 
Expand the Conversion Tools category. Select the To Geodatabase grouping.  

Step Two: Import CAD Annotation 
Select the Import CAD Annotation tool. 

Step Three: Browse for Annotation Feature Class 
Select the Feature Class to import by browsing to the workgroups/MSTA folder that 
contained the original CAD Feature Datasets. Open the Feature Dataset (i.e. rwplan.dgn). It 
should contain an Annotation Feature Class identified by a blue icon with the letter “A” on it. 
Select the Feature Class. Click OK. 

 Each and every drawing file that gets exported to the UTM Geodatabase will need to 
have the text brought over as well (if is necessary). 

Step Four: Browse for Output Feature Class Location (State 
Plane) 

Select the Browse button next to the Output Feature Class field and browse to your project’s 
GIS folder on the y: drive. Double click the Geodatabase (i.e. MDOT-StatePlane_Feet) and 
to the Feature Dataset that resembles the coordinates and units of your project (i.e. 
NAD83(1996) 1804 ME2000 WEST Zone).  

Supply a name for the Annotation Feature Class. Use a logical name that is similar to the 
other feature classes for that same drawing (i.e. rwplan_dgn_text). Use underscores instead 
of hyphens. Select Save.  

Step Five: Add a Reference Scale 
In this step, enter 300 as a scale value. 

Step Six: Create Class from Levels 
There already should be check in this checkbox by default. If there isn’t, add the check. Click 
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OK (Figure 35-20).  

 This will breakdown the text based on the level it is found in. This will give more 
flexibility when mapping the data.  

 
Figure 35-20: Import CAD Annotation dialog. 

Step Seven: Preview Annotation 
Using ArcCatalog, browse to your PINs Geodatabase by utilizing the preset connection 
(Y:\pin\11584). Expand the Geodatabase by hitting the plus (+) sign. Expand the Feature 
Dataset. Select the annotation Feature Class. On the right side of the dialog, click the Preview 
tab. Use your zoom in tools to look at the data. 

Step Eight: Re-Project the Annotation 
Right click the Annotation Feature Class and select Export > To Geodatabase (single) 
(Figure 35-21).   



mdot MicroStation 
01/01/12 

CADD Data and GIS 
 

35-24 
 

 
Figure 35-21: Export the Annotation to another Geodatabase. 

Step Nine: Set Output Location and Name 
In the Feature Class to Feature Class dialog, select the browse button next to the Output 
Location field and browse to the UTM Geodatabase located in the GIS folder of your project. 
Double click the Geodatabase and select the UTM Feature Dataset (Figure 35-22). Click 
Add. 

 
Figure 35-22: Browse to the UTM dataset for an output location. 

In the Output Feature Class field, supply the same name that was supplied earlier (i.e. 
rwplan_dgn_text). This will create a Feature Class with the same name in both 
Geodatabases.  
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Verify by Mapping the Data 
You can verify that your project has been projected into the UTM (metric) coordinate system 
by starting ArcMap and creating a new map. Select the Add Data icon and browse to your 
UTM Geodatabase in your PIN’s GIS folder. Double-click the Geodatabase and select your 
Feature Dataset. Click the Add button. If the annotation lines up with the rest of your data 
then you are done or repeat as necessary with the remaining Annotation Feature Classes. 
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  UUTTMM  DDAATTAA  TTOO  SSTTAATTEE  PPLLAANNEE  
CCOOOORRDDIINNAATTEESS  
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DOWNLOAD AERIAL PHOTOGRAPHY (RASTER 
IMAGES) 

Overview 
Raster images come in a variety of formats with various compressions. The most important 
thing to know about the image is its Spatial Reference. Knowing this will enable the image to 
be re-projected to another known coordinate system. Without this information the image will 
have to be placed manually and will require moving and rotating to best fit with the CADD 
data. The following portion of the document will describe retrieving an image from the 
MEGIS website with the Spatial Reference of NAD83_UTM_19N (meters) and re-projecting 
the image to State Plane coordinates of NAD83(1996) 1804 ME2000 WEST Zone (feet). 

Step One: Browse to MEGIS Website 
MEGIS is a good location to get aerial photography, but it may not be the most recent images 
available and the quality can vary depending on the area of the state. As long as the image 
has Spatial Reference, this documentation will work. 

Open an Internet Browser and enter http://megis.maine.gov. On the left portion of the page, 
select Maps (Figure 35-23). 

 
Figure 35-23: MEGIS webpage. 

Step Two: Open Aerial Photography Viewer 
Select the Aerial Photography Viewer under the Interactive Online Maps heading. When 
the new page loads, close the welcome screen (Figure 35-24). 

http://megis.maine.gov/�
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Figure 35-24: Maine Aerial Photography Viewer welcome page. 

Step Three: Select a Town 
Using the pull down at the bottom of the map (Figure 35-25), select the town you are 
interested in (i.e. Kittery). 
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Figure 35-25: Select a town from the Zoom to town pull down. 

Step Four: Adjust the Legend and Active Layer 

 Overview 
This step will determine the quality of image that is available for the town. In the Legend 
portion of the dialog, you will need to experiment by “checking” and “un-checking” the 
Visible Layers that control the viewing Color Photography on the map. 

 Part One: Test for Highest Quality 
Start by un-checking all but the Town Lines, .5 Foot Color Index, .5 Foot Color 
Photography, Town Names and Road Names. The highest quality image available will be the 
.5 Foot Color Photography. If this quality is available, you should see color map and a grid 
representing “tiles” that are available for download (it may require zooming in or out a bit). 
If no grid displays and the map is black and white, check for Next Highest Quality. 

 Part Two: Test for Next Highest Quality 
Uncheck the Visible Layers .5 Foot Color Photography and .5 Foot Color Index and place 
a check in the 1 Foot Color Index and the 1 Foot Color Photography for the next 
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highest quality images. Now there should be a grid of “tiles” that are available for download 
(it may require zooming in or out a bit) and a color map. If this isn’t available, try the 2 Foot 
Color Photography which is less desirable. 

 Part Three: Set the Active Layer 
Make the highest quality Color Index Active by placing a dot in the “radio” button next to 
the index (i.e. 1 Foot Color Index) as seen in Figure 35-26. 

 
Figure 35-26: Layers set to the highest quality image currently available for the town of Kittery. 

Step Five: Download the Image(s) 

 Part One: Click on the Tile 
Select the Identity tool in the toolbar (Figure 35-27). Click anywhere within a “tile”.  

 
Figure 35-27: Identify tool represented by the letter "i". 
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This will display some image information at the bottom of the map (Figure 35-28) including 
the date and a link to the image. 

 
Figure 35-28: Click link to download the zip file. 

 Part Two: Download the Image(s) 
Click the link to download and save the image that’s in the form of a zip (compressed file). 
Select Save and browse to the desired location (Figure 35-29). The recommendation is to the 
GIS folder within your project’s PIN directory on the Y: drive (i.e. Y:\pin\11584\00\GIS). 
Repeat for all tiles needed. 

 
Figure 35-29: Save the zip file to the desired location. 

 Part Three: Extract Images 
Open Windows Explorer and browse to the image location. Extract the images by right 
clicking the zip file and selecting Extract all (Figure 35-30). When the Extraction Wizard 
dialog appears, click Next.   

 
Figure 35-30: Right click and select Extract All. 
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Clicking Next again (Figure 35-31) will extract the image(s) into folder(s) that are named the 
same name as the original zip file(s). Click Finish when the extraction is complete. 

 
Figure 35-31: Extraction Wizard ready to extract to new folder. 
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RE-PROJECT AERIAL PHOTOGRAPHY 
Overview 
This next process requires that you have ESRI (GIS) software installed on your PC. It’s also 
helpful to setup connections the data. 

Step One: Open ArcCatalog 
Open ArcCatalog. Setup a connection to the location of the images (i.e. Y:\pin\11584). 

 Refer to page 35-3 for detailed information on setting up connections within 
ArcCatalog. 

Step Two: Open ArcToolbox 
Click the ArcToolbox icon from the Standard toolbar within ArcCatalog (Figure 35-32). 

 
Figure 35-32: Click the ArcToolbox from the Standard toolbar. 

Step Three: Open Composite Bands Tool 
Expand the Data Management Tools to expose the Raster > Composite Bands tool (Figure 
35-33). Double Click this tool. 
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Figure 35-33: Composite Bands tool within ArcToolbox. 

Step Four: Select Raster Bands 
Browse to the location of the raster image (i.e. 
Y:\pin\11584\00\GIS\ortho_1f35764776me19). Double click the image displaying its bands. 
Select the image’s Bands and click Add (Figure 35-34). 

 
Figure 35-34: Browse to the image. 
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Step Five: Adjust Output Raster 
Adjust the Output Raster by stripping the name down to the original raster name followed by 
a .tif file extension (Figure 35-35). 

 
Figure 35-35: Adjust Output Raster name and location. 

Step Six: Adjust Environments… 
Click the Environments button. Adjust the following settings: 

 Part One: General Settings 
Under General Settings, change the Output Coordinate System to As Specified Below. 
Click the Browse button (Figure 35-36).  
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Figure 35-36: Click the Browse button. 

Select the Import button and browse the State Plane Geodatabase within your project’s GIS 
folder. Double click the Geodatabase and select the dataset internally that is named the same 
coordinate system as your project. Click the Add button. Click OK. The result should be the 
proposed coordinate system (Figure 35-37). 

 Another option would be to pick the Select button and browse to a projection (.prj) 
file. We have placed the common projection files within the G:\CADD folder on the 
network.  

 
Figure 35-37: The result will be the desired output coordinate system. 

 Part Two: Adjust the Raster Storage Settings 
Scroll down the Environments settings and expand the Raster Storage Settings. Remove 
the check mark next to the Build Pyramids and the Calculate Statistics. Change the 
Compression to None (Figure 35-38). Click OK. Click OK again to start the process. 
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Figure 35-38: Adjust the Raster Storage Settings. 

When the process is complete, the dialog will display the Competed message (Figure 35-39). 

 
Figure 35-39: Completed message once the process has been completed. 
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ATTACHING TO MICROSTATION FILE 
Step One: Open MicroStation 
Launch MicroStation from the Desktop icon. Select the project from the project pull down. 
Open a file that has relativity to the ground and individual plan sheets (i.e., HDPLAN.dgn, 
BDPLAN.dgn or RWPLAN-Clips.dgn).  

Step Two: Adjust MicroStation Preferences (if necessary) 
Open MicroStation. Select Workspace > Preferences from the MicroStation main menu. 
Select the Raster Manager Category. Adjust the preferences to match the dialogs shown in 
Figure 35-40 and Figure 35-41. 

 
Figure 35-40: Raster Manager General Tab preferences adjusted to handle re-projected raster. 

 
Figure 35-41: Raster Manager Georeference Tab preferences adjusted to handle re-projected raster. 
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Step Three: Attach Raster 
Select File > Raster Manager. Select File > Attach > Raster.  Browse to the image within 
the GIS folder of your project. Select the image. Uncheck the Place Interactively option 
(Figure 35-42). Click OK.  This will bring up the Raster Attachment Options dialog. 

 
Figure 35-42: Attach Raster Reference dialog. 

Repeat as necessary. 

Step Four: Adjust Transparency (if Necessary) 
If more than one image is used, it may be necessary to adjust transparency of one or more 
images so that the images match together without a black space between them (Figure 
35-43).  Click the Color tab and ensure the Transparency is set to Hide. 
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Figure 35-43: Raster Attachment Options. Transparency set to Hide. 
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EXPORTING UTM DATA TO CADD 
Overview 
Whether you take the whole GIS layer/feature class/shape file or a selection set of one of 
these through ArcMap, the process of re-projecting the layer is the same. For best results, the 
layer should be re-projected into a Geodatabase that contains a Feature Dataset at the 
proposed State Plane Coordinate System and units. Once there, it can be Exported to CAD 
while using the correct MaineDOT’s MicroStation or AutoCAD seed file. 

GIS data comes from a variety of sources and in a variety of types. ESRI is used to perform 
the following steps. The most important thing about the data is its Spatial Extents or 
coordinate system. Knowing this will allow the re-projection into the State Plane coordinates 
for the project. 

Step One (Option One) - Using ArcMap 

 Part One: Select data 
If all of the data is currently displayed within ArcMap, and you only want a certain area to be 
included within the CADD drawing, a new layer can be made. Select the Select Features 
tool in the Tools tool box (Figure 35-44). Click opposite corners to make a rectangle crossing 
the data you want to select. The lines will highlight.  

 
Figure 35-44: Select Features tool on LT and selected features on the RT. 
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 Part Two: Create New Layer from Selection 
Create a new layer based on the selection set by Right Clicking the data set and selecting 
Selection>Create Layer From Selected Features (Figure 35-45).  

 
Figure 35-45: Create a new layer from selected features. 

 Part Three: Send Feature Class to new Geodatabase Feature Class 
Select Conversion Tools > To Geodatabase>Feature Class to Feature Class tool from the 
Arc Toolbox. Fill in the dialog box with appropriate information (Figure 35-47). 

Select the Input Features from the pull down. 

Select the Output Location browse button and browse to the Geodatabase that contains the 
Feature Dataset that has been setup for your project’s State Plane Coordinate system (Figure 
35-46). 
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Figure 35-46: Set the Output Location to your Project's Geodatabase Feature Data Set. 

Supply a name for the Output Feature Class. 
The dialog should resemble the one in Figure 35-47. Click OK.  

 
Figure 35-47: Dialog setup with the sample data. 

Step One (Option Two) - Using ArcCatalog 

 Part One: Right Click Data to Export 
Open ArcCatalog and browse to the layer to be re-projected. Right click the layer and select 
Export > To Geodatabase (single) (or multiple depending on the data) (Figure 35-48). 
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Figure 35-48: Exporting data to Geodatabase. 

 Part Two: Adjust Feature Class to Feature Class Dialog 
Select the Output Location browse button and browse to the Geodatabase that contains the 
Feature Dataset that has been setup for your project’s State Plane Coordinate system (Figure 
35-49). 

 
Figure 35-49: Set the Output Location to your Project's Geodatabase Feature Data Set. 

Supply a name for the Output Feature Class. 
The dialog should resemble the one in Figure 35-50. Click OK.  
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Figure 35-50: Dialog setup with the sample data. 

Step Two: Test with ArcMap (optional only) 
If you would like to test the resulting file, open ArcMap and select the Add Data button and 
browse to the State Plane Geodatabase’s Feature Dataset and select the map (i.e. 
ME2000_SPW_FT) and the new Feature Class you just created. When mapped together, the 
data should fall in the correct location on the map. The Map will need to be the last thing 
listed in ArcMap. 

Step Three: Export to CAD 
Browse to the Geodatabase containing the GIS data that was re-projected. Right click the 
Feature Class within the Feature Dataset and select Export > To CAD (Figure 35-51). 

 
Figure 35-51: Right Click and select Export>To CAD. 

Step Four: Adjust the Export to CAD Dialog 



mdot MicroStation 
01/01/12 

CADD Data and GIS 
 

35-46 
 

 Part One: Adjust the Output Type 
Select the Output Type down-arrow and select DGN_V8 from the list of options (Figure 
35-52). 

 
Figure 35-52: Adjust the Output Type to DGN_V8. 

 Part Two: Adjust the Output File Location/Name 
Select the browse button next to the Output File field and browse to the proposed location of 
the output file and supply a name including the file extension .dgn as seen in Figure 35-53. 

 It is recommended that you place the new .dgn within the project directory. Certain 
privileges may prevent you from placing into a workgroup folder. Place this in the 
topo folder for the project and someone else can move it if necessary.  

 
Figure 35-53: Adjust the file location and name. Add the .dgn extension. 

 Part Three: Browse and Add MaineDOT Seed File 
Select the browse button next to the Seed File (optional) and browse to the 
G:\CADD\StdCADDSeeds\ folder and select the usMDOT_SEED.DGN from the list and 
click Add (Figure 35-54). 
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Figure 35-54: Select the appropriate seed file based on units and file type. 

 Part Four: Click OK to Process 
Click OK to process the file. 

Step Five: Test with ArcMap (optional only) 
If you would like to test the resulting file, open ArcMap and select the Add Data button and 
browse to the Geodatabase’s Feature Dataset and select the map (i.e. ME2000_SPW_FT). 
Now browse to the CADD file that was exported. You may get an error stating that there is 
no spatial reference for the file, but it should fall in the correct location. 

Step Six: Reference to CADD Files 
Within MicroStation, you or others can open an existing MicroStation file and select File > 
Reference (DOT) > Attach to view the information with other CADD drawings for the 
project. 
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